Subject: [Netconf] Comments on draft-ietf-netconf-restconf-15 -- 3.4.1.1. Timestamp

From: "Steve Truong (struong)" <[email-masked]>
Date: Mon, 11 Jul 2016 17:06:33 +0000

If the RESTCONF server is colocated with a NETCONF server, then the
   last-modified timestamp MUST represent the "running" datastore.

If the "running" datastore can also be accessed and changed by other servers such as CLI, SNMP, ... how would the timestamp be reported?

This question also applied to the Entity Tag in the next subsection.

Another question is since restconf is supposed to be a (simplified) version of netconf (providing "a subset of Netconf functionality") how would netconf provide the equivalent capability to its clients?

Thanks,
steve

---

From: Andy Bierman <[email-masked]>
Date: Wed, 27 Jul 2016 20:49:14 -0700

Hi,

I am working on edits, but I don't see any changes here...

On Mon, Jul 11, 2016 at 10:06 AM, Steve Truong (struong) <[email-masked]>
wrote:

> If the “running” datastore can also be accessed and changed by other
> servers such as CLI, SNMP, … how would the timestamp be reported?
>
>
>

The timestamp is reported the same way no matter why the datastore changed.
The sentence does not need to mention CLI and SNMP

> Another question is since restconf is supposed to be a (simplified)
> version of netconf (providing “a subset of Netconf functionality”) how
> would netconf provide the equivalent capability to its clients?
>
>
>

That is out of scope for this document

> steve

Andy

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>