Subject: [Netconf] NETCONF WG Session Summary and AIs from IETF #96

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Thu, 21 Jul 2016 14:38:45 +0000

Dear Benoit, NETCONF WG,

below is the NETCONF WG session summary and AIs from IETF #96.

=> This mail is at the same time to verify/validate the discussion result and decisions from the IETF 96 NETCONF session.
=> If there is no strong objection we will implement as discussed.

The NETCONF session took place on Monday, July 18, 2016, from 10:00 – 12:30 CET Berlin, Germany.

- We had approx. 120+ participants in the 2.5 hour NETCONF session,
- We reviewed the status of the WG,
- We had a discussion on chartered documents.

The rough notes from the Etherpad are available at:
http://etherpad.tools.ietf.org:9000/p/notes-ietf-96-netconf?useMonospaceFont=true

Chartered items:
      1. Report from documents after WGLC: Restconf, Yang-patch - A. Bierman (15 min.)
Andy will provide an update for RESTCONF and YANG Patch by next week.

      2. Subscribing to YANG datastore push updates - Eric Voit (15 min)
      3. Subscriptions for Event Notifications (RFC 5277bis) - Eric Voit (15 min)
      4. NETCONF Transport for Event Notifications - Eric Voit (10 min)
      5. RESTCONF & HTTP Transport for Event Notifications - Eric Voit (5 min)
“YANG Push” drafts were discussed. The WG agreed to adopt the three drafts 5277bis, NETCONF Transport and RESTCONF & HTTP Transport.
The next version of the drafts will be accepted as draft-ietf.

      6. System Keychain Model - K. Watsen
      7. SSH Client Server Model - K. Watsen
      8. TLS Client Server Model - K. Watsen
      9. NETCONF Client Server Model - K. Watsen
     10. RESTCONF Client Server Model - K. Watsen
     11. Zero Touch Provisioning for NETCONF Call Home (ZeroTouch) - K. Watsen
Issue discussion. Issues will be addressed and drafts will be updated as discussed.
Client models will be addressed in the next version.

Non-Chartered items:
      1. I2RS strawman proposal - S. Hares
Sue presented the I2RS requirements documented in ephemeral state draft. There was no further comments.
The chairs asked the attendees to comment and discuss if they see an issue. Otherwise they will are seen as accepted.
Sue agreed to provide an overview on which requirements are addressed in which draft and where an action is necessary.

      2. Refined YANG datastores with Meta-data
The datastore conceptual discussion is continuing in NETMOD WG.
It has been proposed that the architectural discussion should be continued in NETMOD WG and
the protocol part as well as the necessary changes to the datastore definition to NETCONF RFC should be done in NETCONF WG.

Mehmet & Mahesh

---

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Thu, 21 Jul 2016 14:42:57 +0000

Correction:
The NETCONF session was on Wednesday 1000-1230 CET.

Mehmet

From: Netconf [mailto:[email-masked]] On Behalf Of Ersue, Mehmet (Nokia - DE/Munich)
Sent: Thursday, July 21, 2016 4:39 PM
To: Benoit Claise <[email-masked]>; Netconf <[email-masked]>
Subject: [Netconf] NETCONF WG Session Summary and AIs from IETF #96

Dear Benoit, NETCONF WG,

Chartered items:

Non-Chartered items:

Mehmet & Mahesh

---

From: Andy Bierman <[email-masked]>
Date: Thu, 21 Jul 2016 07:57:45 -0700

Hi,

I think I said in the meeting the RESTCONF and YANG Patch drafts
will be updated 2 weeks after the IETF (by Aug. 6).  It may get done
sooner, or a bit later if some remaining review comments require
clarification.

Andy

On Thu, Jul 21, 2016 at 7:42 AM, Ersue, Mehmet (Nokia - DE/Munich) <
[email-masked]> wrote:

> *From:* Netconf [mailto:[email-masked]] *On Behalf Of *Ersue,
> Mehmet (Nokia - DE/Munich)
> *Sent:* Thursday, July 21, 2016 4:39 PM
> *To:* Benoit Claise <[email-masked]>; Netconf <[email-masked]>
> *Subject:* [Netconf] NETCONF WG Session Summary and AIs from IETF #96
>
>
>
> Dear Benoit, NETCONF WG,
>
>
>
> => This mail is at the same time to verify/validate the discussion result
> and decisions from the IETF 96 NETCONF session.
>
> “YANG Push” drafts were discussed. The WG agreed to adopt the three drafts
> 5277bis, NETCONF Transport and RESTCONF & HTTP Transport.
>
> The chairs asked the attendees to comment and discuss if they see an
> issue. Otherwise they will are seen as accepted.
>
> Sue agreed to provide an overview on which requirements are addressed in
> which draft and where an action is necessary.
>
>
>
> the protocol part as well as the necessary changes to the datastore
> definition to NETCONF RFC should be done in NETCONF WG.
>
>
>
> Mehmet & Mahesh
>
>
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 21 Jul 2016 11:16:50 -0400

Mahesh and Mehmet: 

This is an excellent summary for my talk.

Sue Hares

From: Netconf [mailto:[email-masked]] On Behalf Of Ersue, Mehmet (Nokia - DE/Munich)
Sent: Thursday, July 21, 2016 10:39 AM
To: Benoit Claise; Netconf
Subject: [Netconf] NETCONF WG Session Summary and AIs from IETF #96

Dear Benoit, NETCONF WG, 

 

Chartered items:

Non-Chartered items:      

Mehmet & Mahesh