Subject: [Netconf] Comments on draft-ietf-netconf-yang-patch-09

From: "Steve Truong (struong)" <[email-masked]>
Date: Wed, 6 Jul 2016 18:41:34 +0000

Yang Patch operation can target a datastore resource.   Can we add examples of datastore patching where multiple YANG modules are involved (we need to have at least 2 modules for the demonstration)?

The module ietf-yang-patch<https://tools.ietf.org/html/draft-ietf-netconf-yang-patch-09#section-3> doesn't seem to be compilable?  Should it?

Thanks,
steve

---

From: Andy Bierman <[email-masked]>
Date: Wed, 6 Jul 2016 11:52:33 -0700

On Wed, Jul 6, 2016 at 11:41 AM, Steve Truong (struong) <[email-masked]>
wrote:

> Yang Patch operation can target a datastore resource.   Can we add
> examples of datastore patching where multiple YANG modules are involved (we
> need to have at least 2 modules for the demonstration)?
>
>
>
> The module ietf-yang-patch
> <https://tools.ietf.org/html/draft-ietf-netconf-yang-patch-09#section-3>
> doesn’t seem to be compilable?  Should it?
>
>
>

Not sure why this seems complicated

The "target" for edit1 is set to /foo-mod:X
The "target" for edit2 is set to /bar-mod:X

Thanks,
> steve

Andy

>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>

---

From: Andy Bierman <[email-masked]>
Date: Wed, 6 Jul 2016 12:15:01 -0700

Hi,

Actually the target-resource-offset typedef does not support JSON encoding,
just XPath for XML encoding.  This will be fixed in the next release.

For XML: (use XML prefixes)

edit1:
  <target xmlns:foo="foo-namespace-uri">/foo:X</target>

edit2:
  <target xmlns:bar="bar-namespace-uri">/bar:X</target>

For JSON: (use YANG module name)

edit1:
  "target" : "/foo-mod:X"

edit2:
 "target" : "/bar-mod:X"

Andy

---

From: Andy Bierman <[email-masked]>
Date: Wed, 6 Jul 2016 13:25:37 -0700

> just XPath for XML encoding.  This will be fixed in the next release.

After a little more thought, I would like to change this typedef
so it always uses the JSON encoding (same format as the target resource URI

Andy

> On Wed, Jul 6, 2016 at 11:41 AM, Steve Truong (struong) <[email-masked]
> > wrote:
>