Subject: [Netconf] Comments on draft-ietf-netconf-restconf-14 - 7. Error Reporting

From: "Steve Truong (struong)" <[email-masked]>
Date: Tue, 5 Jul 2016 17:17:03 +0000

In section 7 (preferably) I'd like to see the mapping of the following HTTP status code to the NETCONF <error-tag>:

-          406 Not Acceptable

-          412 Precondition Failed

Can someone tell what they should be?

Thanks,
steve

---

From: Andy Bierman <[email-masked]>
Date: Tue, 5 Jul 2016 11:33:47 -0700

On Tue, Jul 5, 2016 at 10:17 AM, Steve Truong (struong) <[email-masked]>
wrote:

> In section 7 (preferably) I’d like to see the mapping of the following
> HTTP status code to the NETCONF <error-tag>:
>
>
>
> -          406 Not Acceptable
>

we are sending invalid-value

> -          412 Precondition Failed

we are sending operation-failed

> Can someone tell what they should be?

Does anybody want to suggest different error-tags?

> steve

Andy

>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>