Subject: [Netconf] which error-tag?

From: Andy Bierman <[email-masked]>
Date: Mon, 11 Jul 2016 14:58:21 -0700

Hi,

Which error-tag should be returned if an element is present
but it is disabled because if-feature=false?

E.g., using :writable-running; :candidate is not advertised

  <rpc>
     <lock>
        <target><candidate/></target>
     </lock>
  </rpc>

I think this is unknown-object, not invalid-value, since the "if-feature"
statements were added to the ietf-netconf.yang module
I don't think the RFC says either way.

Andy

---

From: [email-masked] (Dale R. Worley)
Date: Tue, 12 Jul 2016 09:49:35 -0400

> I don't think the RFC says either way.

"unknown-object" makes more sense to me -- the philosophy of the RFC
seems to be that the object is nonexistent if if-feature is false.  But
it should be specified clearly, of course.

Dale

---

From: Andy Bierman <[email-masked]>
Date: Tue, 12 Jul 2016 08:01:23 -0700

> it should be specified clearly, of course.
It is called unknown-element.
The original RFC did not have if-feature statements in the <candidate> leaf.

  <lock>
       <target>
           <running>really-invalid-value</running>
       </target>
  </lock>

Passing a string when the leaf is type 'empty' would be an invalid-value,
but only if the leaf is supported.

Andy