Subject: [Netconf] I-D Action: draft-ietf-netconf-restconf-15.txt

From: [email-masked]
Date: Thu, 07 Jul 2016 21:40:45 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Configuration of the IETF.

        Title           : RESTCONF Protocol
        Authors         : Andy Bierman
                          Martin Bjorklund
                          Kent Watsen
	Filename        : draft-ietf-netconf-restconf-15.txt
	Pages           : 125
	Date            : 2016-07-07

Abstract:
   This document describes an HTTP-based protocol that provides a
   programmatic interface for accessing data defined in YANG, using the
   datastore concepts defined in NETCONF.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netconf-restconf/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-netconf-restconf-15

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netconf-restconf-15

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Benoit Claise <[email-masked]>
Date: Tue, 12 Jul 2016 09:56:44 +0200

One more point.

the grouping tree is not exactly right in the draft.

pyang -f tree --tree-print-groupings [email-masked]
module: ietf-restconf
groupings:
   errors
      +---- errors
         +---- error*
            +---- error-type       enumeration
            +---- error-tag        string
            +---- error-app-tag?   string
            +---- error-path?      instance-identifier
            +---- error-message?   string
            +---- error-info?

   restconf
      +---- restconf
         +---- data
         +---- operations
         +--ro yang-library-version    string

Regards, B.
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> .
>