Subject: Re: [Netconf] I-D Action: draft-ietf-netconf-netconf-event-notifications-01.txt

From: Phil Shafer <[email-masked]>
Date: Tue, 1 Nov 2016 11:27:10 -0400

Phil Shafer writes:
>[email-masked] writes:
>>        Title           : NETCONF Support for Event Notifications
>
>Should we stop saying "BEEP" WRT NETCONF?  It's dead.  As dead as a doornail.

Clarification:  BEEP is dead.  NETCONF is alive and prospering.  We
originally had great hopes for BEEP but it hasn't worked or seen
real-world use.  I think Juniper's SDX product was the only fielded
use (and we suffered for it).

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Tue, 1 Nov 2016 09:00:10 -0700

> use (and we suffered for it).

The word BEEP appears once in Figure 1

> Thanks,
>  Phil
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: Kent Watsen <[email-masked]>
Date: Tue, 1 Nov 2016 16:00:35 +0000

I guess you’re referring to the diagram in Section 1.  Yes, BEEP should be removed from that diagram.  The WG deprecated the BEEP transport a few years ago.  RFC 4744 is now HISTORIC.

K.

On 11/1/16, 11:27 AM, "Netconf on behalf of Phil Shafer" <[email-masked] on behalf of [email-masked]> wrote:

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Tue, 1 Nov 2016 09:01:39 -0700

>> use (and we suffered for it).
gmail pressed send, not me ;-)

> The word BEEP appears once in Figure 1

            |                           |                       |
       +-------------+     +-------------------------------------------+
       |  Transport  |     |          BEEP, SSH, SSL, console          |
       |  Protocol   |     |                                           |
       +-------------+     +-------------------------------------------+

If you mean "let's update this diagram", then I agree

>>  Phil

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 1 Nov 2016 19:36:39 +0100

> > The word BEEP appears once in Figure 1

It may be worthwhile to make the figure consistent with Fig. 1 in RFC
6241. I do not care much whether BEEP and/or SOAP is removed but I do
care about the layers, how we call them, and where we place certain
elements.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Phil Shafer <[email-masked]>
Date: Tue, 1 Nov 2016 17:46:32 -0400

Kent Watsen writes:
>I guess you're referring to the diagram in Section 1.

Yup, exactly.

Thanks,
 Phil

---

From: Phil Shafer <[email-masked]>
Date: Tue, 1 Nov 2016 21:13:05 -0400

>If you mean "let's update this diagram", then I agree

Yup.

Thanks,
 Phil

---

From: "Alberto Gonzalez Prieto (albertgo)" <[email-masked]>
Date: Mon, 7 Nov 2016 14:57:00 +0000

Hello,

Thanks for spotting this.
The new version will be updated as follows.
Figure 1 in the draft will be substituted by figure 1 in RFC 6241 minus
"BEEP/TLS, ³ at the ³secure transport² layer.
That is, it will read: "SSH, TLS, SOAP/HTTP/TLS, Š"

Thanks,

Alberto