Subject: [Netconf] Minutes 2-Nov: NETCONF/RESTCONF/HTTP2 Subscription & Event drafts

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 8 Nov 2016 19:18:46 +0000

Minutes posted at:
https://github.com/netconf-wg/yang-push/wiki/Minutes-2016-11-2
(As always, our DezignTM Team is a gathering of individuals providing informal input to NETCONF)

Meeting Materials

Attending

WebEx Recording<https://cisco.webex.com/ciscosales/lsr.php?RCID=ac6a31bc269647bd921f0fe6b364bdff>
password: cSy4T9un

Andy Bierman, Alexander Clemm, Walker, Einar Nilsen-Nygaard, Eric Voit, Tim Jenkins, Peipei Guo

Agenda:

  *   Review the IETF97 slides.
  *   Discuss recommendations to be made in Seoul.
  *   Draft slides are here<http://www.voit.org/IETF/Subscriptions-NETCONF-IETF97.ppt>
Feedback requests IETF-97 (please see slides for details)
for evaluation by the larger NETCONF team in Seoul

  *   Feedback Request #1: Streams and Filter Types: if/when OpState adopted, should we augment with a corresponding new filter-type allowing the OpState datastore to be selected? (believe answer is yes.)
  *   Feedback Request #2: Topic Filtering: Assess WG interest in classifying Model, Subtree, & Leaf via independent categorizations such as Event-type & severity. (Andy to edit Eric's first attempt at slide which is linked above.)
  *   Feedback Request #3: Metadata Filter: This is obviously a need well past subscriptions, and tied to #1. We should look to charter some YANG Metadata filter draft. (in NETCONF or NETMOD?) Who wants to help here?
  *   Feedback Request #4: Do we include an Optional Update-Number to help with the Detection of Loss/Duplication independent of TCP?
  *   Feedback Request #5: HTTP2 compatibility with GRPC: we have proposed messages/exchanges for seamless transport over GRPC implementations. Do people agree with this, or see issues here with the mechanism proposed?
Other thoughts:

  *   Metadata filter + Dampening Period
     *   What if there is a move of an object to Intended or Applied Datastore before it hits the Operational-State datastore.
     *   A dampening period might slow the information that something has hit operational-state.
     *   Based on this, we might need to have the metadata filter type apply for only certain values, construct different subscriptions for different datastores, and/or
     *   Should propose a meeting / get-together in Korea on Metadata filtering.
  *   Alberto will have recording for call-home with subscriptions with Open Daylight for embedded in the slides
  *   Will cancel next week's meeting based on our getting the slides mostly done already.
  *   On the reduced attendance today. It is likely due to this being a slide review call rather than an issues closure call.

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 9 Nov 2016 17:13:41 +0000

Hi All,

While we will be presenting next week, it would be great to get your early thoughts and comments on the items below.    Also feel free to contact me if you want to be a part of the weekly calls.

Eric

From: Netconf [mailto:[email-masked]] On Behalf Of Eric Voit (evoit)
Sent: Tuesday, November 8, 2016 2:19 PM
To: [email-masked]; [email-masked]' <[email-masked]>
Subject: [Netconf] Minutes 2-Nov: NETCONF/RESTCONF/HTTP2 Subscription & Event drafts

Minutes posted at:

Meeting Materials

Attending

Agenda:
*        Review the IETF97 slides.
*        Discuss recommendations to be made in Seoul.
*        Draft slides are here<http://www.voit.org/IETF/Subscriptions-NETCONF-IETF97.ppt>
Feedback requests IETF-97 (please see slides for details)
for evaluation by the larger NETCONF team in Seoul
*        Feedback Request #1: Streams and Filter Types: if/when OpState adopted, should we augment with a corresponding new filter-type allowing the OpState datastore to be selected? (believe answer is yes.)
*        Feedback Request #2: Topic Filtering: Assess WG interest in classifying Model, Subtree, & Leaf via independent categorizations such as Event-type & severity. (Andy to edit Eric's first attempt at slide which is linked above.)
*        Feedback Request #3: Metadata Filter: This is obviously a need well past subscriptions, and tied to #1. We should look to charter some YANG Metadata filter draft. (in NETCONF or NETMOD?) Who wants to help here?
*        Feedback Request #4: Do we include an Optional Update-Number to help with the Detection of Loss/Duplication independent of TCP?
*        Feedback Request #5: HTTP2 compatibility with GRPC: we have proposed messages/exchanges for seamless transport over GRPC implementations. Do people agree with this, or see issues here with the mechanism proposed?
Other thoughts:
*        Metadata filter + Dampening Period
o   What if there is a move of an object to Intended or Applied Datastore before it hits the Operational-State datastore.
o   A dampening period might slow the information that something has hit operational-state.
o   Based on this, we might need to have the metadata filter type apply for only certain values, construct different subscriptions for different datastores, and/or
o   Should propose a meeting / get-together in Korea on Metadata filtering.
*        Alberto will have recording for call-home with subscriptions with Open Daylight for embedded in the slides
*        Will cancel next week's meeting based on our getting the slides mostly done already.
*        On the reduced attendance today. It is likely due to this being a slide review call rather than an issues closure call.