Subject: Re: [Netconf] new NACM draft

From: MehmetErsue <[email-masked]>
Date: Fri, 2 Dec 2016 21:55:26 +0100

Hi Andy, Martin,

thank you for the initial draft.

We discussed in IETF 97 different issues and the additional sections we
could add.
IIRC the list was:
- schema-mount related text into schema-mount or the NACM draft,
- assigning priorities to clients,
- access control on dynamic datastores (e.g. I2RS),
- the issue from RFC 6536 with parent/child relationships which is
important for RESTCONF.

I would like to suggest to have a discussion on these issues and understand
whether they should be included.

Mehmet

On Wed, Nov 30, 2016 at 2:10 AM, Andy Bierman <[email-masked]> wrote:

> Hi,
>
> A new version of draft-bierman-netconf-rfc6536bis has been posted:
> https://www.ietf.org/id/draft-bierman-netconf-rfc6536bis-01.txt
>
>
> We would like this draft to be adopted as the starting point for item #5
> in the current NETCONF charter.
>
>
>
> Andy and Martin
>
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>

-- 
Cheers,
Mehmet

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 07 Dec 2016 09:19:50 +0100 (CET)

> We discussed in IETF 97 different issues and the additional sections we

Ok.  But do we have to resolve all issues before adopting this
document?  I think the current document is ready for adoption, and
then the WG can work on fixing any open issues.

> - schema-mount related text into schema-mount or the NACM draft,

I think schema mount needs to discuss how it works with NACM.  This
should be an open issue in schema mount.

> - assigning priorities to clients,

I don't believe this is a NACM issue.

> - access control on dynamic datastores (e.g. I2RS),

The text in 3.2 probably need to be relaxed a bit to allow NACM to be
applied to other datastores.

> - the issue from RFC 6536 with parent/child relationships which is

Can you elaborate on this?

/martin

---

From: MehmetErsue <[email-masked]>
Date: Wed, 07 Dec 2016 15:54:26 +0000

Hi Martin, All,

we discussed the listed issues in IETF 97 very roughly. The request from
IETF 97 was to have a discussion on the issues and understand better
whether they should be included.
We don't need to solve them before adoption.

> Can you elaborate on this?

IIRC the question was on whether a client with read access to a target node
also has read access to the ancestor nodes in order to be able to read the
target node's data.

@All: We would like to get comments/opinions on to whether the listed
issues should be covered in 6536bis.

important for RESTCONF.

BR,
Mehmet

-- 
Cheers,
Mehmet

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 08 Dec 2016 10:16:42 +0100 (CET)

> We don't need to solve them before adoption.

Ok.

> also has read access to the ancestor nodes in order to be able to read the

Ok.  This issue is already fixed in the recently published
draft-bierman-netconf-rfc6536bis-01.

/martin