Subject: [Netconf] netconf-config-change target in case of delete operation

From: "Lukas Macko -X (lmacko - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]>
Date: Tue, 13 Dec 2016 15:16:49 +0000

Hi,

I am trying to implement netconf-config-change notifications defined in RFC6470.

The issue I came across is that I am not sure what instance id should be provided for leaf /netconf-config-change/list/target in case of delete or remove operation.
Since the target leaf doesn't specify require-instance false in schema, I can not specify instance id of deleted node to pass the validation.

Thanks & Regards,
Lukas

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 14 Dec 2016 12:03:11 +0100 (CET)

"Lukas Macko -X (lmacko - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]> wrote:
> The issue I came across is that I am not sure what instance id should
> be provided for leaf /netconf-config-change/list/target in case of
> delete or remove operation.
> Since the target leaf doesn't specify require-instance false in
> schema, I can not specify instance id of deleted node to pass the
> validation.

I think the intention was that you should set the target to the
deleted instance.  But you are right, this would need a
"require-instance false;".

However, you can set it to the deleted node's parent and the operation
to 'merge'.

/martin