Subject: [Netconf] restconf-notif and HTTP/2

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 27 Dec 2016 14:55:52 +0100

Hi,

in Section 3.2.1 of draft-ietf-netconf-restconf-notif-01, I don't
understand how notification data are supposed to be delivered to the
subscriber. In Fig. 2, the subscriber sends HTTP POST on channel (b) and
receives 200 OK. But then "HTTP Data" is sent from the publisher,
apparently without any extra request from the client/subscriber. Is SSE
expected to be used here as well?

Thanks, Lada

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Thu, 29 Dec 2016 17:13:44 +0000

Hi Lada,

No need for SSE here.  The HTTP2 an OK message on stream (7) consists of headers and an unbounded set of HTTP Data.  The message isn't over until END_STREAM flag is set.  In the case of Fig 2, the OK message doesn't actually end until the "HTTP Headers (end of stream)".

This is identical to how GRPC works.  (Adding Eric A. in case he wants to chime in.)

Eric

> Hi,
> 
> in Section 3.2.1 of draft-ietf-netconf-restconf-notif-01, I don't understand how
> notification data are supposed to be delivered to the subscriber. In Fig. 2, the
> subscriber sends HTTP POST on channel (b) and receives 200 OK. But then
> "HTTP Data" is sent from the publisher, apparently without any extra request
> from the client/subscriber. Is SSE expected to be used here as well?
> 
> Thanks, Lada
> 
> --
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 30 Dec 2016 09:37:55 +0100

Hi Eric,

thanks for explanation, I didn't know this.

Happy New Year, Lada

> On 29 Dec 2016, at 18:13, Eric Voit (evoit) <[email-masked]> wrote:
> 
> Hi Lada,
>