Subject: Re: [Netconf] [Technical Errata Reported] RFC6241 (4856)

From: Benoit Claise <[email-masked]>
Date: Mon, 19 Dec 2016 11:57:57 +0100

Dear all,

Please let me know what you think of this errata.

Regards, Benoit.
> The following errata report has been submitted for RFC6241,
> "Network Configuration Protocol (NETCONF)".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=6241&eid=4856
>
> --------------------------------------
> Type: Technical
> Reported by: frank feng <[email-masked]>
>
> Section: 7.2
>
> Original Text
> -------------
> config:  A hierarchy of configuration data as defined by one of
>           the device's data models.  The contents MUST be placed in an
>           appropriate namespace, to allow the device to detect the
>           appropriate data model, and the contents MUST follow the
>           constraints of that data model, as defined by its capability
>           definition.  Capabilities are discussed in Section 8.
>
> Corrected Text
> --------------
> config:  A hierarchy of configuration data as defined by one or more of
>           the device's data models.  The contents MUST be placed in an
>           appropriate namespace, to allow the device to detect the
>           appropriate data model, and the contents MUST follow the
>           constraints of that data model, as defined by its capability
>           definition.  Capabilities are discussed in Section 8.
>
> Notes
> -----
>
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC6241 (draft-ietf-netconf-4741bis-10)
> --------------------------------------
> Title               : Network Configuration Protocol (NETCONF)
> Publication Date    : June 2011
> Author(s)           : R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed.
> Category            : PROPOSED STANDARD
> Source              : Network Configuration
> Area                : Operations and Management
> Stream              : IETF
> Verifying Party     : IESG
> .
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 19 Dec 2016 13:43:23 +0100

I think this is not needed. I am not sure what the wording change is
trying to fix, I do not see how the new wording would be a significant
improvement. If the 'by one of' is considered problematic, then I would
just remove it.

 config:  A hierarchy of configuration data as defined by 
           the device's data models.  The contents MUST be placed in an

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 19 Dec 2016 08:14:45 -0800

Hi,

this should be rejected.
The changed text implies that different configurations are present,
each derived from some unspecified subset of modules.
This is not correct.

Andy

---

From: Benoit Claise <[email-masked]>
Date: Tue, 20 Dec 2016 12:37:53 +0100

OK, thanks Andy and Jürgen.

Regards, B.
> On Mon, Dec 19, 2016 at 2:57 AM, Benoit Claise <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Dear all,
>
>         <http://www.rfc-editor.org/errata_search.php?rfc=6241&eid=4856>
>
>         Reported by: frank feng <[email-masked]
>         <mailto:[email-masked]>>
>
>         Section: 7.2
>
>         Original Text
>         -------------

---

From: MehmetErsue <[email-masked]>
Date: Tue, 20 Dec 2016 12:28:02 +0000

I kind of agree with Andy and Juergen.

Mehmet

Benoit Claise <[email-masked]> schrieb am Di., 20. Dez. 2016, 12:38:

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
-- 
Cheers,
Mehmet