Subject: [Netconf] WG Adoption Call for draft-bierman-netconf-rfc6536bis WAS:FW: new NACM draft

From: "Mehmet Ersue" <[email-masked]>
Date: Wed, 14 Dec 2016 22:19:59 +0100

Dear NETCONF WG,

for the potential topics to add we only got comments from Martin. We assume
now there are no other comments.

This is a 2+ week WG adoption call for draft-bierman-netconf-rfc6536bis to
adopt as NETCONF WG item.

Please state your opinion on the mail list by December 30, 2016 with
"yes/support" or "no support".  

If you support, please let us know what you would like to address
additionally.
If you don't support, please elaborate your reasons.  

Thank you,
Mehmet & Mahesh

-----Original Message-----
From: Martin Bjorklund [mailto:[email-masked]] 
Sent: Wednesday, December 7, 2016 9:20 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Netconf] new NACM draft

MehmetErsue <[email-masked] <mailto:[email-masked]> > wrote:
> Hi Andy, Martin,
> 
> thank you for the initial draft.
> 
> We discussed in IETF 97 different issues and the additional sections 
> we could add.

Ok.  But do we have to resolve all issues before adopting this document?  I
think the current document is ready for adoption, and then the WG can work
on fixing any open issues.

> IIRC the list was:
> - schema-mount related text into schema-mount or the NACM draft,

I think schema mount needs to discuss how it works with NACM.  This should
be an open issue in schema mount.

> - assigning priorities to clients,

I don't believe this is a NACM issue.

> - access control on dynamic datastores (e.g. I2RS),

The text in 3.2 probably need to be relaxed a bit to allow NACM to be
applied to other datastores.

> - the issue from RFC 6536 with parent/child relationships which is 
> important for RESTCONF.

Can you elaborate on this?

/martin

> 
> I would like to suggest to have a discussion on these issues and 
> understand whether they should be included.
> 
> Mehmet
> 
> On Wed, Nov 30, 2016 at 2:10 AM, Andy Bierman <[email-masked]
<mailto:[email-masked]> > wrote:
> 
> > Hi,
> >
> > A new version of draft-bierman-netconf-rfc6536bis has been posted:
> > https://www.ietf.org/id/draft-bierman-netconf-rfc6536bis-01.txt
> >
> >
> > We would like this draft to be adopted as the starting point for 
> > item #5 in the current NETCONF charter.
> >
> >
> >
> > Andy and Martin
> >
> >
> > _______________________________________________
> > Netconf mailing list
> > [email-masked] <mailto:[email-masked]> 
> > https://www.ietf.org/mailman/listinfo/netconf
> >
> >
> 
> 
> --
> Cheers,
> Mehmet

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 14 Dec 2016 22:26:57 +0100

I support this update since it is necessary to make NACM work with
YANG 1.1 and RESTCONF (and I think this should be the scope of this
update effort).

/js

On Wed, Dec 14, 2016 at 10:19:59PM +0100, Mehmet Ersue wrote:
> [email-masked]

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 15 Dec 2016 09:01:12 +0100

Support. Lada

> On 14 Dec 2016, at 22:19, Mehmet Ersue <[email-masked]> wrote:
> 
> Dear NETCONF WG,
> 

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Kent Watsen <[email-masked]>
Date: Thu, 15 Dec 2016 17:57:57 +0000

yes/support - it needs to be updated.

Kent

Dear NETCONF WG,

Thank you,
Mehmet & Mahesh

-----Original Message-----
From: Martin Bjorklund [mailto:[email-masked]] 
Sent: Wednesday, December 7, 2016 9:20 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Netconf] new NACM draft

/martin