Subject: [Netconf] I-D Action: draft-ietf-netconf-rfc7895bis-03.txt

From: [email-masked]
Date: Wed, 17 Jan 2018 08:07:26 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Configuration WG of the IETF.

        Title           : YANG Library
        Authors         : Andy Bierman
                          Martin Bjorklund
                          Juergen Schoenwaelder
                          Kent Watsen
                          Robert Wilton
	Filename        : draft-ietf-netconf-rfc7895bis-03.txt
	Pages           : 25
	Date            : 2018-01-17

Abstract:
   This document describes a YANG library that provides information
   about all the YANG modules and datastores used by a network
   management server (e.g., a Network Configuration Protocol (NETCONF)
   server).  Simple caching mechanisms are provided to allow clients to
   minimize retrieval of this information.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netconf-rfc7895bis/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-netconf-rfc7895bis-03
https://datatracker.ietf.org/doc/html/draft-ietf-netconf-rfc7895bis-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netconf-rfc7895bis-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 17 Jan 2018 17:12:03 +0100 (CET)

Hi,

This version of the YANG library reflects the consensus from the
Virtual Interim in December.  The YANG module is updated, but not all
text.  The authors will continue to work on the text and expect to
publish an update within a couple of weeks.  However, we felt that it
would be useful to publish this version, since the structure of the
data model has changed quite a lot.

/martin

[email-masked] wrote:
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: Igor Bryskin <[email-masked]>
Date: Thu, 18 Jan 2018 14:41:56 +0000

Hi Martin,

I have a YANG modeling/implementation question for you.
We want to introduce a somewhat unconventional YANG container defined like this:

typedef struct  PolicyVariable   /* PV, SF/ECA state */
{
              string name;      /* key, enables to refer to in conditions and actions */
              string xpath;     /* data store valid xpath  indirectly defining PV's value content */
              anydata value;    /* variable length value (PV's content), length is defined by xpath */
}

As you see, the value/contents of the container is defined indirectly to whatever the xpath is evaluated to. For example, if it is evaluated to a sub-tree, it should be possible to accommodate the entire data store sub-tree in the PV.  This would allow using the PV as a smart filter/ECA state in event-condition evaluations requiring, for example, data store state evolution in time (i.e. history).

I heard a lot of good things about your server side YANG implementations. In your opinion how difficult/demanding for the server to implement the described above? Are you aware of other use cases that require similar semantics? Can you offer alternatives?

Any feedback is hugely appreciated.

Thanks,
Igor