Subject: [Netconf] FW: [netmod] WG: Adoption Poll: draft-bierman-netmod-yang-data-ext-01

From: Kent Watsen <[email-masked]>
Date: Sat, 27 Jan 2018 04:27:16 +0000

Please take a moment to post support for the adoption of the yang-data-ext draft in the NETMOD working group.  

Recall that one of the zerotouch last call comments resulted in a need for a draft such as this, in order to move its normative reference for the "yang-data" extension away from RFC 8040.  

This modification is needed since some claim that rc:yang-data can't encode a top-level 'choice' statement even when it only has descendants that are containers.

Thanks!

Kent  // co-author on both drafts

===== original message =====
Hi,

This is the start of a *two* week poll on making
draft-bierman-netmod-yang-data-ext a working group document. Please send 
email to the list indicating "yes/support" or "no/do not support".  If 
indicating no, please state your reservations with the document.  If 
yes, please also feel free to provide comments you'd like to see 
addressed once the document is a WG document.

This poll ends on February 8.

Thank you!

Lou (and Co-chairs)

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Mon, 29 Jan 2018 00:41:26 +0000

I think this work is excellent.  I would like to see it adopted.

> Recall that one of the zerotouch last call comments resulted in a need for a
> draft such as this, in order to move its normative reference for the "yang-data"
> extension away from RFC 8040.
> 
> This modification is needed since some claim that rc:yang-data can't encode a
> top-level 'choice' statement even when it only has descendants that are
> containers.
> 
> Thanks!
> 
> This is the start of a *two* week poll on making draft-bierman-netmod-yang-
> data-ext a working group document. Please send email to the list indicating
> "yes/support" or "no/do not support".  If indicating no, please state your
> reservations with the document.  If yes, please also feel free to provide
> comments you'd like to see addressed once the document is a WG document.
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: Michael Richardson <[email-masked]>
Date: Tue, 30 Jan 2018 11:36:25 -0500

> indicating no, please state your reservations with the document.  If 

Hi, I have read yang-data-ext.
It seems critical that the document be adopted so that we may reference
it in the ANIMA WG voucher documents.

In particular we are using exactly the functionality of augmenting a
data structure from one protocol to another from document to document.
The current augment mechanism works, but only because we have
constrained ourselves to what it offers, having a more general mechanism
is very welcome.

I would appreciate a more complex example, and I wonder if the example
given (with foo.yang and bar.yang) really belongs withing the YANG
description itself.