Subject: Re: [Netconf] LC on subscribed-notifications-10

From: Qin Wu <[email-masked]>
Date: Fri, 16 Mar 2018 19:33:52 +0000

I have two comments on subscribed-notifications-10:
1.Why protocol parameter is defined in RPC while it is not defined in notification?
Is protocol parameter can be extended to support other transport protocol? Is there any dependency between protocol and DSCP?
2.Section 2.7.6 said
"   The tree structure of "subscription-completed" is almost identical to
   "subscription-resumed", with only the name of the notification
   changing.
"
Is there any key difference between "subscription-completed" and "subscription-resumed", it looks replay-completed is used to push
All event record before stop time expires, would it be great to clarify this in section 2.7.6?

-Qin
> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of Kent 
> Watsen
> Sent: Wednesday, February 28, 2018 6:09 PM
> To: [email-masked]
> Subject: [Netconf] LC on subscribed-notifications-10
> 
> 
> WG,
> 
> The authors of netconf-event-notifications have indicated privately 
> that they believe this document is now ready for Last Call.
> 
> This starts a 2.5-week Last Call on
> draft-ietf-netconf-subscribed-notifications-10
> [1] The LC will end on March 17, or when active threads peter out.
> 
> Please send your comments on this thread. Reviews of the document, and 
> statement of support, are particularly helpful to the authors.  If you 
> have concerns about the document, please state those too.
> 
> Authors please indicate if you are aware of any IPR on the document.
> 
> 
> [1]
> https://tools.ietf.org/html/draft-ietf-netconf-subscribed-notification
> s-10
> 
> 
> Kent & Mahesh
> 
> 
> 
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Fri, 16 Mar 2018 22:11:25 +0000

Hi Qin,

>  Qin Wu, March 16, 2018 3:34 PM
>  

I think you are asking why it is *not* defined in the RPC, but it is within the notification.

The reason is that the protocol used for establishing the subscription via RPC is already part of the RPC, so it is known/implicit.

However for the notification (below), we choose to send over *all* parameters which have been configured to maximize visibility.  As protocol has been configured, it is sent.

+---n subscription-started {configured}?
   +--ro identifier               subscription-id
   +--ro protocol                 transport {configured}? ....

> Is protocol parameter can be extended to support other transport protocol?

Yes.   To do this add new identities of base "transport"

> Is there any dependency between protocol and DSCP?

No.

> Is there any key difference between "subscription-completed" and
> "subscription-resumed", it looks replay-completed is used to push All event
> record before stop time expires, would it be great to clarify this in section
> 2.7.6?

Yes, subscription-completed means that a stop-time has been reached.  Right now I am improving the definition in the YANG model for the identity to say:

This notification is sent to indicate that a subscription has finished passing event records, as the stop-time has been reached.

Thanks,
Eric