Subject: Re: [Netconf] LC on yang-push-15

From: Qin Wu <[email-masked]>
Date: Fri, 16 Mar 2018 19:21:37 +0000

A few comments to follow up.
1. Section 3.10 said the implementation is not capable of on-change notification for a particular object since small object changes are frequent and meaningless (e.g., a temperature gauge changing 0.1 degrees).
Further it said it will be important for client applications to have a way to identify for which objects on-change notifications are supported and for which ones they are not supported.

But In my understanding, this issue has already been resolved by using dampening period mechanism since as described in section 3.1,when NETCONF server know undesirable to send a rapid series of object changes, it will set dampening period parameter to prevent this.

2. What is the difference between dampening period in effect and object value in effect that are discussed in section 3.1?
3.What is the difference between period interval and periodical time interval? Pleae make sure the terminology consistent to avoid confusion.
4.Try to understand whether change type is operation type? Which change type indicate simply object value change? It is not clear from the typedef change-type?
5.It looks Encoding for contents of periodical and on change YANG push update is only applied to datastore-changes and datastore-contents defined under push update notification and push change update? What am I missing?

-Qin
-----邮件原件-----
发件人: Netconf [mailto:[email-masked]] 代表 Qin Wu
发送时间: 2018年3月7日 9:45
收件人: Kent Watsen <[email-masked]>; [email-masked]
主题: Re: [Netconf] LC on yang-push-15

I have reviewed the latest version and supported for publication.

-Qin
> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of Kent 
> Watsen
> Sent: Wednesday, February 28, 2018 6:08 PM
> To: [email-masked]
> Subject: [Netconf] LC on yang-push-15
> 
> 
> WG,
> 
> The authors of netconf-event-notifications have indicated privately 
> that they believe this document is now ready for Last Call.
> 
> This starts a 2.5-week Last Call on draft-ietf-netconf-yang-push-15 
> [1] The LC will end on March 17, or when active threads peter out.
> 
> Please send your comments on this thread. Reviews of the document, and 
> statement of support, are particularly helpful to the authors.  If you 
> have concerns about the document, please state those too.
> 
> Authors please indicate if you are aware of any IPR on the document.
> 
> 
> [1] https://tools.ietf.org/html/draft-ietf-netconf-yang-push-15
> 
> 
> Kent & Mahesh
> 
> 
> 
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: "Alexander Clemm" <[email-masked]>
Date: Tue, 20 Mar 2018 06:56:20 -0000

Hi Qin,

Thank you for your support! Couple of responses below, <ALEX>

--- Alex

-----Original Message-----
From: Netconf <[email-masked]> On Behalf Of Qin Wu
Sent: Friday, March 16, 2018 7:22 PM
To: Kent Watsen <[email-masked]>; [email-masked]
Subject: Re: [Netconf] LC on yang-push-15

<ALEX> Yes, this is addressed by the dampening period.  How to indicate for which objects on-change notifications are supported was removed from this document and is now left to implementations; that aspect will be addressed by a new draft, draft-lengyel-netconf-notification-capabilities.
</ALEX>

2. What is the difference between dampening period in effect and object value in effect that are discussed in section 3.1?
<ALEX> I am not sure I understand your question?  When a dampening period is in effect, an update sent at the end of the dampening period will include the value of the object(s) that is then current.  If the value of an object changes from 5 to 6 during the period, and at the end of the period it is 7, 7 is the value that will be reported.  Does this clarify?</ALEX>

3.What is the difference between period interval and periodical time interval? Pleae make sure the terminology consistent to avoid confusion.
<ALEX> I don't see any instances of "periodical time interval" in the document?  Basically, we have periodic subscriptions that will result in periodic updates; the time interval is the period interval.  There is a single instance of "periodic time interval"; I think where this occurs it is clear what it refers to but we will rephrase this to "period interval" in the next revision.  </ALEX> 

4.Try to understand whether change type is operation type? Which change type indicate simply object value change? It is not clear from the typedef change-type?
<ALEX> The change-type refers to different types of changes that can trigger an update.  For example, a create, a replace, a delete, etc.  In conjunction with objects such as "excluded-change", this can be used by a client to specify which types of updates are of interest (and exclude those that are not).  </ALEX>

5.It looks Encoding for contents of periodical and on change YANG push update is only applied to datastore-changes and datastore-contents defined under push update notification and push change update? What am I missing?
<ALEX> The encoding refers to the way in which updates are represented in the update notifications.  </ALEX>

-Qin
-----邮件原件-----
发件人: Netconf [mailto:[email-masked]] 代表 Qin Wu
发送时间: 2018年3月7日 9:45
收件人: Kent Watsen <[email-masked]>; [email-masked]
主题: Re: [Netconf] LC on yang-push-15

-Qin