Subject: Re: [Netconf] LC on yang-push-15

From: Xufeng Liu <[email-masked]>
Date: Tue, 6 Mar 2018 19:55:46 +0000

Support for publication. The authors have resolve the issues raised recently..

Thanks,
- Xufeng

> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of Kent Watsen
> Sent: Wednesday, February 28, 2018 6:08 PM
> To: [email-masked]
> Subject: [Netconf] LC on yang-push-15
> 
> 
> WG,
> 
> The authors of netconf-event-notifications have indicated privately that they
> believe this document is now ready for Last Call.
> 
> This starts a 2.5-week Last Call on draft-ietf-netconf-yang-push-15 [1] The LC
> will end on March 17, or when active threads peter out.
> 
> Please send your comments on this thread. Reviews of the document, and
> statement of support, are particularly helpful to the authors.  If you have
> concerns about the document, please state those too.
> 
> Authors please indicate if you are aware of any IPR on the document.
> 
> 
> [1] https://tools.ietf.org/html/draft-ietf-netconf-yang-push-15
> 
> 
> Kent & Mahesh
> 
> 
> 
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: Igor Bryskin <[email-masked]>
Date: Tue, 6 Mar 2018 23:44:45 +0000

Yes, support,
Igor
From:Kent Watsen
To:[email-masked],
Date:2018-02-28 18:08:53
Subject:[Netconf] LC on yang-push-15

WG,

The authors of netconf-event-notifications have indicated privately that they believe this document is now ready for Last Call.

This starts a 2.5-week Last Call on draft-ietf-netconf-yang-push-15 [1]
The LC will end on March 17, or when active threads peter out.

Please send your comments on this thread. Reviews of the document, and statement of support, are particularly helpful to the authors.  If you have concerns about the document, please state those too.

Kent & Mahesh

---

From: Tianran Zhou <[email-masked]>
Date: Wed, 7 Mar 2018 02:32:20 +0000

I have read the latest version and support the progress of the document.

Cheer,
Tianran

> Sent: Thursday, March 01, 2018 7:08 AM
> To: [email-masked]
> The authors of netconf-event-notifications have indicated privately that
> they believe this document is now ready for Last Call.
>

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 7 Mar 2018 22:25:00 +0100

+1 on yang-push-15

Viele Grüße,

Henk

---

From: Balazs Lengyel <[email-masked]>
Date: Mon, 19 Mar 2018 13:24:19 +0000

Hell,

I have reviewed and support this draft if my 2 MAJOR comments are addressed.

Some comments:

P7) Generally a number of items are repeated in the draft which makes it 
longer then necessary.  Paragraph: " On-change subscriptions can be 
refined to let users subscribe only to .." could be removed.

Bullet 1.: Just before the change: how can a node know before the change 
that it will happen?

P15) Paragraphs 2 and 3 seem to contradict each other.  Para2. states "A 
publisher MUST allow ..." while Pra 3. states the same MAY be rejected.

P16) "Update records for a single subscription MAY NOT be resequenced"  
Use MUST NOT

P17)
Remove 3.11.2   It says the same as chapter 3.4
4.1  reference the RFC about the tree diagrams instead of describing 
them hereP21) Modify-subscription:  Why can't the resync and excluded 
operation be modified?

P24) Why does the resynch-subscription-error contain period-hints and 
filter-failure-hint ?

P28)  MAJOR
Figure 8 does not follow the YANG model of subscribed-notifications

General) MAJOR
When an error is returned will the identity string contain the prefix? 
According to YANG 1.1 it should however all examples omit it.

P34)
Why is resynch not allowed for configured on-change notifications?
identity datastore-not-subscribable: may indicate the datastore is not 
present at all

P35) "the response's 'error-info' may contain:" unfinished sentence

P46) anydata datastore-changes: delta includes config false nodes

regards Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909              email: [email-masked]

---

From: "Alexander Clemm" <[email-masked]>
Date: Tue, 20 Mar 2018 07:22:14 -0000

Hi Balazs,

Thank you for your comments!  We had already a brief discussion on this in person.  We will address the editorial comments in the next revision; brief replies below just on the items that you called out as "major" (still essentially editorial in nature), <ALEX>.

Thanks
--- Alex

-----Original Message-----
From: Netconf <[email-masked]> On Behalf Of Balazs Lengyel
Sent: Monday, March 19, 2018 1:24 PM
To: Kent Watsen <[email-masked]>; [email-masked]
Subject: Re: [Netconf] LC on yang-push-15

Hell,

Some comments:

P7) Generally a number of items are repeated in the draft which makes it longer then necessary.  Paragraph: " On-change subscriptions can be refined to let users subscribe only to .." could be removed.

Bullet 1.: Just before the change: how can a node know before the change that it will happen?

P15) Paragraphs 2 and 3 seem to contradict each other.  Para2. states "A publisher MUST allow ..." while Pra 3. states the same MAY be rejected.

P16) "Update records for a single subscription MAY NOT be resequenced" Use MUST NOT

P17)
Remove 3.11.2   It says the same as chapter 3.4
4.1  reference the RFC about the tree diagrams instead of describing them hereP21) Modify-subscription:  Why can't the resync and excluded operation be modified?

P24) Why does the resynch-subscription-error contain period-hints and filter-failure-hint ?

P28)  MAJOR

<ALEX> We will fix the example. </ALEX>

General) MAJOR

<ALEX> We will fix any errors in the examples, of course; however, I am not entirely sure regarding which specific issue you are referring to, can you be more specific?   In https://tools.ietf.org/html/draft-ietf-netconf-netconf-event-notifications-08#page-8, section 8, it is clearly specified what error-app-tag will contain, and the examples are consistent with that.  There is an implicit "identity-to-string" conversion that is applied.  RFC 6241 specifies "error-app-tag:  Contains a string identifying the data-model-specific or implementation-specific error condition, if one exists. "  There is no specific mention of a prefix being required nor do I see one in examples there.  I am also not sure I see it in RFC 7950.  (We can perhaps also clarify this offline) 
</ALEX>

P34)
Why is resynch not allowed for configured on-change notifications?
identity datastore-not-subscribable: may indicate the datastore is not present at all

regards Balazs

On 2/28/2018 11:08 PM, Kent Watsen wrote:
> This starts a 2.5-week Last Call on draft-ietf-netconf-yang-push-15 
> [1] The LC will end on March 17, or when active threads peter out.
>

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 20 Mar 2018 14:34:32 +0000

After speaking personally with the other authors, I fully support all 3 
drafts.

regards Balazs