Subject: Re: [Netconf] LC on netconf-event-notifications-08

From: Qin Wu <[email-masked]>
Date: Fri, 16 Mar 2018 19:25:22 +0000

One followup comment.
Section 4, 1st paragraph said:
"
A publisher is allowed to concurrently support both
   [I-D.draft-ietf-netconf-subscribed-notifications] and [RFC5277]'s
   "create-subscription" RPC,
"
There is no "create-subscription" RPC in [I-D.draft-ietf-netconf-subscribed-notifications]? Is "create-subscription" RPC  referred to as “establish-subscription” defined in in [I-D.draft-ietf-netconf-subscribed-notifications]? How is “establish-subscription” Compatibility with RFC-5277's create-subscription? “establish-subscription”  and “create-subscription” can not be used in the same NETCONF session?
 
Section 6.2 configured subscription
Why draft-ietf-netconf-netconf-event-notifications-08
Is a separate draft instead of part of draft-ietf-netconf-subscribed-notifications-10 since the state machine for a configured subscription is mainly defined in draft-ietf-netconf-subscribed-notifications-10?	

-Qin
-----邮件原件-----
发件人: Netconf [mailto:[email-masked]] 代表 Qin Wu
发送时间: 2018年3月7日 9:47
收件人: Kent Watsen <[email-masked]>; [email-masked]
主题: Re: [Netconf] LC on netconf-event-notifications-08

Support for LC.

-Qin
> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of Kent 
> Watsen
> Sent: Wednesday, February 28, 2018 6:11 PM
> To: [email-masked]
> Subject: [Netconf] LC on netconf-event-notifications-08
> 
> WG,
> 
> The authors of netconf-event-notifications have indicated privately 
> that they believe this document is now ready for Last Call.
> 
> This starts a 2.5-week Last Call on draft-ietf-netconf-netconf-event-
> notifications-08 [1] The LC will end on March 17, or when active 
> threads peter out.
> 
> Please send your comments on this thread. Reviews of the document, and 
> statement of support, are particularly helpful to the authors.  If you 
> have concerns about the document, please state those too.
> 
> Authors please indicate if you are aware of any IPR on the document.
> 
> 
> [1]
> https://tools.ietf.org/html/draft-ietf-netconf-netconf-event-notificat
> ions-08
> 
> 
> Kent & Mahesh
> 
> 
> 
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Fri, 16 Mar 2018 22:28:00 +0000

Hi Qin,

Thanks for the comments.  Thoughts in-line...

> Qin Wu, March 16, 2018 3:25 PM
> 
> One followup comment.
> There is no "create-subscription" RPC in [I-D.draft-ietf-netconf-subscribed-
> notifications]? Is "create-subscription" RPC  referred to as “establish-
> subscription” defined in in [I-D.draft-ietf-netconf-subscribed-notifications]?

No.  The create-subscription RPC is actually in RFC-5277.    The subscribed-notifications draft provides establish-subscription as an evolved version of that older RPC.    Nevertheless, a publisher might wish to support both the older and the newer specifications

> How is “establish-subscription” Compatibility with RFC-5277's create-
> subscription? “establish-subscription”  and “create-subscription” can not be
> used in the same NETCONF session?

Correct.  They cannot be used in the same session.

> Is a separate draft instead of part of draft-ietf-netconf-subscribed-notifications-
> 10 since the state machine for a configured subscription is mainly defined in
> draft-ietf-netconf-subscribed-notifications-10?

The subscribed-notifications draft is transport independent.     netconf-event-notifications provides details on how allow subscriptions over NETCONF.  Another draft not currently in last call (draft-ietf-netconf-restconf-notif) describes how to allow subscriptions over RESTCONF or HTTTP.    Other transport binding drafts exist for UDP.  Some are being written up for CBOR.

To get an idea of the interplay between many of the different drafts, read:
draft-voit-netconf-subscription-and-notif-overview 

Eric