Subject: [Netconf] IETF 101 SN Question 3: DSCP as its own feature?

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 3 Apr 2018 20:12:50 +0000

In London, we agreed to get feedback on the following question from the list:

In draft-ietf-netconf-subscribed-notifications, should 'dscp' be its own optional feature?  Or should it be mandatory to implement?

For more on the discussion (and to view the slide) see:
https://youtu.be/KJtg-J-6CZM?t=34m2s
https://etherpad.tools.ietf.org/p/notes-ietf-101-netconf?useMonospaceFont=true

I have no strong preference, but would default to mandatory-to-implement as we already have many optional features, and this is fairly simple.  Thoughts?

On a related discussion, I would like to propose renaming 'dscp' to 'priority'.   The reason is that I have received feedback that the object name 'dscp' will never make it through the IESG, as DSCP is a well-known object in the IP header.  And even though everyone in implementation will map to DSCP, applications are actually requesting a network priority rather than a DSCP.   So any objections to me making the change?

Eric

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 3 Apr 2018 16:20:01 -0400

DSCP and Priority are two different (related but distinct concepts).
The field should be named according to what you want to manipulate.  The 
current text seems to have a meaning closer to DSCP than to Priority.

Yours,
Joel

On 4/3/18 4:12 PM, Eric Voit (evoit) wrote:
> In draft-ietf-netconf-subscribed-notifications, should ‘dscp’ be its own 
> optional feature?  Or should it be mandatory to implement?
> 
> I have no strong preference, but would default to mandatory-to-implement 
> as we already have many optional features, and this is fairly simple.  
> Thoughts?
> 
> On a related discussion, I would like to propose renaming ‘dscp’ to 
> ‘priority’.   The reason is that I have received feedback that the 
> object name ‘dscp’ will never make it through the IESG, as DSCP is a 
> well-known object in the IP header. And even though everyone in 
> implementation will map to DSCP, applications are actually requesting a 
> network priority rather than a DSCP.   So any objections to me making 
> the change?
> 
> Eric
> 
> 
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 3 Apr 2018 22:19:05 +0000

Hi Joel,

I certainly have no issues with leaving it as dscp, and seeing if the IESG would rather it be renamed.

Eric

> > In London, we agreed to get feedback on the following question from
> > the
> > list:
> >
> > In draft-ietf-netconf-subscribed-notifications, should 'dscp' be its
> > own optional feature?  Or should it be mandatory to implement?
> >
> > I have no strong preference, but would default to
> > mandatory-to-implement as we already have many optional features, and
> this is fairly simple.
> > Thoughts?
> >
> > On a related discussion, I would like to propose renaming 'dscp' to
> > 'priority'.   The reason is that I have received feedback that the
> > object name 'dscp' will never make it through the IESG, as DSCP is a
> > implementation will map to DSCP, applications are actually requesting
> > a network priority rather than a DSCP.   So any objections to me
> > making the change?
> >
> > Eric
> >
> >
> >

---

From: Joel Halpern Direct <[email-masked]>
Date: Tue, 3 Apr 2018 18:24:49 -0400

Leaving it as DSCP has the advantage that it becomes there problem to 
come up with another name for it.

Yours,
Joel

---

From: Alexander Clemm <[email-masked]>
Date: Tue, 10 Apr 2018 23:30:25 +0000

So I guess this means option 2 on the slides.  Declare separate features for DSCP and QoS.  Works for me.  
--- Alex

> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of Eric Voit (evoit)
> Sent: Tuesday, April 03, 2018 3:19 PM
> To: Joel M. Halpern <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Netconf] IETF 101 SN Question 3: DSCP as its own feature?
> 
> Hi Joel,
> 
> > The field should be named according to what you want to manipulate.
> > The current text seems to have a meaning closer to DSCP than to Priority.
> >
> > Yours,
> > Joel
> >
> > > https://etherpad.tools.ietf.org/p/notes-ietf-101-netconf?useMonospac
> > > eF
> > > ont=true
> > >
> > >
> > > implementation will map to DSCP, applications are actually
> > > requesting a network priority rather than a DSCP.   So any
> > > objections to me making the change?
> > >
> > > Eric
> > >
> > >
> > >

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Mon, 16 Apr 2018 21:14:50 +0000

Alex and Martin expressed a preference for DSCP as its own separate feature.  And so that is the way it is reflected in the just posted v12 version of:
https://datatracker.ietf.org/doc/draft-ietf-netconf-subscribed-notifications

Unless anyone has a strong issue here, let's close Question 3.

Eric

From: Netconf <[email-masked]> On Behalf Of Eric Voit (evoit)
Sent: Tuesday, April 3, 2018 4:13 PM
To: [email-masked]
Subject: [Netconf] IETF 101 SN Question 3: DSCP as its own feature?

Eric