Subject: [Netconf] Does ietf-yang-library support includes device/nms system or both?

From: MALLI KOSURI <[email-masked]>
Date: Wed, 30 May 2018 18:42:02 +0000

Hello,

As per RFC suggested a server advertises ietf-yang-libaray capabilities, does this applies both a Device or a NMS system implemented using YANG/YANG 1.1, is this true? Are there any exceptions included?

https://tools.ietf.org/html/rfc7950#section-1.1

A server advertises support for YANG 1.1 modules by using

      ietf-yang-library [RFC7895<https://tools.ietf.org/html/rfc7895>] instead of listing them as

      capabilities in the <hello> message.

Thanks
Malli

This message has been classified General Business by MALLI KOSURI on 31 May 2018 at 00:11:58.

---

From: Kent Watsen <[email-masked]>
Date: Wed, 30 May 2018 18:50:05 +0000

Hi Malli,

An NMS that presents a NETCONF or RESTCONF based northbound interface is effectively the "server" for those connections, while being the "client" for the connections to devices it manages via its southbound interface.

Kent

On 5/30/18, 2:42 PM, "Netconf on behalf of MALLI KOSURI" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hello,

https://tools.ietf.org/html/rfc7950#section-1.1<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_rfc7950-23section-2D1.1&d=DwMF-g&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=FeAVwFzFO2xLx9qTCI9azj6ekyllcwiOP3hj1o8s2DI&s=2Jq8OKlIVEMeeWkVW-yc8b2cnXd0wtQxVKIezWSFR28&e=>

      ietf-yang-library [RFC7895<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_rfc7895&d=DwMF-g&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=FeAVwFzFO2xLx9qTCI9azj6ekyllcwiOP3hj1o8s2DI&s=fQQiWG3eaZLQJtmE27iDgv9hdo_56hGuEYsuRvh-W3Q&e=>] instead of listing them as

Thanks
Malli