Subject: [Netconf] How would RESTCONF access multiple datastores defined by NMDA

From: Henry Yu <[email-masked]>
Date: Tue, 29 May 2018 17:23:07 -0400

Hi,

According to my understanding of RFC 8040, there is only one datastore
(which is represented by "{+restconf}/data"). But NMDA introduces multiple
datastores. How does RESTCONF provide access to them? I think a RESTCONF
user would, at minimum, need the access to the <running> and the
<operational>.

Thanks,
Henry
P.S., I would not find an answer in the mailing list's archive. My
apologies if this question has already been asked/answered.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Tue, 29 May 2018 21:49:27 +0000

Hi Henry,

Please take a look @ draft-ietf-netconf-nmda-restconf

Regards,
Reshad.

From: Netconf <[email-masked]> on behalf of Henry Yu <[email-masked]>
Date: Tuesday, May 29, 2018 at 5:23 PM
To: "[email-masked]" <[email-masked]>
Subject: [Netconf] How would RESTCONF access multiple datastores defined by NMDA

Hi,

According to my understanding of RFC 8040, there is only one datastore  (which is represented by "{+restconf}/data"). But NMDA introduces multiple datastores. How does RESTCONF provide access to them? I think a RESTCONF user would, at minimum, need the access to the <running> and the <operational>.

Thanks,
Henry
P.S., I would not find an answer in the mailing list's archive. My apologies if this question has already been asked/answered.