Subject: Re: [Netconf] Adoption poll for crypto-types and trust-anchors

From: Kent Watsen <[email-masked]>
Date: Tue, 1 May 2018 21:57:24 +0000

[I'll get the ball rolling, please, others chime in too]

I support the adoption of these two drafts to replace the existing keystore draft.

Regarding the "certificate-expiration" notification defined in ietf-crypto-types, I would like to discuss removing it, or moving it to be a descendent of the "certificates-grouping" grouping (also in ietf-crypto-types) and maybe also place a copy of the notification in the ietf-trust-anchors module.  That said, I don't like having several otherwise identical notifications in different namespaces, but I do like how the server can incrementally add support for expirations on a feature-by-feature basis.

Kent // contributor

===== original message =====

This is the start of a *two* week poll for adopting the following two drafts as working group documents, specifically to replace draft-ietf-netconf-keystore, which would be removed as a working group document: 

  draft-kwatsen-netconf-crypto-types-00
  draft-kwatsen-netconf-trust-anchors-00

This call for adoption is the result of the Keystore draft presentation given in London.  When the various options were discussed, most preferred to move forward with these two drafts, as opposed to looking to do more factoring or extending to scope to include things not needed by our various client/server drafts.  No one expressed interest in moving forward with draft-ietf-netconf-keystore.  While we could separately confirm this result again on the list, we believe that an adoption call more efficiently achieves two goals at once.

Please send email to the list indicating "yes/support" or "no/do not support".  If indicating no, please state your reservations with the document.  If yes, please also feel free to provide comments you'd like to see addressed once the document is a WG document.

Kent (and Mahesh and Ignas)

_______________________________________________
Netconf mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netconf&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=qXS002RrOOkzqTDm70cWjg7eJeWqtpC_anWUcc9a_3I&s=1W689R8ht-U3FoffJ5uTT24SAPRtiQ9a9B3VxQxM_Wg&e=

---

From: Andy Bierman <[email-masked]>
Date: Tue, 1 May 2018 16:03:02 -0700

Hi,

Is there a problem with multiple YANG modules in the same RFC?
Does replacing the draft with 2 new drafts (later 2 RFCs) really help?
The RFC that gets referenced in an importing module is not important.

I support refactoring YANG modules before they get to RFC publication.
This has minimal cost if done before the RFC is published.

Andy

On Tue, May 1, 2018 at 2:57 PM, Kent Watsen <[email-masked]> wrote:

> Regarding the "certificate-expiration" notification defined in
> ietf-crypto-types, I would like to discuss removing it, or moving it to be
> a descendent of the "certificates-grouping" grouping (also in
> ietf-crypto-types) and maybe also place a copy of the notification in the
> ietf-trust-anchors module.  That said, I don't like having several
> otherwise identical notifications in different namespaces, but I do like
> how the server can incrementally add support for expirations on a
> feature-by-feature basis.
>
> Kent // contributor
>
>
> This is the start of a *two* week poll for adopting the following two
> drafts as working group documents, specifically to replace
> draft-ietf-netconf-keystore, which would be removed as a working group
> document:
>
> This call for adoption is the result of the Keystore draft presentation
> given in London.  When the various options were discussed, most preferred
> to move forward with these two drafts, as opposed to looking to do more
> factoring or extending to scope to include things not needed by our various
> client/server drafts.  No one expressed interest in moving forward with
> draft-ietf-netconf-keystore.  While we could separately confirm this result
> again on the list, we believe that an adoption call more efficiently
> achieves two goals at once.
>
> Please send email to the list indicating "yes/support" or "no/do not
> support".  If indicating no, please state your reservations with the
> document.  If yes, please also feel free to provide comments you'd like to
> see addressed once the document is a WG document.
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_netconf&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=
> qXS002RrOOkzqTDm70cWjg7eJeWqtpC_anWUcc9a_3I&s=1W689R8ht-
> U3FoffJ5uTT24SAPRtiQ9a9B3VxQxM_Wg&e=
>
>
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 02 May 2018 10:08:34 +0200 (CEST)

Hi,

I support the adoption of these two drafts.

/martin

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 2 May 2018 10:46:18 -0700

Support adoption.

// as contributor.

> On May 1, 2018, at 2:57 PM, Kent Watsen <[email-masked]> wrote:
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netconf&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=qXS002RrOOkzqTDm70cWjg7eJeWqtpC_anWUcc9a_3I&s=1W689R8ht-U3FoffJ5uTT24SAPRtiQ9a9B3VxQxM_Wg&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netconf&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=qXS002RrOOkzqTDm70cWjg7eJeWqtpC_anWUcc9a_3I&s=1W689R8ht-U3FoffJ5uTT24SAPRtiQ9a9B3VxQxM_Wg&e=>
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netconf <https://www.ietf.org/mailman/listinfo/netconf>
Mahesh Jethanandani
[email-masked]