Subject: [Netconf] RFC6470bis vs New draft on NMDA Base Event

From: Qin Wu <[email-masked]>
Date: Tue, 19 Jun 2018 09:19:06 +0000

One issue raised in last meeting what need to be modified in RFC6470 to support NMDA and whether it is a good idea to make bis for RFC6470 to 
cover additional new event related to NMDA. 

The con:
republish YANG notifications that are not changing is not a good idea
NMDA event not specific to NETCONF, although RFC6470 allows NETONF Base Event applied to non-Netconf session by setting session-id to zero.
NETCONF session without NMDA support can not understand new NMDA event.
The Pro:
One Base Event notification module cover all events which help monitor lifecycle of Netconf session change.

After discussing with RFC6470 author, we decide to separate NMDA notification from NETCONF base event notification. 
Comments or suggestions if you have different opinion.

-Qin
-----邮件原件-----
发件人: Qin Wu 
发送时间: 2018年6月19日 17:12
收件人: [email-masked]
抄送: [email-masked]'
主题: RE: New Version Notification for draft-wu-netconf-base-notification-nmda-01.txt

Hi, folks:
We rewrite NMDA Base Event draft based on last meeting discussion in the netconf session and re-scope to NMDA specific Base Event Notification definition. 
The changes include:
1. remove ietf-netconf-data-change notification which has potential overlapping with YANG push on change update mechanism.
2.Add NMDA data validation notification to keep track of the validation result of <intended> data-store and  the reason why the configuration were not applied.
3. Problem space change in the introduction.
https://www.ietf.org/rfcdiff?url2=draft-wu-netconf-base-notification-nmda-01

We would like to request WG to adopt this draft. Please indicate if you like this draft or idea.
Many thanks.

-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2018年6月19日 16:46
收件人: Rohit R Ranade; Rohit R Ranade; Qin Wu
主题: New Version Notification for draft-wu-netconf-base-notification-nmda-01.txt

A new version of I-D, draft-wu-netconf-base-notification-nmda-01.txt
has been successfully submitted by Qin Wu and posted to the IETF repository.

Name:		draft-wu-netconf-base-notification-nmda
Revision:	01
Title:		Base Notifications for NMDA
Document date:	2018-06-19
Group:		Individual Submission
Pages:		10
URL:            https://www.ietf.org/internet-drafts/draft-wu-netconf-base-notification-nmda-01.txt
Status:         https://datatracker.ietf.org/doc/draft-wu-netconf-base-notification-nmda/
Htmlized:       https://tools.ietf.org/html/draft-wu-netconf-base-notification-nmda-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-wu-netconf-base-notification-nmda
Diff:           https://www.ietf.org/rfcdiff?url2=draft-wu-netconf-base-notification-nmda-01

Abstract:
   The Network Configuration Protocol (NETCONF) provides mechanisms to
   manipulate configuration datastores.  NMDA introduces additional
   datastores for systems that support more advanced processing chains
   converting configuration to operational state.  However, client
   applications are not able to be aware of common events pertaining to
   additional datstores, such as a data validation state change in
   NETCONF server, that may impact management applications.  This
   document updates [RFC6470] to allow a NETCONF client to receive
   additional notifications for some common system events pertaining to
   the Network Management Datastore Architecture (NMDA) defined in
   [RFC8342].

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Tue, 19 Jun 2018 09:33:57 +0000

Qin/All,

So if we don't bis6470 then how do we handle the datastore leaf in RFC6470 not supporting the new NMDA data stores?

BR,
Tim

-----Original Message-----
From: Qin Wu [mailto:[email-masked]] 
Sent: Tuesday, June 19, 2018 5:19 PM
To: [email-masked]
Cc: Carey, Timothy (Nokia - US) <[email-masked]>; Andy Bierman <[email-masked]>
Subject: RFC6470bis vs New draft on NMDA Base Event

One issue raised in last meeting what need to be modified in RFC6470 to support NMDA and whether it is a good idea to make bis for RFC6470 to cover additional new event related to NMDA. 

The con:
republish YANG notifications that are not changing is not a good idea NMDA event not specific to NETCONF, although RFC6470 allows NETONF Base Event applied to non-Netconf session by setting session-id to zero.
NETCONF session without NMDA support can not understand new NMDA event.
The Pro:
One Base Event notification module cover all events which help monitor lifecycle of Netconf session change.

-Qin
-----邮件原件-----
发件人: Qin Wu
发送时间: 2018年6月19日 17:12
收件人: [email-masked]
抄送: [email-masked]'
主题: RE: New Version Notification for draft-wu-netconf-base-notification-nmda-01.txt

Hi, folks:

-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2018年6月19日 16:46
收件人: Rohit R Ranade; Rohit R Ranade; Qin Wu
主题: New Version Notification for draft-wu-netconf-base-notification-nmda-01.txt

Abstract:

The IETF Secretariat

---

From: Qin Wu <[email-masked]>
Date: Tue, 19 Jun 2018 10:46:26 +0000

My understanding is base events defined in RFC6470 is unchanged, but if we want to see base events defined in RFC6470 also applicable to
New NMDA datastores, I think these existing base event may need to be updated as well, to indicate specific NMDA datastore that need to be changed,
e.g., netconf-config-change
However based on our analysis, netconf-config-change is only applicable to <running> and <startup> . <intended> and <operational> is read only and 
Can not be changed by user in a specific management session. Other base events doesn't have datastore leaf. Therefore base event defined in RFC6470
Can keep as it does. Hope this answer your question.

-Qin
-----邮件原件-----
发件人: Carey, Timothy (Nokia - US) [mailto:[email-masked]] 
发送时间: 2018年6月19日 17:34
收件人: Qin Wu; [email-masked]
抄送: Andy Bierman
主题: RE: RFC6470bis vs New draft on NMDA Base Event

Qin/All,

BR,
Tim

-----Original Message-----
From: Qin Wu [mailto:[email-masked]] 
Sent: Tuesday, June 19, 2018 5:19 PM
To: [email-masked]
Cc: Carey, Timothy (Nokia - US) <[email-masked]>; Andy Bierman <[email-masked]>
Subject: RFC6470bis vs New draft on NMDA Base Event

The con:

-Qin
-----邮件原件-----
发件人: Qin Wu
发送时间: 2018年6月19日 17:12
收件人: [email-masked]
抄送: [email-masked]'
主题: RE: New Version Notification for draft-wu-netconf-base-notification-nmda-01.txt

Hi, folks:

-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2018年6月19日 16:46
收件人: Rohit R Ranade; Rohit R Ranade; Qin Wu
主题: New Version Notification for draft-wu-netconf-base-notification-nmda-01.txt

Abstract:

The IETF Secretariat

---

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Tue, 19 Jun 2018 13:01:12 +0000

Qin,

It does - thanks for the explaination.

BR,
Tim

-----Original Message-----
From: Qin Wu [mailto:[email-masked]] 
Sent: Tuesday, June 19, 2018 6:46 PM
To: Carey, Timothy (Nokia - US) <[email-masked]>; [email-masked]
Cc: Andy Bierman <[email-masked]>
Subject: RE: RFC6470bis vs New draft on NMDA Base Event

My understanding is base events defined in RFC6470 is unchanged, but if we want to see base events defined in RFC6470 also applicable to New NMDA datastores, I think these existing base event may need to be updated as well, to indicate specific NMDA datastore that need to be changed, e.g., netconf-config-change However based on our analysis, netconf-config-change is only applicable to <running> and <startup> . <intended> and <operational> is read only and Can not be changed by user in a specific management session. Other base events doesn't have datastore leaf. Therefore base event defined in RFC6470 Can keep as it does. Hope this answer your question.

-Qin
-----邮件原件-----
发件人: Carey, Timothy (Nokia - US) [mailto:[email-masked]]
发送时间: 2018年6月19日 17:34
收件人: Qin Wu; [email-masked]
抄送: Andy Bierman
主题: RE: RFC6470bis vs New draft on NMDA Base Event

Qin/All,

BR,
Tim

-----Original Message-----
From: Qin Wu [mailto:[email-masked]]
Sent: Tuesday, June 19, 2018 5:19 PM
To: [email-masked]
Cc: Carey, Timothy (Nokia - US) <[email-masked]>; Andy Bierman <[email-masked]>
Subject: RFC6470bis vs New draft on NMDA Base Event

The con:

-Qin
-----邮件原件-----
发件人: Qin Wu
发送时间: 2018年6月19日 17:12
收件人: [email-masked]
抄送: [email-masked]'
主题: RE: New Version Notification for draft-wu-netconf-base-notification-nmda-01.txt

Hi, folks:

-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2018年6月19日 16:46
收件人: Rohit R Ranade; Rohit R Ranade; Qin Wu
主题: New Version Notification for draft-wu-netconf-base-notification-nmda-01.txt

Abstract:

The IETF Secretariat