Subject: Re: [Netconf] I-D Action: draft-ietf-netconf-yang-push-16.txt

From: Alexander Clemm <[email-masked]>
Date: Tue, 12 Jun 2018 17:51:46 +0000

Hi Tom,
thank you for your comments.  We will address this as we post an updated revision shortly.
Kind regards
--- Alex

> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of t.petch
> Sent: Thursday, May 31, 2018 3:02 AM
> To: [email-masked]
> Subject: Re: [Netconf] I-D Action: draft-ietf-netconf-yang-push-16.txt
> 
> This I-D would appear to have a number of defects in the YANG module.
> 
> - no Copyright
> 
> - no request to the RFC Editor to update the revision date to the publication date
> 
> - no Reference statements for
>      import ietf-yang-types { prefix yang;}
>      import ietf-subscribed-notifications {prefix sn;  }
>      import ietf-datastores {prefix ds; }
>      import ietf-restconf   { prefix rc;
> 
> - Restconf is an Informative Reference in the I-D
> 
> - no reference in the I-D for yang-types
> 
> - I-D references RFC7223 which is obsoleted by RFC8343
> 
> Tom Petch
> 
> 
> ----- Original Message -----
> From: <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, May 31, 2018 7:50 AM
> 
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> > This draft is a work item of the Network Configuration WG of the IETF.
> >
> >         Title           : YANG Datastore Subscription
> >         Authors         : Alexander Clemm
> >                           Eric Voit
> >                           Alberto Gonzalez Prieto
> >                           Ambika Prasad Tripathy
> >                           Einar Nilsen-Nygaard
> >                           Andy Bierman
> >                           Balazs Lengyel
> > Filename        : draft-ietf-netconf-yang-push-16.txt
> > Pages           : 54
> > Date            : 2018-05-30
> >
> > Abstract:
> >    Via the mechanism described in this document, subscriber
> applications
> >    may request a continuous, customized stream of updates from a YANG
> >    datastore.  Providing such visibility into changes made upon YANG
> >    configuration and operational datastore nodes enables new
> >    capabilities based on the remote mirroring of configuration and
> >    operational state.
> >
> >
> > The IETF datatracker status page for this draft is:
> > https://datatracker.ietf.org/doc/draft-ietf-netconf-yang-push/
> >
> > There are also htmlized versions available at:
> > https://tools.ietf.org/html/draft-ietf-netconf-yang-push-16
> > https://datatracker.ietf.org/doc/html/draft-ietf-netconf-yang-push-16
> >
> > A diff from the previous version is available at:
> > https://www.ietf.org/rfcdiff?url2=draft-ietf-netconf-yang-push-16
> >
> >
> > Please note that it may take a couple of minutes from the time of
> submission
> > until the htmlized version and diff are available at tools.ietf.org.
> >
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> >
> > _______________________________________________
> > I-D-Announce mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/i-d-announce
> > Internet-Draft directories: http://www.ietf.org/shadow.html or
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: Alexander Clemm <[email-masked]>
Date: Tue, 12 Jun 2018 17:51:46 +0000

Hi Tom,

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 13 Jun 2018 08:52:32 +0200

Hi,

just one nit: I noticed that in the example in Figure 10
<error-app-tag> has a mismatched closing XML tag </error-message>.

Lada

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67