Subject: [Netconf] Editorial comments on draft-kwatsen-netmod-artwork-folding-05

From: "Jonathan Hansford" <[email-masked]>
Date: Tue, 26 Jun 2018 15:45:36 +0000

Hi,

Just a few editorial comments on 
draft-kwatsen-netmod-artwork-folding-05:
General:Though there is a header to indicate where the artwork starts, 
there is no footer to indicate where it ends. How would a parser know 
when to stop? Should the header (and footer) be deleted for any artwork 
that does not require folding?Section 4.1: 1st paragraph: A very minor 
issue, but "e.g." and "etc." should not be used in the same list. "e.g." 
is used for a list of examples and by implication isn't complete, 
therefore "etc." is already inferred.2nd paragraph: Not sure what the 
1st sentence is saying. 2nd sentence: s/susceptible is/susceptible to3rd 
sentence: s/fair/fairsSection 4.2, 3rd paragraph, 1st sentence: 
repetition of "out" - one of them needs removingSection 5.2:2nd 
paragraph, 1st sentence: s/than then/than the3rd paragraph, 1st 
sentence: s/be lead/leadSection 5.3:2nd paragraph: 
s/Caluculate/Calculate4th paragraph: Arguably this should be from 
bottom-to-top as, going from top-to-bottom, once you have concatenated 
two lines the '\' will not be on the folding-column
Jonathan

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

---

From: Qin Wu <[email-masked]>
Date: Wed, 27 Jun 2018 08:09:47 +0000

Thanks Jonathan for comments, please see my reply inline below.

发件人: Netconf [mailto:[email-masked]] 代表 Jonathan Hansford
发送时间: 2018年6月26日 23:46
收件人: [email-masked]
主题: [Netconf] Editorial comments on draft-kwatsen-netmod-artwork-folding-05

Hi,

Just a few editorial comments on draft-kwatsen-netmod-artwork-folding-05:

  *   General:

     *   Though there is a header to indicate where the artwork starts, there is no footer to indicate where it ends. How would a parser know when to stop?
[Qin]: Good point, if you follows netmod discussion, Martin has similar suggestion. We need to decide whether we should support fold framing or extract artwork based on header and footer in this draft.

     *   Should the header (and footer) be deleted for any artwork that does not require folding?
[Qin]If we allow the user to specify maximum length limit for each line, I think header and footer is not needed,
        If we use header and footer to indicate where the line start and where the line end, header and footer is only needed during artwork extraction phase.

  *   Section 4.1:

     *   1st paragraph: A very minor issue, but "e.g." and "etc." should not be used in the same list. "e.g." is used for a list of examples and by implication isn't complete, therefore "etc." is already inferred.
                          [Qin]: Okay.

     *   2nd paragraph:

        *   Not sure what the 1st sentence is saying.
                      [Qin] Suppose the artwork is a table, the table needs to be folded, folding result may look bad.

        *   2nd sentence: s/susceptible is/susceptible to
        *   3rd sentence: s/fair/fairs
                    [Qin]: Okay, thanks.

  *   Section 4.2, 3rd paragraph, 1st sentence: repetition of "out" - one of them needs removing
  *   Section 5.2:

     *   2nd paragraph, 1st sentence: s/than then/than the
     *   3rd paragraph, 1st sentence: s/be lead/lead
               [Qin]: Okay, thanks.

  *   Section 5.3:

     *   2nd paragraph: s/Caluculate/Calculate
     *   4th paragraph: Arguably this should be from bottom-to-top as, going from top-to-bottom, once you have concatenated two lines the '\' will not be on the folding-column
            [Qin]:In our code, we will delete unneeded ‘\’ line by line from top to bottom. It think whether from bottom to top or from top to bottom, it doesn’t matter since it is implementation specific.
Jonathan

[https://ipmcdn.avast.com/images/icons/icon-envelope-tick-round-orange-animated-no-repeat-v1.gif]<https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient>

Virus-free. www.avast.com<https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient>

---

From: "Jonathan Hansford" <[email-masked]>
Date: Wed, 27 Jun 2018 08:54:47 +0000

Re Section 4.1, 2nd paragraph, can I suggest the first sentence be 
reworded along the lines of "Fundamentally, the issue is whether the 
artwork remains readable once folded." And I would add that sentence to 
the end of the previous paragraph and start paragraph 2 afterwards.

------ Original Message ------
From: "Qin Wu" <[email-masked]>
To: "Jonathan Hansford" <[email-masked]>; "[email-masked]" 
<[email-masked]>; "[email-masked]" <[email-masked]>
Sent: 27/06/2018 09:09:47
Subject: RE: [Netconf] Editorial comments on 
draft-kwatsen-netmod-artwork-folding-05

>收件人:[email-masked]
>when to stop?
>[Qin]: Good point, if you follows netmod discussion, Martin has similar 
>suggestion. We need to decide whether we should support fold framing or 
>extract artwork based on header and footer in this draft.
>
>Should the header (and footer) be deleted for any artwork that does not 
>require folding?
>[Qin]If we allow the user to specify maximum length limit for each 
>line, I think header and footer is not needed,
>
>         If we use header and footer to indicate where the line start 
>and where the line end, header and footer is only needed during artwork 
>extraction phase.
>
>Section 4.1: 1st paragraph: A very minor issue, but "e.g." and "etc." 
>should not be used in the same list. "e.g." is used for a list of 
>examples and by implication isn't complete, therefore "etc." is already 
>inferred.
>                           [Qin]: Okay.
>
>2nd paragraph: Not sure what the 1st sentence is saying.
>                       [Qin] Suppose the artwork is a table, the table 
>needs to be folded, folding result may look bad.
>
>2nd sentence: s/susceptible is/susceptible to3rd sentence: s/fair/fairs
>                     [Qin]: Okay, thanks.
>
>Section 4.2, 3rd paragraph, 1st sentence: repetition of "out" - one of 
>them needs removingSection 5.2:2nd paragraph, 1st sentence: s/than 
>then/than the3rd paragraph, 1st sentence: s/be lead/lead
>                [Qin]: Okay, thanks.
>
>Section 5.3:2nd paragraph: s/Caluculate/Calculate4th paragraph: 
>Arguably this should be from bottom-to-top as, going from 
>top-to-bottom, once you have concatenated two lines the '\' will not be 
>on the folding-column
>             [Qin]:In our code, we will delete unneeded ‘\’ line by line 
>from top to bottom. It think whether from bottom to top or from top to 
>bottom, it doesn’t matter since it is implementation specific.
>
>Jonathan
>
>
>
><https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient>
>
>Virus-free. www.avast.com 
><https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient>
>
>
>

---

---

From: Qin Wu <[email-masked]>
Date: Wed, 27 Jun 2018 09:14:08 +0000

Good suggestion, thanks Jonathan.

-Qin
发件人: Jonathan Hansford [mailto:[email-masked]]
发送时间: 2018年6月27日 16:55
收件人: Qin Wu; [email-masked]; [email-masked]
主题: Re[2]: [Netconf] Editorial comments on draft-kwatsen-netmod-artwork-folding-05

Re Section 4.1, 2nd paragraph, can I suggest the first sentence be reworded along the lines of "Fundamentally, the issue is whether the artwork remains readable once folded." And I would add that sentence to the end of the previous paragraph and start paragraph 2 afterwards.

------ Original Message ------
From: "Qin Wu" <[email-masked]<mailto:[email-masked]>>
To: "Jonathan Hansford" <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Sent: 27/06/2018 09:09:47
Subject: RE: [Netconf] Editorial comments on draft-kwatsen-netmod-artwork-folding-05

发件人: Netconf [mailto:[email-masked]<mailto:[email-masked]>] 代表 Jonathan Hansford
发送时间: 2018年6月26日 23:46
收件人: [email-masked]<mailto:[email-masked]>
主题: [Netconf] Editorial comments on draft-kwatsen-netmod-artwork-folding-05

Hi,

  *   General:

  *   Section 4.1:

     *   2nd paragraph:

  *   Section 5.3:

     *   2nd paragraph: s/Caluculate/Calculate
     *   4th paragraph: Arguably this should be from bottom-to-top as, going from top-to-bottom, once you have concatenated two lines the '\' will not be on the folding-column
            [Qin]:In our code, we will delete unneeded ‘\’ line by line from top to bottom. I think whether from bottom to top or from top to bottom, it doesn’t matter since it is implementation specific.
Jonathan