Subject: [Netconf] stream-filter list in draft-ietf-netconf-subscribed-notifications

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Fri, 15 Jun 2018 14:51:09 +0000

Minor question: why don’t the names of the container wrapper (filters) and the list (stream-filter) match (e.g. filters and filter or stream-filters and stream-filter), is it because we could have another list with other types of filters? If that’s the case, shouldn’t there be a container wrapper stream-filters for the list stream-filter. Looked in the archive and didn’t find discussions on this.

Regards,
Reshad.

  container filters {
    description
      "This container contains a list of configurable filters
       that can be applied to subscriptions.  This facilitates
       the reuse of complex filters once defined.";
    list stream-filter {
      key "identifier";
      description
        "A list of pre-configured filters that can be applied to
        subscriptions.";
      leaf identifier {
        type filter-id;
        description
          "An identifier to differentiate between filters.";
      }
      uses stream-filter-elements;
    }
  }

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Fri, 15 Jun 2018 15:23:16 +0000

Hi Reshad,

From: Reshad Rahman, June 15, 2018 10:51 AM

Minor question: why don’t the names of the container wrapper (filters) and the list (stream-filter) match (e.g. filters and filter or stream-filters and stream-filter), is it because we could have another list with other types of filters?

<Eric>  This is exactly why.  YANG-Push augments in selection-filters.

If that’s the case, shouldn’t there be a container wrapper stream-filters for the list stream-filter. Looked in the archive and didn’t find discussions on this.

<Eric> The container “filters” is because there it is a top level container.  It doesn’t seem necessary to have independent containers underneath for the lists of stream-filters and selection-filters.

Eric

Regards,
Reshad.

  container filters {
    description

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Fri, 15 Jun 2018 16:15:19 +0000

Thanks Eric, makes sense.

From: "Eric Voit (evoit)" <[email-masked]>
Date: Friday, June 15, 2018 at 11:23 AM
To: "Reshad Rahman (rrahman)" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: stream-filter list in draft-ietf-netconf-subscribed-notifications

Hi Reshad,

Eric

Regards,
Reshad.

  container filters {
    description