Subject: [Netconf] is "boot image" the right term?

From: Kent Watsen <[email-masked]>
Date: Tue, 21 Aug 2018 19:49:02 +0000

Regarding what the zerotouch draft calls it, a person responsible for JUNOS builds told me that the term "boot image" may not be a good one; that it means different things to different people and will lead to confusion.  

He suggests "software image" or "software package".

Does anyone have any thoughts about this?

Kent // contributor

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 21 Aug 2018 14:57:12 -0700

> On Aug 21, 2018, at 12:49 PM, Kent Watsen <[email-masked]> wrote:
> 
> 
> He suggests "software image" or "software package”.

I would think that boot-image is more descriptive than “software image” or “software package”. Maybe adding a definition of boot-image in the terminology section would alleviate any confusion people might have.

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

Mahesh Jethanandani // as contributor.
[email-masked]

---

From: Qin Wu <[email-masked]>
Date: Thu, 23 Aug 2018 09:43:30 +0000

-----邮件原件-----
发件人: Netconf [mailto:[email-masked]] 代表 Mahesh Jethanandani
发送时间: 2018年8月22日 5:57
收件人: Kent Watsen
抄送: [email-masked]
主题: Re: [Netconf] is "boot image" the right term?

> Does anyone have any thoughts about this?

[Qin]: Try to figure whether boot image is related to VM image, does boot image also include operating system?
I see 'software image' is a more generic term than boot image. "software package” is also good to me.

---

From: tom petch <[email-masked]>
Date: Thu, 23 Aug 2018 11:31:24 +0000

----- Original Message -----
From: "Mahesh Jethanandani" <[email-masked]>
To: "Kent Watsen" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, August 21, 2018 10:57 PM

> > Regarding what the zerotouch draft calls it, a person responsible
for JUNOS builds told me that the term "boot image" may not be a good
one; that it means different things to different people and will lead to
confusion.
> I would think that boot-image is more descriptive than “software
 image” or “software package”. Maybe adding a definition of boot-image
in the terminology section would alleviate any confusion people might
have.

I agree.

I am unclear which part of 'boot image' is thought  inappropriate.
'boot' is used in a large number of places in the I-D, by itself, in
bootstrap, BOOTP and so on so the use here of 'boot' seems right.

And what is being loaded is an image, that is something that needs no,
or very little, processing, not like code that needs compiling, linking
or some other processing before it can run.  You load the image, you
reboot and you have a system.  I know of no other word that conveys that
meaning (even if .img files are only loosely related).

That said, I would look again at the wording of
..able to update the boot image..
..includes updating the boot image,..
..raw boot image file ..
since, for me, you take or leave an image, you do not update it and it
is what it is, not raw, cooked or whatever.

Tom Petch

---

From: Kent Watsen <[email-masked]>
Date: Thu, 23 Aug 2018 14:37:24 +0000

Thanks, all.

Let's keep the current "boot image" usage then.

Kent

----- Original Message -----
From: "Mahesh Jethanandani" <[email-masked]>
To: "Kent Watsen" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, August 21, 2018 10:57 PM

I agree.

Tom Petch

> > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netconf&d=DwIGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=7IOUACFtaMOnYNPiMdQQihSqrAcQNBSJpOnZjQaCiVg&s=kEdcCyRuhZTrLgeM4QICztea6Qu-bF5WtuRR95uDj0Q&e=
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netconf&d=DwIGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=7IOUACFtaMOnYNPiMdQQihSqrAcQNBSJpOnZjQaCiVg&s=kEdcCyRuhZTrLgeM4QICztea6Qu-bF5WtuRR95uDj0Q&e=
>