Subject: Re: [Netconf] should onboarding information *set* the debug level?

From: Kent Watsen <[email-masked]>
Date: Mon, 27 Aug 2018 19:34:07 +0000

No comments on this?   vendor-decision or operator-decision?

Kent

----- original message ------

Hey folks,

The current (-23) zerotouch text, with all the additional progress report types, says that it's a vendor implementation decision as to whether the device sends, to a trusted bootstrapping server, just the minimal/required progress reports, or the maximal number of progress reports, for better visibility/debugability.

It occurs to me that it would be a better thing to flip this from being a vendor-decision to being an operator-decision, to specify how much debugging the operator wants reported.  This could be added as a flag in the onboarding information itself.

What do people think, worth it?

Kent // author

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 27 Aug 2018 13:25:00 -0700

It makes sense that it be a operator-decision. After all they are the ones in the field trying to diagnose the problem in the field.

> On Aug 27, 2018, at 12:34 PM, Kent Watsen <[email-masked]> wrote:
> 
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

Mahesh Jethanandani // as contributor
[email-masked]

---

From: Kent Watsen <[email-masked]>
Date: Tue, 28 Aug 2018 19:44:00 +0000

Hi Mahesh, all,

> It makes sense that it be an operator-decision. After all they are
> the ones in the field trying to diagnose the problem in the field.

In thinking about how to enable an operator (via a bootstrap server) to
indicate that it would like "verbose" progress reports, I came up with
the following.

  rpc get-bootstrapping-data {
    input {
      ...
    }
    output {
      leaf reporting-level {
        default standard;
        type enumeration {
          enum standard {
            description
              "Send just the progress reports required by RFC XXXX.";
          }
          enum verbose {
            description
              "Send additional progress reports that might help
               troubleshooting an SZTP bootstrapping issue.";
          }
        }
        description
          "Specifies the reporting level for progress reports the
           bootstrap server would like to receive when processing
           onboarding information.  Progress reports are not sent
           when processing redirect information.";
      }
      leaf zerotouch-information {...}
      leaf owner-certificate {...}
      leaf ownership-voucher {...}
  }

Note that it's a value, being an RPC output leaf, is outside of the 
standard zerotouch information artifact, which is perfect for this.

My only question is, when wouldn't a bootstrap server set it to
"verbose"?  ;)

Do people like or dislike this direction?

Kent // contributor

---

From: Kent Watsen <[email-masked]>
Date: Fri, 31 Aug 2018 19:29:32 +0000

No comments after a few days.   I will proceed with the assumption that
the proposed solution is okay.  

Kent // author

-----Original Message-----

Hi Mahesh, all,

Note that its value, being an RPC output leaf, is outside of the 
zerotouch information artifact, which seems perfect for this.

Kent // contributor

_______________________________________________
Netconf mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netconf&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=a0XPEigzgdYjfNHIBQBW7R7uCzPnLnWyVIpxUGYtRSk&s=3o3csxwIJBuIvzQ5qufX_XDB8V9hXiS1e0Ypol_jrrw&e=