Subject: Re: [Netconf] I-D Action: draft-wu-netconf-restconf-factory-restore-03.txt

From: Qin Wu <[email-masked]>
Date: Fri, 12 Oct 2018 06:47:55 +0000

A new version factory restore draft has been posted
https://tools.ietf.org/html/draft-wu-netconf-restconf-factory-restore-03
The main changes include:
o  Restructured
o  Made new datastore optional
o  Removed Netconf capability
o  Listed Open issues

-Qin
-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2018年10月12日 8:45
收件人: [email-masked]
主题: I-D Action: draft-wu-netconf-restconf-factory-restore-03.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Factory default Setting
        Authors         : Qin Wu
                          Balazs Lengyel
                          Ye Niu
	Filename        : draft-wu-netconf-restconf-factory-restore-03.txt
	Pages           : 10
	Date            : 2018-10-11

Abstract:
   This document defines a method to reset a YANG datastore to its
   factory-default content.  The reset operation may be used e.g. during
   initial zero-touch configuration or when the existing configuration
   has major errors, so re-starting the configuration process from
   scratch is the best option.

   A new reset-datastore RPC is defined.  Several methods of documenting
   the factory-default content are specified.

   Optionally a new "factory-default" read-only datastore is defined,
   that contains the data that will be copied over to the running
   datastore at reset.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-wu-netconf-restconf-factory-restore/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-wu-netconf-restconf-factory-restore-03
https://datatracker.ietf.org/doc/html/draft-wu-netconf-restconf-factory-restore-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-wu-netconf-restconf-factory-restore-03

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Rohit R Ranade <[email-masked]>
Date: Fri, 12 Oct 2018 07:13:09 +0000

Some suggestions.

1.  I feel "ietf-factory" is a better module name when compared to "ietf-factory-reset" as the latter is more restrictive.
2.  I feel that we need to add a section which shows difference between <startup> and <factory-default>. Maybe we can add below section for it.

"3.1  Difference between <startup> datastore and <factory-default> datastore
   
       When the device first boots up, the content of the <startup> and <factory-default> will be identical. 
The content of <startup> can be subsequently changed by using <startup> as a target in a 
<copy-config> operation.  The <factory-default> is a read-only datastore and it is usually static as described
in earlier sections.
"

3.  Whether "factory-reset-config" / "factory-restore-config" is a better RPC name ? As it will be similar to "copy-config", only that now the source is <factory-default> datastore.
4.  The datastore name as <factory> is sufficient I feel, as the only factory datastore coming will be this one.

With Regards,
Rohit

-----Original Message-----
From: Netconf [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: 12 October 2018 12:18
To: [email-masked]
Subject: Re: [Netconf] I-D Action: draft-wu-netconf-restconf-factory-restore-03.txt

-Qin
-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2018年10月12日 8:45
收件人: [email-masked]
主题: I-D Action: draft-wu-netconf-restconf-factory-restore-03.txt

Abstract:

Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Qin Wu <[email-masked]>
Date: Wed, 17 Oct 2018 07:57:20 +0000

Thanks Rohi.

-----邮件原件-----
发件人: Rohit R Ranade 
发送时间: 2018年10月12日 15:13
收件人: Qin Wu; [email-masked]
主题: RE: I-D Action: draft-wu-netconf-restconf-factory-restore-03.txt

Some suggestions.

1.  I feel "ietf-factory" is a better module name when compared to "ietf-factory-reset" as the latter is more restrictive.
[Qin]: Understand, currently we only define one new rpc that is factory-reset, I think we need a more generic name if there is some other RPCs that need to be defined.

   
       When the device first boots up, the content of the <startup> and <factory-default> will be identical. 
The content of <startup> can be subsequently changed by using <startup> as a target in a <copy-config> operation.  The <factory-default> is a read-only datastore and it is usually static as described in earlier sections.
"
[Qin]: I agree with the difference between these two datastores, will see how to incorporate them in.

[Qin]: I think this is datastore level operation, it will be more accurate to call it datastore-reset as we proposed. Regarding reset and restore, I think they are equivalent.

4.  The datastore name as <factory> is sufficient I feel, as the only factory datastore coming will be this one.
[Qin]: Point taken, will see how to tweak it.

With Regards,
Rohit

-----Original Message-----
From: Netconf [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: 12 October 2018 12:18
To: [email-masked]
Subject: Re: [Netconf] I-D Action: draft-wu-netconf-restconf-factory-restore-03.txt

-Qin
-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2018年10月12日 8:45
收件人: [email-masked]
主题: I-D Action: draft-wu-netconf-restconf-factory-restore-03.txt

Abstract: