Subject: [Netconf] I-D Action: draft-ietf-netconf-subscribed-notifications-18.txt

From: [email-masked]
Date: Tue, 23 Oct 2018 16:41:18 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Configuration WG of the IETF.

        Title           : Subscription to YANG Event Notifications
        Authors         : Eric Voit
                          Alexander Clemm
                          Alberto Gonzalez Prieto
                          Einar Nilsen-Nygaard
                          Ambika Prasad Tripathy
	Filename        : draft-ietf-netconf-subscribed-notifications-18.txt
	Pages           : 77
	Date            : 2018-10-23

Abstract:
   This document defines a YANG data model and associated mechanisms
   enabling subscriber-specific subscriptions to a publisher's event
   streams.  Applying these elements allows a subscriber to request for
   and receive a continuous, custom feed of publisher generated
   information.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netconf-subscribed-notifications/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-netconf-subscribed-notifications-18
https://datatracker.ietf.org/doc/html/draft-ietf-netconf-subscribed-notifications-18

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netconf-subscribed-notifications-18

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 24 Oct 2018 15:58:12 +0000

Very minimal changes.   

(a) Name change to unify the set of subscription drafts

(b) Transport leaf made optional in the YANG model.

(c) Nit fix per the thread "WGLC on restconf-notif-08".  SN should have always had the same behavior between <modify-subscription> and <delete-subscription> in whether they need to come from the same subscriber as the <establish-subscription>.    The behavior is now re-unified with the text. 

Still tracking the outcome of the "xpath expressions in JSON" thread on the NETMOD list.   This has implications across many drafts.   

Eric

-----Original Message-----
From: Netconf <[email-masked]> On Behalf Of [email-masked]
Sent: Tuesday, October 23, 2018 7:41 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Netconf] I-D Action: draft-ietf-netconf-subscribed-notifications-18.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf