Subject: Re: [Netconf] Solicit comments on inline action capability for NETCONF

From: Qin Wu <[email-masked]>
Date: Thu, 25 Oct 2018 13:30:37 +0000

发件人: Robert Wilton [mailto:[email-masked]]
发送时间: 2018年7月17日 20:09
收件人: Qin Wu; [email-masked]
抄送: Eric Voit (evoit)
主题: Re: [Netconf] Solicit comments on inline action capability for NETCONF

Hi Qin,

Having read this draft, I can understand what the draft is proposing, but I don't currently understand why this is useful.  Specifically, I don't find the example that is in the draft as compelling.  If the desire is to set the MTU and enable the interface as one configuration operation, then wouldn't the client just configure both mtu and enabled leaves at the same time.  Why is a separate action required here to enable the interface?

So I'm struggling to think of actions that apply to configuration datastores where the same behaviour cannot just be achieved via a simple configuration manipulation.  One use case could be wanting to repeat the same configuration on many interfaces at the same time, but for this, I think that a configuration templating solution would be preferable rather than using actions, and a templating would probably just reused edit-config/edit-data.  So, if you have some other more concrete examples of actions that apply to configuration datastores, that might be helpful.

[Qin]: Come back for this discussion. One typical example is Configure multiple UserVLANTag range on trunk interface Ethernet0/0

UserVLANTag Range 1 [1,5]

UserVLANTag Range [6,10]

Using configuration template to replicate multiple copies on the same interface from the client to the server result in a significant amount of signaling traffic(e.g,edit-config operation related to protocol message) on a periodic basis, in this example, we require 10 time exchange between the client and the server(device).

With inline action, we can introduce bulk operation, so we only need to send one protocol message for such bulk operatio, configuration template can also be used in this case, the difference is configuration template is only used within the server, which is more efficient.

Another question (which I think is similar to the one that Eric has also asked) is whether to have transactions that mix configuration operations and action operations on <operational>.  E.g. perhaps enable an interface and reset the counters at the same time, or perform some config change and establish a dynamic subscription at the same time.  But I question how robust this would end up being (I'm not generally a fan of distributed transactions - they never seem to be as robust as they claim to be).  Perhaps one for future thought and discussion.

[Qin]: Withdraw such case.

Thanks,
Rob

On 03/07/2018 22:01, Qin Wu wrote:
Hi, Folks:
We have posted inline action capability draft on Jun 28:
https://www.ietf.org/mail-archive/web/netconf/current/msg14823.html

One comment we received from the list is:

https://www.ietf.org/mail-archive/web/netconf/current/msg14863.html

The v-(01) is uploaded to address this comment.
Therefore we would like to draw you attention again on this draft

https://tools.ietf.org/html/draft-zheng-netconf-inline-action-capability-01
We would like to receive more review and feedback on this draft, thanks.

-Qin

_______________________________________________

Netconf mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/netconf

---

From: Robert Wilton <[email-masked]>
Date: Thu, 25 Oct 2018 14:46:04 +0100

Hi Qin,

On 25/10/2018 14:30, Qin Wu wrote:
>
> *发件人:*Robert Wilton [mailto:[email-masked]]
> *发送时间:*2018年7月17日20:09
> *收件人:*Qin Wu; [email-masked]
> *抄送:*Eric Voit (evoit)
> *主题:*Re: [Netconf] Solicit comments on inline action capability for 
> NETCONF
>
> Hi Qin,
>
> Having read this draft, I can understand what the draft is proposing, 
> but I don't currently understand why this is useful.  Specifically, I 
> don't find the example that is in the draft as compelling.  If the 
> desire is to set the MTU and enable the interface as one configuration 
> operation, then wouldn't the client just configure both mtu and 
> enabled leaves at the same time.  Why is a separate action required 
> here to enable the interface?
>
> So I'm struggling to think of actions that apply to configuration 
> datastores where the same behaviour cannot just be achieved via a 
> simple configuration manipulation.  One use case could be wanting to 
> repeat the same configuration on many interfaces at the same time, but 
> for this, I think that a configuration templating solution would be 
> preferable rather than using actions, and a templating would probably 
> just reused edit-config/edit-data.  So, if you have some other more 
> concrete examples of actions that apply to configuration datastores, 
> that might be helpful.
>
> [Qin]: Come back for this discussion. One typical example is Configure 
> multiple UserVLANTag range on trunk interface Ethernet0/0
>
> Using configuration template to replicate multiple copies on the same 
> interface from the client to the server result in a significant amount 
> of signaling traffic(e.g,edit-config operation related to protocol 
> message) on a periodic basis, in this example, we require 10 time 
> exchange between the client and the server(device).
>
I'm sorry, but I don't follow this example.  Why can't this be done as a 
single edit-config request that updates all the VLANs in a single message?

Thanks,
Rob

> With inline action, we can introduce bulk operation, so we only need 
> to send one protocol message for such bulk operatio, configuration 
> template can also be used in this case, the difference is 
> configuration template is only used within the server, which is more 
> efficient.
>
> Another question (which I think is similar to the one that Eric has 
> also asked) is whether to have transactions that mix configuration 
> operations and action operations on <operational>.  E.g. perhaps 
> enable an interface and reset the counters at the same time, or 
> perform some config change and establish a dynamic subscription at the 
> same time.  But I question how robust this would end up being (I'm not 
> generally a fan of distributed transactions - they never seem to be as 
> robust as they claim to be).  Perhaps one for future thought and 
> discussion.
>
>     [email-masked] <mailto:[email-masked]>
>

---

From: Qin Wu <[email-masked]>
Date: Thu, 25 Oct 2018 14:56:05 +0000

If you configure 100 interfaces, specify 10 vlan tag for each interface, the message size will be extremely long. In addition, it doesn't support vlan range merge or split.

发件人： Robert Wilton
收件人： Qin Wu<[email-masked]<mailto:[email-masked]>>;netconf<[email-masked]<mailto:[email-masked]>>
抄送： Eric Voit (evoit)<[email-masked]<mailto:[email-masked]>>
主题： Re: [Netconf] Solicit comments on inline action capability for NETCONF
时间： 2018-10-25 21:46:28

Hi Qin,

On 25/10/2018 14:30, Qin Wu wrote:
发件人: Robert Wilton [mailto:[email-masked]]
发送时间: 2018年7月17日 20:09
收件人: Qin Wu; [email-masked]<mailto:[email-masked]>
抄送: Eric Voit (evoit)
主题: Re: [Netconf] Solicit comments on inline action capability for NETCONF

Hi Qin,

UserVLANTag Range [6,10]

I'm sorry, but I don't follow this example.  Why can't this be done as a single edit-config request that updates all the VLANs in a single message?

Thanks,
Rob

Thanks,
Rob

-Qin

Netconf mailing list