Subject: [Netconf] Comments on draft-ietf-netconf-netconf-event-notifications-13

From: "Tim Jenkins (timjenki)" <[email-masked]>
Date: Tue, 9 Oct 2018 18:48:42 +0000

All,

I have reviewed https://tools.ietf.org/html/draft-ietf-netconf-netconf-event-notifications-13 and while I have minor comments, I support this moving forward.

My minor comments are:

* In section 2, should there be a statement that there are no additional terms defined?

* Section 5: Suggest rephrasing this
"For a dynamic subscription a "modify-subscription", "delete-
   subscription", or "resynch-subscription" RPC MUST be sent using same
   the NETCONF session"
to
   "For a dynamic subscription, the "modify-subscription", "delete-
   subscription", or "resynch-subscription" RPCs MUST be sent using same
   the NETCONF session".
because two of them can be used multiple times per subscription.

* Section A.4: I'm not sure how useful the XPath specification would as examples of filters, since the filters are so specific the what the stream provides.

* References: It looks like some of the links to outside items are inconsistent. For example, the first two are different in both heading and reference (one to datatracker).

Thanks,

Tim

--
Cisco Systems Canada Co.
2000 Innovation Drive
Kanata, ON, Canada, K2K 3E8
Preferences <http://www.cisco.com/offer/subscribe/?sid=000478326>
Unsubscribe <http://www.cisco.com/offer/unsubscribe/?sid=000478327>
Privacy <http://www.cisco.com/web/siteassets/legal/privacy.html>

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 9 Oct 2018 19:44:56 +0000

Thanks Tim.   In-line...

From: Netconf <[email-masked]> On Behalf Of Tim Jenkins (timjenki)
Sent: Tuesday, October 9, 2018 2:49 PM
To: [email-masked]
Subject: [Netconf] Comments on draft-ietf-netconf-netconf-event-notifications-13

All,

My minor comments are:

<Eric> Added the statement.

<eric> Updated.   Made it:
“For a dynamic subscription, any "modify-subscription", "delete-subscription", or "resynch-subscription" RPCs MUST be sent using the same NETCONF session”

<eric> This section was requested by Martin, and recently added.  The value is that it becomes possible to link an event notification from an existing YANG model (i.e., RFC-8347), to the syntax of how filters can be continuously changes.

<eric> unified the formatting.  I think this will just become RFC links when all is complete here (i.e., through the queue), so not sure if this will impact the end product.

Eric

Thanks,

Tim