Subject: [Netconf] I-D Action: draft-ietf-netconf-subscribed-notifications-19.txt

From: [email-masked]
Date: Tue, 18 Dec 2018 09:59:23 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Configuration WG of the IETF.

        Title           : Subscription to YANG Event Notifications
        Authors         : Eric Voit
                          Alexander Clemm
                          Alberto Gonzalez Prieto
                          Einar Nilsen-Nygaard
                          Ambika Prasad Tripathy
	Filename        : draft-ietf-netconf-subscribed-notifications-19.txt
	Pages           : 78
	Date            : 2018-12-18

Abstract:
   This document defines a YANG data model and associated mechanisms
   enabling subscriber-specific subscriptions to a publisher's event
   streams.  Applying these elements allows a subscriber to request for
   and receive a continuous, custom feed of publisher generated
   information.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netconf-subscribed-notifications/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-netconf-subscribed-notifications-19
https://datatracker.ietf.org/doc/html/draft-ietf-netconf-subscribed-notifications-19

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netconf-subscribed-notifications-19

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 19 Dec 2018 14:52:02 +0100 (CET)

Hi,

The YANG module in this draft doesn't compile.  The new text for the
XPath context contains double quote characters.  I suggest you change
them to single quotes.

/martin

[email-masked] wrote:
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 19 Dec 2018 17:03:03 +0000

Thanks Martin,

I have the version addressing the double quotes here:

https://github.com/netconf-wg/rfc5277bis/blob/master/draft-ietf-netconf-subscribed-notifications-20.xml

Before I upload this -20, I want to see if you have concerns with the Pyang Validation issue shown below.   Reshad mentioned that other users have seen it.  Is this something which should stop me from posting?

Eric

----------------------------------
[email-masked]
Pyang Validation
Traceback (most recent call last):
pyang", line 444, in <module>
    run()
pyang", line 219, in run
    repos = pyang.FileRepository(path, no_path_recurse=o.no_path_recurse)
__init__.py", line 408, in __init__
    location = pip.locations.distutils_scheme('pyang')
AttributeError: 'module' object has no attribute 'locations'
Pyang Output
No warnings or errors

> -----Original Message-----

> From: Netconf <[email-masked]> On Behalf Of Martin Bjorklund

> Sent: Wednesday, December 19, 2018 8:52 AM

> To: [email-masked]

> Subject: Re: [Netconf] I-D Action: draft-ietf-netconf-subscribed-notifications-

> 19.txt

> The YANG module in this draft doesn't compile.  The new text for the XPath

> context contains double quote characters.  I suggest you change them to single

> quotes.

> [email-masked]<mailto:[email-masked]> wrote:

> > https://datatracker.ietf.org/doc/draft-ietf-netconf-subscribed-notific

> > ations/

> > https://tools.ietf.org/html/draft-ietf-netconf-subscribed-notification

> > s-19

> > https://datatracker.ietf.org/doc/html/draft-ietf-netconf-subscribed-no

> > tifications-19

> > https://www.ietf.org/rfcdiff?url2=draft-ietf-netconf-subscribed-notifi

> > cations-19

> > Please note that it may take a couple of minutes from the time of

> > submission until the htmlized version and diff are available at tools.ietf.org.

> > [email-masked]<mailto:[email-masked]>

> [email-masked]<mailto:[email-masked]>

---

From: Carl Moberg <[email-masked]>
Date: Wed, 19 Dec 2018 20:37:10 +0100

Eric,

 No, it’s a bug on my side. Working to fix now. Apologies.

> On Dec 19, 2018, at 6:03 PM, Eric Voit (evoit) <[email-masked]> wrote:
> 
> Thanks Martin,
>

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 19 Dec 2018 20:40:27 +0100 (CET)

> Before I upload this -20, I want to see if you have concerns with the Pyang Validation issue shown below.   Reshad mentioned that other users have seen it.  Is this something which should stop me f…

You get this error b/c you are running an old version of pyang that
isn't compatible with the (newer) version of pip on your system.  I
suggest you upgrade pyang.

/martin

---

From: Carl Moberg <[email-masked]>
Date: Thu, 20 Dec 2018 00:37:15 +0100

> On Dec 19, 2018, at 8:40 PM, Martin Bjorklund <[email-masked]> wrote:
> 

 Yup, thanks. Upgraded and yangvalidator.org now works (better).

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 19 Dec 2018 23:46:06 +0000

Hi Carl,

Yangvalidator.org has the following errors for -20, pyang is fine though.

Regards,
Reshad.

Confdc Output
[email-masked]:18: error: module 'ietf-yang-schema-mount' not found
yanglint Validation
err : Data model "ietf-yang-schema-mount" not found.
err : Importing "ietf-yang-schema-mount" module into "ietf-network-instance" failed.
err : Module "ietf-network-instance" parsing failed.
err : Importing "ietf-network-instance" module into "ietf-subscribed-notifications" failed.
err : Module "ietf-subscribed-notifications" parsing failed.

On 2018-12-19, 6:37 PM, "Netconf on behalf of Carl Moberg" <[email-masked] on behalf of [email-masked]> wrote:

---

From: Carl Moberg <[email-masked]>
Date: Thu, 20 Dec 2018 00:57:10 +0100

Reshad,

 Yes, so the YANG modules in the draft tries to import the 'ietf-yang-schema-mount’ and 'ietf-network-instance' YANG modules which are not available in the repo in the validator. The reason why we don’t keep them in the repo is that the specification that defines those modules (draft-ietf-netmod-schema-mount, and draft-ietf-rtgwg-ni-model respectively) are not published yet and we only keep published YANG modules.

 The easiest way forward is probably to extract the YANG modules from your draft (perhaps using the https://github.com/xym-tool/xym tool), zip up your module with the imported modules and validate them using the “Upload multiple YANG files or a zip archive” option.

 I am considering storing draft-level YANG files (they are many and broken :-) in the validator repo as well. Maybe time to revisit that.

> On Dec 20, 2018, at 12:46 AM, Reshad Rahman (rrahman) <[email-masked]> wrote:
> 
> Hi Carl,
>

---

From: Carl Moberg <[email-masked]>
Date: Thu, 20 Dec 2018 01:13:10 +0100

Actually, and to put a finer point on the below. I do extract YANG modules from drafts, but only store those that pass extraction and validation. And it turns out that validation of the module extracted from https://www.ietf.org/id/draft-ietf-netmod-schema-mount-12.txt fails because the file name in the CODE BEGINS marker is missing the “.yang” suffix which violates https://tools.ietf.org/html/rfc6087#section-3.1.

> On Dec 20, 2018, at 12:57 AM, Carl Moberg <[email-masked]> wrote:
> 
> Reshad,
>

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 20 Dec 2018 08:46:35 +0100 (CET)

Carl Moberg <[email-masked]> wrote:
> 
>  Actually, and to put a finer point on the below. I do extract YANG
>  modules from drafts, but only store those that pass extraction and
>  validation. And it turns out that validation of the module
>  extracted from
>  https://www.ietf.org/id/draft-ietf-netmod-schema-mount-12.txt fails
>  because the file name in the CODE BEGINS marker is missing the
>  “.yang” suffix which violates
>  https://tools.ietf.org/html/rfc6087#section-3.1.

whoops.  now fixed in my local copy of the tool I use to generate
drafts.

The same tool, same error, was used to render 
draft-ietf-netconf-nmda-netconf-08

/martin

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 20 Dec 2018 13:28:40 +0000

Thanks Carl. What is interesting is that pyang shows no errors, while confdc and yanglint do.

Regards,
Reshad.

On 2018-12-19, 7:13 PM, "Carl Moberg" <[email-masked]> wrote: