Subject: Re: [Netconf] I-D Action: draft-ietf-netconf-zerotouch-26.txt

From: Kent Watsen <[email-masked]>
Date: Wed, 2 Jan 2019 23:26:52 +0000

Hi Tom,

> You have added the reference to RFC8174 to the YANG modules but ...
> it appears as [RFC8174] which to my eyes looks like a HTML/XML anchor
> which will not work in a plain text YANG module.

Right you are, I had simply copy/pasted the text from the plain-text
version of a draft.

Below is the my proposed diff to the YANG modules - any concerns?

     The key words 'MUST', 'MUST NOT', 'REQUIRED', 'SHALL',
     'SHALL NOT', 'SHOULD', 'SHOULD NOT', 'RECOMMENDED', 
     'NOT RECOMMENDED', 'MAY', and 'OPTIONAL' in this document
-    are to be interpreted as described in BCP 14 [RFC2119]
-    [RFC8174] when, and only when, they appear in all
+    are to be interpreted as described in BCP 14 (RFC 2119,
+    RFC 8174) when, and only when, they appear in all
     capitals, as shown here.

PS: Welcome to 2019 all!

Kent

---

From: tom petch <[email-masked]>
Date: Fri, 4 Jan 2019 11:43:02 +0000

----- Original Message -----
From: "Kent Watsen" <[email-masked]>

Sent: Wednesday, January 02, 2019 11:26 PM
> +    RFC 8174) when, and only when, they appear in all

Depends what the XML looks like :-) but that looks ok.

Tom Petch