Subject: Re: [Netconf] Invalid when-stmts in yang-push

From: Kent Watsen <[email-masked]>
Date: Mon, 7 Jan 2019 20:23:42 +0000

Hi Alex,

Have you had a chance to look at this issue yet?  The assigned YANG Doctor says that they immediately stumbled on this error and is waiting for an update with a valid module before proceeding with the review.

PS: All authors should integrate the validation of YANG modules and examples as part of the `xml2rfc` build process.  Also recommended is dynamic generation of the tree diagrams, and execution of the `idnits` tool.  The time it takes to set this up in the beginning is easily recovered over the course of the draft’s lifetime.  Remember, it’s not just your time, but also the time of everyone else that runs into these issues, and then the slow restart times (this thread is an example of that).

Kent // shepherd/chair

On 11/29/18, 4:58 PM, "Netconf on behalf of Eric Voit (evoit)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Thanks Andy.   Adding Alex to make the change.

Eric

From: Netconf <[email-masked]> On Behalf Of Andy Bierman
Sent: Thursday, November 29, 2018 4:52 PM
To: Netconf <[email-masked]>
Subject: Re: [Netconf] Invalid when-stmts in yang-push

Hi,

I think this diff fixes the yang-push module.
It looks like the augment to modify-subscription used the wrong grouping
because the 'datastore' leaf was missing.

365c365
<       when "../sn:target/yp:datastore";
---
>       when "yp:datastore";
572c572
<     when "sn:target/yp:datastore";
---
>     when "yp:datastore";
616c616
<     when "sn:target/yp:datastore";
---
>     when "yp:datastore";
632c632
<       uses selection-filter-objects;
---
>       uses datastore-criteria;
816c816
<     when "sn:target/yp:datastore";
---
>     when "yp:datastore";

Andy

On Wed, Nov 28, 2018 at 3:03 PM Andy Bierman <[email-masked]<mailto:[email-masked]>> wrote:

On Wed, Nov 28, 2018 at 2:48 PM Andy Bierman <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

During implementation of yang-push-20 our developer found that
the when-stmts for establish-subscription are always false.

E.g. line 365:
    choice update-trigger {
      when "../sn:target/yp:datastore";

The node 'target' is a choice. The node 'datastore' is a case.
Since the when-stmt is looking for data nodes not schema nodes,
the node-set is always empty.

There are 4 occurrences:

Warning: no child node 'ietf-subscribed-notifications:target' found for parent 'ietf-subscribed-notifications:subscriptions'
XPath: ../sn:target/yp:datastore
ietf-yang-push.yang:365.15: warning(1032): no child node available

Warning: no child node 'ietf-subscribed-notifications:target' found for parent 'ietf-subscribed-notifications:input'
XPath: sn:target/yp:datastore
ietf-yang-push.yang:572.10: warning(1032): no child node available

Warning: no child node 'ietf-subscribed-notifications:target' found for parent 'ietf-subscribed-notifications:input'
XPath: sn:target/yp:datastore
ietf-yang-push.yang:616.10: warning(1032): no child node available

Warning: no child node 'ietf-subscribed-notifications:target' found for parent 'ietf-subscribed-notifications:subscription'
XPath: sn:target/yp:datastore
ietf-yang-push.yang:816.10: warning(1032): no child node available

pyang is also reporting these warnings:

ietf-yang-push.yang:365: warning: XPath for "../sn:target/yp:datastore" does not exist
ietf-yang-push.yang:572: warning: XPath for "sn:target/yp:datastore" does not exist
ietf-yang-push.yang:616: warning: XPath for "sn:target/yp:datastore" does not exist
ietf-yang-push.yang:816: warning: XPath for "sn:target/yp:datastore" does not exist

Andy

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 7 Jan 2019 20:52:03 +0000

FYI, this is also causing validation of the examples in netconf-notif to fail (doing this as part of YD review).

err : When condition "../ietf-subscribed-notifications:target/ietf-yang-push:datastore" not satisfied. (/ietf-subscribed-notifications:modify-subscription/ietf-yang-push:periodic)

Regards,
Reshad.

From: Netconf <[email-masked]> on behalf of Kent Watsen <[email-masked]>
Date: Monday, January 7, 2019 at 3:24 PM
To: "Eric Voit (evoit)" <[email-masked]>, 'Andy Bierman' <[email-masked]>, Netconf <[email-masked]>, Alexander Clemm <[email-masked]>
Subject: Re: [Netconf] Invalid when-stmts in yang-push

Hi Alex,

Kent // shepherd/chair

Eric

Hi,

365c365
572c572
616c616
632c632
816c816

Andy

E.g. line 365:
    choice update-trigger {

There are 4 occurrences:

Andy