Subject: [netconf] Benjamin Kaduk's Discuss on draft-ietf-netconf-subscribed-notifications-23: (with DISCUSS)

From: Benjamin Kaduk via Datatracker <[email-masked]>
Date: Mon, 29 Apr 2019 10:40:31 -0700

Benjamin Kaduk has entered the following ballot position for
draft-ietf-netconf-subscribed-notifications-23: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-netconf-subscribed-notifications/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

[putting this out early in the hopes it can be resolved quickly; I'm just
starting to review the document.]

This document started life as a rfc5277bis, published in July 2008, before RFC
5378 (BCP 78) was published in November of 2008.  If we are using any text from
RFC 5277 and did not gain the additional rights declaration from the authors of
that document, this document needs to use a different boilerplate text (the
"pre-2008" text).  I look at the sibling document draft-ietf-netfonf-yang-push
of this document, which does use the pre-2008 boilerplate, and am having a hard
time understanding why this document does not also have the pre-2008
boilerplate.

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Mon, 29 Apr 2019 17:58:19 +0000

Hi Benjamin,

I think you are asking why the following boilerplate text wasn't included...

   This document may contain material from IETF Documents or IETF
   Contributions published or made publicly available before November
   10, 2008.  The person(s) controlling the copyright in some of this
   material may not have granted the IETF Trust the right to allow
   modifications of such material outside the IETF Standards Process.
   Without obtaining an adequate license from the person(s) controlling
   the copyright in such materials, this document may not be modified
   outside the IETF Standards Process, and derivative works of it may
   not be created outside the IETF Standards Process, except to format
   it for publication as an RFC or to translate it into languages other
   than English.

This was likely an oversight during the initial author's submission.  If this text was included and uploaded as a -24 update, would that cover your concern?

BTW: the same boilerplate update should also be made to 
draft-ietf-netconf-netconf-event-notification  and draft-ietf-netconf-restconf-notif

Thanks,
Eric

> -----Original Message-----
> From: Benjamin Kaduk via Datatracker <[email-masked]>
> Subject: Benjamin Kaduk's Discuss on draft-ietf-netconf-subscribed-
> notifications-23: (with DISCUSS)
> 
> [putting this out early in the hopes it can be resolved quickly; I'm just starting to
> review the document.]
> 
> that document, this document needs to use a different boilerplate text (the "pre-
> 2008" text).  I look at the sibling document draft-ietf-netfonf-yang-push of this
> document, which does use the pre-2008 boilerplate, and am having a hard time
> understanding why this document does not also have the pre-2008 boilerplate.
> 
> 
>

---

From: Benjamin Kaduk <[email-masked]>
Date: Mon, 29 Apr 2019 13:25:03 -0500

>    it for publication as an RFC or to translate it into languages other

Exactly so.

> This was likely an oversight during the initial author's submission.  If this text was included and uploaded as a -24 update, would that cover your concern?

Definitely.
(Note that there's an XML keyword for this; IIRC, <rfc [...]
ipr="pre5378Trust200902">.)

> draft-ietf-netconf-netconf-event-notification  and draft-ietf-netconf-restconf-notif

Thanks for spotting those early!

-Ben

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Mon, 29 Apr 2019 19:31:40 +0000

ipr="pre5378Trust200902"

change made and uploaded as v24

Eric

> From: Benjamin Kaduk, April 29, 2019 2:25 PM
> 
> > This was likely an oversight during the initial author's submission.  If this text
> was included and uploaded as a -24 update, would that cover your concern?
> 
> Definitely.
> > > [putting this out early in the hopes it can be resolved quickly; I'm
> > > just starting to review the document.]
> > >
> > > 5378 (BCP 78) was published in November of 2008.  If we are using
> > > any text from RFC 5277 and did not gain the additional rights
> > > declaration from the authors of that document, this document needs
> > > to use a different boilerplate text (the "pre- 2008" text).  I look
> > > at the sibling document draft-ietf-netfonf-yang-push of this
> > > document, which does use the pre-2008 boilerplate, and am having a hard

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 30 Apr 2019 08:32:00 +0000

Hi,

I think it should be avoided if possible to add the pre-5378
boilerplate, it is better to get the rights. Especially in this
situation where there has been many version published stating that the
rights have been had. Is there a problem of getting the rights?

Cheers

Magnus

-- 

Magnus Westerlund 

----------------------------------------------------------------------
Network Architecture & Protocols, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Torshamnsgatan 23           | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 30 Apr 2019 16:21:31 +0000

> From: Magnus Westerlund, April 30, 2019 4:32 AM
> 
> Hi,
> 
> I think it should be avoided if possible to add the pre-5378 boilerplate, it is better
> to get the rights. Especially in this situation where there has been many version
> published stating that the rights have been had. Is there a problem of getting the
> rights?

Hi Magnus,

Here is the current status...

There are no full sentences from RFC-5277 used in this document.  However there are a few sentence fragments in the terminology, as well as quite a few concepts adopted based on RFC5277.  On the basis of that Benjamin's DISCUSS however, it felt like we should err on the side of caution by adding his suggestion.  

Along with this, at the end of 2016 the original authors of RFC-5277 (Sharon & Hector) stated they no longer needed to be on this draft.  I haven't been in contact with them since.  So without a relationship here, it seemed like the including the "pre5378Trust200902" text was again erring on the side of caution.

Eric

> >>>> -------------------------------------------------------------------
> >>>> -
> >>>> --
> >>>> DISCUSS:
> >>>> -------------------------------------------------------------------
> >>>> -
> >>>> --
> >>>>
> >>>> [putting this out early in the hopes it can be resolved quickly;
> >>>> I'm just starting to review the document.]
> >>>>

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 30 Apr 2019 11:25:27 -0500

> Along with this, at the end of 2016 the original authors of RFC-5277 (Sharon & Hector) stated they no longer needed to be on this draft.  I haven't been in contact with them since.  So without a re…

To be clear, I don't have any favored resolution I'm trying to push, here
(though Magnus' point is fairly compelling) -- I was just noting the
cross-document disparity and, in the absence of a note explaining it in the
shepherd writeup(s), wondering how to bring the documents in line with each
other.  If we think that the pre-5378 boilerplate is not actually needed
here and have explictly thought about the question, I am happy to accept
that as well.

-Ben

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 30 Apr 2019 16:37:26 +0000

> From: Benjamin Kaduk, April 30, 2019 12:25 PM
> 
> > > situation where there has been many version published stating that
> > > the rights have been had. Is there a problem of getting the rights?
> >
> > Hi Magnus,
> >
> > There are no full sentences from RFC-5277 used in this document.  However
> there are a few sentence fragments in the terminology, as well as quite a few
> concepts adopted based on RFC5277.  On the basis of that Benjamin's DISCUSS
> however, it felt like we should err on the side of caution by adding his
> suggestion.
> >
> > Along with this, at the end of 2016 the original authors of RFC-5277 (Sharon &
> Hector) stated they no longer needed to be on this draft.  I haven't been in
> contact with them since.  So without a relationship here, it seemed like the
> including the "pre5378Trust200902" text was again erring on the side of caution.
> 
> To be clear, I don't have any favored resolution I'm trying to push, here (though
> Magnus' point is fairly compelling) -- I was just noting the cross-document
> disparity and, in the absence of a note explaining it in the shepherd writeup(s),
> wondering how to bring the documents in line with each other.  If we think that
> the pre-5378 boilerplate is not actually needed here and have explictly thought
> about the question, I am happy to accept that as well.

Is there a process in the IETF to determine copyright coverage based on a couple sentence fragments and concept reuse?  I don't feel capable of providing a legal opinion here.  That is why I l felt converging on the narrower "pre5378Trust200902" boilerplate was safer.

Eric