Subject: [netconf] reporting-level enum value

From: Kent Watsen <[email-masked]>
Date: Sat, 6 Apr 2019 12:03:11 +0000

The zerotouch draft is in AUTH48 and one thing came up...

In Section 7.3, in the RPC-reply for the `get-boostrapping-data` RPC, there is a leaf called `reporting-level`:

         "Specifies the reporting level for progress reports the
           bootstrap server would like to receive when processing
           onboarding information.

With current values "standard" and "verbose".

The question to the WG is, would it be in anyway better to NOT use the word "standard"?
Perhaps it should be "minimal", “default”, “mandatory”, or “required” instead?
Thoughts?

Kent

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 9 Apr 2019 19:18:57 +0000

“minimal” seems appropriate to me.

Cheers,
Charles

From: netconf <[email-masked]> on behalf of Kent Watsen <[email-masked]>
Date: Saturday, April 6, 2019 at 2:03 PM
To: "[email-masked]" <[email-masked]>
Subject: [netconf] reporting-level enum value

Kent

---

From: Kent Watsen <[email-masked]>
Date: Tue, 9 Apr 2019 23:42:17 +0000

Thanks Charles.  Any objections?

Kent // contributor 

> On Apr 9, 2019, at 3:18 PM, Charles Eckel (eckelcu) <[email-masked]> wrote:
> 
> From: netconf <[email-masked] <mailto:[email-masked]>> on behalf of Kent Watsen <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>