Subject: [netconf] ietf crypto types - identities

From: Martin Bjorklund <[email-masked]>
Date: Fri, 03 May 2019 09:20:32 +0200 (CEST)

Hi,

It seems all sec* identities have the same description:

     identity secp192r1 {
       base asymmetric-key-algorithm;
       description
         "The ECDSA algorithm using a NIST P256 Curve.";
       reference
         "RFC 6090:
            Fundamental Elliptic Curve Cryptography Algorithms.";
     }

This I assume should have been "NIST P191 Curve".

Also, it wasn't clear to me by looking at the reference what this
actually means.  I had to google for "secp192r1", which lead me to RFC
5480 which defines the *curve* "secp192r1".  So I wonder if the
reference needs to be updated, and if the name of this identity is
really correct?

/martin

---

From: Wang Haiguang <[email-masked]>
Date: Thu, 9 May 2019 16:26:29 +0000

Hi, Martin,

Sorry for the late reply.

Thanks very much to point out the mistake. I think it is a careless mistake and I am going to check draft and try to fix the errors in next version.

Regarding the reference, if I am not wrong, RFC 6090 explains the mathematical formulas used by the ECDSA, RFC 5480 gives an object identifier of the curve.

I did some search found the NIST report FIPS 186-3  not only explains the mathematical formulas, but also list the recommended parameters. How do you think we put FIPS 186-3 as an additional reference for secp192r1, ...

https://csrc.nist.gov/csrc/media/publications/fips/186/3/archive/2009-06-25/documents/fips_186-3.pdf

Best regards.

Haiguang

________________________________
From: netconf <[email-masked]> on behalf of Martin Bjorklund <[email-masked]>
Sent: Friday, 3 May 2019 3:20:32 PM
To: [email-masked]
Subject: [netconf] ietf crypto types - identities

Hi,

     identity secp192r1 {

/martin

_______________________________________________
netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf