Subject: [netconf] Balazs comments on draft-mahesh-netconf-https-notif-00

From: Balázs Lengyel <[email-masked]>
Date: Mon, 22 Jul 2019 15:30:30 +0000

Hello,

*	I very much like and support and need this work. Some comments:

-        Identities like “https” specifying protocols seem to be a generic
issue. They could/should be in some more generic RFC e.g.
ietf-inet-types.yang. We already had the need for protocol identities in
other design work.

-        leaf “name”: this is a typical example where a description is not
needed, only forced by our style guide. Maybe the style guide should be
changed.

Regards Balazs

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 29 Jul 2019 21:42:26 -0700

Hi Balasz,

> On Jul 22, 2019, at 8:30 AM, Balázs Lengyel <[email-masked]> wrote:
> 
> Hello,
> I very much like and support and need this work. Some comments:
> -        Identities like “https” specifying protocols seem to be a generic issue. They could/should be in some more generic RFC e.g. ietf-inet-types.yang. We already had the need for protocol identities in other design work.

[mj] The identity definition is of base type subscribed-notifications:transport. As such, it is not a generic protocol type. I am not sure it would belong in ietf-inet-types.

> -        leaf “name”: this is a typical example where a description is not needed, only forced by our style guide. Maybe the style guide should be changed.

[mj] I know I left it as a blank, but even if the description is generic, I do not mind putting one. I would rather not change the guidance on adding descriptions, as we are woefully short on adding good descriptions in the first place.

Thanks.

>  
> Regards Balazs
> _______________________________________________
> netconf mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netconf <https://www.ietf.org/mailman/listinfo/netconf>