Subject: Re: [netconf] Comment on draft-ietf-notification-capabilities

From: Balázs Lengyel <[email-masked]>
Date: Wed, 14 Aug 2019 09:00:18 +0000

Hello Reshad,

https://tools.ietf.org/html/draft-ietf-netconf-notification-capabilities-03#section-3 includes the text:

For the run-time use-case: It SHALL be available via NETCONF
      [RFC6241 <https://tools.ietf.org/html/rfc6241> ] or RESTCONF [RFC8040 <https://tools.ietf.org/html/rfc8040> ] from the live server during
      runtime.  
 
      As these capabilities might change during run-time,
      implementations that support the YANG-Push on-change feature,
      SHOULD support sending on-change notifications about this module.

I think that should cover your comment. Or is it something else you want?

Regards Balazs

From: Balázs Lengyel <[email-masked]> 
Sent: 2019. július 23., kedd 23:56
To: Reshad Rahman (rrahman) <[email-masked]>; [email-masked]
Subject: RE: Comment on draft-ietf-notification-capabilities

OK, will add it.  Balazs

From: Reshad Rahman (rrahman) <[email-masked] <mailto:[email-masked]> > 
Sent: 2019. július 23., kedd 16:34
To: Balázs Lengyel <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: Comment on draft-ietf-notification-capabilities

Hi Balazs,

Section 2 mentions that the capabilities could change at run-time. For those implementations which support this, there would be value if the datastore-subscription-capabilities container is on-change capable?

This should be indicated with an entry for that node in the on-change-notification-capability list (for the operational datastore)? Could we have some text in the draft for this?

Regards,

Reshad.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 19 Aug 2019 22:25:34 +0000

Hi Balazs,

Thanks for adding this text. I think the text is a bit ambiguous, since it’s implementations which support changing capabilities at run-time which should support on-change notifications about the datastore-subscription-capabilities container.
Also it’d be great if one of the examples in Appendix A explicitly mentioned whether capabilities can change at run-time. For instance, the second example has on-change-supported-for-state set to true, so this would imply that the capabilities can change at run-time since there is no entry for the datastore-subscription-capabilities node. You could add the following and state that the on-change capabilities can’t change at run-time.
        <per-node-capabilities>
          <node-selector>
            /inc:datastore-subscription-capabilities</node-selector>
          <on-change-supported>false</on-change-supported>
        </per-node-capabilities>

Regards,
Reshad.

From: Balázs Lengyel <[email-masked]>
Date: Wednesday, August 14, 2019 at 5:01 AM
To: Balázs Lengyel <[email-masked]>, "Reshad Rahman (rrahman)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Comment on draft-ietf-notification-capabilities

Hello Reshad,

      [RFC6241<https://tools.ietf.org/html/rfc6241>] or RESTCONF [RFC8040<https://tools.ietf.org/html/rfc8040>] from the live server during

      runtime.

OK, will add it.  Balazs

From: Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>>
Sent: 2019. július 23., kedd 16:34
To: Balázs Lengyel <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Comment on draft-ietf-notification-capabilities

Hi Balazs,

Regards,
Reshad.