Subject: [netconf] FW: New Version Notification for draft-ietf-netconf-notification-capabilities-03.txt

From: Balázs Lengyel <[email-masked]>
Date: Tue, 13 Aug 2019 15:07:54 +0000

I updated the draft with all comments from and after the meeting. Please review.
Changes v02 - v03

   o  Allow throughput related capabilities to be defined on top,
      datastore or data node level.  Described that specific capability
      values always override generic ones.

   o  Indicate that non-NMDA servers can also use this model.

   o  Updated according to draft-ietf-netmod-yang-instance-file-
      format-04

Regards Balazs

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: 2019. augusztus 13., kedd 17:02
To: Benoit Claise <[email-masked]>; Alexander Clemm <[email-masked]>; Balázs Lengyel <[email-masked]>
Subject: New Version Notification for draft-ietf-netconf-notification-capabilities-03.txt

A new version of I-D, draft-ietf-netconf-notification-capabilities-03.txt
has been successfully submitted by Balazs Lengyel and posted to the IETF repository.

Name:		draft-ietf-netconf-notification-capabilities
Revision:	03
Title:		Yang-Push Notification Capabilities
Document date:	2019-08-13
Group:		netconf
Pages:		18
URL:            https://www.ietf.org/internet-drafts/draft-ietf-netconf-notification-capabilities-03.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-netconf-notification-capabilities/
Htmlized:       https://tools.ietf.org/html/draft-ietf-netconf-notification-capabilities-03
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-netconf-notification-capabilities
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-netconf-notification-capabilities-03

Abstract:
   This document proposes a YANG module that allows a server to specify
   server capabilities related to "Subscription to YANG Datastores"
   (Yang-Push).  It proposes to use YANG Instance Data to document this
   information and make it already available at implementation time, but
   also allow it to be reported at runtime.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Tue, 13 Aug 2019 17:33:42 +0000

Balazs, I don't think the comment in the attached email has been addressed?

Regards,
Reshad.

On 2019-08-13, 11:12 AM, "netconf on behalf of Balázs Lengyel" <[email-masked] on behalf of [email-masked]> wrote:

    

    Regards Balazs
    
    -----Original Message-----
    From: [email-masked] <[email-masked]> 
    Sent: 2019. augusztus 13., kedd 17:02
    To: Benoit Claise <[email-masked]>; Alexander Clemm <[email-masked]>; Balázs Lengyel <[email-masked]>
    Subject: New Version Notification for draft-ietf-netconf-notification-capabilities-03.txt

    
    Abstract:

    
    
    The IETF Secretariat

Subject: RE: Comment on draft-ietf-notification-capabilities
From: Balázs Lengyel <[email-masked]>
To: "Reshad Rahman (rrahman)" <[email-masked]>, "[email-masked]" <[email-masked]>
Date: Tue, 23 Jul 2019 21:55:44 +0000

OK, will add it.  Balazs

From: Reshad Rahman (rrahman) <[email-masked]> 
Sent: 2019. július 23., kedd 16:34
To: Balázs Lengyel <[email-masked]>; [email-masked]
Subject: Comment on draft-ietf-notification-capabilities

Hi Balazs,

Section 2 mentions that the capabilities could change at run-time. For those implementations which support this, there would be value if the datastore-subscription-capabilities container is on-change capable?

This should be indicated with an entry for that node in the on-change-notification-capability list (for the operational datastore)? Could we have some text in the draft for this?

Regards,

Reshad.