Subject: Re: [netconf] I-D Action: draft-dai-quic-netconf-01.txt

From: tom petch <[email-masked]>
Date: Tue, 29 Oct 2019 12:06:55 +0000

Dai

There is something wrong with the formatting of this I-D which, for me,
makes it too hard to read.  The  text is littered     with additional
spaces, like tab characters gone wild or a malign word processor.  I
would like that    fixed before I try    and read it (extra spaces
inserted for     effect:-).

Tom Petch

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Monday, October 28, 2019 2:29 PM

> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
>
>
>         Title           : Using NETCONF over QUIC connection
>         Authors         : Jinyou Dai
>                           Xueshun Wang
>                           Yang Kou
>                           Lifen Zhou
> Filename        : draft-dai-quic-netconf-01.txt
> Pages           : 13
> Date            : 2019-10-28
>
> Abstract:
>    The Network Configuration Protocol (NETCONF) provides mechanisms to
>    install, manipulate, and delete the configuration of network
devices.
>    At present, almost all implementations of NETCONF are based on TCP
>    protocol. QUIC, a new UDP-based transport protocol, can facilitate
to
>    improve the transportation performance when being used as an
>    infrastructure layer of NETCONF.   This document describes how to
use
>    the QUIC protocol as the transport   protocol of
>    NETCONF(NETCONFoQUIC).
>
>
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-dai-quic-netconf/
>
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-dai-quic-netconf-01
> https://datatracker.ietf.org/doc/html/draft-dai-quic-netconf-01
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-dai-quic-netconf-01
>
>
> Please note that it may take a couple of minutes from the time of
submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 29 Oct 2019 11:53:32 -0700

Thanks Tom for bringing it to the NETCONF mailing list.

Authors, have you considered presenting this draft in the NETCONF WG?

Some quick comment:

s/This document specifies how to use QUIC as the secure transport protocol for QUIC./This document specifies how to use QUIC as the secure transport protocol for NETCONF./

Can you also expand on the following statement, in light of the fact that NETCONF is a client/server protocol, and that each NETCONF session is a separate TCP connection?

As is well know, TCP has some shortcomings such as head-of-line blocking

Thanks.

> On Oct 29, 2019, at 5:06 AM, tom petch <[email-masked]> wrote:
> 
> Dai
> 
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

Mahesh Jethanandani
[email-masked]