Subject: [netconf] More capabilities for ietf-notification-capabilities (WGLC)

From: Balázs Lengyel <[email-masked]>
Date: Wed, 9 Oct 2019 14:33:27 +0000

Hello,

During WGLC it was asked that  we could/should add some more capabilities to
the ietf-notification-capabilities model.

In https://tools.ietf.org/html/rfc8641#appendix-A.1 there are two more error
conditions mentioned.

cant-exclude 

datastore-not-subscribable

The publisher might be able to declare which change types can be used in the
leaf-list excluded-change 

The publisher might want to declare that not even periodic subscriptions are
supported for a specific datastore. Some people stated that supporting
periodic subscriptions is mandatory if RFC8641 (Yang-Push) is supported, so
we should not add this capability. But is it really mandatory to support
periodic subscriptions for e.g. the start-up datastore?

I intend to add these 2 to the model.

Opinions?

Regards Balazs

-- 

Balazs Lengyel                    Senior Specialist
Ericsson Hungary Ltd. 

Mobile: +36-70-330-7909              email: [email-masked]

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 9 Oct 2019 16:11:49 +0000

I have no objection to these additions.

Eric

From: Balázs Lengyel <[email-masked]> 
Sent: Wednesday, October 9, 2019 10:33 AM
To: Netconf <[email-masked]>; Alexander Clemm <[email-masked]>; Eric
Voit (evoit) <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>
Subject: More capabilities for ietf-notification-capabilities (WGLC)

Hello,

cant-exclude 

Opinions?

Regards Balazs

-- 

Mobile: +36-70-330-7909              email: [email-masked]
<mailto:[email-masked]>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 11 Oct 2019 12:46:01 +0000

I support adding these.

I think that it is plausible that a server may not support periodic subscriptions on either "candidate" or "startup" datastores, hence the ability to clearly express this in the capabilities model is important.

I think that it also has the benefit of making the model slightly more regular.

Thanks,
Rob

From: Balázs Lengyel <[email-masked]>
Sent: 09 October 2019 15:33
To: Netconf <[email-masked]>; Alexander Clemm <[email-masked]>; Eric Voit (evoit) <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>
Subject: More capabilities for ietf-notification-capabilities (WGLC)

Hello,
During WGLC it was asked that  we could/should add some more capabilities to the ietf-notification-capabilities model.
In https://tools.ietf.org/html/rfc8641#appendix-A.1 there are two more error conditions mentioned.
cant-exclude
datastore-not-subscribable

The publisher might be able to declare which change types can be used in the  leaf-list excluded-change
The publisher might want to declare that not even periodic subscriptions are supported for a specific datastore. Some people stated that supporting periodic subscriptions is mandatory if RFC8641 (Yang-Push) is supported, so we should not add this capability. But is it really mandatory to support periodic subscriptions for e.g. the start-up datastore?

Opinions?

Regards Balazs

--
Balazs Lengyel                    Senior Specialist                       Ericsson Hungary Ltd.
Mobile: +36-70-330-7909              email: [email-masked]<mailto:[email-masked]>