Subject: Re: [netconf] [Technical Errata Reported] RFC8040 (5633)

From: Ignas Bagdonas <[email-masked]>
Date: Thu, 17 Oct 2019 14:07:58 +0100

Hi there,

This applies to an example, and while factually correct, it does not seem
to be a technical errata as such, it is an editorial one

A nit -  a Date: header also needs to be changed.

Any objections?

On Mon, Feb 11, 2019 at 10:14 AM RFC Errata System <
[email-masked]> wrote:

> The following errata report has been submitted for RFC8040,
> "RESTCONF Protocol".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata/eid5633
>
> --------------------------------------
> Type: Technical
> Reported by: Qin WU <[email-masked]>
>
> Section: B.2.2.
>
> Original Text
> -------------
>       PATCH /restconf/data/example-jukebox:jukebox/\
>           library/artist=Foo%20Fighters/album=Wasting%20Light/\
>           genre HTTP/1.1
>       Host: example.com
>       If-Unmodified-Since: Thu, 26 Jan 2017 20:56:30 GMT
>       Content-Type: application/yang-data+json
>
>       { "example-jukebox:genre" : "example-jukebox:alternative" }
>
>    In this example, the datastore resource has changed since the time
>    specified in the "If-Unmodified-Since" header.  The server might
>    respond as follows:
>
>       HTTP/1.1 412 Precondition Failed
>       Date: Thu, 26 Jan 2017 20:56:30 GMT
>       Server: example-server
>       Last-Modified: Thu, 26 Jan 2017 19:41:00 GMT
>       ETag: "b34aed893a4c"
>
>
> Corrected Text
> --------------
>       PATCH /restconf/data/example-jukebox:jukebox/\
>           library/artist=Foo%20Fighters/album=Wasting%20Light/\
>           genre HTTP/1.1
>       Host: example.com
>       If-Unmodified-Since: Thu, 26 Jan 2017 20:56:30 GMT
>       Content-Type: application/yang-data+json
>
>       { "example-jukebox:genre" : "example-jukebox:alternative" }
>
>    In this example, the datastore resource has changed since the time
>    specified in the "If-Unmodified-Since" header.  The server might
>    respond as follows:
>
>       HTTP/1.1 412 Precondition Failed
>       Date: Thu, 26 Jan 2017 20:56:30 GMT
>       Server: example-server
>       Last-Modified: Thu, 26 Jan 2017 20:57:10 GMT
>       ETag: "b34aed893a4c"
>
>
> Notes
> -----
> The date in the Last-Modified field of the response HTTP header should be
> greater than the date in the If-Unmodified-Since field of the request HTTP
> header.
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC8040 (draft-ietf-netconf-restconf-18)
> --------------------------------------
> Title               : RESTCONF Protocol
> Publication Date    : January 2017
> Author(s)           : A. Bierman, M. Bjorklund, K. Watsen
> Category            : PROPOSED STANDARD
> Source              : Network Configuration
> Area                : Operations and Management
> Stream              : IETF
> Verifying Party     : IESG
>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 17 Oct 2019 12:57:28 -0700

> A nit -  a Date: header also needs to be changed.

I agree the example is wrong -- probably a cut-and-paste from
If-Modified-Since.
In the example shown where 412 Precondition Failed is sent as the response,
the
server Date should be later than Last-Modified date returned.
The fixed example looks like the resource was changed in the future.

Andy