Subject: [netconf] Adoption request//FW: New Version Notification for draft-zhou-netconf-multi-stream-originators-09.txt

From: Tianran Zhou <[email-masked]>
Date: Sat, 2 Nov 2019 09:02:21 +0000

Hi Folks,

We just updated the draft to address some more clarification questions.
I think it’s ready as the starting point for working group discussion.
We request the adoption call.

Cheers,
Tianran

________________________________
Sent from WeLink

发件人： internet-drafts<[email-masked]<mailto:[email-masked]>>
收件人： Andy Bierman<[email-masked]<mailto:[email-masked]>>;Eric Voit<[email-masked]<mailto:[email-masked]>>;Zhengguangying (Walker)<[email-masked]<mailto:[email-masked]>>;Alexander Clemm<[email-masked]<mailto:[email-masked]>>;Tianran Zhou<[email-masked]<mailto:[email-masked]>>
主题： New Version Notification for draft-zhou-netconf-multi-stream-originators-09.txt
时间： 2019-10-31 14:00:22

A new version of I-D, draft-zhou-netconf-multi-stream-originators-09.txt
has been successfully submitted by Tianran Zhou and posted to the
IETF repository.

Name:           draft-zhou-netconf-multi-stream-originators
Revision:       09
Title:          Subscription to Multiple Stream Originators
Document date:  2019-10-31
Group:          Individual Submission
Pages:          22
URL:            https://www.ietf.org/internet-drafts/draft-zhou-netconf-multi-stream-originators-09.txt
Status:         https://datatracker.ietf.org/doc/draft-zhou-netconf-multi-stream-originators/
Htmlized:       https://tools.ietf.org/html/draft-zhou-netconf-multi-stream-originators-09
Htmlized:       https://datatracker.ietf.org/doc/html/draft-zhou-netconf-multi-stream-originators
Diff:           https://www.ietf.org/rfcdiff?url2=draft-zhou-netconf-multi-stream-originators-09

Abstract:
   This document describes the distributed data export mechanism that
   allows multiple data streams to be managed using a single
   subscription.  Specifically, multiple data streams are pushed
   directly to the collector without passing through a broker for
   internal consolidation.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Kent Watsen <[email-masked]>
Date: Tue, 5 Nov 2019 00:20:04 +0000

All, and Tianran.

The chairs have been working closely with the authors for the last week in trying to make improvements to this draft prior to agreeing to initiate an adoption poll.  Our primary concern has been, and continues to be so, that the draft doesn't clearly specify the problem statement, while describing perhaps too many implementation-level details.

We understand that adoptions of a draft is just a starting point for the WG to develop the draft from.  However, without a clear problem statement, it is difficult to discern what is scope the draft.  In particular, we perceive this draft as enabling clients to 1) discover how many line cards there are and 2) determine the "message-generator-id" for each (however 'each' is mapped).  Additionally, we feel that this draft's claim to defining a distributed logging architecture is overreaching, as distributed Syslog-based implementations have existed for years.  

What does the WG think?   The chairs are cognizant that such questions may be sussed out in the course of an adoption poll, but felt the need the WG to focus on this particular point first.  We would welcome the WG to discuss this point on list before the 106 meeting.

Kent and Mahesh

> On Nov 2, 2019, at 5:02 AM, Tianran Zhou <[email-masked]> wrote:
> 
> Hi Folks,
>