Subject: [netconf] NACM and draft-ietf-netconf-notification-capabilities-07

From: Benoit Claise <[email-masked]>
Date: Mon, 18 Nov 2019 17:34:43 +0800

Dear all,

Coming back to Rob Wilton's message at the mike about NACM reference to 
draft-ietf-netmod-rfc6991-bis-02 
<https://datatracker.ietf.org/doc/draft-ietf-netmod-rfc6991-bis/>
 From draft-ietf-netconf-notification-capabilities-07

    import ietf-netconf-acm  { prefix nacm; }
    import ietf-yang-push    {
      prefix yp;
      description
        "This module requires ietf-yang-push to be implemented.";
    }

Along the same lines, I believe it makes sense to add "This module does 
not require NACM to be implemented."

Thinking some more about it... Actually, I don't like "This module 
requires ietf-yang-push to be implemented."
What if I want to implement this draft for gRPC and not YANG-push?
This capability should be independent of the streaming protocol IMO

Regards, Benoit

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 18 Nov 2019 18:27:59 +0800

On Mon, 2019-11-18 at 17:34 +0800, Benoit Claise wrote:
> Dear all,
> 
> Coming back to Rob Wilton's message at the mike about NACM reference to draft-
> ietf-netmod-rfc6991-bis-02
> Along the same lines, I believe it makes sense to add "This module does not
> require NACM to be implemented."

Yes, see also my Yang Doctor review:

https://datatracker.ietf.org/doc/review-ietf-netconf-notification-capabilities-05-yangdoctors-lc-lhotka-2019-10-29/

> 
> Thinking some more about it... Actually, I don't like "This module requires
> ietf-yang-push to be implemented."

This draft (of which you are a co-author:-) states explicitly that the
capabilities are 'related to "Subscription to YANG Datastores" (YANG-Push)'.

Lada

> 
> Regards, Benoit
> _______________________________________________
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Andy Bierman <[email-masked]>
Date: Mon, 18 Nov 2019 14:18:39 -0800

> > require NACM to be implemented."

This is a rather ad-hoc way to declare module conformance and dependencies.
Not sure it is even correct.

In this draft it looks like all the objects that are related to yang-push
use "if-feature yp:on-change".  So does this module really require
yang-push if
feature on-change is not supported?

For nacm, only a typedef is used and no objects are used at all.

It seems clear that if the importing module augments the imported module,
or if leafref nodes exist that point to the imported module, then it is
supposed to be implemented.

Andy