Subject: Re: [netconf] [netconf-wg/https-notif] Should the receivers container be moved under the augment statement and the leafref renamed? (#2)

From: Martin Bjorklund <[email-masked]>
Date: Tue, 11 Feb 2020 14:24:56 +0100 (CET)

Kent Watsen <[email-masked]> wrote:
> Hi Martin,
> 
> 
> > On Nov 19, 2019, at 10:18 AM, Martin Bjorklund <[email-masked]> wrote:
> > 
> >> The reason to not move the receiver container under the augment is so
> >> as to allow the leafref to point to multiple receivers.
> > 
> > I don't understand this reason.
> 
> Each "receiver" (in https-notif) maps to an HTTPS connection from the
> publisher to the receiver.
> 
> There is likely to be more than one configured subscription, yet all
> notifications should go to the same receiver.
> 
> We'd like to use the same HTTPS "connection" for all, as opposed to
> having an HTTPS connection for each.
> 
> The "receiver-ref" leaf provides an indirection enabling this
> many-to-one relationship.

I can't find the original thread about this issue, so I'll rephrase
what I (think I) wrote from the start:

I understand the reason for the many-to-one, and I wish we had that in
the base model itself (i.e., RFC 8639), so that protocol-documents
didn't have to invent this, and so that we could have
receiver-specific config in one place.

> > Since this is not a stand-alone model, I think it should augment
> > /sn:subscriptions.  In some way it doesn't matter what nodes are
> > called and where they are located, but having descriptive names and
> > keep related nodes under common subtrees helps the understanding of
> > models.
> 
> Is s/receiver-ref/https-receiver-ref/ what you had in mind?

Yes, as a minimum.

I would also change the top-level container "receivers" to augment
/sn:subscriptions:

  augemnt /sn:subscriptions {
    container https-receivers {
      ...
    }
  }

/martin

---

From: Kent Watsen <[email-masked]>
Date: Tue, 11 Feb 2020 15:25:59 +0000

Hi Martin,

> receiver-specific config in one place.

I agree, it would’ve been better in RFC 8639.  I recall Juergen writing once that he expected it to be a common pattern.  But that is behind us now, or are you suggesting a -bis?  Is there is an action coming out of this fork in the thread?

>    container https-receivers {

Ah, I see now, thank you for providing the snippet.

Kent // contributor

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 11 Feb 2020 16:31:55 +0100 (CET)

Kent Watsen <[email-masked]> wrote:
> I agree, it would’ve been better in RFC 8639.  I recall Juergen
> writing once that he expected it to be a common pattern.  But that is
> behind us now, or are you suggesting a -bis?  Is there is an action
> coming out of this fork in the thread?

No I don't expect a -bis for this.  When/if we do a -bis, we should
have a look at this.

/martin