Subject: [netconf] Using Netconf in Segment Routing for Database exchange and Path request/reply

From: "Rakesh Adulkar (radulkar)" <[email-masked]>
Date: Mon, 4 May 2020 04:58:58 +0000

Hi Team,

Hope you are doing well.

I have below idea, as off now I am not sure if it will work or not.
In current Segment Routing implementation we are using BGP-LS to exchange database and PCEP for path request/reply between PE/P devices and SR controller. I am just thinking that can we use Netconf to exchange database and also path request and reply protocol between PE/P devices and SR controller?
I Understand that the sole purpose of netconf is to manage the network devices with specific use cases to install, manipulate, and delete the configuration of network devices. It’s not meant to carry IGP and TE-related stuff, nor can it react to network topology changes. Each protocol is there for its reasons, and IMHO netconf is not intended to replace BGP-LS and PCEP, and even if it does, there needs to be various development on the netconf side.

So I wanted to know if there is any development in Netconf is going in this direction? If yes, than I would like to share my thoughts on it.

Thanks & Regards,
--
Rakesh Adulkar
Technical Consulting Engineer – Customer Delivery | Cisco TAC

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 4 May 2020 14:23:30 -0700

Rakesh,

You have mostly answered your question in its second part.
Leaving aside that this is a bad idea
- PCEP communication state is ephemeral, and as such, Restconf would have been a better candidate.
- there are already implementations streaming LSDB content over gNMI

Cheers,
Jeff
On May 4, 2020, 2:02 PM -0700, Rakesh Adulkar (radulkar) <radulkar=[email-masked]>, wrote:
> _______________________________________________
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf