Subject: [netconf] RESTCONF PUT method on list URI/Resources

From: Anton Snitser <[email-masked]>
Date: Thu, 4 Jun 2020 16:00:14 +0000

Hello everyone,

I am inquiring about the validity of the PUT method on a list resource

As per RFC 8040

  *   List entries are data resources but not list themselves – not sure as not explicitly mentioned.
[/var/folders/nz/22bwbzbn2rqczddy9629czsc0000gn/T/com.microsoft.Outlook/WebArchiveCopyPasteTempFiles/[email-masked]]

  *   PUT is used to create/replace the target “data resource”
[/var/folders/nz/22bwbzbn2rqczddy9629czsc0000gn/T/com.microsoft.Outlook/WebArchiveCopyPasteTempFiles/[email-masked]]

So would it be a valid implementation to allow PUT method on a list resource? /restconf/data/module:top-level-cont/list

Also, generally speaking is it fair to assume if not explicitly denied/mandated it is up to the implementation?

Thanks,
Best regards

[id:[email-masked]]
Anton Snizar | Systems Engineer 
m: +972-504042744
e: [email-masked]<mailto:[email-masked]>
w: sedonasys.com<https://sedonasys.com/>
l: Linkedin<http://linkedin.com/in/anton-snizar-4aa57646/>

---

From: Kent Watsen <[email-masked]>
Date: Sat, 6 Jun 2020 19:03:26 +0000

Hi Anton,

> On Jun 4, 2020, at 12:00 PM, Anton Snitser <[email-masked]> wrote:
> 
> Hello everyone,
>  

Currently, a list is not itself a data resource.  It’s tempting, I know, but it’s per RFC 8040...

> As per RFC 8040
>  
> List entries are data resources but not list themselves – not sure as not explicitly mentioned.
> PUT is used to create/replace the target “data resource”
>  

No, that would be invalid API.

> Also, generally speaking is it fair to assume if not explicitly denied/mandated it is up to the implementation?

RFCs intend to be fully-specified, so as to ensure interoperability.   If you find something unclear, it is best to ping the list here; not only will you get clarification, but we may find the need to file an errata if warranted.

K.

>  
> Thanks,
> Best regards
>  
>  
> Anton Snizar | Systems Engineer > 
> m: +972-504042744
> e: [email-masked] <mailto:[email-masked]>
> w: sedonasys.com <https://sedonasys.com/>
> l: Linkedin <http://linkedin.com/in/anton-snizar-4aa57646/>
>  
> _______________________________________________
> netconf mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netconf <https://www.ietf.org/mailman/listinfo/netconf>