Subject: Re: [netconf] [netmod] <get-data> operation with "table join" capability

From: Qin Wu <[email-masked]>
Date: Tue, 2 Jun 2020 01:55:11 +0000

Hi, Kent and Xufeng:
Should this table join capability be also applied to YANG Push subscription, so we can use YANG Push Notification to get all attributes of the object containing the leafref and the attributes referenced by the leafref statement.
I raised this issue before
https://mailarchive.ietf.org/arch/msg/netconf/4PHiS7EYqehZOz3lIxFMaLZ6rAo/

-Qin
发件人: netconf [mailto:[email-masked]] 代表 Kent Watsen
发送时间: 2020年5月21日 21:36
收件人: Xufeng Liu <[email-masked]>
抄送: [email-masked]
主题: Re: [netconf] [netmod] <get-data> operation with "table join" capability

[moving 'netmod' to BCC since this question has no modeling impact]

The desired capability is:

When a leafref or multiple leafrefs reference one or more objects specified in other parts of the schema, the operator can use a single <get-data> operation to retrieve all attributes of the object containing the leafref and the attributes referenced by the leafref statement.

The motivation is clear.

A solution would likely entail returning a multi-part response, perhaps a single tree for NETCONF.   Note that the resolutions may themselves include leafrefs, a full-response may be N levels deep.

K.

---

From: Qin Wu <[email-masked]>
Date: Tue, 2 Jun 2020 02:26:08 +0000

One further question, when the leaf bb in the module bar uses leafref to reference aa in module foo,
Can we use get-data operation to retrieve all data nodes associated with “myabc” list in module bar
and all data nodes associated with “fooins” list in module foo,e.g.,
foo/fooins[aa = /bar/myabc/bb]/{ aa,descr,admin,rules}

-Qin
发件人: netconf [mailto:[email-masked]] 代表 Qin Wu
发送时间: 2020年6月2日 9:55
收件人: Kent Watsen <[email-masked]>; Xufeng Liu <[email-masked]>
抄送: [email-masked]
主题: Re: [netconf] [netmod] <get-data> operation with "table join" capability

Hi, Kent and Xufeng:

-Qin
发件人: netconf [mailto:[email-masked]] 代表 Kent Watsen
发送时间: 2020年5月21日 21:36
收件人: Xufeng Liu <[email-masked]<mailto:[email-masked]>>
抄送: [email-masked]<mailto:[email-masked]>
主题: Re: [netconf] [netmod] <get-data> operation with "table join" capability

The motivation is clear.

K.