Subject: [netconf] Adoption-suitability for draft-wang-netconf-adaptive-subscription

From: Kent Watsen <[email-masked]>
Date: Wed, 5 Aug 2020 22:18:28 +0000

NETCONF WG,

Per the previous email sent moments ago, the chairs would like to solicit input on the following draft:

   Title: Adaptive Subscription to YANG Notification
   Link: https://tools.ietf.org/html/draft-wang-netconf-adaptive-subscription
   Abstract:

      This document defines a YANG data model and associated mechanism
      enabling subscriber's adaptive subscriptions to a publisher's event
      streams at various different period intervals with which to report
      updates.  Applying these elements allows both subscriber and
      publisher to automatically adjust the volume of telemetry traffic
      sent from publisher to the receivers.

In particular, please discuss adoption-suitability as it regards to the following questions:

    1) is the problem important for the NETCONF WG to solve?
    2) is the draft a suitable basis for the work?

PS: this message is itself not an adoption poll, but rather an attempt to gauge interest/support for a potential future adoption poll.

NETCONF Chairs

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 10 Aug 2020 16:08:30 +0800

Hi, Chairs

    I would like to contribute to the draft. 

I believe that it is important to adjust the volume of telemetry traffic sent from publisher to the receivers based on situation changes Adaptive subscription draft
enables various subscription policy based on threshold support, timer-event-support and support multiple update interval, can effectively eliminate data collection 
performance bottleneck on the device.
And I also believe that the NETCONF WG is the appropriate WG for this work. RFC8639 and RFC8640 provide a good basis for this work.

I have read the latest version of the draft and believe it has been in good shape and served as a reasonable good starting point.
I have been aware one implementation ongoing. One white paper has been planned for publication to make the whole community benefit from it.
If this work gets adopted, I am willing to review this work as contributor and contribute to any discussion needed and 
we are interested to implement and plan to deploy this technology.

Best Regards
Zongpeng Du

[email-masked] & [email-masked]
 
From: Kent Watsen
Date: 2020-08-06 06:18
To: [email-masked]
Subject: [netconf] Adoption-suitability for draft-wang-netconf-adaptive-subscription
NETCONF WG,

NETCONF Chairs

---

From: Andy Bierman <[email-masked]>
Date: Mon, 10 Aug 2020 12:39:32 -0700

Hi,

I am trying to understand the problem statement in this draft.
It appears to propose a complex self-monitoring system so that YANG Push
subscriptions can change their parameters on the fly to adapt to
changing network conditions. E.g. lower the 'period' parameter when
conditions are right, to produce more push-update records than normal.

The problem is somewhat interesting.
The filtering mechanisms in YANG Push are really awful and there is a need
to improve both filter and trigger mechanisms.  I don't think this draft
offers
a reasonable solution, but I encourage further experimentation.
Prove it works in real products then maybe it will be ready for
standardization.

Andy

On Wed, Aug 5, 2020 at 3:18 PM Kent Watsen <[email-masked]> wrote:

>    Link:
> https://tools.ietf.org/html/draft-wang-netconf-adaptive-subscription
>    Abstract:
>
> PS: this message is itself not an adoption poll, but rather an attempt to
> gauge interest/support for a potential future adoption poll.
>
> NETCONF Chairs
> _______________________________________________
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 11 Aug 2020 09:42:45 +0800

Hi, Andy

    I am interested in the mechinism, too. 
    The mechenism can be seen as a more intelligent negociation between the server and the client.

Best Regards
Zongpeng Du

From: Andy Bierman
Date: 2020-08-11 03:39
To: Kent Watsen
CC: [email-masked]
Subject: Re: [netconf] Adoption-suitability for draft-wang-netconf-adaptive-subscription
Hi,

The problem is somewhat interesting.
The filtering mechanisms in YANG Push are really awful and there is a need
to improve both filter and trigger mechanisms.  I don't think this draft offers
a reasonable solution, but I encourage further experimentation.
Prove it works in real products then maybe it will be ready for standardization.

Andy

NETCONF Chairs

---

From: Andy Bierman <[email-masked]>
Date: Mon, 10 Aug 2020 19:04:25 -0700

> the server and the client.
The draft describes some use-cases for an "ECA Framework".
The challenge is how to move client programming logic to the server in a
workable solution.
Simplistic solutions that allow 1 counter to be checked, etc. are not good
enough.
Robust solutions that are simple enough to be useful are hard to design and
standardize.

Obviously the client can poll the server and issue a <modify-subscription>
or <edit-config> to change the push parameters, then change the parameters
back
again when the special mode is no longer needed. If the network is up, and
not too busy,
and the latency does not cause events to be missed.

IMO, only a generalized ECA solution makes business sense, because it is
too complex
to duplicate over and over in ad-hoc ways for each point solution.

Best Regards

Andy

> ------------------------------
> *From:* Andy Bierman <[email-masked]>
> *Date:* 2020-08-11 03:39
> *To:* Kent Watsen <[email-masked]>
> *CC:* [email-masked]
> *Subject:* Re: [netconf] Adoption-suitability for
> draft-wang-netconf-adaptive-subscription
> Hi,
>