Subject: Re: [netconf] Adoption-suitability for draft-wang-netconf-adaptive-subscription

From: Qin Wu <[email-masked]>
Date: Tue, 11 Aug 2020 02:34:22 +0000

Andy:
I fully agree there is limitation for the current filter and trigger mechanisms when we implement YANG push mechanism in our products.
We do implement this feature in our product.
We see a lot of similar implementations which try to address some of these challenges, e.g., adaptive sampling implemented
by Microsoft in Azure, Event based telemetry proposed by many different vendors,
I am hoping we need to keep on working on ECA model and align this draft with ECA.  low hanging fruit is not far from us,:-).
I also hope who are interested to tackle this issue can join and work together. We need to seek common ground while reserving differences.

-Qin
发件人: netconf [mailto:[email-masked]] 代表 Andy Bierman
发送时间: 2020年8月11日 3:40
收件人: Kent Watsen <[email-masked]>
抄送: [email-masked]
主题: Re: [netconf] Adoption-suitability for draft-wang-netconf-adaptive-subscription

Hi,

I am trying to understand the problem statement in this draft.
It appears to propose a complex self-monitoring system so that YANG Push
subscriptions can change their parameters on the fly to adapt to
changing network conditions. E.g. lower the 'period' parameter when
conditions are right, to produce more push-update records than normal.

The problem is somewhat interesting.
The filtering mechanisms in YANG Push are really awful and there is a need
to improve both filter and trigger mechanisms.  I don't think this draft offers
a reasonable solution, but I encourage further experimentation.
Prove it works in real products then maybe it will be ready for standardization.

Andy

On Wed, Aug 5, 2020 at 3:18 PM Kent Watsen <[email-masked]<mailto:[email-masked]>> wrote:
NETCONF WG,

Per the previous email sent moments ago, the chairs would like to solicit input on the following draft:

   Title: Adaptive Subscription to YANG Notification
   Link: https://tools.ietf.org/html/draft-wang-netconf-adaptive-subscription
   Abstract:
      This document defines a YANG data model and associated mechanism
      enabling subscriber's adaptive subscriptions to a publisher's event
      streams at various different period intervals with which to report
      updates.  Applying these elements allows both subscriber and
      publisher to automatically adjust the volume of telemetry traffic
      sent from publisher to the receivers.

In particular, please discuss adoption-suitability as it regards to the following questions:

    1) is the problem important for the NETCONF WG to solve?
    2) is the draft a suitable basis for the work?

PS: this message is itself not an adoption poll, but rather an attempt to gauge interest/support for a potential future adoption poll.

NETCONF Chairs
_______________________________________________
netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf

---

From: 王巍 <[email-masked]>
Date: Tue, 18 Aug 2020 20:09:19 +0800 (CST)

Hi all,

I have read this draft, here is my answer to the following two questions:

1) is the problem important for the NETCONF WG to solve?
I believe that it is important to provide adaptive sampling and allow the server switch sampling rate, i.e.,adjusts the volume of telemetry sent from the publisher to the subscriber.
I also have been aware that Microsoft has already adopted adaptive telemetry in ASP.NET and Azure function.
And I believe that the NETCONF WG is the appropriate WG for this work. RFC8639 and RFC8640 provide a good basis for this work.

2) is the draft a suitable basis for the work?
I have reviewed the draft and believe it provide a good basis for the starting point.
If this draft gets adopted, I am willing to review any version of this work and contribute to any discussion.

Best Regards,

----------------------------

Wei Wang

China Telecom

发件人: netconf [mailto:[email-masked]] 代表 Kent Watsen
发送时间: 2020 年8月6日 6:18
收件人: [email-masked]
主题: [netconf] Adoption-suitability for draft-wang-netconf-adaptive-subscription

NETCONF WG,

NETCONF Chairs

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 19 Aug 2020 00:24:39 +0800

Dear all,

I read the draft, regarding the two questions, the comments are as follows:

1. Is the problem important for the NETCONF WG to solve?
I believe that it is important to allows the publisher to adjust the volume of telemetry data sent to the subscribers by changing data collection rate when both publishers and subscribers support multiple update intervals or data collection rates. This will reduce overload on the receivers on one hand, getting more telemetry data for network failure diagnosis on the other hand. And I believe that the NETCONF WG is the appropriate WG for this work. RFC8639 and RFC8640 provide a good basis for this work.

2. Is the draft a suitable basis for the work?
I think this draft is mature enough and provide a solid basis for starting point.

Best regards,

Yuan ZHANG 张园 

China Telecom Research Institute 中国电信研究院
Tel: +86-18918588990
Email: [email-masked]