Subject: [netconf] Regarding 108 adoption hums

From: Kent Watsen <[email-masked]>
Date: Wed, 5 Aug 2020 22:13:28 +0000

NETCONF WG,

The Chairs & AD discussed the results of the various adoption hums conducted during the 108 meeting.  There is a sense that the results didn’t adequately determine if the drafts should be adopted.  In particular, it wasn’t clear if the hums reflected a general desire to solve the problem or support for the particular draft.

As such, we’ve decided to send subsequent emails for each draft, or set of drafts if appropriate, to solicit input on following questions:

    1) is the problem important for the NETCONF WG to solve?
    2) is the draft a suitable basis for the work?

NETCONF Chairs

---

From: Tianran Zhou <[email-masked]>
Date: Fri, 7 Aug 2020 02:54:43 +0000

Hi Kent, Mahesh and Robert,

I am just thinking, are these questions redundant to the Adoption call?
It seems the similar questions as supposed to be asked in the adoption call.

Best,
Tianran

-----Original Message-----
From: netconf [mailto:[email-masked]] On Behalf Of Kent Watsen
Sent: Thursday, August 6, 2020 6:13 AM
To: [email-masked]
Subject: [netconf] Regarding 108 adoption hums

NETCONF WG,

NETCONF Chairs

_______________________________________________
netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 7 Aug 2020 09:59:15 +0100

Hi chairs,

I think this is an interesting approach to determining whether there is interest in a number of drafts at the same time, and I agree with you that a hum at a working group meeting means nothing without confirming the opinion on the mailing list.

But I'm worried that you may be introducing yet another piece of process into how we process documents.

The adoption poll, itself, is not necessary if it is obvious to the chairs that a draft is within charter and has support [RFC7221]. But in addition to the poll, we also have somehow introduced an IPR poll at adoption time (while I can see the merits of being explicit about IPR, and we have seen one or two people attempt to wriggle out of their responsibilities, it seems unnecessary to serialize the two calls). Now you appear to be introducing an additional step to test "adoption suitability".

Can I urge you (strongly? :-) to consider the responses to you adoption suitability tests and, if they are solid, to move straight to adoption without making the working group go though a prolonged series of polls. We would, I think, prefer to get on with the work!

Best,
Adrian

-----Original Message-----
From: netconf <[email-masked]> On Behalf Of Kent Watsen
Sent: 05 August 2020 23:13
To: [email-masked]
Subject: [netconf] Regarding 108 adoption hums

NETCONF WG,

NETCONF Chairs

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 7 Aug 2020 11:15:42 +0200

Hi chairs,
hi list,

I have to admit that I am also tad bit puzzled by this procedure, I am 
afraid. If this this would be a WGLC instead of a WGA, I'd be inclined 
to support a more fine grained gateway procedure. But presenting the 
session output as "the results didn’t adequately determine if the drafts 
should be adopted" seems to be a bit off. Why not ask for discrete 
concerns about adoption motions for specific contributions instead of 
this (rather surprising) reset?

Viele Grüße,

Henk

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 7 Aug 2020 11:17:15 +0200

Adrian,

technical discussion of the drafts on the mailing list would help more
than having process meta-discussions. It is good to know who (other
than the authors) is volunteering to substantially review the drafts,
is willing to contribute to the discussions of any issues, and is
planning to implement the technology defined in the drafts as this
will likely help the chairs to make a decision.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 7 Aug 2020 11:27:46 +0200

Hi Jürgen,

piano is 3/5 stars. I think that is a typical moderate agreement (not an 
enthusiastic one, but we are talking about NETCONF here). Two contested 
hums that compete with say 2/5 and 3/5 results should be discussed 
further. In a standard IETF session room hum, I think 3/5 would never 
have had any opposition at all. Please think of the hum results as a 
star rating with all its pros and cons:

> https://xkcd.com/937/

If interest shows to be "an empty promise" this will certainly show in 
the WG as an adopted item. My impression was that the content is 
appropriate and that there is an established baseline for support.

Viele Grüße,

Henk

On 07.08.20 11:19, Juergen Schoenwaelder wrote:
> Henk,
> 
> as far as I recall, all hums were 'piano' and given the new humming
> tool, nobody really knows what a 'piano' result really means. And as
> you know, all WG decisions are taken on the mailing list - so I do
> not see anything wrong with asking the mailing list.
> 
> /js
> 
> On Fri, Aug 07, 2020 at 11:15:42AM +0200, Henk Birkholz wrote:
>> Hi chairs,
>> hi list,
>>
>> afraid. If this this would be a WGLC instead of a WGA, I'd be inclined to
>> support a more fine grained gateway procedure. But presenting the session
>> output as "the results didn’t adequately determine if the drafts should be
>> adopted" seems to be a bit off. Why not ask for discrete concerns about
>> adoption motions for specific contributions instead of this (rather
>> surprising) reset?
>>
>> Viele Grüße,
>>
>> Henk
>>
>>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 7 Aug 2020 11:19:59 +0200

Henk,

/js

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 7 Aug 2020 11:29:41 +0200

Oh, and I fully agree with the quote below!

The scope and phrasing is what leaves me puzzled. An ask about concerns 
with the 3/5 results would be the thing I am expecting - not a reset.

On 07.08.20 11:19, Juergen Schoenwaelder wrote:
> I do

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 7 Aug 2020 12:02:45 +0100

Yes to everything you say, Juergen.

And, indeed, this is often what an adoption poll is intended to measure.

Just saying that (per 7221) you can know these things without a poll, and (perhaps) your test of adoption suitability will collect exactly this information so that a further poll will not be necessary.

Best,
Adrian (who hopes that WG participants will respond carefully to the seven separate requests for info)

-----Original Message-----
From: Juergen Schoenwaelder <[email-masked]> 
Sent: 07 August 2020 10:17
To: Adrian Farrel <[email-masked]>
Cc: 'Kent Watsen' <[email-masked]>; [email-masked]
Subject: Re: [netconf] Regarding 108 adoption hums

Adrian,

/js

---

From: tom petch <[email-masked]>
Date: Fri, 7 Aug 2020 11:12:38 +0000

From: netconf <[email-masked]> on behalf of Adrian Farrel <[email-masked]>
Sent: 07 August 2020 12:02

<tp>
My left field view is to oppose adoption regardless.  The WG has some nine I-D comprising over 400pp dating in some cases back four years.  I think that it the WG has any energy then at least some of these need to get to the IESG before the WG considers more work.  Indeed I know of an AD who once changed the WG charter to stop any more work being taken on until the existing work had progressed.

Tom Petch

Best,

-----Original Message-----
From: Juergen Schoenwaelder <[email-masked]>
Sent: 07 August 2020 10:17
To: Adrian Farrel <[email-masked]>
Cc: 'Kent Watsen' <[email-masked]>; [email-masked]
Subject: Re: [netconf] Regarding 108 adoption hums

Adrian,

/js

---

From: Andy Bierman <[email-masked]>
Date: Fri, 7 Aug 2020 16:13:16 -0700

Hi,

> will likely help the chairs to make a decision.

IMO it makes more sense to discuss what problems the NETCONF/NETMOD WGs
should be solving, rather than adoption of solutions to problems. The WG
should be
finishing up configured notifications. Try to standardize binary telemetry
instead
of just leaving placeholders for proprietary vendor solutions.

Your questions are most relevant because we do not have any clear definition
or "support" or "oppose" for adoption of a draft.
Support often means "I am happy for you to work on this draft".
The culture of the IETF creates a strong bias against anybody actually
opposing adoption of anything. Usual attitude: "Let people experiment.
Maybe they will
come up with something good in the end."

If only the co-authors support, and nobody opposes, then the work will get
stuck.
Often WGs adopt after such a poll outcome and act surprised a year later
when
the draft goes nowhere.

Andy

> > I think this is an interesting approach to determining whether there is
> interest in a number of drafts at the same time, and I agree with you that
> a hum at a working group meeting means nothing without confirming the
> opinion on the mailing list.
> >
> > The adoption poll, itself, is not necessary if it is obvious to the
> chairs that a draft is within charter and has support [RFC7221]. But in
> addition to the poll, we also have somehow introduced an IPR poll at
> adoption time (while I can see the merits of being explicit about IPR, and
> we have seen one or two people attempt to wriggle out of their
> responsibilities, it seems unnecessary to serialize the two calls). Now you
> appear to be introducing an additional step to test "adoption suitability".
> >
> > Can I urge you (strongly? :-) to consider the responses to you adoption
> suitability tests and, if they are solid, to move straight to adoption
> without making the working group go though a prolonged series of polls. We
> would, I think, prefer to get on with the work!
> >
> > Best,
> > Adrian
> >
> > The Chairs & AD discussed the results of the various adoption hums
> conducted during the 108 meeting.  There is a sense that the results didn’t
> adequately determine if the drafts should be adopted.  In particular, it
> wasn’t clear if the hums reflected a general desire to solve the problem or
> support for the particular draft.
> >
> > As such, we’ve decided to send subsequent emails for each draft, or set
> of drafts if appropriate, to solicit input on following questions:
> >

---

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 7 Aug 2020 17:51:08 -0700

> On Aug 7, 2020, at 4:13 PM, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
> 
> 
> On Fri, Aug 7, 2020 at 2:17 AM Juergen Schoenwaelder <[email-masked] <mailto:[email-masked]>> wrote:
> Adrian,
> 
> should be solving, rather than adoption of solutions to problems.

Precisely. 

Coming out of the meeting, it was not clear to us (the chairs, at least), whether the problem the drafts were describing are issues the WG wanted to see solved. We are hoping that the individual e-mails on the drafts trigger the kind of technical discussion that leads us to get a gauge of what the WG thinks are the problems they want to see solved, or not solved. As Juergen suggests, when responding, it would be great to see who, outside the pool of authors, is willing to review the drafts, contribute to the discussion of the draft, and is planning to implement the draft. 

For us it will also answer the process question of whether the drafts should be adopted or not, in which case we can skip the adoption poll.

> The WG should be
> finishing up configured notifications. Try to standardize binary telemetry instead

Good point. While we are at it, we should discuss whether these are problems WG should be working on.

> opposing adoption of anything. Usual attitude: "Let people experiment. Maybe they will
> If only the co-authors support, and nobody opposes, then the work will get stuck.
> Often WGs adopt after such a poll outcome and act surprised a year later when
> the draft goes nowhere.
> 
> 
> Andy
> 
> 
> 
> 
> 
> 
> /js
> 
> > From: netconf <[email-masked] <mailto:[email-masked]>> On Behalf Of Kent Watsen
> > To: netconf@ietf..org <mailto:[email-masked]>
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/netconf <https://www.ietf.org/mailman/listinfo/netconf>
> > 
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/netconf <https://www.ietf.org/mailman/listinfo/netconf>
> 
> -- 
> Fax:   +49 421 200 3103         <https://www.jacobs-university.de/ <https://www.jacobs-university.de/>>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netconf <https://www.ietf.org/mailman/listinfo/netconf>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netconf <https://www.ietf.org/mailman/listinfo/netconf>
Mahesh Jethanandani
[email-masked]

---

From: Tianran Zhou <[email-masked]>
Date: Mon, 10 Aug 2020 09:36:00 +0000

The working group should not function as a rubber stamp for proprietary solutions and academic work.
We should not ask for the working group adoption, if the solution does not have requirement.
I strongly suggest the Chairs and the ADs to set a high bar to only adopt solutions with at least two implementations.

Tianran

From: netconf [mailto:[email-masked]] On Behalf Of Andy Bierman
Sent: Saturday, August 8, 2020 7:13 AM
To: Juergen Schoenwaelder <[email-masked]>; Adrian Farrel <[email-masked]>; Kent Watsen <[email-masked]>; Netconf <[email-masked]>
Subject: Re: [netconf] Regarding 108 adoption hums

Hi,

On Fri, Aug 7, 2020 at 2:17 AM Juergen Schoenwaelder <[email-masked]<mailto:[email-masked]>> wrote:
Adrian,

IMO it makes more sense to discuss what problems the NETCONF/NETMOD WGs
should be solving, rather than adoption of solutions to problems. The WG should be
finishing up configured notifications. Try to standardize binary telemetry instead
of just leaving placeholders for proprietary vendor solutions.

Andy

/js

On Fri, Aug 07, 2020 at 09:59:15AM +0100, Adrian Farrel wrote:
> From: netconf <[email-masked]<mailto:[email-masked]>> On Behalf Of Kent Watsen
> To: netconf@ietf..org<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf