Subject: Re: [netconf] Adoption-suitability for draft-tao-netconf-notif-node-tag-capabilities

From: "[email-masked]" <[email-masked]>
Date: Mon, 10 Aug 2020 16:58:42 +0800

Hi, Chairs

    I would like to contribute to the draft. 

    1) is the problem important for the NETCONF WG to solve?

I believe that it is important to capture characteristics data or KPI data for service assurance application and reduce the amount of 
unnecessary data to be streamed out to the destination. Telemetry data tagging capability draft provides telemetry data classification and 
help the client only fetch characteristics data.
And I also believe that the NETCONF WG is the appropriate WG for this work. draft-ietf-netconf-notification-capabilities provides a good basis for server capabilities advertisement and has already stable for publication.
Telemetry data tagging capability can be built on top of it.

    2) is the draft a suitable basis for the work?

I have read the latest version of the draft and believe it has been in good shape and served as a reasonable good starting point.
I have been aware one implementation has been demonstrated last year in IETF hackathon.
If this work gets adopted, I am willing to review this work as contributor and contribute to any discussion needed and 
we are interested to implement and plan to deploy this technology.

Best Regards
Zongpeng Du

[email-masked] & [email-masked]
 
From: Kent Watsen
Date: 2020-08-06 06:17
To: [email-masked]
Subject: [netconf] Adoption-suitability for draft-tao-netconf-notif-node-tag-capabilities

NETCONF WG,

Per the previous email sent moments ago, the chairs would like to solicit input on the following draft:

   Title: Self-explanation data Node tag capability
   Link: https://tools.ietf.org/html/draft-tao-netconf-notif-node-tag-capabilities
   Abstract:

      Before a client application subscribes to updates from a datastore,
      server capabilities related to "Subscription to YANG Datastores" can
      be advertised using YANG Instance Data format.  These server
      capabilities can be documented at implement time or reported at run-
      time.

      This document proposes a YANG module for self-explanation data Node
      tag capability which augments system capabilities model and provide
      additional self-explanation data node attributes associated with node
      selectors within per-node capabilities.

In particular, please discuss adoption-suitability as it regards to the following questions:

    1) is the problem important for the NETCONF WG to solve?
    2) is the draft a suitable basis for the work?

PS: this message is itself not an adoption poll, but rather an attempt to gauge interest/support for a potential future adoption poll.

NETCONF Chairs

---

From: Qin Wu <[email-masked]>
Date: Tue, 11 Aug 2020 02:10:38 +0000

发件人: netconf [mailto:[email-masked]] 代表 Andy Bierman
发送时间: 2020年8月11日 3:39
收件人: Kent Watsen <[email-masked]>
抄送: [email-masked]
主题: Re: [netconf] Adoption-suitability for draft-tao-netconf-notif-node-tag-capabilities

Hi,

I am trying to understand the problem statement in this draft.
It seems to be a way to assign various tags to data node objects.
It uses the tags type from ietf-module-tags, which implies that modules and nodes
share the same set of tags.
[Qin]: It is not the goal to share the same set of tags for module and nodes, nodes could
Have their own tags and used to tag management and operation data or telemetry data defined within the module , it is data node level tag, not module level tag.
If this will be the issue, we can define tag separately.
There is also an assumption that the error/hints mechanism in RFC 8639 and 8641
do not work and this significant amount of proposed metadata could be used to avoid
receiving an <rpc-error> for an <establish-subscription> or <edit-config> request.

[Qin]: See clarification for data export capability draft, it is designed as server capability exposure, not targeted to replace error handling  for <establish-subscription> and <edit-config>.
They are used at different phase. The big different with Data export capability, is it doesn’t tell the client how to select transport protocol, encoding, security scheme, etc, it tells the client
Which data object is characteristics data or KPI data, which help avoid fetch noise data from the data source and provide comprehensive view of the network quality or network health
from different angles.

IMO the current approach is sufficient and new mechanisms are not needed.

Andy

On Wed, Aug 5, 2020 at 3:18 PM Kent Watsen <[email-masked]<mailto:[email-masked]>> wrote:

NETCONF WG,

NETCONF Chairs
_______________________________________________
netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf

---

From: 王巍 <[email-masked]>
Date: Tue, 18 Aug 2020 20:34:56 +0800 (CST)

Hi all,

1) is the problem important for the NETCONF WG to solve?
I believe that it is important to capture characteristics data or KPI data for service assurance application and reduce the amount of
unnecessary data to be streamed out to the destination. Telemetry data tagging capability draft provides telemetry data classification and
help the client only fetch characteristics data.
And I also believe that the NETCONF WG is the appropriate WG for this work.
draft-ietf-netconf-notification-capabilities defines server capabilities advertisement and provides a good basis for Telemetry data tagging capability draft.

2) is the draft a suitable basis for the work?
I have review v-02 and believe it provides a sound basis for this work. Also if I remember correct, the demo on this idea has been presented in one of hackathon in last year.
If this work gets adopted, I am willing to review it and contribute to the discussion.

Best Regards,

----------------------------

Wei Wang

China Telecom

发件人: netconf [mailto:[email-masked]] 代表 Kent Watsen
发送时间: 2020 年8月6日 6:18
收件人: [email-masked]
主题: [netconf] Adoption-suitability for draft-tao-netconf-notif-node-tag-capabilities

NETCONF WG,

time.

NETCONF Chairs

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 19 Aug 2020 00:23:45 +0800

Dear all, 

Regarding the two questions, the comments are as follows:

1. Is the problem important for the NETCONF WG to solve?
I believe that it is important to retrieve different KPI data from various different data source and correlate them together and provide comprehensive view of the network quality or network health from different angles. In addition, it is important to eliminate noise data to be exported to the management plane. Telemetry data tagging and classification is crucial to help capture characteristics data and reduce amount of streamed data to the destination. And I also believe that the NETCONF WG is the appropriate WG for this work. draft-ietf-netconf-notification-capabilities separate notification capability model into system capability model and ietf-notification-capabilities model which serve as a good basis for telemetry data node capabilities definitions.

2. Is the draft a suitable basis for the work?
I have been aware MDT Telemetry tagging Hackathon project in IETF 106 which was demonstrated in both IETF 106 Hakcathon meeting and Hackdemo Happy Hour. I think this draft is mature enough and provide a solid basis for starting point. If this work gets adopted, I will be glad to review any update of this draft and contribute to relate discussion.

I believe it should move forward.

Best regards,

Yuan ZHANG 张园 

China Telecom Research Institute 中国电信研究院
Tel: +86-18918588990
Email: [email-masked]