Subject: [netconf] Netconf over QUIC

From: tom petch <[email-masked]>
Date: Mon, 26 Oct 2020 17:42:50 +0000

I see an I-D aimed at the QUIC WG proposing QUIC as a transport for Netconf.  Is this something that the Netconf WG should be involved in ?  I do not recognise the names of the authors of this I-D!

Tom Petch

---

From: Kent Watsen <[email-masked]>
Date: Mon, 26 Oct 2020 19:46:07 +0000

> On Oct 26, 2020, at 1:42 PM, tom petch <[email-masked]> wrote:
> 

I haven’t seen the draft but, per your description, the NETCONF's charter [1] says that the WG is “responsible” for:

	c) The transports and encodings used by the data model-driven protocols.

I don’t think this is an exclusive responsibility, but it would be odd for another WG to take on this work (especially without involving us!), likely to the point of an objection.

FWIW, what the CORE WG did is different, as they defined a whole new protocol (COAP), which happens to resemble RESTCONF.

[1] https://datatracker.ietf.org/wg/netconf/about/ <https://datatracker.ietf.org/wg/netconf/about/>

Kent // as co-chair

---

From: tom petch <[email-masked]>
Date: Tue, 27 Oct 2020 17:17:20 +0000

From: Kent Watsen <[email-masked]>
Sent: 26 October 2020 19:46

On Oct 26, 2020, at 1:42 PM, tom petch <[email-masked]<mailto:[email-masked]>> wrote:

Tom Petch

<tp>
Kent 
some more details
=======================================
Network Working Group                                             J. Dai
INTERNET-DRAFT                                                   X. Wang
Intended Status: Proposed Standard                                Y. Kou
Expires: April 26, 2021                                          L. Zhou
                      China Information Communication Technologies Group
                                                        October 26, 2020

                  Using NETCONF over QUIC connection 
                       draft-dai-quic-netconf-03

Abstract

   The Network Configuration Protocol (NETCONF) provides mechanisms to  
   install, manipulate, and delete the configuration of network devices.
   At present, almost all implementations of NETCONF are based on TCP 
   based protocol. QUIC, a new UDP-based transport protocol, can 
   facilitate to improve the transportation performance, information 
   security and resource utility when being used as an infrastructure layer
   of NETCONF. This document describes how to use the QUIC protocol as the 
   transport protocol of NETCONF(It is so called NETCONFoQUIC).
=============================================

Tom Petch

[1] https://datatracker.ietf.org/wg/netconf/about/

Kent // as co-chair