Subject: [netconf] Normative reference to XML specification

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 13 Oct 2020 22:45:19 -0700

[As a contributor]

Hi WG,

RFC Editors want to update the normative reference to XML from what is specified in RFC 6241. The latest such specification is W3C.REC-xml-20081126, per the editors.

RFC 6241 refers to W3C.REC-xml-20001006. The TWAMP YANG model is trying to give an example of NETCONF configuration of the model in XML, and the editors wanted to update the reference to W3C.REC-xml-20081126. I do not know what the differences between the two versions are, but would it be ok for them to update the reference? 

Thanks.

Mahesh Jethanandani
[email-masked]

---

From: Martin Björklund <[email-masked]>
Date: Wed, 14 Oct 2020 08:11:53 +0200 (CEST)

Hi,

Mahesh Jethanandani <[email-masked]> wrote:
> [As a contributor]
> 
> Hi WG,
> 
> RFC Editors want to update the normative reference to XML from what is
> specified in RFC 6241. The latest such specification is
> W3C.REC-xml-20081126, per the editors.
> 
> RFC 6241 refers to W3C.REC-xml-20001006. The TWAMP YANG model is
> trying to give an example of NETCONF configuration of the model in
> XML, and the editors wanted to update the reference to
> W3C.REC-xml-20081126. I do not know what the differences between the
> two versions are, but would it be ok for them to update the reference?

I think it is ok.  The example is still valid according to XML 1.0
second edition (W3C.REC-xml-20001006) so it is still valid according
to RFC 6241.

/martin