Subject: [netconf] draft-ietf-netconf-udp-notif encoding option

From: Andy Bierman <[email-masked]>
Date: Wed, 18 Nov 2020 20:07:00 -0800

Hi,

There was a suggestion to assign an encoding enumeration to
represent "other".  I think this could work, if it meant that the
receiver should check the options for an "Encoding ID Option",

  Type = to be assigned
  Length = 2 + length of variable data
  Variable data = some string identifying the encoding type

IMO this allows a good balance between message size and interoperability,
and it is very extensible.

Andy

---

From: Pierre Francois <[email-masked]>
Date: Thu, 19 Nov 2020 09:01:30 +0100

Hey Andy,

I like this. Let me check around and get back to you.

Cheers,

Pierre.

Le jeu. 19 nov. 2020 à 05:07, Andy Bierman <[email-masked]> a écrit :

> _______________________________________________
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 19 Nov 2020 08:47:08 -0800

> I like this. Let me check around and get back to you.

There are some details like padding (to maintain quad alignment), but
this completely decouples the encoding politics from the transport layer.

Remember the content-id field I asked about awhile back?
This can be used for that.

Rob touched on the $64 question in the meeting that got ignored

How do you know which protobuff it is? Is it gNMI? OC-telemetry? vendor
gRPC data?

Perhaps:

  encoding-id = gpb/gnmi
                      = gpb/openconfig-telemetry
                      = gpb/example-bgp-state

Cheers,

Andy