Subject: [netconf] [Technical Errata Reported] RFC8040 (6363)

From: RFC Errata System <[email-masked]>
Date: Tue, 22 Dec 2020 06:39:49 -0800 (PST)

The following errata report has been submitted for RFC8040,
"RESTCONF Protocol".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6363

--------------------------------------
Type: Technical
Reported by: Muly Ilan <[email-masked]>

Section: 4.8.2.

Original Text
-------------
   By default, the server will include all sub-resources within a
   retrieved resource that have the same resource type as the requested
   resource.  The exception is the datastore resource.  If this resource
   type is retrieved, then by default the datastore and all child data
   resources are returned.

Corrected Text
--------------
   By default, the server SHOULD include all sub-resources within a
   retrieved resource that have the same resource type as the requested
   resource.  The exception is the datastore resource.  If this resource
   type is retrieved, then by default the datastore and all child data
   resources are returned.

Notes
-----
Substitute "will" by "SHOULD".

Use one of the keywords of RFC2119 to clarify the expected server behavior.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8040 (draft-ietf-netconf-restconf-18)
--------------------------------------
Title               : RESTCONF Protocol
Publication Date    : January 2017
Author(s)           : A. Bierman, M. Bjorklund, K. Watsen
Category            : PROPOSED STANDARD
Source              : Network Configuration
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Andy Bierman <[email-masked]>
Date: Tue, 22 Dec 2020 07:06:48 -0800

Hi,

This errata should be rejected.
The proposed text changes the semantics of the paragraph.
The original word "will" is not ambiguous or used in error.

Andy

---

From: Kent Watsen <[email-masked]>
Date: Tue, 22 Dec 2020 16:57:09 +0000

+1

> On Dec 22, 2020, at 10:06 AM, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
> 
> On Tue, Dec 22, 2020 at 6:40 AM RFC Errata System <[email-masked] <mailto:[email-masked]>> wrote:
> https://www.rfc-editor.org/errata/eid6363 <https://www.rfc-editor.org/errata/eid6363>
> 
> Reported by: Muly Ilan <[email-masked] <mailto:[email-masked]>>
> 
> Section: 4.8.2.
> 
> Original Text
> -------------