Subject: [netconf] [Editorial Errata Reported] RFC8650 (6368)

From: RFC Errata System <[email-masked]>
Date: Thu, 24 Dec 2020 06:56:19 -0800 (PST)

The following errata report has been submitted for RFC8650,
"Dynamic Subscription to YANG Events and Datastores over RESTCONF".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6368

--------------------------------------
Type: Editorial
Reported by: Muly Ilan <[email-masked]>

Section: A.2.1

Original Text
-------------
A.2.1.  "subscription-modified"

   A "subscription-modified" encoded in JSON would look like:

   {
     "ietf-restconf:notification" : {
       "eventTime": "2007-09-01T10:00:00Z",
       "ietf-subscribed-notifications:subscription-modified": {
         "id": 39,
         "uri": "https://example.com/restconf/subscriptions/22"
         "stream-xpath-filter": "/example-module:foo",
         "stream": {
            "ietf-netconf-subscribed-notifications" : "NETCONF"
         }
       }
     }
   }

Corrected Text
--------------
A.2.1.  "subscription-modified"

   A "subscription-modified" encoded in JSON would look like:

   {
     "ietf-restconf:notification" : {
       "eventTime": "2007-09-01T10:00:00Z",
       "ietf-subscribed-notifications:subscription-modified": {
         "id": 22,
         "uri": "https://example.com/restconf/subscriptions/22"
         "stream-xpath-filter": "/example-module:foo",
         "stream": {
            "ietf-netconf-subscribed-notifications" : "NETCONF"
         }
       }
     }
   }

Notes
-----
Subscription ID should be 22 instead of 39.

An existing subscription ID cannot be changed. According to the previous examples in Appendix A the subscription got the ID 22. Also the example URI indicates ID of 22.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8650 (draft-ietf-netconf-restconf-notif-15)
--------------------------------------
Title               : Dynamic Subscription to YANG Events and Datastores over RESTCONF
Publication Date    : November 2019
Author(s)           : E. Voit, R. Rahman, E. Nilsen-Nygaard, A. Clemm, A. Bierman
Category            : PROPOSED STANDARD
Source              : Network Configuration
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Thu, 24 Dec 2020 15:14:15 +0000

Rather than changing the subscription from 22 to 39, the URI should be made:
https://example.com/restconf/subscriptions/39

Reasons:
(1) There is no assumption that the subscription is the same one as for the 
previous example.
(2) We want to keep the examples in lock-step with RFC8640.

Eric

> -----Original Message-----
> From: RFC Errata System <[email-masked]>
> Sent: Thursday, December 24, 2020 9:56 AM
> To: Eric Voit (evoit) <[email-masked]>; Reshad Rahman (rrahman)
> <[email-masked]>; Einar Nilsen-Nygaard (einarnn) <[email-masked]>;
> [email-masked]; [email-masked]; [email-masked]; Rob Wilton
> (rwilton) <[email-masked]>; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Editorial Errata Reported] RFC8650 (6368)
>
> The following errata report has been submitted for RFC8650, "Dynamic
> Subscription to YANG Events and Datastores over RESTCONF".
>
> An existing subscription ID cannot be changed. According to the previous
> examples in Appendix A the subscription got the ID 22. Also the example URI
> indicates ID of 22.
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please use 
> "Reply
> All" to discuss whether it should be verified or rejected. When a decision 
> is
> reached, the verifying party can log in to change the status and edit the 
> report, if
> necessary.
>
> Title               : Dynamic Subscription to YANG Events and Datastores 
> over
> RESTCONF

---

From: Kent Watsen <[email-masked]>
Date: Thu, 24 Dec 2020 16:23:20 +0000

Hi Eric,

Thank you for you comment.  But note that the errata system is binary, either an errata is accepted or rejected.  To do what you say entails rejecting this errata and submitting a different one to say it,  Is this what you advocate?

Thanks,
Kent

> On Dec 24, 2020, at 10:14 AM, Eric Voit (evoit) <[email-masked]> wrote:
>

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Thu, 24 Dec 2020 18:27:31 +0000

Yes, that is what I suggest: that we change '22' to '39' in the URI.

Eric

> From: Kent Watsen <[email-masked]>
> Sent: Thursday, December 24, 2020 11:23 AM
> To: Eric Voit (evoit) <[email-masked]>
> Cc: RFC Errata System <[email-masked]>; Reshad Rahman (rrahman)
> (rwilton) <[email-masked]>; Mahesh Jethanandani
> <[email-masked]>; [email-masked]; [email-masked]
> Subject: Re: [Editorial Errata Reported] RFC8650 (6368)
> 
> Hi Eric,
> 
> Thank you for you comment.  But note that the errata system is binary,
either an
> errata is accepted or rejected.  To do what you say entails rejecting this
errata
> and submitting a different one to say it,  Is this what you advocate?
> 
> Thanks,
> Kent
> 
> 
> > (1) There is no assumption that the subscription is the same one as
> > for the previous example.