Subject: [netext] [Fwd: I-D Action:draft-ietf-netext-pmip6-lr-ps-02.txt]

From: Marco Liebsch <[email-masked]>
Date: Wed, 27 Jan 2010 11:42:05 +0100

Folks,

in parallel to the charter discussion, work goes on. Please find an 
update of
the PMIPv6 Localized Routing Problem Statement uploaded to the
drafts repository. This version addresses all comments we received so far.
Many thanks to Mohana; her comments to the last version helped a lot to
improve the PS, in particular w.r.t. definitions and consistency.

Please have a look and let us know if you have further comments to the
problem statement.

Best regards,
marco

Subject: [netext] I-D Action:draft-ietf-netext-pmip6-lr-ps-02.txt
From: [email-masked]
To: [email-masked]
Cc: [email-masked]
Date: Fri, 22 Jan 2010 08:45:02 -0800 (PST)
List-Id: "Mailing list for discusion of extensions to network mobility protocol, i.e PMIP6. " <netext.ietf.org>

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network-Based Mobility Extensions Working Group of the IETF.

	Title           : PMIPv6 Localized Routing Problem Statement
	Author(s)       : M. Liebsch, et al.
	Filename        : draft-ietf-netext-pmip6-lr-ps-02.txt
	Pages           : 17
	Date            : 2010-01-22

Proxy Mobile IPv6 is the IETF standard for network-based mobility
management.  In Proxy Mobile IPv6, mobile nodes are topologically
anchored at a Local Mobility Anchor, which forwards all data for
registered mobile nodes.  The set up and maintenance of localized
routing, which allows forwarding of data packets between mobile nodes
and correspondent nodes directly without involvement of the Local
Mobility Anchor in forwarding, is not considered.  This document
describes the problem space of localized routing in Proxy Mobile
IPv6.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-netext-pmip6-lr-ps-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
netext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netext

---

From: Xiangsong Cui <[email-masked]>
Date: Thu, 28 Jan 2010 10:56:00 +0800

Dear Marco and all,

I am reading the draft, and I have some thought and questions.

In section 3.1 (last sentence of the first paragraph) , it says:
    In the context of this document, such localized
   communication comprises offloading traffic from LMAs and establish a
   direct forwarding path between the two communication endpoints.
                                                        ^^^^^^^^^^^^^^^^^^^^^^^  
I wonder does that means the two access gateways or the mobile nodes?

Additionally,  in the scenario part,
One use case is MN and CN in same LMA/MAG,
        :   
        +
        |   
     +----+ 
     |LMA1| 
     +----+ 
        |   
        |   
        |        
     +----+      
     |MAG1|      
     +----+      
     :    :      
   +---+ +---+   
   |MN | |CN1|   
   +---+ +---+   

Another use case is MN and CN in different LMA/MAG,

           Internet Backbone         
          :                  :       
          +------------------+       
          |                  |       
       +----+              +----+    
       |LMA1|              |LMA2|    
       +----+              +----+    
          |                  |       
          |                  |       
     +----+------------------+----+  
     |                            |  
  +----+                       +----+
  |MAG1|                       |MAG2|
  +----+                       +----+
  :    :                          :  
+---+ +---+                     +---+
|MN | |CN1|                     |CN2|
+---+ +---+                     +---+

These cases recall me to another case, 
if MN is MIP based while CN is PMIP based, how about that?
Is it intercrossed to LR scope?

       Internet Backbone
      :                  :
      +------------------+
      |                  |
   +----+              +----+
   |HA1 |              |LMA2|
   +----+              +----+
      |                  |
      |                  |
      +------------------+
      |                  |
   +----+             +----+
   | MN |             |MAG2|
   +----+             +----+
                         :
                       +---+
                       |CN2|
                       +---+
 
There is a separate draft for this case,
http://tools.ietf.org/id/draft-cui-netext-route-optimization-agent-ext-02.txt

In this draft, the Route Optimization Agent is also for optimized routing.

And more, it partly matches the LR space, the other part in MIP RO space.
It also does "establish a direct forwarding path between the two 
communication endpoints."

[lr-ps-draft]
4.  Functional Requirements for Localized Routing

   Several tasks need to be performed by the network infrastructure
   components before relevant information for such direct communication
   is discovered and associated states for localized routing can be set
   up.  The following list summarizes some key functions, which need to
   be performed by the PMIPv6 enabled network infrastructure to
   substitute mobile nodes in setting up a direct route.

[roa-draft] ROA (the infrastructure) operation before ... , associated 
states ... set up in ROA

[lr-ps-draft]
   o  Detection of the possibility to perform localized routing.  This
      function includes looking at data packets' source and destination
      address.

[roa-draft] MN sends HoTI and CoTI for detection, and ROA does
check agent role based on the packets' source and destination address.

[lr-ps-draft]
   o  Initiation of a procedure, which sets up a localized routing path.

[roa-draft] MN initiates the procedure, and ROA reflects and involved in 
the procedure.

[lr-ps-draft]
   o  Discovery of stateful entities (i.e. the LMA(s) and/or the
      MAG(s)), which maintain and can provide relevant information
      needed to set up a localized routing path.  Such information may
      include the routable address of an LMA or MAG, where one or both
      mobile nodes are connected to and registered with.

[roa-draft] ROA maintains the information ...  routable address ...

[lr-ps-draft]
   o  Control in setting up and maintaining (e.g. during handover) the
      localized routing path.  Control is also needed to terminate the
      use of a localized routing path and to delete associated states,
      whereas a trigger for the termination may come from a non-PMIPv6
      related component.

[roa-draft] ROA controls and maintains ......

So, what do you think about the roa draft? 
Is it also a network based mobility management?

Thanks and regards

Xiangsong

----- Original Message ----- 
From: "Marco Liebsch" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, January 27, 2010 6:42 PM
Subject: [netext] [Fwd: I-D Action:draft-ietf-netext-pmip6-lr-ps-02.txt]

> Please have a look and let us know if you have further comments to the

--------------------------------------------------------------------------------