Subject: Re: [netext] [Fwd: I-D Action:draft-ietf-netext-pmip6-lr-ps-02.txt]

From: Marco Liebsch <[email-masked]>
Date: Tue, 02 Mar 2010 16:38:46 +0100

Hi Xiangsong,

Xiangsong Cui wrote:
> Dear Marco and all,
>
> I am reading the draft, and I have some thought and questions.
>
> In section 3.1 (last sentence of the first paragraph) , it says:
>    In the context of this document, such localized
>   communication comprises offloading traffic from LMAs and establish a
>   direct forwarding path between the two communication endpoints.
>                                                        
> ^^^^^^^^^^^^^^^^^^^^^^^  I wonder does that means the two access 
> gateways or the mobile nodes?
we discussed a similar statement in the draft in the same context between
co-authors.
We think that "path between the two endpoints" is ok, as the sentence is
not about "tunnel endpoints". The communication path is between MN and CN.
When the draft would write about tunnel endpoints, the two MAGs must be 
referred
to. Do you agree?

>
> Additionally,  in the scenario part,
> One use case is MN and CN in same LMA/MAG,
>        :          +
>        |       +----+     |LMA1|     +----+        |          |   
>        |            +----+          |MAG1|          +----+          
> :    :        +---+ +---+     |MN | |CN1|     +---+ +---+  
> Another use case is MN and CN in different LMA/MAG,
>
>           Internet Backbone                  :                  
> :                +------------------+                
> |                  |             +----+              +----+          
> |LMA1|              |LMA2|          +----+              +----+    
>          |                  |                |                  
> |           +----+------------------+----+      
> |                            |   +----+                       +----+
>  |MAG1|                       |MAG2|
>  +----+                       +----+
>  :    :                          :  +---+ +---+                     +---+
> |MN | |CN1|                     |CN2|
> +---+ +---+                     +---+
>
> These cases recall me to another case, if MN is MIP based while CN is 
> PMIP based, how about that?
> Is it intercrossed to LR scope?
We had some discussion in the past about the scope of localized routing
in NetExt. According to the conclusion, NetExt scope covers only localized
routing between PMIP managed nodes. Hence, the PS covers only such
use cases.

marco

>
>       Internet Backbone
>      :                  :
>      +------------------+
>      |                  |
>   +----+              +----+
>   |HA1 |              |LMA2|
>   +----+              +----+
>      |                  |
>      |                  |
>      +------------------+
>      |                  |
>   +----+             +----+
>   | MN |             |MAG2|
>   +----+             +----+
>                         :
>                       +---+
>                       |CN2|
>                       +---+
>
> There is a separate draft for this case,
> http://tools.ietf.org/id/draft-cui-netext-route-optimization-agent-ext-02.txt 
>
>
> In this draft, the Route Optimization Agent is also for optimized 
> routing.
>
> And more, it partly matches the LR space, the other part in MIP RO space.
> It also does "establish a direct forwarding path between the two 
> communication endpoints."
>
>
> [lr-ps-draft]
> 4.  Functional Requirements for Localized Routing
>
>   Several tasks need to be performed by the network infrastructure
>   components before relevant information for such direct communication
>   is discovered and associated states for localized routing can be set
>   up.  The following list summarizes some key functions, which need to
>   be performed by the PMIPv6 enabled network infrastructure to
>   substitute mobile nodes in setting up a direct route.
>
> [roa-draft] ROA (the infrastructure) operation before ... , associated 
> states ... set up in ROA
>
>
> [lr-ps-draft]
>   o  Detection of the possibility to perform localized routing.  This
>      function includes looking at data packets' source and destination
>      address.
>
> [roa-draft] MN sends HoTI and CoTI for detection, and ROA does
> check agent role based on the packets' source and destination address.
>
>
> [lr-ps-draft]
>   o  Initiation of a procedure, which sets up a localized routing path.
>
> [roa-draft] MN initiates the procedure, and ROA reflects and involved 
> in the procedure.
>
>
> [lr-ps-draft]
>   o  Discovery of stateful entities (i.e. the LMA(s) and/or the
>      MAG(s)), which maintain and can provide relevant information
>      needed to set up a localized routing path.  Such information may
>      include the routable address of an LMA or MAG, where one or both
>      mobile nodes are connected to and registered with.
>
> [roa-draft] ROA maintains the information ...  routable address ...
>
>
> [lr-ps-draft]
>   o  Control in setting up and maintaining (e.g. during handover) the
>      localized routing path.  Control is also needed to terminate the
>      use of a localized routing path and to delete associated states,
>      whereas a trigger for the termination may come from a non-PMIPv6
>      related component.
>
> [roa-draft] ROA controls and maintains ......
>
>
> So, what do you think about the roa draft? Is it also a network based 
> mobility management?
>
> Thanks and regards
>
> Xiangsong
>
>
> ----- Original Message ----- From: "Marco Liebsch" 
> <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, January 27, 2010 6:42 PM
> Subject: [netext] [Fwd: I-D Action:draft-ietf-netext-pmip6-lr-ps-02.txt]
>
>
>> Folks,
>>
>> in parallel to the charter discussion, work goes on. Please find an 
>> update of
>> the PMIPv6 Localized Routing Problem Statement uploaded to the
>> drafts repository. This version addresses all comments we received so 
>> far.
>> Many thanks to Mohana; her comments to the last version helped a lot to
>> improve the PS, in particular w.r.t. definitions and consistency.
>>
>> Please have a look and let us know if you have further comments to the
>> problem statement.
>>
>> Best regards,
>> marco
>>
>>
>>
>>
>>
>>
>>
>
>
> -------------------------------------------------------------------------------- 
>
>
>
>> _______________________________________________
>> netext mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/netext
>>

---

From: Xiangsong Cui <[email-masked]>
Date: Tue, 09 Mar 2010 13:07:12 +0800

Hi Marco,

Sorry for the late response,
my comment inline.

Regards
Xiangsong

----- Original Message ----- 
From: "Marco Liebsch" <[email-masked]>
To: "Xiangsong Cui" <[email-masked]>
Cc: "Marco Liebsch" <[email-masked]>; <[email-masked]>
Sent: Tuesday, March 02, 2010 11:38 PM
Subject: Re: [netext] [Fwd: I-D Action:draft-ietf-netext-pmip6-lr-ps-02.txt]

> When the draft would write about tunnel endpoints, the two MAGs must be 

I am not sure,
In your mail, it reads "NetExt scope covers only localized routing between 
PMIP managed nodes. " So the endpoints (where we are studying 
optimization)  must be MAG and the tunnel doesn't matter?  
Because the path between MN and MAG can not be optimized 
or we didn't cover this segment from the whole "end-to-end path".
It is unnecessary to expand the optimized path to endpoint to endpoint?
(if it is exactly a middle-box to middle-box optimization)

Xiangsong