Subject: [netext] Needs of traffic spec. on MAG?

From: "Youn-Hee Han" <[email-masked]>
Date: Wed, 28 Jul 2010 21:43:04 +0900

Dear Bernardos,

I'd like to ask a question about "draft-bernardos-netext-pmipv6-flowmob-00."

In the call procedure figure, I noticed that traffic specification is
delivered to MAG from LMA. 

I understand that the specification should be managed at LMA to do a traffic
filtering. 

However, is such a traffic filtering still needed at MAG?

IMHO, it is not needed at MAG. If so, why is the specification delivered to
MAG?

Isn't sufficient that the home network prefix related to the traffic is
delivered to MAG?

Youn-Hee Han

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Wed, 28 Jul 2010 15:06:37 +0200

Dear Youn-Hee,

On Wed, 2010-07-28 at 21:43 +0900, Youn-Hee Han wrote:
> Dear Bernardos,
> 
>  
> 
> I’d like to ask a question about
> “draft-bernardos-netext-pmipv6-flowmob-00.”
> 
> I understand that the specification should be managed at LMA to do a
> traffic filtering. 
> 
>  
> 

The MAG needs to know the flow that is gonna be routed through it, so it
can insert the required routing state.

> 
> IMHO, it is not needed at MAG. If so, why is the specification
> delivered to MAG?

This is something that can be discussed. The minimum info required is
the MN's prefix of the moved flow, so the route is installed at the MAG.
If finer control is required (e.g., prevent the MN send flows through a
MAG that is not the one the LMA has setup flow mobility state, or other
purposes), then the flow mobility (traffic selector, e.g., 5-tuple)
should be delivered to the MAG.

> 
> Isn’t sufficient that the home network prefix related to the traffic
> is delivered to MAG?

That'd be the minimum info. As mentioned before, the MAG may need the
whole flow definition, and in that case the LMA has to deliver that
information to the MAG.

Thanks,

Carlos

> 
>  
> 
> Youn-Hee Han
> 
>  
> 
> 
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext

-- 
Carlos Jesús Bernardos Cano     http://www.netcoms.net
GPG FP: D29B 0A6A 639A A561 93CA  4D55 35DC BA4D D170 4F67

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Wed, 28 Jul 2010 17:18:21 +0200

One more comment. As I mentioned in another e-mail to Julien,
there might be the need of making the MAG aware of the flow descriptions
(traffic selector) in case the MN is attached through different
interfaces to the same MAG. In that case we might need some support and
signaling to make the MAG aware of the interface that should be used to
deliver packets of this flow to the MN.

Opinions?

Carlos

---

From: "Laganier, Julien" <[email-masked]>
Date: Thu, 29 Jul 2010 04:49:24 -0700

Carlos Jesús Bernardos Cano wrote:
> The MAG needs to know the flow that is gonna be routed through it, so
> it can insert the required routing state.

If a single prefix is use across all of the MN accesses then there's no need for this.

> should be delivered to the MAG.

I don't think this is needed.

> whole flow definition, and in that case the LMA has to deliver that

If a single prefix is use across all of the MN accesses then there's no need to do this.

--julien

---

From: "Koodli, Rajeev" <[email-masked]>
Date: Thu, 29 Jul 2010 18:45:36 -0400

Single prefix on multiple MAGs is clearly one choice. 

We agree that the prefix has to be valid on an interface for the corresponding flow to traverse the MAG.
If MAG1 has prefix p1 and MAG2 has p2, then the simplest form is p1 and p2 are valid on both MAG1 and MAG2.
However, I should also be able to assign p3 to MAG2 (for example), which you can do today with RFC 5213. 
The prefix p3 does not have to be simultaneously assigned to MAG1. This should be continued to be allowed with the flow mobility support.

-Rajeev

-----Original Message-----
From: [email-masked] on behalf of Laganier, Julien
Sent: Thu 7/29/2010 4:49 AM
To: [email-masked]; Youn-Hee Han
Cc: [email-masked]
Subject: Re: [netext] Needs of traffic spec. on MAG?
 
Carlos Jesús Bernardos Cano wrote:
> > I'd like to ask a question about
> > "draft-bernardos-netext-pmipv6-flowmob-00."
> >

> > Isn't sufficient that the home network prefix related to the traffic
> > is delivered to MAG?
> 

--julien

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 30 Jul 2010 13:49:40 -0700 (PDT)

Hi Carlos,

  What I don't understand is why we are not reusing great work already done in 
Mext WG? They defined Flow Identification Mobility Option. What is wrong in 
reusing this option? Many things are similar in PMIPv6.
  Why try to reinvent the wheel? Remember that one of the design decisions made 
for PMIPv6 was to reuse Mobile IPv6 as much as possible. There are a lot of 
synergies we can get from such reuse. If you look a few years back, attempts to 
define totally new protocol for netlmm was not favored, PMIPv6 was selected 
instead.

Regards,

Behcet

----- Original Message ----
> From: Carlos Jesús Bernardos Cano <[email-masked]>
> To: Youn-Hee Han <[email-masked]>
> Cc: [email-masked]
> Sent: Wed, July 28, 2010 10:18:21 AM