Subject: [netext] FW: Needs of traffic spec. on MAG?

From: "Youn-Hee Han" <[email-masked]>
Date: Thu, 29 Jul 2010 22:00:54 +0900

Dear Bernardos,

> Dear Youn-Hee,
> 
> On Wed, 2010-07-28 at 21:43 +0900, Youn-Hee Han wrote:
> > Dear Bernardos,
> >
> >
> >
> > I’d like to ask a question about
> > “draft-bernardos-netext-pmipv6-flowmob-00.”
> >
> > In the call procedure figure, I noticed that traffic specification is
> > delivered to MAG from LMA.
> >
> > I understand that the specification should be managed at LMA to do a
> > traffic filtering.
> >
> >
> >
> > However, is such a traffic filtering still needed at MAG?
> 
> The MAG needs to know the flow that is gonna be routed through it, so it
> can insert the required routing state.
>

For example, if the 5-tuple sent by LMA is <*, IP1, *, Port1, UDP>, 
what does MAG's routing module do with the information? 
The 5-tuple is only useful at LMA for the traffic filtering. 
When receiving a packet from LMA, MAG will just check if the destination IP 
includes the home network prefix which the MAG manages for a registered MN.

> >
> > IMHO, it is not needed at MAG. If so, why is the specification
> > delivered to MAG?
> 
> This is something that can be discussed. The minimum info required is the
> MN's prefix of the moved flow, so the route is installed at the MAG.

IMHO, the MN's prefix of the moved flow is necessary and sufficient info. 

> If finer control is required (e.g., prevent the MN send flows through a
> MAG that is not the one the LMA has setup flow mobility state, or other
> purposes), then the flow mobility (traffic selector, e.g., 5-tuple) should
> be delivered to the MAG.

Yes. If we want to support any finer control for flow mobility, IMHO, 
we need to distinguish downlink flow from uplink flow. 
Any type of flow, e.g., VoIP flow, has different 5-tuples for downlink and uplink.
For a downlink flow, LMA can put its 5-tuple on its flow filtering module  at will. 
For a uplink flow, however, I am not sure that LMA can also put its 5-tuple on MAG (or MN) at will.

I am not saying that the two (uplink and downlink) 5-tuples will be not related.
Somehow, they are mirrored by each other...

Thanks,

Youn-Hee Han

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 30 Jul 2010 13:43:29 -0700 (PDT)

Hi Youn-Hee,
  
  MAG might need the flow binding info simply because it would relay it to MN 
possibly using some L2 means.

I don't understand your concerns on this. This info needs to be sends 
downstream.

Regards,

Behcet

----- Original Message ----
> From: Youn-Hee Han <[email-masked]>
> To: [email-masked]
> Sent: Thu, July 29, 2010 8:00:54 AM
> Subject: [netext] FW:  Needs of traffic spec. on MAG?
> 
> Dear Bernardos,
> 
> > Dear Youn-Hee,
> > 
> _______________________________________________
> netext mailing  list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext
>