Subject: Re: [netext] Needs of traffic spec. on MAG?

From: "Laganier, Julien" <[email-masked]>
Date: Mon, 2 Aug 2010 00:37:10 -0700

In the scenario you describe p3 is confined to MAG2 and thus is, as you note, a straightforward application of 5213. We do not need to do anything to support this.

--julien

> -----Original Message-----
> From: Koodli, Rajeev [mailto:[email-masked]]
> Sent: Friday, July 30, 2010 12:46 AM
> To: Laganier, Julien; [email-masked]; Youn-Hee Han
> Cc: [email-masked]
> Subject: RE: [netext] Needs of traffic spec. on MAG?
> 
> 
> Single prefix on multiple MAGs is clearly one choice.
> 
> We agree that the prefix has to be valid on an interface for the
> corresponding flow to traverse the MAG.
> If MAG1 has prefix p1 and MAG2 has p2, then the simplest form is p1 and
> p2 are valid on both MAG1 and MAG2.
> However, I should also be able to assign p3 to MAG2 (for example),
> which you can do today with RFC 5213.
> The prefix p3 does not have to be simultaneously assigned to MAG1. This
> should be continued to be allowed with the flow mobility support.
> 
> -Rajeev
> 
> 
> 
> -----Original Message-----
> From: [email-masked] on behalf of Laganier, Julien
> Sent: Thu 7/29/2010 4:49 AM
> To: [email-masked]; Youn-Hee Han
> Cc: [email-masked]
> Subject: Re: [netext] Needs of traffic spec. on MAG?
> 
> Carlos Jesús Bernardos Cano wrote:
> >
> > Dear Youn-Hee,
> >
> > On Wed, 2010-07-28 at 21:43 +0900, Youn-Hee Han wrote:
> > > Dear Bernardos,
> > >
> > >
> > >
> > > I'd like to ask a question about
> > > "draft-bernardos-netext-pmipv6-flowmob-00."
> > >
> > > In the call procedure figure, I noticed that traffic specification
> is
> > > delivered to MAG from LMA.
> > >
> > > I understand that the specification should be managed at LMA to do
> a
> > > traffic filtering.
> > >
> > >
> > >
> > > However, is such a traffic filtering still needed at MAG?
> >
> > The MAG needs to know the flow that is gonna be routed through it, so
> > it can insert the required routing state.
> 
> If a single prefix is use across all of the MN accesses then there's no
> need for this.
> 
> > > IMHO, it is not needed at MAG. If so, why is the specification
> > > delivered to MAG?
> >
> > This is something that can be discussed. The minimum info required is
> > the MN's prefix of the moved flow, so the route is installed at the
> MAG.
> > If finer control is required (e.g., prevent the MN send flows through
> a
> > MAG that is not the one the LMA has setup flow mobility state, or
> other
> > purposes), then the flow mobility (traffic selector, e.g., 5-tuple)
> > should be delivered to the MAG.
> 
> I don't think this is needed.
> 
> > > Isn't sufficient that the home network prefix related to the
> traffic
> > > is delivered to MAG?
> >
> > That'd be the minimum info. As mentioned before, the MAG may need the
> > whole flow definition, and in that case the LMA has to deliver that
> > information to the MAG.
> 
> If a single prefix is use across all of the MN accesses then there's no
> need to do this.
> 
> --julien
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext

---

From: Tran Minh Trung <[email-masked]>
Date: Tue, 3 Aug 2010 11:48:53 +0900

I agree that the prefix p3, according to RFC 5213 , does not have to
be simultaneously assigned to MAG1. However when we use logical
interface at the MN, the prefix p3 should be shareable to allow flow
mobility.  In addition, the logical interface can receive packets sent
to any of its sub-interfaces as described in
draft-melia-netext-logical-interface-support-01 (property #2).

The question here is how to change RFC 5213 to support shared-prefix model?

Regards,
TrungTM

On Fri, Jul 30, 2010 at 7:45 AM, Koodli, Rajeev <[email-masked]> wrote:
> We agree that the prefix has to be valid on an interface for the corresponding flow to traverse the MAG.
> If MAG1 has prefix p1 and MAG2 has p2, then the simplest form is p1 and p2 are valid on both MAG1 and MAG2.
> However, I should also be able to assign p3 to MAG2 (for example), which you can do today with RFC 5213.
> The prefix p3 does not have to be simultaneously assigned to MAG1. This should be continued to be allowed with the flow mobility support.
>
> -Rajeev
>
>

>> > In the call procedure figure, I noticed that traffic specification is
>> > I understand that the specification should be managed at LMA to do a
>> > traffic filtering.
>> >
>> >
>> >
> If a single prefix is use across all of the MN accesses then there's no need for this.
>
>> the MN's prefix of the moved flow, so the route is installed at the MAG.
>> If finer control is required (e.g., prevent the MN send flows through a
>> MAG that is not the one the LMA has setup flow mobility state, or other
>> > Isn't sufficient that the home network prefix related to the traffic
>> > is delivered to MAG?
>>
> If a single prefix is use across all of the MN accesses then there's no need to do this.
>
> --julien

-- 
Ph.D., Senior Member
Electronics and Telecommunications Research Institute
Standards Research Center
161 Gajeong-Dong, Yuseong-Gu, Daejeon, 305-350, KOREA
Tel : +82-42-860-1132,   Fax : +82-42-861-5404

---

From: "Koodli, Rajeev" <[email-masked]>
Date: Tue, 3 Aug 2010 01:22:55 -0400

Even though the logical interface can make the packets available to the MN, the main issue is whether MAG1 forwards those packets.
MAG1 needs to advertise p3 as well. It is for such cases we need signaling from LMA *whenever* the LMA decides to move the flow(s).

-Rajeev

-----Original Message-----
From: [email-masked] on behalf of Tran Minh Trung
Sent: Mon 8/2/2010 7:48 PM
To: Koodli, Rajeev
Cc: Laganier, Julien; [email-masked]; Youn-Hee Han; [email-masked]
Subject: Re: [netext] Needs of traffic spec. on MAG?

Regards,
TrungTM

---

From: Tran Minh Trung <[email-masked]>
Date: Tue, 3 Aug 2010 15:51:33 +0900

You are right. After LMA deciding to move the flows, both MAG2 and
MAG1 will advertise p3. It means that the prefix p3 is now shared
across 2 physical interfaces.
That is the reason why, IMHO, we do not need to consider two different
scenarios, just consider shared-prefix model is enough.

If we have a solution for the LMA to assign the same prefix(es) to
MAGs for the logical interface, then it is very easy to support flow
mobility.

Regards,
TrungTM

---

From: Rajeev Koodli <[email-masked]>
Date: Tue, 03 Aug 2010 10:30:16 -0700

I see this is a terminology issue.

What is considered unique prefix in the draft is that each access is free to
assign whatever prefix is deemed right at the time of attachment - as folks
have pointed out, this is already supported in 5213. Now, *whenever* the LMA
decides to move one or more flows from a prefix for that access to another
access, it would have to signal the corresponding MAG. Looks like we agree
here.

What is considered a shared prefix in the draft is that the LMA assigns the
same prefix(es) to the new attachment. In this case, the LMA does not need
to signal the MAG for flow mobility purposes. However, we need to make some
extensions to RFC 5213 signaling requesting LMA to assign the same
prefix(es).

I hope this clarifies.

We need to support both models, regardless of what terminology you use.

I will send out some text on the topic.

-Rajeev

On 8/2/10 11:51 PM, "Tran Minh Trung" <[email-masked]> wrote:

>> Even though the logical interface can make the packets available to the MN,
>> the main issue is whether MAG1 forwards those packets.
>> MAG1 needs to advertise p3 as well. It is for such cases we need signaling
>> from LMA *whenever* the LMA decides to move the flow(s).
>> 
>> -Rajeev
>> 
>>

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 04 Aug 2010 11:13:17 -0700

Agree. Just a minor semantical requirement with respect to multiple prefix
support. In 5213, we do allow multiple prefix configuration on a link.
However, for handoffs we move the whole set to a new link. For moving
partial set of the flows, example P3 below to a new link, we would need
extension of the Handoff Indicator as covered in and is a straight foward
extension to 5213.

http://datatracker.ietf.org/doc/draft-jeyatharan-netext-pmip-partial-handoff
/

Now, the sharing of the prefix, across links in the absence of MN - network
hints is some thing different. We need to address all the issues there.

Regards
Sri

On 8/2/10 12:37 AM, "Laganier, Julien" <[email-masked]> wrote:

> In the scenario you describe p3 is confined to MAG2 and thus is, as you note,
> a straightforward application of 5213. We do not need to do anything to
> support this.
> 
> --julien
>

---

From: "Laganier, Julien" <[email-masked]>
Date: Thu, 19 Aug 2010 08:27:47 -0700

Tran Minh Trung wrote:
> be simultaneously assigned to MAG1. 

I think talking about prefix assigned to a specific MAG is misleading. The prefix is assigned to the mobile node thru the NETLMM fabric, irrespective of which MAG(s) the mobile node is attached too.

When flow mobility is enabled, the prefixes assigned to the mobile node can be used thru more than one interfaces, attached to more than one MAG.

>                                          However when we use logical

Right.

--julien
 
> > The prefix p3 does not have to be simultaneously assigned to MAG1.
> This should be continued to be allowed with the flow mobility support.
> >
> > -Rajeev
> >
> >
> 
> 
> >

---

From: "Laganier, Julien" <[email-masked]>
Date: Thu, 19 Aug 2010 08:29:26 -0700

I think it is simple, any MAG to which the mobile node is attached shall forward packets from/to that mobile node. That does not require signaling when LMA decides to move a flow.

--julien

> Sent: Monday, August 02, 2010 10:23 PM
> To: Tran Minh Trung
> Even though the logical interface can make the packets available to the
> MN, the main issue is whether MAG1 forwards those packets.
> MAG1 needs to advertise p3 as well. It is for such cases we need
> signaling from LMA *whenever* the LMA decides to move the flow(s).
> 
> -Rajeev
> 
>

---

From: "Laganier, Julien" <[email-masked]>
Date: Thu, 19 Aug 2010 08:30:32 -0700

I completely agree.

--julien

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Tran Minh Trung
> Sent: Monday, August 02, 2010 11:52 PM
> To: Koodli, Rajeev
> Cc: [email-masked]; Laganier, Julien
> > Even though the logical interface can make the packets available to
> the MN, the main issue is whether MAG1 forwards those packets.

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Thu, 19 Aug 2010 17:45:29 +0200

> > The question here is how to change RFC 5213 to support shared-prefix

We should be careful about the wording, "shared-prefix model" is
commonly referred to the assignment of the same prefix to multiple MNs,
whereas here we are talking about assigning the same prefix to multiple
interfaces of the same MN. It is not exactly the same thing, IMHO.

Carlos

-- 
Carlos Jesús Bernardos Cano     http://www.netcoms.net
GPG FP: D29B 0A6A 639A A561 93CA  4D55 35DC BA4D D170 4F67

---

From: "Laganier, Julien" <[email-masked]>
Date: Thu, 19 Aug 2010 08:52:52 -0700

Carlos Jesús Bernardos Cano [mailto:[email-masked]] wrote:
> > I think talking about prefix assigned to a specific MAG is misleading.
> > The prefix is assigned to the mobile node thru the NETLMM fabric,
> > irrespective of which MAG(s) the mobile node is attached too.
> >
> > When flow mobility is enabled, the prefixes assigned to the mobile
> > node can be used thru more than one interfaces, attached to more than
> > one MAG.
> >
> > > mobility.  In addition, the logical interface can receive packets
> > > sent to any of its sub-interfaces as described in

Fair enough.

How about "per-MN HNP set"?

--julien

---

From: "Laganier, Julien" <[email-masked]>
Date: Thu, 19 Aug 2010 13:48:04 -0700

> I see this is a terminology issue.

I do not think so...
 
> What is considered unique prefix in the draft is that each access is
> free to assign whatever prefix is deemed right at the time of attachment

If a new prefix is assigned by an access, the LMA is aware of it (either new prefix is signaled by MAG in PBU sent to LMA, or new prefix is assigned by LMA itself.) That prefix is subsequently added to the BCE for the mobile node.

The new prefix is not tied to a specific access but is valid on any access, thus making it possible to move flows across access irrespective of the prefix to which they belongs. 

> - as folks have pointed out, this is already supported in 5213. Now, *whenever*
> the LMA decides to move one or more flows from a prefix for that access to
> another access, it would have to signal the corresponding MAG. Looks like we
> agree here.

I disagree. Since all prefixes assigned to a mobile node while attaching to whatever accesses belongs to that mobile node, a MAG only needs to be made aware of the complete set of prefixes to be able to perform its function -- forward packets between the mobile node and the network.
 
> What is considered a shared prefix in the draft is that the LMA assigns
> the same prefix(es) to the new attachment. In this case, the LMA does not
> need to signal the MAG for flow mobility purposes. However, we need to make
> some extensions to RFC 5213 signaling requesting LMA to assign the same
> prefix(es).
> 
> I hope this clarifies.
> 

I think that to support flow mobility the only model that we need to support is one in which all prefixes assigned to a mobile node can be used on any access to which the mobile attaches.

That is orthogonal to the function of a new access assigning an additional prefix that you hint at.

--julien

> the MN,
> signaling
> sent
> >>> If MAG1 has prefix p1 and MAG2 has p2, then the simplest form is p1
> and p2
> >>> are valid on both MAG1 and MAG2.
> This
> >>> If a single prefix is use across all of the MN accesses then
> there's no need
> >>> for this.
> >>>
> >>> If a single prefix is use across all of the MN accesses then
> there's no need
> >>> to do this.
> >>>
> >>> --julien

---

From: "Youn-Hee Han" <[email-masked]>
Date: Fri, 20 Aug 2010 12:07:16 +0900

Hi all,

> How about "per-MN HNP set"?

IMHO, we don't need any more to care about the prefix model when designing
a network-based flow mobility. We already have the per-MN (more exactly 
per-interface) prefix model which is the basic principle of RFC 5213.

Even when we support our network-based flow mobility, we should keep 
the principle if any flow is not needed to be moved at the time of a new MN 
attachment. The new MAG will be assigned a new prefix according to the
principle.

If a flow is needed to be moved to the new MAG at the time of a new MN
attachment, 
the existing prefix which the flow uses should be assigned to the MAG.
This strategy has been already supported in the handover case of RFC 5213.
However, we did not mentioned "shared-prefix model" in order to support the
same 
prefix allocation at the case of handover when designing RFC 5213.

Of course, I know well the same prefix allocation can happen frequently 
if we support flow mobility in PMIPv6. For all that, we do not need say that

PMIPv6 should support two strategies of prefix allocation.

One more thing.

As others mentioned in ML, I also think LMA does not need to know the
logical 
interface configuration on each MN.
However, IMHO, if LMA can know it, the reason to keep the per-MN
(per-interface) 
prefix model naturally disappear. LMA can allocate just one set of prefixes 
to any interfaces of MNs, at any cases and at any  times, 
because the number of MN's interface is just one in the LMA's perspective. 
This strategy will make the flow mobility extremely easy.

Youn-Hee Han