Subject: Re: [netext] The requirements for supporting flow mobility in PMIPv6

From: "Laganier, Julien" <[email-masked]>
Date: Mon, 4 Oct 2010 10:38:20 -0700

Hi Trung,

Thank you for sharing the requirements you considered in developing your flow mobility solution.

I mostly agree, but I think that your #4 below is not something that you have to consider as part of developing a flow mobility signaling extension to PMIPv6. The reason is that the uplink forwarding decision is taken locally on the mobile node and invisible to the IP layer since it sends all packet through the logical interface. As such, requirement #4 is internal to the logical interface and has no bearing on the PMIPv6 signaling between the MAG and the LMA.

--julien

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Tran Minh Trung
> Sent: Wednesday, September 22, 2010 6:29 PM
> To: [email-masked]
> Subject: [netext] The requirements for supporting flow mobility in
> PMIPv6
> 
> Hi Julien and all
> 
> I send again the simple requirements for sporting flow mobility stated
> in our document:
> http://tools.ietf.org/html/draft-trung-netext-flow-mobility-support-00
> 
> 1. The network should support shared-prefix model (The Mobile Node's
> Home Network  Prefix should be able to be shared across its
> attachments)
> 2. The network should support flow-based routing (The Local Mobility
> Anchor should be able to bind a particular flow to a Proxy-CoA without
> affecting other flow using the same HNP)
> 3. The MN should use a single logical interface to hide all existing
> physical interfaces.
> 4. On receiving a downlink traffic flow, the MN should be able to
> select the same path for sending the uplink traffic flow.
> 
> If all of the above requirements are satisfied, then the flow mobility
> can be supported. Without one of them, the flow mobility can not be
> supported.
> 
> For the requirement #4, if we amuse that the MN has it own flow
> policy, then we can just state that: The MN is assumed to be able to
> selects the most suitable interface for sending an uplink flow. (In
> our next draft version we may add this text)
> 
> I hope that it clears enough for discussing about what are simple
> solution requirements.
> 
> Regards,
> TrungTM
> 
> --
> Ph.D., Senior Member
> Electronics and Telecommunications Research Institute
> Standards Research Center
> 161 Gajeong-Dong, Yuseong-Gu, Daejeon, 305-350, KOREA
> Tel : +82-42-860-1132,   Fax : +82-42-861-5404
> 
> 
> 
> --
> Ph.D., Senior Member
> Electronics and Telecommunications Research Institute
> Standards Research Center
> 161 Gajeong-Dong, Yuseong-Gu, Daejeon, 305-350, KOREA
> Tel : +82-42-860-1132,   Fax : +82-42-861-5404
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext

---

From: Tran Minh Trung <[email-masked]>
Date: Tue, 5 Oct 2010 15:15:17 +0900

Hi Julien,

> Thank you for sharing the requirements you considered in developing your flow mobility solution.

Thank you for your agreement.

> I mostly agree, but I think that your #4 below is not something that you have to consider as part of developing a flow mobility signaling extension to PMIPv6. The reason is that the uplink forwardi…

I agree. It is out of scope of the PMIPv6's solution document.

> --julien

It would be nice if you have time to review our solution and give us comments.

Regards,
TrungTM