Subject: [netmod] Can a key value be changed?

From: Balazs Lengyel <[email-masked]>
Date: Thu, 13 Nov 2008 13:50:18 +0100

Hello,
Is it possible to change a key value? IMHO No.
How would one address the key leaf in edit config?
Balazs
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Thu, 13 Nov 2008 05:32:03 -0800

> How would one address the key leaf in edit config?

You cannot say "/interface[name='foo']/name = bar" in XML.
You cannot rename entries using the NETCONF protocol.
It only supports delete and re-create.

> Balazs

Andy

---

From: Phil Shafer <[email-masked]>
Date: Thu, 13 Nov 2008 09:43:24 -0500

>You cannot say "/interface[name='foo']/name = bar" in XML.

Well, in YANG, no, but in XML, sure:

<interface>
   <name>foo</name>
   <name>bar</name>
</interface>

>It only supports delete and re-create.

FWIW, we've supported this in JUNOS forever in both the
JUNOScript and NETCONF APIs.

http://www.juniper.net/techpubs/software/junos/junos92/junoscript-guide/rename.html

IMHO delete and re-create won't cut it.

Thanks,
 Phil

---

From: Balazs Lengyel <[email-masked]>
Date: Thu, 13 Nov 2008 15:59:12 +0100

> Well, in YANG, no, but in XML, sure:
Could you provide the full edit-config because I don't get the idea.
Won't the above replace the complete list entry?
> http://www.juniper.net/techpubs/software/junos/junos92/junoscript-guide/rename.html
But you use a proprietary rename attribute. Can the same be done in standard Netconf?

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Phil Shafer <[email-masked]>
Date: Thu, 13 Nov 2008 09:57:14 -0500

>But you use a proprietary rename attribute. Can the same be done in standard N

Yes, via proprietary data model operations. ;^)/2

NETCONF's lobotomy left it with very few operations.  YANG fixes
this somewhat (insert), so adding rename would be another nice-to-have
feature.

Thanks,
 Phil