Subject: [netmod] anyxml syntax

From: Andy Bierman <[email-masked]>
Date: Sun, 21 Dec 2008 11:36:08 -0800

Hi,

The anyxml-stmt is not allowed to have any must-stmts.
This seems odd because the XPath is allowed to point
off somewhere else -- it cannot point inside the anyxml
node, but other than that, it is pretty much the same as a leaf.

Andy

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 22 Dec 2008 09:02:28 +0100 (CET)

> node, but other than that, it is pretty much the same as a leaf.

You're right.  I will add this.

/martin

---

From: Phil Shafer <[email-masked]>
Date: Mon, 22 Dec 2008 10:42:34 -0500

>You're right.  I will add this.

If we undo this, it means that the server _must_ do xpath,
since it has to apply an expression to unknown xml.  I
am strongly against this.

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Mon, 22 Dec 2008 08:02:06 -0800

> am strongly against this.

That is not allowed.
The agent cannot reference inside an anyxml node
from a must/when expression.  It makes no difference
where the must-stmt is located.  Disallowing must-stmt
within anyxml has no impact whatsoever on this issue.

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 22 Dec 2008 19:11:34 +0100 (CET)

> am strongly against this.

No, the change is merely to allow 'must' on an anxml node.  The must
expression itself cannot point inside the unknown chunk of data, just
as today.

/martin