Subject: [netmod] repeat refine-stmts

From: Andy Bierman <[email-masked]>
Date: Fri, 05 Dec 2008 19:19:09 -0800

Hi,

Sec. 7.2.12 should specify what to do when conflicting refinements
are found.  Is it an error or is it 'last one wins' or what?

grouping foo {
   leaf bar { type string; }
}

container X {
   uses foo {
      refine bar {
        config false;
      }
      refine bar {
        config true;
      }
   }
}

The ABNF clearly allows this, but I doubt that it the intent.

Andy

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Sun, 07 Dec 2008 15:50:55 +0100 (CET)

> are found.  Is it an error or is it 'last one wins' or what?

The old text (i.e. draft -01) made this an error (it said A node can
be refined only once in "uses".)

Unless anyone objects, I will put this text back.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Sun, 07 Dec 2008 08:30:23 -0800

> Unless anyone objects, I will put this text back.

Is it an error to set a sub-stmt to the same value?
A duplicate with the same value == warning.
A duplicate with a conflicting value == error.

Or any duplicate is an error is OK too, since there
isn't any reason to do this.

Andy