Subject: [netmod] xinclude

From: Andy Bierman <[email-masked]>
Date: Sat, 27 Mar 2010 10:32:10 -0700

Hi,

Are file representations of NETCONF databases, or YIN representations
of YANG modules, allowed to contain the 'xinclude' directive?
Does the YANG spec say anywhere?

http://www.w3.org/TR/xinclude/

thanks,
Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Sun, 28 Mar 2010 20:46:36 +0200 (CEST)

> Does the YANG spec say anywhere?

The YIN representation cannot contain this attribute, since YIN is
just a different syntax for YANG, and no xinclude can occur in YANG.

A NETCONF db in general can contain any XML, but if you're using YANG,
there is no YANG construct that would allow xinclude, except for
anyxml.

/martin

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 29 Mar 2010 07:27:12 +0200

> there is no YANG construct that would allow xinclude, except for

One could define it as an extension, right?

Lada

> 
> 
> /martin
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C