Subject: [netmod] Draft agenda (v1) & call for agenda items

From: David Kessens <[email-masked]>
Date: Thu, 11 Mar 2010 15:34:46 -0800

Please see below for our draft agenda.

Please let us know whether you have any additional items that you would like
to add to the agenda.

David & David
---

Draft Agenda (v1): NETMOD WG
Meeting:   IETF 77
Location:  Hilton Anaheim, Anaheim, CA, USA
WG Chairs: David Kessens ([email-masked])
	   David Partain ([email-masked])
Jabber:    xmpp:[email-masked]
WG URL:    http://tools.ietf.org/wg/netmod/

TUESDAY, March 23, 2010, 0900-1130, Huntington Room

1) Administrivia
   [chairs][ 5 min ]

   - minutes scribe     {volunteers welcome in advance!}
   - jabber scribe      {volunteers welcome in advance!}
   - blue sheets
   - agenda bashing

2) Status Update
   [chairs][ 5 min ]

   - How we're doing against the charter

3) Active Drafts

   For each draft: current status, delta from previous draft,
   open issues, and discussion.

   3.1 Common YANG Data Types
       http://tools.ietf.org/html/draft-ietf-netmod-yang-types-07
       Status: IETF Last Call
       (Juergen Schoenwaelder)
       
   3.2 YANG - A data modeling language for NETCONF
       http://tools.ietf.org/html/draft-ietf-netmod-yang-11
       Status: IETF Last Call
       (Martin Bjorklund)
 
   3.3 YANG Usage Guidelines
       http://tools.ietf.org/html/draft-ietf-netmod-yang-usage-03
       Status: WG Last Call completed when meeting takes place
       (Andy Bierman)
       
   3.4 NETMOD Architecture
       http://tools.ietf.org/html/draft-ietf-netmod-arch-04
       Status: WG Last Call completed
       (Phil Shafer)
   
   3.5 Mapping of YANG to DSDL
       http://tools.ietf.org/html/draft-ietf-netmod-dsdl-map-05
       Status: will be in WG Last Call
       (Ladislav Lhotka)
   
4) Other (non WG) Internet-Drafts, for feedback and discussion
   [chairs, we will only spend time on these items if we have time]

5) I/O with other WGs (NETCONF/IPFIX/others ?), activities this week
   [chairs]

6) Plans post IETF77 and after completion of charter

7) A.O.B. and open mike
   [N.N.]
   {please identify issues in advance}

---

---

From: "Linowski, Bernd (EXT-Other - DE)" <[email-masked]>
Date: Fri, 12 Mar 2010 16:08:44 +0200

Hi All,

we revised our draft on "Extending YANG with Language Abstractions" with
a new co-author Siarhei Kuryla from Jacobs University Bremen.

After review and comments from different parties we introduced changes
which we hope get the draft round and more stable.

We also started two implementations based on existing open source
packages for the proposed YANG extensions (pyang and libsmi). 
Pyang part will be hopefully available parallel to the IETF week. libsmi
is going to come end of April.
Please send your comments and suggestions to Netmod list. 

Regards,
Bernd

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Fri, 12 Mar 2010 15:36:08 +0100

Please find the draft at:
http://tools.ietf.org/html/draft-linowski-netmod-yang-abstract-02

Cheers,
Mehmet

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of ext Linowski, 
> Bernd (EXT-Other - DE)
> Sent: Friday, March 12, 2010 3:09 PM
> To: NETMOD Working Group
> Subject: [netmod] New version of draft-linowski-netmod-yang-abstract
> 
> Hi All,
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: "Linowski, Bernd (EXT-Other - DE)" <[email-masked]>
Date: Mon, 22 Mar 2010 23:01:57 +0200

Hi,

The complex type plug-in for pyang that implements the YANG extensions described in
draft-linowski-netmod-yang-abstract-02 can be downloaded from 

http://code.google.com/p/pyang-ct/

In case you have questions or comments concerning the plug-in, please send 
them to Siarhei and me.

Regards,
Bernd