Subject: [netmod] yang namespace suggestion

From: Mark Scott <[email-masked]>
Date: Tue, 11 May 2010 14:02:43 -0400

Andy and Martin,

During the Gen-ART review of the monitoring draft some comments related to yang namespace came up which I thought I'd raise to the attention of this ML.

Please advise if any updates are warranted in the yang guidelines to address these, or what netmod's current response to each is:

1.  Section 8 (IANA). The registration fails to explicitly mention that the YANG Module Names registry is established by draft-ietf-netmod-yang.  Without this information, it might be difficult to IANA to find that registry, because it does not exist yet.

Question:  What is the recommended means to refer to the Yang module registry at this point?

2.  draft-ietf-netmod-yang proposes a namespace prefix for registering modules, but I would suggest, if possible, to include the term "modules" in the namespace name. This would easily differentiate namespaces of modules from other YANG parameters different than modules.
In your case, this namespace would be:
urn:ietf.params.xml:ns:yang:modules:ietf-netconf-monitoring:rfcXXXX
                           ^^^^^^^^
Question:  What is netmod view on including this in the namespace?

Another comment was made suggesting the removal of ":rfcXXX".  I see that was agreed earlier so plan to update the remove this from the monitoring namespace and yang module.

cheers,
Mark

---

From: Andy Bierman <[email-masked]>
Date: Tue, 11 May 2010 12:37:40 -0700

Mark Scott wrote:
>
> Andy and Martin,
>
>  
>
> During the Gen-ART review of the monitoring draft some comments
> related to yang namespace came up which I thought I’d raise to the
> attention of this ML.
>
>  
>
> Please advise if any updates are warranted in the yang guidelines to
> address these, or what netmod’s current response to each is:
>
>  
>
> 1.  Section 8 (IANA). The registration fails to explicitly mention
> that the YANG Module Names registry is established by
> draft-ietf-netmod-yang.  Without this information, it might be
> difficult to IANA to find that registry, because it does not exist yet.
>
>  
>

The YANG draft says this registry must be used.

>  
>
>  
>
> 2.  draft-ietf-netmod-yang proposes a namespace prefix for registering
> modules, but I would suggest, if possible, to include the term
> "modules" in the namespace name. This would easily differentiate
> namespaces of modules from other YANG parameters different than modules.
>
> Another comment was made suggesting the removal of “:rfcXXX”.  I see
> that was agreed earlier so plan to update the remove this from the
> monitoring namespace and yang module.
>
Yes, you should remove :rfcXXXX.

The URI string is defined in the YANG draft, not this draft.

I do not think we need to make the YANG base URI string longer.
It is already in use. The term 'modules' is sort of redundant.

This is the XML namespace YANG uses for the XML attributes
it adds to the NETCONF protocol:

    urn:ietf:params:xml:ns:yang:1

Note that '1' is not a valid YANG module name, so
there it no chance a valid module will be confused
with the YANG XML namespace (yang-12, sec. 5.3.1).

> Mark

Andy