Subject: Re: [netmod] encapsulating containers

From: Gerhard Muenz <[email-masked]>
Date: Wed, 11 Aug 2010 21:17:10 +0200

Hi Lada,

> Another observation: Perhaps it would be useful to introduce extra
> containers encapsualting the entries of each list, e.g.
>
> container collectingProcesses {
>     list collectingProcess {
>         ...
>     }
> }
>
> As it is now, entries from different lists could be freely interleaved,
> for instance
>
> <collectingProcess>...</collectingProcess>
> <exportingProcess>...</exportingProcess>
> <collectingProcess>...</collectingProcess>

Is this true? There is no choice statement but a sequence of list 
statements. So, one list should follow the other. List elements should 
not be interleaved.

Anyway, I do not think that interleaving is a problem.

Gerhard

>
> This is usually not very desirable.
>
> Lada

---

From: Andy Bierman <[email-masked]>
Date: Wed, 11 Aug 2010 12:55:04 -0700

> statements. So, one list should follow the other. List elements should

I agree.  A server should be able to find all the siblings no matter
what order.  It turns out that preserving CLI order is an interesting
problem.  (Which is interesting if CLI order matters to existing instrumentation.)

A use-case could be that the application wants the data processed in document order,
or the application is converting CLI to NETCONF on the fly,
and grouping all sibling nodes together in the application breaks that use-case.

>> This is usually not very desirable.

to the server it should not matter, and to the application wrt/ user-ordered data,
it may matter.

>> Lada

Andy

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 12 Aug 2010 09:19:07 +0200

> statements. So, one list should follow the other. List elements should 

Yes, see the last paragraph in section 7.8.5.

Lada

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C