Subject: [netmod] RFC 6020 on YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)

From: [email-masked]
Date: Wed, 6 Oct 2010 12:17:43 -0700 (PDT)

A new Request for Comments is now available in online RFC libraries.

        RFC 6020

        Title:      YANG - A Data Modeling 
                    Language for the Network Configuration Protocol 
                    (NETCONF) 
        Author:     M. Bjorklund, Ed.
        Status:     Standards Track
        Stream:     IETF
        Date:       October 2010
        Mailbox:    [email-masked]
        Pages:      173
        Characters: 324178
        Updates/Obsoletes/SeeAlso:   None

        I-D Tag:    draft-ietf-netmod-yang-13.txt

        URL:        http://www.rfc-editor.org/rfc/rfc6020.txt

YANG is a data modeling language used to model configuration and
state data manipulated by the Network Configuration Protocol
(NETCONF), NETCONF remote procedure calls, and NETCONF notifications.
[STANDARDS TRACK]

This document is a product of the NETCONF Data Modeling Language Working Group of the IETF.

This is now a Proposed Standard Protocol.

STANDARDS TRACK: This document specifies an Internet standards track
protocol for the Internet community,and requests discussion and suggestions
for improvements.  Please refer to the current edition of the Internet
Official Protocol Standards (STD 1) for the standardization state and
status of this protocol.  Distribution of this memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  http://www.ietf.org/mailman/listinfo/ietf-announce
  http://mailman.rfc-editor.org/mailman/listinfo/rfc-dist

For searching the RFC series, see http://www.rfc-editor.org/rfcsearch.html.
For downloading RFCs, see http://www.rfc-editor.org/rfc.html.

Requests for special distribution should be addressed to either the
author of the RFC in question, or to [email-masked].  Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.

The RFC Editor Team
Association Management Solutions, LLC

---

From: David Partain <[email-masked]>
Date: Wed, 6 Oct 2010 21:54:10 +0200

Hello all,

The day has finally arrived!

>         Author:     M. Bjorklund, Ed.

and...

On Wednesday 06 October 2010 21.17.53 [email-masked] wrote:
>         RFC 6021
>         Title:      Common YANG Data Types
>         Author:     J. Schoenwaelder, Ed.

I'd like to thank the working group and, in particular, the editors for their 
tireless work.  When this little adventure began, there were many who said 
we'd never get to this point.  I'm very happy that we proved them wrong, even 
if it is a wee bit later than I wanted :-)

We're not finished yet, but this is a very big step forward.

Thanks, everyone!

David

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 7 Oct 2010 11:38:29 +0200

Congratulations to the authors, chairs and the whole WG for this
achievement. 

Regards,

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Wednesday, October 06, 2010 9:18 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: [netmod] RFC 6020 on YANG - A Data Modeling Language 
> for theNetwork Configuration Protocol (NETCONF)
> 
> 
> YANG is a data modeling language used to model configuration 
> and state data manipulated by the Network Configuration 
> Protocol (NETCONF), NETCONF remote procedure calls, and 
> NETCONF notifications.
> [STANDARDS TRACK]
> 
> STANDARDS TRACK: This document specifies an Internet 
> standards track protocol for the Internet community,and 
> requests discussion and suggestions for improvements.  Please 
> refer to the current edition of the Internet Official 
> Protocol Standards (STD 1) for the standardization state and 
> For searching the RFC series, see 
> http://www.rfc-editor.org/rfcsearch.html.
> Requests for special distribution should be addressed to 
> either the author of the RFC in question, or to 
> [email-masked].  Unless specifically noted 
> otherwise on the RFC itself, all RFCs are for unlimited distribution.
> 
> 
> The RFC Editor Team
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 7 Oct 2010 11:40:10 +0200

Great - we do have a data modeling language. Let us write some models!

Dan

> [mailto:[email-masked]] On Behalf Of David Partain
> Sent: Wednesday, October 06, 2010 9:54 PM
> To: [email-masked]
> Subject: [netmod] The new RFCs!
> 
> Hello all,
> 
> I'd like to thank the working group and, in particular, the 
> editors for their tireless work.  When this little adventure 
> began, there were many who said we'd never get to this point. 
>  I'm very happy that we proved them wrong, even if it is a 
> wee bit later than I wanted :-)
>