Subject: [netmod] Mirja Kühlewind's Discuss on draft-ietf-netmod-acl-model-19: (with DISCUSS)

From: Mirja Kühlewind <[email-masked]>
Date: Fri, 21 Sep 2018 06:47:17 -0700

Mirja Kühlewind has entered the following ballot position for
draft-ietf-netmod-acl-model-19: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-netmod-acl-model/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

1) The tcp options element is type uint32, however, the option field in the TCP
header can be up to 40 bytes.

2) Why are only TCP and UDP supported? What's about SCTP and DCCP?

3) The icmp rest-of-header can also be larger than 4 bytes but the type is
uint32 again.

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 24 Sep 2018 15:56:01 -0700

> On Sep 21, 2018, at 6:47 AM, Mirja Kühlewind <[email-masked]> wrote:
> 

You are right that the options field can be up to 40 bytes long.

To the WG - We have two options in front of us. Take the field out completely or change the type to binary, and add a ‘length’ restriction of 40. Unless there is a objection, we will go with the latter option.

> 2) Why are only TCP and UDP supported? What's about SCTP and DCCP?

There has been no requirement to support either of those protocols. Support for those protocols can be added as augmentations to the base model in the future if such a need arises.

> 3) The icmp rest-of-header can also be larger than 4 bytes but the type is

You are right that the rest-of-header can be more than 4 bytes, but in reality we have not had a requirement to support more than 4 bytes. 

To the WG - We will give it the same treatment as above - two options. Take it out completely, or change this to binary also. The only difference is that there does not seem to be a length restriction on the size of the field, so the field will be left unbounded. Unless there is a objection, we will go with the conversion to binary option.

Cheers.

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Tue, 25 Sep 2018 11:32:28 +0200

Hi Mahesh,

please see below.

> Am 25.09.2018 um 00:56 schrieb Mahesh Jethanandani <[email-masked]>:
> 
> 
> 

Not sure what exactly you mean but change the type to binary and add a length restriction but I’ll leave it to you to have the appropriate change.

> There has been no requirement to support either of those protocols. Support for those protocols can be added as augmentations to the base model in the future if such a need arises.

That’s do bad. However, the document must at least say that it’s scope is restricted to TCP and UDP only and it would also be nice to reason why that restriction is and what would need to be done to extend it in future.

> To the WG - We will give it the same treatment as above - two options. Take it out completely, or change this to binary also. The only difference is that there does not seem to be a length restrict…

Again, leaving it to you to apply the appropriate fix.

Mirja

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 25 Sep 2018 11:35:59 -0700

Hi Mirja,

See responses inline.

> On Sep 25, 2018, at 2:32 AM, Mirja Kuehlewind (IETF) <[email-masked]> wrote:
> 
> Hi Mahesh,
> 
> please see below.
> 

Ok.

> That’s do bad. However, the document must at least say that it’s scope is restricted to TCP and UDP only and it would also be nice to reason why that restriction is and what would need to be done t…

To the contrary. The model is not restricted to TCP and UDP. In Section 2, the document states that:

   ACL implementations in every device may vary greatly in terms of the
   filter constructs and actions that they support.  Therefore this
   draft proposes a model that can be augmented by standard extensions
   and vendor proprietary models.

It is a different matter that it has chosen not to support SCTP and DCCP. That is because implementations today have not felt the market need to add support for those protocols. But that does not prevent anyone from adding support for them.

As far as an example for how the model can be extended in the future, see Appendix A - Extending ACL model examples.

> Again, leaving it to you to apply the appropriate fix.

Ok.

Thanks.

---

From: Eliot Lear <[email-masked]>
Date: Tue, 25 Sep 2018 22:25:54 +0200

Just on this point:

On 25.09.18 20:35, Mahesh Jethanandani wrote:
>> That’s do bad. However, the document must at least say that it’s
>> scope is restricted to TCP and UDP only and it would also be nice to
>> reason why that restriction is and what would need to be done to
>> extend it in future.
>
> To the contrary. The model is *not* restricted to TCP and UDP. In
> Section 2, the document states that:
>
> It is a different matter that it has chosen not to support SCTP and
> DCCP. That is because implementations today have not felt the market
> need to add support for those protocols. But that does not prevent
> anyone from adding support for them.
>
> As far as an example for how the model can be extended in the future,
> see Appendix A - Extending ACL model examples.

It's important to not try to boil the ocean, and this model is already
boiling a rather large river.  There's room for someone else to do more
work.  I know I did ;-)

Eliot

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Wed, 26 Sep 2018 00:22:46 +0200

Hi Mahesh, hi Eliot,

please see below.

> Am 25.09.2018 um 22:25 schrieb Eliot Lear <[email-masked]>:
> 
> Just on this point:
> 
>>> That’s do bad. However, the document must at least say that it’s scope is

(sorry for the type… I meant to say „too bad“.)

>>> restricted to TCP and UDP only and it would also be nice to reason why that restriction is and what would need to be done to extend it in future.
>> 
Yes, ACL implementations differ, however, the protocol spec for SCTP and DCCP don’t have different implementation; their are mostly fixed. Unfortunately, firewalls often just block any other traffic than TCP and UDP, and restricting such a model only to those protocols will definitely not help the situation.

>> It is a different matter that it has chosen not to support SCTP and DCCP. That is because implementations today have not felt the market need to add support for those protocols. But that does not…

If your YANG model does not support long-existent and well-specified protocols, that doesn’t make it any easier to add support for these protocols to your firewall.

> It's important to not try to boil the ocean, and this model is already boiling a rather large river.  There's room for someone else to do more work.  I know I did ;-)

I would think that adding another well-specified protocols is actually only a limited effort. However, I don’t want to enforce a lot of additional work if people are not interested in that. What I still would like to see in the document is to make clear that these protocols have not just been not considered but some reasoning why only the currently supported protocols have been selected (in order to make the reader aware that this is not a full set).

Mirja

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 25 Sep 2018 22:37:23 +0000

Mirja, 

See inline. 

On 9/25/18, 6:29 PM, "netmod on behalf of Mirja Kuehlewind (IETF)" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Mahesh, hi Eliot,
    
    please see below.

    

    
    > It's important to not try to boil the ocean, and this model is already boiling a rather large river.  There's room for someone else to do more work.  I know I did ;-)
    
    I would think that adding another well-specified protocols is actually only a limited effort.

How many YANG models have you authored? This would be a great opportunity. 

   However, I don’t want to enforce a lot of additional work if people are not interested in that. What I still would like to see in the document is to make clear that these protocols have not just been    not considered but some reasoning why only the currently supported protocols have been selected (in order to make the reader aware that this is not a full set).

I would think pointing out that these protocols are out of scope would suffice. However, I'll leave that to the author.

Thanks,
Acee

    Mirja

    > Eliot
    
    _______________________________________________
    netmod mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/netmod