Subject: Re: [netmod] I-D Action: draft-wu-netmod-base-notification-nmda-00.txt

From: Qin Wu <[email-masked]>
Date: Fri, 14 Sep 2018 08:06:35 +0000

Hi, WG:
We resubmit this draft as netmod draft based on discussion in last NETCONF session and chair's suggestion on the list
https://www.ietf.org/mail-archive/web/netconf/current/msg15111.html
The main changes are:
1. Add two new event notifications for NMDA
2. Narrow document scope down to applied intended configuration notification.
3. Clarify the sequence of NDMA events
4. Deal with multiple commit cases and clarify the relation between confirmed commit and intended-apply-start event.
5. Clarify the relation with NMDA Diff.

One pending issue is it looks two new event notifications are defined to report start time and end time of intended configuration applying procedure.
However nmda-intended-applied can also use applied-event parameter to indicate the start time and end time of intended configuration applying procedure.
The difference is nmda-intended-applied provide more details on failed applied target and reasons.

Another issue is the way to deal with multiple commit. We think we should treat two phase commits as one commit, in other cases when two commits are detected,
It should be tackled one by one in sequence. 

Would it be great to get some input on these.

-Qin
-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2018年9月14日 15:44
收件人: [email-masked]
主题: I-D Action: draft-wu-netmod-base-notification-nmda-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : NMDA Base Notification for Applied Intended Configuration
        Authors         : Qin Wu
                          Rohit R Ranade
	Filename        : draft-wu-netmod-base-notification-nmda-00.txt
	Pages           : 15
	Date            : 2018-09-14

Abstract:
   The Network Configuration Protocol (NETCONF)and RESTCONF provides
   mechanisms to manipulate configuration datastores.  NMDA introduces
   additional datastores for systems that support more advanced
   processing chains converting configuration to operational state.
   However, client applications are not able to be aware of common
   events in these additional datstores of the management system, such
   as a applied configuration state change in NETCONF server or RESTCONF
   server, that may impact management applications.  This document
   define a YANG module that allows a client to receive additional
   notifications for some common system events pertaining to the Network
   Management Datastore Architecture (NMDA) defined in [RFC8342].

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-wu-netmod-base-notification-nmda/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-wu-netmod-base-notification-nmda-00
https://datatracker.ietf.org/doc/html/draft-wu-netmod-base-notification-nmda-00

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Qin Wu <[email-masked]>
Date: Sun, 30 Sep 2018 09:37:36 +0000

NMDA Base Notification has been updated based on discussion in last meeting and comments on the list
And resubmitted to Netmod WG as v-00 draft.
https://datatracker.ietf.org/doc/html/draft-wu-netmod-base-notification-nmda-00
Your review and comments are welcome.

-Qin
-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2018年9月14日 15:44
收件人: [email-masked]
主题: I-D Action: draft-wu-netmod-base-notification-nmda-00.txt

Abstract: