Subject: [netmod] module names starting with underscore

From: Balazs Lengyel <[email-masked]>
Date: Thu, 6 Sep 2018 16:52:05 +0200

Hello,

One of our customers wants to introduce module names starting
with underscores. As far as I know it is not forbidden even if
unusual. Do you see any problems with it or do you know about any
tools that would have problems with _my-module.yang ?

Is this stupid or OK?

regards Balazs

--
Balazs Lengyel Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909 email: [email-masked]

---

From: Andy Bierman <[email-masked]>
Date: Thu, 6 Sep 2018 09:59:19 -0700

On Thu, Sep 6, 2018 at 7:52 AM, Balazs Lengyel <[email-masked]>
wrote:

> Hello,
>
> One of our customers wants to introduce module names starting with
> underscores. As far as I know it is not forbidden even if unusual. Do you
> see any problems with it or do you know about any tools that would have
> problems with *_my-module.yang* ?
>
> Is this stupid or OK?
>

It is legal YANG.
There is no text anywhere AFAIK reserving names starting with 1 or 2
underscores.
This will likely confuse people who know about C and C++ naming conventions.
It also stretches the module naming guidelines in 6087bis.
https://tools.ietf.org/html/draft-ietf-netmod-rfc6087bis-20#section-4.1

regards Balazs

Andy

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>
>