Subject: [netmod] 6991bis - Any plans to add more URI Syntax components?

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 27 Sep 2019 18:39:54 -0700

Hi Juergen,

Is there a plan to add more URI syntax components in rfc6991bis? I know there is a typedef for uri, but I was looking specifically for the following that are defined in RFC 3986.
Scheme
Authority field including
User information
Path
Query
Fragment

Thanks.

Mahesh Jethanandani
[email-masked]

---

From: Schönwälder, Jürgen <[email-masked]>
Date: Sat, 28 Sep 2019 08:57:17 +0000

Hi Mahesh,

are these frequently needed? Are there YANG modules that use these
fields already?

/js

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 30 Sep 2019 14:27:49 -0700

Hi Juergen,

> On Sep 28, 2019, at 1:57 AM, Schönwälder, Jürgen <[email-masked]> wrote:
> 
> Hi Mahesh,
> 

Over in ETSI, I just added them to the YANG model that defines VNF Descriptors (VNFD), as part of what is called VnfConfigurableProperties.

In addition, I know that draft-kwatsen-netconf-http-client-server draft tries to define 'user-id'. And there has been discussion around draft-ietf-netconf-https-notif needing to define a ‘path’ attribute, although Martin does not think it is needed. Anyway, these are the instances I know of that could use these definitions. I am sure there are more.

Cheers.

Mahesh Jethanandani
[email-masked]