Subject: [netmod] Suresh Krishnan's Discuss on draft-ietf-netmod-artwork-folding-09: (with DISCUSS and COMMENT)

From: Suresh Krishnan via Datatracker <[email-masked]>
Date: Thu, 05 Sep 2019 07:41:06 -0700

Suresh Krishnan has entered the following ballot position for
draft-ietf-netmod-artwork-folding-09: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

After some thought I think there are two things about this document that make
me uncomfortable enough to ballot Discuss.

a) Due to its home in the netmod WG it is highly likely that people outside the
yang community have not paid enough attention to this work. Since this is
applicable to code fragments of all kinds, I think the home chosen for this RFC
might have inadvertently limited input from the broader community.

b) Given a) I think it is better that this document go forward as an
Informational document rather than a BCP so that use of this technique becomes
optional, without the force of a BCP behind it.

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I do agree with my Abstaining colleagues that this should probably not be on
the IETF stream but I think the work is useful enough to go forward.

---

From: Kent Watsen <[email-masked]>
Date: Thu, 5 Sep 2019 17:08:01 +0000

Hi Suresh,

Thank you for your review.  Comments below.

Kent // as co-author

> On Sep 5, 2019, at 10:41 AM, Suresh Krishnan via Datatracker <[email-masked]> wrote:
> 

> optional, without the force of a BCP behind it.

I'm okay with this, modulo my comment to Alissa.   Actually, if we only view the RFC as specifying a format then, in my mind, it doesn't actually contain the "best practice".  FWIW, SHOULD appears only once, in a sentence stating that folding SHOULD be automated, in a section titled "Goals".  That said, if not a BCP, then how to encourage people to use it, so that automation works?  For this reason alone, it seems that either the draft should be a BCP or Datatracker is updated to auto-fold as needed.  Perhaps  the right answer is to do Informational now and hope that Datatracker is updated in time?

It should've been on the IAB stream.  Whether it should go forward, after having the BCP attribute removed, or re-run via the IAB stream is up to the IESG.

Kent // as co-author

---

From: Andy Bierman <[email-masked]>
Date: Thu, 5 Sep 2019 14:46:59 -0700

On Thu, Sep 5, 2019 at 10:08 AM Kent Watsen <[email-masked]> wrote:

> Agreed.  The original I-D was targeted for IAB stream.  It wasn't going to
> be presented in NETMOD, but did (by coercion).  During the presentation I
> mentioned that its applicability was more than NETMOD and that it should go
> thru IAB, just like the "xml2rfc" RFCs (7749 and 7991).  The working group
> felt that it should stay in the WG and hence here we are.  :sigh:
>
>
It seemed self-evident that the scope of this draft did not fit the NETMOD
WG charter.
I assumed the work was permitted to start because (1) nobody else was
willing to
work on it and (2) nowhere else to put it.

> I'm okay with this, modulo my comment to Alissa.   Actually, if we only
> view the RFC as specifying a format then, in my mind, it doesn't actually
> contain the "best practice".  FWIW, SHOULD appears only once, in a sentence
> stating that folding SHOULD be automated, in a section titled "Goals".
> That said, if not a BCP, then how to encourage people to use it, so that
> automation works?  For this reason alone, it seems that either the draft
> should be a BCP or Datatracker is updated to auto-fold as needed.  Perhaps
>  the right answer is to do Informational now and hope that Datatracker is
> updated in time?
>
>
>
IMO Informational status is the only option.
There is a simple solution that solves applicability:

Add some text in this draft that UPDATES RFC 8407 so that only RFCs
that contain YANG modules are required to use this line-wrap solution.

Andy

> It should've been on the IAB stream.  Whether it should go forward, after
> having the BCP attribute removed, or re-run via the IAB stream is up to the
> IESG.
>
>
> Kent // as co-author
>
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Kent Watsen <[email-masked]>
Date: Thu, 5 Sep 2019 22:07:31 +0000

Hi Suresh, 

Please see https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding-10 <https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding-10> for updates.  It's now Informational.

Kent // as co-author

> On Sep 5, 2019, at 1:08 PM, Kent Watsen <[email-masked]> wrote:
> 
> Hi Suresh,
> 
>> On Sep 5, 2019, at 10:41 AM, Suresh Krishnan via Datatracker <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html <https://www.ietf.org/iesg/statement/discuss-criteria.html>
>> https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/ <https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/>
>> 
>> 
>>