Subject: Re: [netmod] I-D Action: draft-ietf-netmod-node-tags-00.txt

From: Peng Liu | 刘鹏<[email-masked]>
Date: 18 Feb 2021 19:51:23 +0800

Hi Qin and authors,

I have read the v-00 of draft-ietf-netmod-node-tags and have two quick questions
1. For section 1.1.1, can an object have more than one metric tags? Maybe it can be used in the uml model but may have the problem of hard to distinguish in yang module.
2. Can the Multiple Source Tag be applied to the property tag of OPM? If so, is there any example?

Thanks,

Peng

-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2020年12月29日 22:52
收件人: [email-masked]
抄送: [email-masked]
主题: I-D Action: draft-ietf-netmod-node-tags-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Modeling WG of the IETF.

        Title           : Self Describing Data Object Tags
        Authors         : Qin Wu
                          Benoit Claise
                          Liang Geng
                          Zongpeng Du
                          Mohamed Boucadair
Filename        : draft-ietf-netmod-node-tags-00.txt
Pages           : 26
Date            : 2020-12-28

Abstract:
   This document defines a method to tag data objects associated with
   operation and management data in YANG Modules.  This YANG data object
   tagging method can be used to classify data objects from different
   YANG modules and identify characteristics data.  It also can provide
   input, instruction, indication to selection filter and filter queries
   of operational state on a server during a "pub/sub" service for YANG
   datastore updates.  When the state of all subscriptions of a
   particular Subscriber to be fetched is huge, the amount of data to be
   streamed out to the destination can be greatly reduced and only
   targeted to the characteristics data.  These data object tags may be
   registered as well as assigned during the module definition; assigned
   by implementations; or dynamically defined and set by users.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netmod-node-tags/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-netmod-node-tags-00
https://datatracker.ietf.org/doc/html/draft-ietf-netmod-node-tags-00

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Qin Wu <[email-masked]>
Date: Fri, 19 Feb 2021 12:57:00 +0000

Hi, Peng:
Thanks for your comment, see my reply inline.

发件人: Peng Liu | 刘鹏 [mailto:[email-masked]]
发送时间: 2021年2月18日 19:51
收件人: Qin Wu <[email-masked]>
抄送: netmod <[email-masked]>
主题: Re: I-D Action: draft-ietf-netmod-node-tags-00.txt

Hi Qin and authors,

[Qin]:Good point, take root node “tunnel-svc” in figure 2 of this draft as an example, tunnel-svc can have multiple metric-tags, one is for tunnel-svc/avg-latency, one is for tunnel-svc/packet-loss,

Both are under root node “tunnel-svc”, but modelling these in YANG, we actually tag avg-latency leaf node with metric tag, and packet-loss with metric-tag, so both avg-latency leaf node and packet-loss

Can be seen as new data objects, for each data object, they will be limited to have one metric tag and one object tag. I will make this clear in the text.

[Qin]:In the current document, multi-source tag is only applicable to metric related data object such as avg-latency, packet-loss, see we can identify

Whether data object value or metric value is aggregated or not, I haven’t see any case that the multi-source tag can be applied to property related data object,

If you have, please let me know.

Thanks,
Peng

-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]<mailto:[email-masked]>
发送时间: 2020年12月29日 22:52
收件人: [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>
主题: I-D Action: draft-ietf-netmod-node-tags-00.txt

Abstract:

[email-masked]<mailto:[email-masked]>