Subject: [netmod] warn: Module's revisions are not unique (2018-06-28).

From: Vladimir Vassilev <[email-masked]>
Date: Tue, 16 Mar 2021 13:36:32 +0100

Hei,

Many drafts and RFCs are flagged with warnings by the tracker validation 
tools:

...
yanglint SO 1.6.7: yanglint --verbose -p {tmplib} -p {rfclib} -p {draftlib} -p {ianalib} -p {cataloglib} {model} -i:
warn: Module's revisions are not unique (2018-06-28).

...

Does anyone know what causes this warning?

Vladimir

---

From: Vladimir Vassilev <[email-masked]>
Date: Wed, 17 Mar 2021 16:35:22 +0100

On 16/03/2021 13.36, Vladimir Vassilev wrote:
> Hei,
>
> Many drafts and RFCs are flagged with warnings by the tracker 
> validation tools:
>
> ...
> yanglint SO 1.6.7: yanglint --verbose -p {tmplib} -p {rfclib} -p 
> {draftlib} -p {ianalib} -p {cataloglib} {model} -i:

Seems the warning is issued when [email-masked] is 
processed. It contains 2 revision (history) statements with identical 
dates 2018-06-28.

IMO Multiple revision statements with the same date are valid so the 
tool reporting the warning has to be fixed.

Vladimir

---

From: Andy Bierman <[email-masked]>
Date: Wed, 17 Mar 2021 11:21:18 -0700

> tool reporting the warning has to be fixed.

I disagree.  Our compiler has a similar warning.

The YANG Library treats entries with the exact same module name and
revision-date as
the same module.  The protocols that currently advertise YANG module
capabilities
all use module name and revision-date to identify a unique module revision.

A compiler warning simply means "Are you sure you meant to do this?"
This is usually a cut-and-paste error.

> Vladimir
Andy

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: William Lupton <[email-masked]>
Date: Wed, 17 Mar 2021 18:36:33 +0000

Also note that the YANG catalog keys modules by (name, revision,
organization).

---

From: Andy Bierman <[email-masked]>
Date: Wed, 17 Mar 2021 11:47:44 -0700

> Also note that the YANG catalog keys modules by (name, revision,

This 3rd key implies that some organizations have their own versions of
YANG modules from SDOs.
We have a bit of that only to fix known Errara in some IETF modules.
YANG has deviations so vendors can change the modules from other
organizations
without hacking the original modules.

Andy

---

From: William Lupton <[email-masked]>
Date: Wed, 17 Mar 2021 19:45:04 +0000

I thought it might also be so as not to impose a module naming convention
on external organisations?

On Wed, 17 Mar 2021, 18:47 Andy Bierman, <[email-masked]> wrote:

>
>
> On Wed, Mar 17, 2021 at 11:36 AM William Lupton <
> [email-masked]> wrote:
>

---

From: Vladimir Vassilev <[email-masked]>
Date: Wed, 17 Mar 2021 21:36:20 +0100

On 17/03/2021 19.21, Andy Bierman wrote:
>
>
> On Wed, Mar 17, 2021 at 8:36 AM Vladimir Vassilev 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>

If the tools could some how indicate that the warning is for an imported 
module and not the one validated it would be easier to differentiate 
between that case and the case the warning is caused by an imported 
standard module like iana-if-type.

Vladimir

> [email-masked] <mailto:[email-masked]>