Subject: Re: [netmod] ECA Policy: What is an adequate abstraction level to express policies and intent

From: Qin Wu <[email-masked]>
Date: Thu, 18 Mar 2021 01:06:29 +0000

Randy:
We feel that we are victim of this discussion with confusing title. I don’t want to comment on whether the intent is right or it is time for intent or not, you have your judgement, but:
1. The liaison is sent to NMRG instead of this WG since they believe the more relevant work is over there. (https://datatracker.ietf.org/liaison/1724/)
2. The intent in different context means different things, intent translation, intent mapping, combining with AL/ML is not in the scope of this work.
3. The ECA model borrows similar concept from RMON which is successfully specified by IETF, ROMN is extension of SNMP, provides traffic flow data for troubleshooting and provides the control to adjust for better performance. So why not ECA
4. ECA is abstracted from bottom up and use telemetry protocol as a good basis and provide a clear semantics which is different from intent you quoted from elsewhere.

-Qin
-----邮件原件-----
发件人: netmod [mailto:[email-masked]] 代表 Randy Presuhn
发送时间: 2021年3月18日 6:47
收件人: [email-masked]
主题: Re: [netmod] ECA Policy: What is an adequate abstraction level to express policies and intent

Hi -

On 2021-03-17 4:15 AM, tom petch wrote:
> From: netmod <[email-masked]> on behalf of Randy Presuhn 
> <[email-masked]>
> Sent: 10 March 2021 18:28
> On 2021-03-10 12:43 AM, Juergen Schoenwaelder wrote:
>> Dear Qin,
>>
>> I believe this work repeats failures of the past but since the WG 
>> agreed to entertain this, I will keep my mouth shut. I suggest you do 
>> not spend your energy to convince the that this work is viable since 
>> it is rather unlikely that I will change my mind.
> 
> <tp>
> 
> Meanwhile the ITU-T has just liaised the IETF that it is starting work on intent-based management.  I have not looked to see if the same words mean the same thing but guess that they do.

:-)  A risky guess, based on my experience.  I vividly remember an
X3T5.4 meeting in which we *thought* we were wrapping things up, until someone (me) foolishly drew an E-R diagram on the whiteboard, causing us to realize that although we thought we had reached agreement, we had in fact been using the same words strung together in the same order to talk about radically different models.

Randy

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Randy Presuhn <[email-masked]>
Date: Wed, 17 Mar 2021 18:35:46 -0700

Qin -

It puzzles me that you should take umbrage at my statement,
when it seems that you are in full agreement with my point
in response to Tom's stated assumption.

Randy

---

From: Andy Bierman <[email-masked]>
Date: Wed, 17 Mar 2021 18:49:43 -0700

Hi,

Addressing only point 3 below...
Some article in the 90s claimed that RMON was going to replace SNMP.
RMON is just another set of MIB modules. It does not extend or replace SNMP.
It is SNMP.  (pet peeve of former RMONMIB WG Chair).

Most of the RMON RFCs were widely deployed, but not all of them.
One lesson learned from these failed MIB modules:
It is quite possible to use the SMIv2 language to create a data model that
nobody can implement within the business constraints given to them.
And therefore, no implementations of such a module ever get written or
deployed.

Andy

On Wed, Mar 17, 2021 at 6:07 PM Qin Wu <[email-masked]> wrote:

> Randy:
> We feel that we are victim of this discussion with confusing title. I
> don’t want to comment on whether the intent is right or it is time for
> intent or not, you have your judgement, but:
> 1. The liaison is sent to NMRG instead of this WG since they believe the
> more relevant work is over there. (
> https://datatracker.ietf.org/liaison/1724/)
> 2. The intent in different context means different things, intent
> translation, intent mapping, combining with AL/ML is not in the scope of
> this work.
> 3. The ECA model borrows similar concept from RMON which is successfully
> specified by IETF, ROMN is extension of SNMP, provides traffic flow data
> for troubleshooting and provides the control to adjust for better
> performance. So why not ECA
> 4. ECA is abstracted from bottom up and use telemetry protocol as a good
> basis and provide a clear semantics which is different from intent you
> quoted from elsewhere.
>
> -Qin
> -----邮件原件-----
> > Meanwhile the ITU-T has just liaised the IETF that it is starting work
> on intent-based management.  I have not looked to see if the same words
> mean the same thing but guess that they do.
>
> X3T5.4 meeting in which we *thought* we were wrapping things up, until
> someone (me) foolishly drew an E-R diagram on the whiteboard, causing us to
> realize that although we thought we had reached agreement, we had in fact
> been using the same words strung together in the same order to talk about
> radically different models.
>
> Randy
>