Subject: [netmod] YANG Versioning Weekly Call Minutes - 2021-04-27

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 27 Apr 2021 14:04:50 +0000

YANG Versioning Weekly Call Minutes - 2021-04-27

We continued reviewing Reshad's Module Versioning slides from IETF110 to capture feedback to roll into the draft.

Comparison draft should do the following (need to raise Github issues)
- have switches for how/if to consider extension statement changes
- output should differentiate between changes in config vs changes in state (separate output reports for config and for state)

Issue for tooling/comparison draft:
- consider an extension that defines whether changes to an extension (or adding/removing) is BC or NBC (Github issue #92)

Extensions (Github issue #12):
- differentiate between the *declaration/definition* (i.e. the YANG 'extension' statement keyword) of an extension, and the *use* of the extension
- go with 7950 rules for the *declaration/definition* (i.e. you can add a new extension definition and that is BC, but removing or changing one is NBC)
- For *usage* of an extension:
     a) everything is BC unless specified otherwise ?
                b) using the extension in a newly added schema node is BC, anything else is NBC (e.g. newly adding/using the extension in a pre-existing schema node is NBC, or removing a use of an extension is NBC)
                c) usage changes are indeterminate (i.e. may break compatibility) unless otherwise specified by the specification of the extension

Reshad's IETF110 slides: Finished slide 7, start with slide 8 next meeting

Jason

----------------------------------------------
Weekly webex call details:
Meeting number (access code): 171 069 0374
Meeting password: semver?
Occurs every Tuesday effective Tuesday, September 1, 2020 until Tuesday, August 24, 2021 from 9:00 AM to 10:00 AM, (UTC-04:00) Eastern Time (US & Canada)
9:00 am  |  (UTC-04:00) Eastern Time (US & Canada)  |  1 hr
https://ietf.webex.com/ietf/j.php?MTID=ma7627a2ae7b770537cff5f5b89293c70
Tap to join from a mobile device (attendees only)
+1-650-479-3208,,1710690374## Call-in toll number (US/Canada)

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 29 Apr 2021 20:54:54 +0000

I created issues 93 and 94 for the comparison tool issues mentioned below.
Jason

From: Sterne, Jason (Nokia - CA/Ottawa)
Sent: Tuesday, April 27, 2021 10:05 AM
To: [email-masked]
Subject: YANG Versioning Weekly Call Minutes - 2021-04-27

Jason