Subject: [netmod] inet:ipv4-address

From: Christian Hopps <[email-masked]>
Date: Sat, 08 May 2021 19:26:46 -0400

How did we end up with "ipv4-address" being a zoned IPv4 address and having to use the non-obvious "ipv4-address-no-zone" type to get the IPv4 address type used by everyone, everywhere?

I see that OpenConfig chose the opposite meaning for the "obvious" names (i.e., you want zoned addresses you use "-zoned" types e.g., "ipv6-address-zoned").

Thanks,
Chris.

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 10 May 2021 08:32:37 +0200

On 09. 05. 21 1:26, Christian Hopps wrote:
> 
> How did we end up with "ipv4-address" being a zoned IPv4 address and
> having to use the non-obvious "ipv4-address-no-zone" type to get the
> IPv4 address type used by everyone, everywhere?

It was discussed e.g. in these threads:

*
https://mailarchive.ietf.org/arch/browse/netmod/?gbt=1&q=subject%3A%22draft-schoenw-netmod-rfc6021-bis-01%20(20130204)%22

*
https://mailarchive.ietf.org/arch/browse/netmod/?gbt=1&index=gcMx6c-NFt2UCbtBFi7BsUWf0EU

Lada

> 
> I see that OpenConfig chose the opposite meaning for the "obvious" names
> (i.e., you want zoned addresses you use "-zoned" types e.g.,
> "ipv6-address-zoned").
> 
> Thanks,
> Chris.
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Christian Hopps <[email-masked]>
Date: Mon, 10 May 2021 02:45:32 -0400

Well you were right, ipv4-address is used all over the place and it probably shouldn't have been. Chalk another one up to sticking to the rules even when it harms us.

Thanks,
Chris.

---

From: Don Fedyk <[email-masked]>
Date: Mon, 10 May 2021 14:02:01 +0000

Thanks - In DetNet we have an ID in progress we should change from type inet:ip-address to inet:ip-address-no-zone. I did not know that. 

My other thought is since the ipv4-address (with the zone) is of format "127.1.1.0%AndAUnterminatedString..", shouldn't every use of ipv4-address type also have a maximum length restriction? - If not - what controls the Maximum length? It is good practice to have maximums on input strings and I have come across xml validation rules that require exceptions for long strings - and the definition long is not usually very long.

Thanks
Don   

-----Original Message-----
From: netmod <[email-masked]> On Behalf Of Christian Hopps
Sent: Monday, May 10, 2021 2:46 AM
To: Ladislav Lhotka <[email-masked]>
Cc: [email-masked]
Subject: Re: [netmod] inet:ipv4-address

Thanks,
Chris.

Ladislav Lhotka <[email-masked]> writes:

> https://mailarchive.ietf.org/arch/browse/netmod/?gbt=1&q=subject%3A%22
> draft-schoenw-netmod-rfc6021-bis-01%20(20130204)%22
>
> *
>> I see that OpenConfig chose the opposite meaning for the "obvious" 
>> names (i.e., you want zoned addresses you use "-zoned" types e.g., 
>> "ipv6-address-zoned").
>>
>> Thanks,
>> Chris.
>>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 10 May 2021 16:14:08 +0200

The zone identifiers you find in practice are either numeric
(interface indexes) or symbolic interface names, this is also stated
in the description.

          The zone index is used to disambiguate identical address
          values.  For link-local addresses, the zone index will
          typically be the interface index number or the name of an
          interface.  If the zone index is not present, the default
          zone of the device will be used.

in other words, its 'not usually very long' but there is not concrete
restriction. Note that the interface name leaf in RFC 8343 also has no
restriction.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>