Subject: [netmod] [Technical Errata Reported] RFC7950 (6570)

From: RFC Errata System <[email-masked]>
Date: Tue, 4 May 2021 04:49:55 -0700 (PDT)

The following errata report has been submitted for RFC7950,
"The YANG 1.1 Data Modeling Language".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6570

--------------------------------------
Type: Technical
Reported by: Jernej Tuljak <[email-masked]>

Section: 11

Original Text
-------------
   o  New typedefs, groupings, rpcs, notifications, extensions,
      features, and identities may be added.

Corrected Text
--------------
   o  New typedefs, groupings, rpcs, actions, notifications,
      extensions, features, and identities may be added.

Notes
-----
The original text unintentionally fails to mention actions. A definition in a published module may be revised by adding actions to this definition.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7950 (draft-ietf-netmod-rfc6020bis-14)
--------------------------------------
Title               : The YANG 1.1 Data Modeling Language
Publication Date    : August 2016
Author(s)           : M. Bjorklund, Ed.
Category            : PROPOSED STANDARD
Source              : Network Modeling
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Martin Björklund <[email-masked]>
Date: Tue, 04 May 2021 13:59:13 +0200 (CEST)

Hi,

This errata is correct and should be verified.

/martin

RFC Errata System <[email-masked]> wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 4 May 2021 12:11:14 +0000

I agree.

I'll leave this a couple of days in case anyone else wants to express an opinion, but assuming that I hear no dissenting voices, I'll verify it.

Regards,
Rob

> -----Original Message-----
> From: Martin Björklund <[email-masked]>
> Sent: 04 May 2021 12:59
> To: [email-masked]
> Cc: [email-masked]; Rob Wilton (rwilton) <[email-masked]>;
> [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [netmod] [Technical Errata Reported] RFC7950 (6570)
> 
> Hi,
> 
> > The original text unintentionally fails to mention actions. A definition
> in a published module may be revised by adding actions to this definition.
> >
> > Instructions:
> > -------------