Subject: Re: [netmod] I-D Action: draft-lear-opsawg-ol-01.txt

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 27 May 2021 15:38:22 +0200

Hi,

I have not followed the discussion but skimming through the document,
I felt that calling a grouping an extension is somewhat confusing
since YANG also has extensions that are a very different thing
(i.e. we get a clash between a MUD and YANG extensions). Perhaps more
careful wording can help. In the YANG definitions, I would rather
avoid using 'extension'.

OLD

     grouping ol-extension {
       description
         "OL extension grouping";

NEW

     grouping owner-licence-grouping {
       description
         "A grouping expression ownership and license information";

Whether 'ol' makes a good container name can be discussed.

Whether allowing multiple owners all sharing a single license is
appropriate I do not know; in the open source world there are
occasionally projects that can be used with different licenses
(perhaps making this just a list of (owner, spdx-tag, license-info)
instead of a leaf-list of owners with exactly one spdx-tag and
license-info would be more flexible. I am also not sure that using an
'owner' leaf to contain a copyright statement is what I would have
expected to be an 'owner' (i.e., a person or legal entity).

/js

On Thu, May 27, 2021 at 06:21:44AM -0700, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : Ownership and licensing statements in YANG
>         Authors         : Eliot Lear
>                           Carsten Bormann
> 	Filename        : draft-lear-opsawg-ol-01.txt
> 	Pages           : 7
> 	Date            : 2021-05-27
> 
> Abstract:
>    This memo provides for an extension to RFC 8520 that allows MUD file
>    authors to specify ownership and licensing of MUD files themselves.
>    This memo updates RFC 8520.  However, it can also be used for
>    purposes outside of MUD, and the grouping is structured as such.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-lear-opsawg-ol/
> 
> There is also an htmlized version available at:
> https://datatracker.ietf.org/doc/html/draft-lear-opsawg-ol-01
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-lear-opsawg-ol-01
> 
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Eliot Lear <[email-masked]>
Date: Thu, 27 May 2021 15:47:03 +0200

Hi Juergen,

> On 27 May 2021, at 15:38, Juergen Schoenwaelder <[email-masked]> wrote:
> 
> Hi,
> 

Thanks, accepted.

Eliot