Subject: Re: [netmod] [OPSAWG] Francesca Palombini's Discuss on draft-ietf-opsawg-l3sm-l3nm-16: (with DISCUSS and COMMENT)

From: Carsten Bormann <[email-masked]>
Date: Mon, 4 Oct 2021 17:49:53 +0200

On 2021-10-04, at 13:34, [email-masked] wrote:
> bytes per second (bps),

Whoa.

I know that the IETF doesn’t usually care about precision in these things, but “bps” is kitchen slang for “bit/s”, so this is very confusing.

(Given that we have done the work in RFC 8428 and 8798, I’d rather see that we use it, instead of creating more confusion at each further step.
We do have ms and B/s in RFC 8798, because people using SenML asked for that.)

Grüße, Carsten

---

From: <[email-masked]>
Date: Tue, 5 Oct 2021 06:02:25 +0000

Hi Carsten,

I confirm that what I meant is "bits per second" to align with rfc8299#6.12.1.

I'm actually for more explicit units similar to what we are using in another active spec: 

==
      enum bit-ps {
        value 2;
        description
          "Bits per Second (bit/s).";
      }
      enum byte-ps {
        value 3;
        description
          "Bytes per second (Byte/s).";
      }
==

However, we are in a territory where we are trying to map as much to the above service model and hence use the same labels for the units.

FWIW, RFC8466 used to have the following:

=
                  leaf pbs {
                    type uint64;
                    units "bps";
                    description
                      "Peak Burst Size.  It is measured in bytes per
                       second.";
                  }
=

...which is weird. This is why we don't blindly inherit that draft-ietf-opsawg-l2nm and went for the following: 

                      leaf pbs {
                        type uint64;
                        units "bytes per second";
                        description
                          "Peak Burst Size.";
                      }

Cheers,
Med

> -----Message d'origine-----
> De : Carsten Bormann <[email-masked]>
> Envoyé : lundi 4 octobre 2021 17:50
> À : BOUCADAIR Mohamed INNOV/NET <[email-masked]>
> Cc : Francesca Palombini <[email-masked]>; The IESG
> <[email-masked]>; [email-masked]; opsawg-
> [email-masked]; [email-masked]; [email-masked]
> Objet : Re: [OPSAWG] Francesca Palombini's Discuss on draft-ietf-opsawg-
> l3sm-l3nm-16: (with DISCUSS and COMMENT)
> 
> I know that the IETF doesn’t usually care about precision in these things,
> but “bps” is kitchen slang for “bit/s”, so this is very confusing.
> 
> (Given that we have done the work in RFC 8428 and 8798, I’d rather see
> that we use it, instead of creating more confusion at each further step.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 5 Oct 2021 09:05:21 +0200

Hi Med,

> I confirm that what I meant is "bits per second" to align with rfc8299#6.12.1.

Ah.

> I'm actually for more explicit units similar to what we are using in another active spec: 

As long as there is this confusion in YANG units, that is the only way that makes sense.

>          "Bytes per second (Byte/s).";

Maybe use the actual ISO/IEC 80000 notation here: B/s.
(For those that don’t know how ISO/IEC 80000 allocates “B” for byte, the legend “Bytes per second” is unambiguous.)

> ...which is weird.

This is really errata land, as “bps” is used as the kitchen slang for “bit/s” in all other cases (along with “mbps” for Mbit/s, shudder).

> This is why we don't blindly inherit that draft-ietf-opsawg-l2nm and went for the following: 
> 
>                      leaf pbs {
>                        type uint64;

I think this would also benefit from “Bytes per Second (B/s)”.

Grüße, Carsten

---

From: Francesca Palombini <[email-masked]>
Date: Tue, 5 Oct 2021 14:11:53 +0000

Thanks Carsten for noticing this! I did overlook completely that bps was being used as bytes per seconds… Thanks Med for clarifying in this document and for opening errata https://www.rfc-editor.org/errata/eid6703 . The OPS ADs are on it, I am sure.

Francesca

From: Carsten Bormann <[email-masked]>
Date: Tuesday, 5 October 2021 at 09:05
To: [email-masked] <[email-masked]>
Cc: Francesca Palombini <[email-masked]>, The IESG <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [OPSAWG] Francesca Palombini's Discuss on draft-ietf-opsawg-l3sm-l3nm-16: (with DISCUSS and COMMENT)
Hi Med,

Ah.

Grüße, Carsten

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 5 Oct 2021 14:56:08 +0000

Carsten & Med,

Thanks for raising this.  I agree with the errata, but this will need to be hold for doc update, because we cannot create a different revision of a YANG module through the errata process.

Thanks,
Rob

From: iesg <[email-masked]> On Behalf Of Francesca Palombini
Sent: 05 October 2021 15:12
To: Carsten Bormann <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; The IESG <[email-masked]>; [email-masked]
Subject: Re: [OPSAWG] Francesca Palombini's Discuss on draft-ietf-opsawg-l3sm-l3nm-16: (with DISCUSS and COMMENT)

Thanks Carsten for noticing this! I did overlook completely that bps was being used as bytes per seconds... Thanks Med for clarifying in this document and for opening errata https://www.rfc-editor.org/errata/eid6703 . The OPS ADs are on it, I am sure.

Francesca

From: Carsten Bormann <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 5 October 2021 at 09:05
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: Francesca Palombini <[email-masked]<mailto:[email-masked]>>, The IESG <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OPSAWG] Francesca Palombini's Discuss on draft-ietf-opsawg-l3sm-l3nm-16: (with DISCUSS and COMMENT)
Hi Med,

Ah.

Maybe use the actual ISO/IEC 80000 notation here: B/s.
(For those that don't know how ISO/IEC 80000 allocates "B" for byte, the legend "Bytes per second" is unambiguous.)

>                      "Peak Burst Size.  It is measured in bytes per

This is really errata land, as "bps" is used as the kitchen slang for "bit/s" in all other cases (along with "mbps" for Mbit/s, shudder).

>                        units "bytes per second";

I think this would also benefit from "Bytes per Second (B/s)".

Grüße, Carsten

>> De : Carsten Bormann <[email-masked]<mailto:[email-masked]>>
>> À : BOUCADAIR Mohamed INNOV/NET <[email-masked]<mailto:[email-masked]>>
>> Cc : Francesca Palombini <[email-masked]<mailto:[email-masked]>>; The IESG
>> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; opsawg-
>> [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
>> On 2021-10-04, at 13:34, [email-masked]<mailto:[email-masked]> wrote:
>>>
>>> bytes per second (bps),
>>
>> Whoa.
>>
>> I know that the IETF doesn't usually care about precision in these things,
>> but "bps" is kitchen slang for "bit/s", so this is very confusing.
>>
>> (Given that we have done the work in RFC 8428 and 8798, I'd rather see