Subject: [netmod] Clarification on the description for chassis and stack in RFC 8348

From: Aihua Guo <[email-masked]>
Date: Wed, 13 Oct 2021 15:17:10 -0400

Hi All,

RFC 8348 defines chassis and stack as two identities for networking
equipment. The description for chassis says that* "Any class of physical
component, except a stack, may be contained within a chassis; a chassis may
only be contained within a stack." *First statement of this sentence seems
to suggest that a chassis (which is a component) can also be contained
within a chassis, while the next statement, "*a chassis may only be
contained within a stack.*" seems to suggest that a chassis can be
only contained within a stack and not within another chassis, which seems
to contradict with the previous statement. So, which statement is correct?

Another point to clarify is that in the description for stack, "*...a stack
may be contained within another stack.  Only chassis components should be
contained within a stack.*" Is it correct to understand that a stack can
contain either another stack or a chassis, or both, but nothing else?

I would appreciate the clarification.

Thanks,
Aihua

---

From: tom petch <[email-masked]>
Date: Wed, 20 Oct 2021 11:10:09 +0000

From: netmod <[email-masked]> on behalf of Aihua Guo <[email-masked]>
Sent: 13 October 2021 20:17

Hi All,

RFC 8348 defines chassis and stack as two identities for networking equipment. The description for chassis says that "Any class of physical component, except a stack, may be contained within a chassis; a chassis may only be contained within a stack." First statement of this sentence seems to suggest that a chassis (which is a component) can also be contained within a chassis, while the next statement, "a chassis may only be contained within a stack." seems to suggest that a chassis can be only contained within a stack and not within another chassis, which seems to contradict with the previous statement. So, which statement is correct?

<tp>
I do not know what the authors had in mind but to me a chassis is clearly a chassis and a stack a stack:-)

A chassis is a frame, usually metal, often with PSU and perhaps managements functions into which blades can be slotted.  Without at least one blade it is usually not good for much except testing the management module although that may well be a blade and not integral with the chassis.  A multi-protocol switch would be a likely example.  I have not seen a chassis within a chassis.

By contrast, a stack is made up of stackable elements, each of which is complete in itself and could be used by itself as a one element stack but which also have in/out sockets which enable multiple elements to be integrated into a single functional element.  A LAN hub where each element supports 16 ports and eight can be stacked to form a 128 port hub would be an example.  If the elements are all connected together, I see a stack.  If they are physically co-located but function as several separate entities then I see several stacks but not  a stack within a stack.

HTH

Tom Petch

Another point to clarify is that in the description for stack, "...a stack may be contained within another stack.  Only chassis components should be contained within a stack." Is it correct to understand that a stack can contain either another stack or a chassis, or both, but nothing else?

Thanks,
Aihua

---

From: <[email-masked]>
Date: Wed, 20 Oct 2021 12:50:31 +0000

The confusion appears to stem from the exclusion of "chassis" in the first part of this sentence:

"Any class of physical component, except a stack, may be contained within a chassis; a chassis may only be contained within a stack."

It takes a rather pedantic read of the text to suggest that "any class of physical component" may also include a chassis, but perhaps it is worth updating the text to specifically state "Any class of physical component, except a stack or a chassis, may be contained within a chassis". 

Nesting a chassis within a chassis I don't see being useful to permit in practice/practically useful. 

Nested stacking sounds plausible. 'A stack of stacks' reminds me of a few designs I've seen in the past (4-way Cisco VSS, perhaps?) 

Regards,

Tom

My sincere apologies for Outlook.

-----Original Message-----
From: netmod <[email-masked]> On Behalf Of tom petch
Sent: 20 October 2021 12:10
To: Aihua Guo <[email-masked]>; [email-masked]
Subject: Re: [netmod] Clarification on the description for chassis and stack in RFC 8348

Hi All,

<tp>

HTH

Tom Petch

Thanks,
Aihua

_______________________________________________
netmod mailing list
[email-masked]
https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fnetmod&amp;data=04%7C01%7Ctom.2.hill%40bt.com%7Ceceaf59456654bcbc2cb08d993ba4469%7Ca7f356889c004d5eba4129f146377ab0%7C0%7C0%7C637703250499568112%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=hdfDrlNtUJpN%2FddyjlDwn5tjHDosdORIC0qa%2BmCA2fc%3D&amp;reserved=0

---

From: Aihua Guo <[email-masked]>
Date: Wed, 20 Oct 2021 12:07:10 -0400

Hi Tom,

Thank you for the clarification.

In telecom there are also "shelves" mounted on racks. A shelf is a metal
frame with PSU and slots that can contain other cards. It is usually 1U-9U
in height. So it looks to me that a shelf is a type of chassis.

Now, there are usually subtended shelves that sit next to a main shelf and
connected by external cables. A subtended shelf (or subshelf) is also a
metal frame with PSU and slots, but it does not have its own control units
and instead is managed directly by the main shelf. If a subshelf is also
considered as a type of chassis, then it means that a chassis (shelf) could
contain another chassis (subshelf) as its child, and a subshelf has a shelf
as its parent.

Alternatively, it could be modeled by using a "stack" to group these
chassises together, but then to capture the parent-child relationship
between a shelf and a subshelf, it needs to create a stack that contains
both the main shelf and another stack which contains the subshelf. It
sounds a little redundant to me.

Thoughts are much appreciated.

Thanks,
Aihua

On Wed, Oct 20, 2021 at 8:51 AM <tom.2.hill=[email-masked]> wrote:

> "Any class of physical component, except a stack, may be contained within
> a chassis; a chassis may only be contained within a stack."
>
> It takes a rather pedantic read of the text to suggest that "any class of
> physical component" may also include a chassis, but perhaps it is worth
> updating the text to specifically state "Any class of physical component,
> except a stack or a chassis, may be contained within a chassis".
>
> Nested stacking sounds plausible. 'A stack of stacks' reminds me of a few
> designs I've seen in the past (4-way Cisco VSS, perhaps?)
>
> Regards,
>
> Tom
>
> equipment. The description for chassis says that "Any class of physical
> only be contained within a stack." First statement of this sentence seems
> within a chassis, while the next statement, "a chassis may only be
> contained within a stack." seems to suggest that a chassis can be only
> contained within a stack and not within another chassis, which seems to
> contradict with the previous statement. So, which statement is correct?
>
> <tp>
> A chassis is a frame, usually metal, often with PSU and perhaps
> managements functions into which blades can be slotted.  Without at least
> one blade it is usually not good for much except testing the management
> module although that may well be a blade and not integral with the
> chassis.  A multi-protocol switch would be a likely example.  I have not
> seen a chassis within a chassis.
>
> By contrast, a stack is made up of stackable elements, each of which is
> complete in itself and could be used by itself as a one element stack but
> which also have in/out sockets which enable multiple elements to be
> integrated into a single functional element.  A LAN hub where each element
> supports 16 ports and eight can be stacked to form a 128 port hub would be
> an example.  If the elements are all connected together, I see a stack.  If
> they are physically co-located but function as several separate entities
> then I see several stacks but not  a stack within a stack.
>
> HTH
>
> Tom Petch
>
>
> Another point to clarify is that in the description for stack, "...a stack
> contained within a stack." Is it correct to understand that a stack can
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: tom petch <[email-masked]>
Date: Fri, 22 Oct 2021 11:00:47 +0000

From: netmod <[email-masked]> on behalf of tom.2.hill=[email-masked] <tom.2.hill=[email-masked]>
Sent: 20 October 2021 13:50

<tp>

Yes.  I looked back and the text has been the same for decades so clearly the authors are happy with this.  My initial take was on the common sense (to me) usage of chassis but this is a bit different.

Perhaps raise an erratum which would likely get the attention of the authors and the AD with OLD and NEW as you suggest.

Tom Petch

Regards,

Tom

-----Original Message-----
From: netmod <[email-masked]> On Behalf Of tom petch
Sent: 20 October 2021 12:10
To: Aihua Guo <[email-masked]>; [email-masked]
Subject: Re: [netmod] Clarification on the description for chassis and stack in RFC 8348

Hi All,

<tp>

HTH

Tom Petch

Thanks,
Aihua

---

From: tom petch <[email-masked]>
Date: Fri, 22 Oct 2021 11:14:07 +0000

From: netmod <[email-masked]> on behalf of Aihua Guo <[email-masked]>
Sent: 20 October 2021 17:07

Hi Tom,

In telecom there are also "shelves" mounted on racks. A shelf is a metal frame with PSU and slots that can contain other cards. It is usually 1U-9U in height. So it looks to me that a shelf is a type of chassis.

Now, there are usually subtended shelves that sit next to a main shelf and connected by external cables. A subtended shelf (or subshelf) is also a metal frame with PSU and slots, but it does not have its own control units and instead is managed directly by the main shelf. If a subshelf is also considered as a type of chassis, then it means that a chassis (shelf) could contain another chassis (subshelf) as its child, and a subshelf has a shelf as its parent.

Alternatively, it could be modeled by using a "stack" to group these chassises together, but then to capture the parent-child relationship between a shelf and a subshelf, it needs to create a stack that contains both the main shelf and another stack which contains the subshelf. It sounds a little redundant to me.

<tp>

Yes, I am well familiar with telecoms racks and with cabling racks.  With cabling racks, then I think that there is too little logic to qualify for this model and I wonder if the same is true for subshelves which is something I am not familiar with.   The model, like much of the IETF, is aimed at bridges, switches and routers and higher level protocol devices so if the subtended modules do not have their own control units then I would be inclined not to see them as chassis.  I agree with Tom that the text as written does not cater for a chassis contained within  a chassis and so that would be a technical change to the RFC which would call for a fresh RFC whereas the change Tom suggests is editorial IMHO and so could be made by an erratum to the RFC.

Tom Petch

Thanks,
Aihua

On Wed, Oct 20, 2021 at 8:51 AM <tom.2.hill=[email-masked]<mailto:[email-masked]>> wrote:
The confusion appears to stem from the exclusion of "chassis" in the first part of this sentence:

Regards,

Tom

-----Original Message-----
From: netmod <[email-masked]<mailto:[email-masked]>> On Behalf Of tom petch
Sent: 20 October 2021 12:10
To: Aihua Guo <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [netmod] Clarification on the description for chassis and stack in RFC 8348

From: netmod <[email-masked]<mailto:[email-masked]>> on behalf of Aihua Guo <[email-masked]<mailto:[email-masked]>>
Sent: 13 October 2021 20:17

Hi All,

<tp>

HTH

Tom Petch

Thanks,
Aihua

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fnetmod&amp;data=04%7C01%7Ctom.2.hill%40bt.com%7Ceceaf59456654bcbc2cb08d993ba4469%7Ca7f356889c004d5eba4129f146377ab0%7C0%7C0%7C637703250499568112%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=hdfDrlNtUJpN%2FddyjlDwn5tjHDosdORIC0qa%2BmCA2fc%3D&amp;reserved=0

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

---

From: Randy Presuhn <[email-masked]>
Date: Fri, 22 Oct 2021 10:34:58 -0700

Hi -

On 2021-10-22 4:14 AM, tom petch wrote:
...
> Yes, I am well familiar with telecoms racks and with cabling racks.  With cabling racks, then I think that there is too little logic to qualify for this model and I wonder if the same is true for s…

Some products I worked on (both data and voice processing) had
considerable intelligence and configuration in the subshelves.
But that was long ago, and we were using proprietary methods or
CMIP to manage them.

Randy