Subject: Re: [netmod] New Version Notification for draft-richardson-anima-rfc8366bis-04.txt

From: Michael Richardson <[email-masked]>
Date: Wed, 01 Dec 2021 20:05:06 -0500

Name:		draft-richardson-anima-rfc8366bis

Diff: https://www.ietf.org/rfcdiff?url1=draft-richardson-anima-rfc8366bis-00&url2=draft-richardson-anima-rfc8366bis-04

I uploaded -01, found some yang errors... I did -02/-03 before I figured out
how to run the right pyang command myself to determine the source of the
error.

This version has a new iana-voucher-assertion-type which is intended to be
handed to IANA to maintain.
I don't think that our IANA Considerations are correct as yet.
I think that we need a FAQ somewhere.

In the meantime, I would really like some YANG Doctor help here.

Toerless: I think that this is the major change.

Qiufang Ma did the bulk of the YANG work here, and with the blessing of the
WG chairs, I'd like to add her as a co-author.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: "Fries, Steffen" <[email-masked]>
Date: Fri, 3 Dec 2021 13:37:45 +0000

Hi Michael,

Thank you for the update, I included the updated voucher also in BRSKI-PRM (working version on github), which should address issue https://github.com/anima-wg/anima-brski-prm/issues/4. Nevertheless, BRSKI-PRM currently does not contain a YANG module for the voucher itself, only for the voucher-request. To my understanding we do not need an augmentation for the voucher, as agent-proximity is already included in draft RFC 8366bis.

Did I miss something?

Best regards
Steffen

> -----Original Message-----
> From: Anima <[email-masked]> On Behalf Of Michael Richardson
> Sent: Donnerstag, 2. Dezember 2021 02:05
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Anima] New Version Notification for draft-richardson-anima-
> rfc8366bis-04.txt
> 
> 
> Diff:
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf
> .org%2Frfcdiff%3Furl1%3Ddraft-richardson-anima-rfc8366bis-
> 00%26url2%3Ddraft-richardson-anima-rfc8366bis-
> 04&amp;data=04%7C01%7Csteffen.fries%40siemens.com%7Ce31fb7323d1949
> a349e208d9b52fd8f7%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C
> 637740039811249891%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMD
> AiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=y9
> fmZnQrHPXMIwGCM8uZaV4x5Yg2kdy2LoUjUqxIelY%3D&amp;reserved=0
> 
> I uploaded -01, found some yang errors... I did -02/-03 before I figured out how
> to run the right pyang command myself to determine the source of the error.
> 
> Qiufang Ma did the bulk of the YANG work here, and with the blessing of the WG
> chairs, I'd like to add her as a co-author.

---

From: Michael Richardson <[email-masked]>
Date: Fri, 03 Dec 2021 19:01:49 -0500

Fries, Steffen <[email-masked]> wrote:
    > Thank you for the update, I included the updated voucher also in
    > BRSKI-PRM (working version on github), which should address issue
    > https://github.com/anima-wg/anima-brski-prm/issues/4. Nevertheless,
    > BRSKI-PRM currently does not contain a YANG module for the voucher
    > itself, only for the voucher-request. To my understanding we do not
    > need an augmentation for the voucher, as agent-proximity is already
    > included in draft RFC 8366bis.

I think that is correct.