Subject: [netmod] Schema Mount

From: Michal Vaško <[email-masked]>
Date: Mon, 24 Jan 2022 14:12:09 +0100

Hello,
I wanted to implement this RFC [1] but I have great difficulty understanding how exactly it should work so I would like to ask for some clarification.

As for the ietf-yang-library data, they are mentioned several times but I could find no details as to how exactly they should look like. There is an example [2], which has only 'ietf-yang-library:modules-state' data tree that is deprecated. Am I to understand that is what is expected?

Another thing, there are 3 ways mentioned [3] as to when to specify the schema (YANG modules) for the mounted data and that only 2nd and 3rd are covered in the RFC. However, I was not able to find anything more about the 2nd option (implementation-time) and think that everything concerns only the 3rd option (run-time).

Lastly, I was also looking at another RFC [4] and its examples. There I could see 'ietf-yang-library:yang-library' data tree instead meaning every 'module-set' and corresponding 'schema' need to be referenced by some 'datastore'. The consequence would be that one must know the datastore of the data before they can be parsed, is that right? Moreover, for parsing one would also need the 'ietf-yang-schema-mount:schema-mounts' data (which are found in the operation data in the example) but where should the NETCONF/RESTCONF server (for instance) get them?

Thanks for any clarification.

Regards,
Michal

---

From: Michal Vaško <[email-masked]>
Date: Mon, 24 Jan 2022 14:49:10 +0100

Sorry, adding links. 

> Thanks for any clarification.

[1] https://datatracker.ietf.org/doc/html/rfc8528
[2] https://datatracker.ietf.org/doc/html/rfc8528#appendix-A.2
[3] https://datatracker.ietf.org/doc/html/rfc8528#page-5
[4] https://datatracker.ietf.org/doc/html/rfc8529#appendix-A.3

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 25 Jan 2022 13:33:29 +0000

Hi Michal,

This isn't directly answering your questions, but I wanted to point out that YANG versioning work is currently discussing YANG packages, and how they work with Schema mount.  There are weekly calls (which starts in just under half an hour), that are open to all:

https://ietf.webex.com/ietf/j.php?MTID=me2c6491ebcc37b8127c1244d244d2754

Regards,
Rob

-----Original Message-----
From: netmod <[email-masked]> On Behalf Of Michal Vaško
Sent: 24 January 2022 13:12
To: netmod <[email-masked]>
Subject: [netmod] Schema Mount

Hello,

Regards,
Michal