Subject: [netmod] Difference between current() and "."

From: Balázs Lengyel <[email-masked]>
Date: Mon, 11 Apr 2022 13:04:24 +0000

Hello Xpath experts,
What is the difference between the meaning of
Current()
And "." Single dot
In YANG-Xpath ?

must ". <= 10"

must "current() <= 10"

Are these the same?
Regards Balazs

---

From: Jürgen Schönwälder <[email-masked]>
Date: Mon, 11 Apr 2022 15:29:11 +0200

Google pointed me to

https://developer.mozilla.org/en-US/docs/Web/XPath/Functions/current

and the Notes section on that page explains the difference.

/js

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Jürgen Schönwälder              Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>