Subject: [netmod] new extensions in draft-ietf-netmod-node-tags-06

From: Andy Bierman <[email-masked]>
Date: Mon, 11 Apr 2022 08:18:28 -0700

Hi,

I do not find this draft useful.
I am curious about the extensions introduced.

It looks like all containers and lists are tagged as 'object'.
All config=true terminals are tagged as 'property'
and perhaps all config=false terminals are tagged as 'metric'
(although the example shows a config=true leaf 'bar' tagged as a metric)
This seems like a lot of clutter without any real value.

RFC 8819 is about functional classification (e.g. 'qos' or 'oam').
It seems this draft should just extend the granularity of the tags
to schema nodes.

>From sec 8.1:

   module example-module-A {
     //...
     import ietf-data-node-tags { prefix ntags; }

     container top {
       ntags:opm-tag "ietf:object";
       list X {
         leaf foo {
            ntags:opm-tag "ietf:property";
         }
         leaf bar {
           ntags:opm-tag "ietf:metric";
         }
       }
     }
     // ...
   }

Andy

---

From: Qin Wu <[email-masked]>
Date: Tue, 12 Apr 2022 15:57:22 +0000

It looks like all containers and lists are tagged as 'object'.
[Qin Wu] No, the container , leaf-list, list can also be tagged as metric tag,  the most important tag value is metric tag value,
With metric tag value , we can easily capture all KPI data or characteristics data, in addition, we introduce metric-type tag and multi-source tag,
They are secondly level, which help you further classify performance metric related data nodes or data node instances.
Object tag value and property tag in many cases are not needed and doesn’t need to appear.
See more clarification in my response to Balazs’s comments. Thanks!
All config=true terminals are tagged as 'property'
[Qin Wu] No, take interface module as an example,
        +--rw interface* [name]
           +--rw name                        string
           +--rw description?                string
           +--rw type                        identityref
           +--rw enabled?                    boolean
          +--ro last-change?                yang:date-and-time

configure false leaf such as last-change can also be seen as ‘property’
and perhaps all config=false terminals are tagged as 'metric'
[Qin Wu] not always , see ietf-te-kpi-telemetry as an example, performance-type is not configure false node.
(although the example shows a config=true leaf 'bar' tagged as a metric)
This seems like a lot of clutter without any real value.

RFC 8819 is about functional classification (e.g. 'qos' or 'oam').
It seems this draft should just extend the granularity of the tags
to schema nodes.
[Qin Wu] based on some discussion on the list, it was also suggested to extend
the granularity of the tags to data node instance levels.
From sec 8.1:

     //...

     container top {

       list X {

         leaf foo {

         }

         leaf bar {

         }

       }

     }

     // ...

   }

[Qin Wu] We also have second level tags such as metric-type tag and multi-source tag to help further classify the performance metric related data.