Subject: Re: [netmod] [Errata Held for Document Update] RFC8407 (6899)

From: "John R. Levine" <[email-masked]>
Date: 1 Apr 2022 14:22:30 -0400

> Hi John, all,
>
> If we want the fix to the appendix to be immediately visible to the readers (in the rendered version), wouldn’t be more appropriate to mark this erratum as “verified” rather than “held for doc update”?

I suppose.  In 2018 when this RFC was published, the Trust still said 
"Simplified" so what's in the text matches what the author intended at the 
time.  Not a big deal either way for me, since as I noted, the actual 
license it points to has always been correct.  Only the name was wrong.

R's,
John

> De : Andy Bierman <[email-masked]>
> Envoyé : jeudi 31 mars 2022 19:11
> À : John R. Levine <[email-masked]>
> Cc : tom petch <[email-masked]>; BOUCADAIR Mohamed INNOV/NET <[email-masked]>; Kent Watsen <[email-masked]>; [email-masked]; [email-masked]
> Objet : Re: [netmod] [Errata Held for Document Update] RFC8407 (6899)
>
>
>
> On Thu, Mar 31, 2022 at 9:56 AM John R. Levine <[email-masked]<mailto:[email-masked]>> wrote:
>> There are not thousands of RFCs that include a "Module Review Checklist" :-), which is the purpose of this erratum. Thanks.
>>
>> <tp>
>>
>> I agree.  There may be lots of RFC in error because RFC8407 gets it wrong but if the update to the lots of RFC was wanted then it should have been investigated last Autumn when the announcement of the change to the TLP was made, an announcement that passed me by despite being on all the right mailing lists.
>
> The fix to the TLP was my idea in the first place and it's not that big of
> a deal.  If you follow the link and read that part of the TLP, the actual
> license has never changed.  We just give it the correct name now.
>
> I agree the checklist in Appendix A should be updated.
>
> The corrected RFC (any RFC where Errata Exists) should be available online.
> Not erasing the published RFC, but with a link to rfcNNNN-current (where all accepted Errata is applied).
>
>
> Regards,
> John Levine, [email-masked]<mailto:[email-masked]>, Primary Perpetrator of "The Internet for Dummies",
> Please consider the environment before reading this e-mail. https://jl.ly
>
>
> Andy
>
> _______________________________________________
> netmod mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netmod
>
> _________________________________________________________________________________________________________________________
>
> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
> Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>
> This message and its attachments may contain confidential or privileged information that may be protected by law;
> they should not be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
> Thank you.
>
>

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Andy Bierman <[email-masked]>
Date: Fri, 1 Apr 2022 12:18:50 -0700

On Fri, Apr 1, 2022 at 11:22 AM John R. Levine <[email-masked]> wrote:

> > Hi John, all,
> >
> > If we want the fix to the appendix to be immediately visible to the
> readers (in the rendered version), wouldn’t be more appropriate to mark
> this erratum as “verified” rather than “held for doc update”?
>
We intended to include the text provided.
If people follow the guidelines in Appendix A now,
and use the word "Simplified", it is going to need to be fixed later.
Better to avoid that if possible.

R's,

Andy

> > Cc : tom petch <[email-masked]>; BOUCADAIR Mohamed INNOV/NET <
> [email-masked]>; Kent Watsen <[email-masked]>;
> [email-masked]; [email-masked]
> >> There are not thousands of RFCs that include a "Module Review
> Checklist" :-), which is the purpose of this erratum. Thanks.
> >>
> >> <tp>
> >>
> >> I agree.  There may be lots of RFC in error because RFC8407 gets it
> wrong but if the update to the lots of RFC was wanted then it should have
> been investigated last Autumn when the announcement of the change to the
> TLP was made, an announcement that passed me by despite being on all the
> right mailing lists.
> >
> > John Levine, [email-masked]<mailto:[email-masked]>, Primary
> Perpetrator of "The Internet for Dummies",
> > Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> > pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> > a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> > This message and its attachments may contain confidential or privileged
> information that may be protected by law;