Subject: [Netslices] Data-plane work in DMM WG with slicing concept

From: Satoru Matsushima <[email-masked]>
Date: Tue, 7 Feb 2017 15:01:46 +0900

All,

IETF DMM (Distributed Mobility Management) working group has been chartered 
to make separation of data-plane from mobile control-plane, which defines 
data-plane obstruction models with network slicing concept.

Through the discussion on the Netslices list, I’ve noticed what the draft calls
“Domain” would almost close to “Network Slicing”. 

Data-plane model of FPC provides information and data model by YANG for mobile network
which IMO would be helpful to figure slicing model out. 

FPC-topology tree is one for that. FPC-policy would be requirements to the slice.

https://datatracker.ietf.org/doc/draft-ietf-dmm-fpc-cpdp/

Protocol for Forwarding Policy Configuration (FPC) in DMM
             draft-ietf-dmm-fpc-cpdp-05.txt

Abstract

   This document describes the solution of data-plane separation from
   control-plane which enables a flexible mobility management system
   using agent and client functions.  To configure data-plane nodes and
   functions, the data-plane is abstracted by an agent interface to the
   client.  The data-plane abstraction model is extensible in order to
   support many different type of mobility management systems and data-
   plane functions.

Best regards,
--satoru

---

From: Satoru Matsushima <[email-masked]>
Date: Tue, 7 Feb 2017 16:04:36 +0900

oops,

s/obstruction/abstraction/;

--satoru

> 2017/02/07 15:01、Satoru Matsushima <[email-masked]> のメール：
> 
> All,
>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 8 Feb 2017 03:17:55 +0000

Hi Satoru, 

Thanks for introducing the network slicing related work in DMM. 

While I don't have much expertise in DMM, my rough understanding is the separation of data plane and control plane in mobile network may have some requirement on network slicing, and for E2E network slicing it may be needed to jointly consider the slicing in mobile network and transport network. It would be great if you could help to describe the slicing requirements from DMM perspective. 

Best regards,
Jie

> -----Original Message-----
> From: Netslices [mailto:[email-masked]] On Behalf Of Satoru
> Matsushima
> Sent: Tuesday, February 07, 2017 2:02 PM
> To: [email-masked]
> Subject: [Netslices] Data-plane work in DMM WG with slicing concept
> 
> All,
> 
> IETF DMM (Distributed Mobility Management) working group has been
> chartered to make separation of data-plane from mobile control-plane, which
> defines data-plane obstruction models with network slicing concept.
> 
> Data-plane model of FPC provides information and data model by YANG for
> mobile network which IMO would be helpful to figure slicing model out.
> 
> _______________________________________________
> Netslices mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netslices

---

From: Satoru Matsushima <[email-masked]>
Date: Thu, 9 Feb 2017 19:33:51 +0900

Hi Jie,

> While I don't have much expertise in DMM, my rough understanding is the separation of data plane and control plane in mobile network may have some requirement on network slicing, and for E2E networ…

Thanks, but sorry just terse introduction for that DMM work.

Yes you’re right.

The DMM work named Forwarding Policy Configuration (FPC) is a neutral interface from specific mobility management systems, like 3GPP GTP or IETF (P)MIP for example, that to manage data-plane configurations. One of original motivations of DMM is to provide optimal data-path for mobile applications. Each application may see different path as its optimal path so that FPC need to be able to provide that.

Let me explain a little bit about it. FPC is designed to support that an infrastructure operator provides its network as data-plane for multiple mobile operators as tenants who are able to virtually construct multiple Domain (slices) to meet requirements of their applications. The entities of mobility management in a Domain are abstracted as FPC-topology model on the FPC agent which configure data-plane nodes in the infrastructure. That configurations are based on the constructed model and the session states of which mobile control-plane or applications generated with its policies.

For sure that, the virtually constructed model of Domains should be bound to appropriate infrastructure resources, like links, bandwidth and queueing schedule priorities, etc,. Let me think for that with YANG model, I suppose that resources would also be abstracted as a slice topology using i2rs based schemas, ACTN for example, and be instantiated statically or dynamically on demand basis. Then the constructed FPC model can be able to bind that slice instance as its data-plane. In that FPC model if some specific mobile data-plane entities which require NFV infrastructure to be instantiated on it, the data-plane model should also be able to include NFVI as its part of resources as well.

Hope it helps you to understand DMM FPC work, and I’m happy if we can discuss on this perspective.

Best regards,
--satoru