Subject: [Netslices] Discussion about network slicing in IETF

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 6 Feb 2017 13:53:04 +0000

Dear all, 

According to some early investigations, the topic network slicing would cross several WGs, even multiple Areas in IETF, and there are some existing and ongoing works in IETF related to network slicing, such as the various VPN technologies, the ongoing ACTN work in TEAS WG, the work on deterministic network in DETNET WG, the work on autonomic management in ANIMA WG, etc. Through the discussion on this mailing list, we'd like to understand if there are gaps in meeting the network slicing requirements, and if needed, to combine the existing and ongoing works, together with potential protocol enhancements or new protocols to achieve network slicing of the mobile transport network. 

In order to have better understanding of the gaps in transport network slicing, we may start with a few questions: 

1. To what extent can the requirements of network slicing in data plane be addressed by existing IETF technologies such as VPNs (and VPN like technologies)? We note in asking this that in some cases VPNs may need to be enhanced by some deterministic technology such as that being investigated in the DETNET WG.

And to what extent do the control planes of existing technologies satisfy the needs of network slicing? Note that in some 5G use cases the customized or dedicated control plane may be needed for some of the network slices, while in some other cases the control plane may be shared between slices.

2. Does ACTN completely satisfy the abstraction of Network Slices (NS) to the operators or the customers who instantiate, monitor and manage an NS through its lifecycle, including dynamically changing a slice to account for the varying needs during its lifecycle from creation to disposal, is there any additional mechanism also required?

3. How do we characterize the determinism requirement of NS? To what extent is the determinism hard and to what extent is it soft, i.e. what are the absolute requirements, and what requirements can be met by some form of probability mask? Does the design being proposed by the DETNET design team (which is still in stealth mode) address all of this?

4. To what extent does the network need to open the control and management of the network slices to the third parties? And to what extent can this be addressed by existing technologies, such as PCE, Segment Routing, SFC and Netconf?

Your insightful thoughts are much appreciated.

Best regards,
Jie

---

From: Leeyoung <[email-masked]>
Date: Mon, 6 Feb 2017 23:11:55 +0000

Hi Jim,

I can speak for ACTN. Please see inline for my comment.

Thanks.
Young

-----Original Message-----
From: Netslices [mailto:[email-masked]] On Behalf Of Dongjie (Jimmy)
Sent: Monday, February 06, 2017 7:53 AM
To: [email-masked]
Subject: [Netslices] Discussion about network slicing in IETF

Dear all, 

YOUNG>> I think so. ACTN allows VN slice to be created/monitored/modified/deleted dynamically supporting CRUD operations. I just want to make a point that the abstraction of network slices in ACTN is only for network resources but not for compute or storage. CSO (Cross-Stratum Optimzation) work address how to combine compute and storage slices with ACTN's network slices. My understanding for the scope of network slicing is primarily network resource slicing, correct? 

Best regards,
Jie

_______________________________________________
Netslices mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netslices

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 6 Feb 2017 18:48:29 -0500

Jie: 

The opening of the control plane to 3rd party reporting on deterministic
information with the NETCONF/NETMOD improved notification, pub/sub,
ephemeral state (from I2RS), and revised data stores.   The pub/sub and
improved NETCONF notification has a number of knobs that can allow
increasing or decreasing the level at which events are monitored.  One of
the questions about network slicing is whether network slicing needs to
define additional BGP, PCE, RIB, and filter-base RIBS yang data models or
augmentation to existing data models.   

Sue Hares 

-----Original Message-----
From: Netslices [mailto:[email-masked]] On Behalf Of Dongjie
(Jimmy)
Sent: Monday, February 6, 2017 8:53 AM
To: [email-masked]
Subject: [Netslices] Discussion about network slicing in IETF

Dear all, 

According to some early investigations, the topic network slicing would
cross several WGs, even multiple Areas in IETF, and there are some existing
and ongoing works in IETF related to network slicing, such as the various
VPN technologies, the ongoing ACTN work in TEAS WG, the work on
deterministic network in DETNET WG, the work on autonomic management in
ANIMA WG, etc. Through the discussion on this mailing list, we'd like to
understand if there are gaps in meeting the network slicing requirements,
and if needed, to combine the existing and ongoing works, together with
potential protocol enhancements or new protocols to achieve network slicing
of the mobile transport network. 

In order to have better understanding of the gaps in transport network
slicing, we may start with a few questions: 

1. To what extent can the requirements of network slicing in data plane be
addressed by existing IETF technologies such as VPNs (and VPN like
technologies)? We note in asking this that in some cases VPNs may need to be
enhanced by some deterministic technology such as that being investigated in
the DETNET WG.

And to what extent do the control planes of existing technologies satisfy
the needs of network slicing? Note that in some 5G use cases the customized
or dedicated control plane may be needed for some of the network slices,
while in some other cases the control plane may be shared between slices.

2. Does ACTN completely satisfy the abstraction of Network Slices (NS) to
the operators or the customers who instantiate, monitor and manage an NS
through its lifecycle, including dynamically changing a slice to account for
the varying needs during its lifecycle from creation to disposal, is there
any additional mechanism also required?

3. How do we characterize the determinism requirement of NS? To what extent
is the determinism hard and to what extent is it soft, i.e. what are the
absolute requirements, and what requirements can be met by some form of
probability mask? Does the design being proposed by the DETNET design team
(which is still in stealth mode) address all of this?

4. To what extent does the network need to open the control and management
of the network slices to the third parties? And to what extent can this be
addressed by existing technologies, such as PCE, Segment Routing, SFC and
Netconf?

Best regards,
Jie

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 7 Feb 2017 03:10:40 +0000

Hi Sue,

Thanks a lot for the information about the latest Netconf/Netmod features. They may become valuable tools for the management of network slices. 

As for your question about additional data models, so far it is not quite clear to me what new models or augmentations are needed, we need to first understand the required interactions between the third parties and their network slices.

It would be great if the operators or the third party users of 5G could provide some input on the use cases and requirements in this respect.

Best regards,
Jie

> From: Susan Hares [mailto:[email-masked]]
> Sent: Tuesday, February 07, 2017 7:48 AM
> To: Dongjie (Jimmy) <[email-masked]>; [email-masked]
> Subject: RE: [Netslices] Discussion about network slicing in IETF
> 
> Jie:
> 
> improved NETCONF notification has a number of knobs that can allow increasing
> or decreasing the level at which events are monitored.  One of the questions
> about network slicing is whether network slicing needs to define additional BGP,
> PCE, RIB, and filter-base RIBS yang data models or
> According to some early investigations, the topic network slicing would cross
> several WGs, even multiple Areas in IETF, and there are some existing and
> ongoing works in IETF related to network slicing, such as the various VPN
> technologies, the ongoing ACTN work in TEAS WG, the work on deterministic
> network in DETNET WG, the work on autonomic management in ANIMA WG, etc.
> Through the discussion on this mailing list, we'd like to understand if there are
> gaps in meeting the network slicing requirements, and if needed, to combine the
> existing and ongoing works, together with potential protocol enhancements or
> new protocols to achieve network slicing of the mobile transport network.
> 
> addressed by existing IETF technologies such as VPNs (and VPN like technologies)?
> We note in asking this that in some cases VPNs may need to be enhanced by
> some deterministic technology such as that being investigated in the DETNET
> WG.
> 
> And to what extent do the control planes of existing technologies satisfy the
> needs of network slicing? Note that in some 5G use cases the customized or
> dedicated control plane may be needed for some of the network slices, while in
> some other cases the control plane may be shared between slices.
> 
> 2. Does ACTN completely satisfy the abstraction of Network Slices (NS) to the
> operators or the customers who instantiate, monitor and manage an NS through
> its lifecycle, including dynamically changing a slice to account for the varying
> needs during its lifecycle from creation to disposal, is there any additional
> mechanism also required?
> 
> is the determinism hard and to what extent is it soft, i.e. what are the absolute
> requirements, and what requirements can be met by some form of probability
> mask? Does the design being proposed by the DETNET design team (which is still
> in stealth mode) address all of this?
>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 8 Feb 2017 02:41:45 +0000

Hi Young, 

Thanks a lot for your feedbacks about ACTN. 

As E2E network slicing is required in 5G, it would cover the slicing of end to end resources including the network, compute and storage. While IMO the scope of network slicing in IETF would be mainly related to the network part, the coordination/interaction between network and other parts (network or service functions) of the E2E slicing may also need to be considered.

Best regards,
Jie

> From: Leeyoung
> Sent: Tuesday, February 07, 2017 7:12 AM
> Subject: RE: Discussion about network slicing in IETF
> 
> Hi Jim,
> 
> YOUNG>> I think so. ACTN allows VN slice to be
> created/monitored/modified/deleted dynamically supporting CRUD operations. I
> just want to make a point that the abstraction of network slices in ACTN is only
> for network resources but not for compute or storage. CSO (Cross-Stratum
> Optimzation) work address how to combine compute and storage slices with
> ACTN's network slices. My understanding for the scope of network slicing is
> primarily network resource slicing, correct?
>