Subject: Re: [Netslices] Discussion about network slicing in IETF

From: "Kiran.Makhijani" <[email-masked]>
Date: Tue, 7 Feb 2017 01:09:22 +0000

Hello Young, 
To me, it has a broader scope; to look at overall resource efficiency, agility and independent 3rd party slice control over different network segments and network functions. With limited knowledge on ACTN, my assumption is that it is a centralized controller solution with main goal to compute constraints based paths over what's abstracted from various controllers. NetSlices shouldn’t bind to central, hierarchical or distributed approach (at least at the beginning).  In that sense, let’s look at slices from all aspects data, control, management and services in a generic fashion.

I agree with Pedro’s email suggestion that a couple of collaborative live documents will be good starting point.

Regards
Kiran 

On 2/6/17, 3:11 PM, "Netslices on behalf of Leeyoung" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Jim,
    
    I can speak for ACTN. Please see inline for my comment.
    
    Thanks.
    Young
    
    -----Original Message-----
    From: Netslices [mailto:[email-masked]] On Behalf Of Dongjie (Jimmy)
    Sent: Monday, February 06, 2017 7:53 AM
    To: [email-masked]
    Subject: [Netslices] Discussion about network slicing in IETF
    
    Dear all, 
    
    According to some early investigations, the topic network slicing would cross several WGs, even multiple Areas in IETF, and there are some existing and ongoing works in IETF related to network slicing, such as the various VPN technologies, the ongoing ACTN work in TEAS WG, the work on deterministic network in DETNET WG, the work on autonomic management in ANIMA WG, etc. Through the discussion on this mailing list, we'd like to understand if there are gaps in meeting the network slicing requirements, and if needed, to combine the existing and ongoing works, together with potential protocol enhancements or new protocols to achieve network slicing of the mobile transport network. 
    
    In order to have better understanding of the gaps in transport network slicing, we may start with a few questions: 
    
    1. To what extent can the requirements of network slicing in data plane be addressed by existing IETF technologies such as VPNs (and VPN like technologies)? We note in asking this that in some cases VPNs may need to be enhanced by some deterministic technology such as that being investigated in the DETNET WG.
    
    And to what extent do the control planes of existing technologies satisfy the needs of network slicing? Note that in some 5G use cases the customized or dedicated control plane may be needed for some of the network slices, while in some other cases the control plane may be shared between slices.
    
    2. Does ACTN completely satisfy the abstraction of Network Slices (NS) to the operators or the customers who instantiate, monitor and manage an NS through its lifecycle, including dynamically changing a slice to account for the varying needs during its lifecycle from creation to disposal, is there any additional mechanism also required?
    
    YOUNG>> I think so. ACTN allows VN slice to be created/monitored/modified/deleted dynamically supporting CRUD operations. I just want to make a point that the abstraction of network slices in ACTN is only for network resources but not for compute or storage. CSO (Cross-Stratum Optimzation) work address how to combine compute and storage slices with ACTN's network slices. My understanding for the scope of network slicing is primarily network resource slicing, correct? 
    
    3. How do we characterize the determinism requirement of NS? To what extent is the determinism hard and to what extent is it soft, i.e. what are the absolute requirements, and what requirements can be met by some form of probability mask? Does the design being proposed by the DETNET design team (which is still in stealth mode) address all of this?
    
    4. To what extent does the network need to open the control and management of the network slices to the third parties? And to what extent can this be addressed by existing technologies, such as PCE, Segment Routing, SFC and Netconf?
    
    Your insightful thoughts are much appreciated.
    
    Best regards,
    Jie

    _______________________________________________
    Netslices mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/netslices
    
    _______________________________________________
    Netslices mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/netslices

---

From: Leeyoung <[email-masked]>
Date: Tue, 7 Feb 2017 17:15:54 +0000

Hi Kiran,

Here's the latest ACTN framework and Requirements for your reference if you want to know more about ACTN. ACTN is not just a controller solution. It allows the third party customers/clients to instantiate Virtual Networks to the operator networks to be able to own and control VN slicing as they will. But as you said, there may be other network resources that you have in mind in a larger context beyond what ACTN is covering. I would be interested in hearing what would be these "other" resouces you would like to include in the  new work (NetSlices). 

https://tools.ietf.org/html/draft-ietf-teas-actn-framework-03 
https://datatracker.ietf.org/doc/draft-ietf-teas-actn-requirements/ 

Thanks.
Young

-----Original Message-----
From: Kiran.Makhijani 
Sent: Monday, February 06, 2017 7:09 PM
To: Leeyoung <[email-masked]>; Dongjie (Jimmy) <[email-masked]>; [email-masked]
Subject: Re: [Netslices] Discussion about network slicing in IETF

Hello Young, 

Regards
Kiran 

    Hi Jim,

    Thanks.
    Young
    
    -----Original Message-----
    From: Netslices [mailto:[email-masked]] On Behalf Of Dongjie (Jimmy)
    Sent: Monday, February 06, 2017 7:53 AM
    To: [email-masked]
    Subject: [Netslices] Discussion about network slicing in IETF
    
    Dear all, 

    

    

    
    
    Best regards,
    Jie