Subject: [Netslices] New draft on Network Slicing use cases

From: "Kiran.Makhijani" <[email-masked]>
Date: Fri, 17 Mar 2017 06:53:36 +0000

Hello,
We have submitted a Network slicing use case draft.

This draft briefly describes use cases that benefit from Network Slicing. We have divided use cases into broader categories, and mention a few related requirements.

It will be presented during the side meeting in Chicago. We welcome both comments and contributions. This is first version and very much a work in progress.

https://tools.ietf.org/html/draft-qin-netslices-use-cases-00

Regards
Kiran  (on behalf of all the authors)

---

From: li zhenqiang <[email-masked]>
Date: Fri, 17 Mar 2017 07:34:56 +0000

Hi Kiran and all,

I read your draft. The services or applications that would benifit from 5G network slicing are described. That's right that ITU classifies the 5G mobile network services into three categories, i.e. eMBB, uRLLC and mMTC. However does this mean that we should provide three kinds of NSs accordingly?

Best Regards,

________________________________
[email-masked]

From: Kiran.Makhijani<mailto:[email-masked]>
Date: 2017-03-17 14:53
To: [email-masked]<mailto:[email-masked]>
CC: Dongjie \(Jimmy\)<mailto:[email-masked]>; pengshuping<mailto:[email-masked]>; qinjun \(G\)<mailto:[email-masked]>; qiangli \(D\)<mailto:[email-masked]>
Subject: [Netslices] New draft on Network Slicing use cases
Hello,
We have submitted a Network slicing use case draft.

Regards

---

From: Anton Ivanov <[email-masked]>
Date: Fri, 17 Mar 2017 11:57:16 +0000

This is again - repeating from ITU and 3GPP into IETF. What goes on 
there can happily stay there.

The MOST BASIC Slice case which predates 3GPP and ITU by at least 5 
years (if not a decade) is vCPE. Not present.

It also is a DEPLOYED use case while the rest are all at varying pipe 
dream leve.

So I suggest rewriting the document starting with deployed use cases in 
active use and putting pipe dreams of various diameter on the backburner.

A.

On 17/03/17 06:53, Kiran.Makhijani wrote:
> __
> This draft briefly describes use cases that benefit from Network 
> Slicing. We have divided use cases into broader categories, and 
> mention a few related requirements.
>
> It will be presented during the side meeting in Chicago. We welcome 
> both comments and contributions. This is first version and very much a 
> work in progress.
>
> _______________________________________________
> Netslices mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netslices

---

From: "Kiran.Makhijani" <[email-masked]>
Date: Fri, 17 Mar 2017 20:38:01 +0000

Hi Anton,
Agreed.
My apologies, I am not well aware of vCPE use case. It will be useful to discuss it as well (can you please share reference/pointer to this?). Right now, name suggests it is a n/w function or a virtualized CPE– I am sure there’s more to it.
In fact, VoLTE problem that David described can also be included. That is why I said there are 2 considerations, one for emerging/newer and second for existing/active ones. Section 3.4 is meant to serve existing use cases.

Architecture/Deployment of NS should provide support for both.

-Kiran

From: Netslices <[email-masked]> on behalf of Anton Ivanov <[email-masked]>
Date: Friday, March 17, 2017 at 4:57 AM
To: "[email-masked]" <[email-masked]>
Subject: Re: [Netslices] New draft on Network Slicing use cases

This is again - repeating from ITU and 3GPP into IETF. What goes on there can happily stay there.

The MOST BASIC Slice case which predates 3GPP and ITU by at least 5 years (if not a decade) is vCPE. Not present.

It also is a DEPLOYED use case while the rest are all at varying pipe dream leve.

So I suggest rewriting the document starting with deployed use cases in active use and putting pipe dreams of various diameter on the backburner.

A.

Regards

Netslices mailing list

[email-masked]<mailto:[email-masked]>

---

From: "Kiran.Makhijani" <[email-masked]>
Date: Fri, 17 Mar 2017 22:57:28 +0000

Hello Zhenqiang,
I think your question is similar to Anton’s comment. We wanted to start with established/known scenarios specifically mentioned for Slicing. It certainly does not mean that we limit to just these 3 kinds. A fully flexible model should be able to either deliver/allocate requested resources for a slice or inform it is not possible.
However, having some form of categorization helps define problem space better. This is one of the discussions we could have at side meeting.

Regards
Kiran

From: li zhenqiang <[email-masked]>
Date: Friday, March 17, 2017 at 12:34 AM
To: "Kiran.Makhijani" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "Dongjie (Jimmy)" <[email-masked]>, pengshuping <[email-masked]>, "qinjun (G)" <[email-masked]>, "qiangli (D)" <[email-masked]>
Subject: Re: [Netslices] New draft on Network Slicing use cases

Hi Kiran and all,

Best Regards,

Regards

---

From: Anton Ivanov <[email-masked]>
Date: Sat, 18 Mar 2017 15:23:36 +0000

I will see if I can write it up properly before Chicago.

Cannot promise - my schedule is quite full.

A

On 17/03/17 20:38, Kiran.Makhijani wrote:
>
> Hi Anton,
>
> Agreed.
>
> My apologies, I am not well aware of vCPE use case. It will be useful 
> to discuss it as well (can you please share reference/pointer to 
> this?). Right now, name suggests it is a n/w function or a virtualized 
> CPE– I am sure there’s more to it.
>
> In fact, VoLTE problem that David described can also be included. That 
> is why I said there are 2 considerations, one for emerging/newer and 
> second for existing/active ones. Section 3.4 is meant to serve 
> existing use cases.
>
> *From: *Netslices <[email-masked]> on behalf of Anton 
> Ivanov <[email-masked]>
> *Date: *Friday, March 17, 2017 at 4:57 AM
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *Re: [Netslices] New draft on Network Slicing use cases
>
> So I suggest rewriting the document starting with deployed use cases 
> in active use and putting pipe dreams of various diameter on the 
> backburner.
>
> A.
>
>
>     It will be presented during the side meeting in Chicago. We
>     welcome both comments and contributions. This is first version and
>     very much a work in progress.
>
>     [email-masked] <mailto:[email-masked]>
>

---

From: <[email-masked]>
Date: Wed, 22 Mar 2017 09:22:08 +0000

Dear Anton, all,

Putting aside whether vCPE can be called a (network) slice case or not, some documents that can be cited are available here: https://tools.ietf.org/html/draft-lee-vhs-ps-02 and https://tools.ietf.org/html/draft-lee-vhs-usecases-02.

Cheers,
Med

De : Netslices [mailto:[email-masked]] De la part de Anton Ivanov
Envoyé : samedi 18 mars 2017 16:24
À : Kiran.Makhijani; [email-masked]
Objet : Re: [Netslices] New draft on Network Slicing use cases

-Kiran

From: Netslices <[email-masked]><mailto:[email-masked]> on behalf of Anton Ivanov <[email-masked]><mailto:[email-masked]>
Date: Friday, March 17, 2017 at 4:57 AM
To: "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Subject: Re: [Netslices] New draft on Network Slicing use cases

A.

Regards

Netslices mailing list

---

From: Anton Ivanov <[email-masked]>
Date: Wed, 22 Mar 2017 09:46:57 +0000

On 22/03/17 09:22, [email-masked] wrote:
>
> Dear Anton, all,
>
> Putting aside whether vCPE can be called a (network) slice case or not,
>

vCPE itself - no. The whole vertical - Virtualized Home Network + 
Backhaul or VPN resource to transport it + the vCPE instance at the 
provider CO is an obvious slice. It is a better fit to the "abstract" 
definition of a slice than the 5G use case.

> some documents that can be cited are available here: 
> https://tools.ietf.org/html/draft-lee-vhs-ps-02and 
> https://tools.ietf.org/html/draft-lee-vhs-usecases-02.
>

Thanks, will look at them.

A.

> Cheers,
>
> Med
>
> *De :*Netslices [mailto:[email-masked]] *De la part de* 
> Anton Ivanov
> *Envoyé :* samedi 18 mars 2017 16:24
> *À :* Kiran.Makhijani; [email-masked]
> *Objet :* Re: [Netslices] New draft on Network Slicing use cases
>
>     My apologies, I am not well aware of vCPE use case. It will be
>     useful to discuss it as well (can you please share
>     reference/pointer to this?). Right now, name suggests it is a n/w
>     function or a virtualized CPE– I am sure there’s more to it.
>
>     In fact, VoLTE problem that David described can also be included.
>     That is why I said there are 2 considerations, one for
>     emerging/newer and second for existing/active ones. Section 3.4 is
>     meant to serve existing use cases.
>
>     *From: *Netslices <[email-masked]>
>     <mailto:[email-masked]> on behalf of Anton Ivanov
>     <[email-masked]>
>     <mailto:[email-masked]>
>     *To: *"[email-masked]" <mailto:[email-masked]>
>     <[email-masked]> <mailto:[email-masked]>
>     The MOST BASIC Slice case which predates 3GPP and ITU by at least
>     5 years (if not a decade) is vCPE. Not present.
>
>     So I suggest rewriting the document starting with deployed use
>     cases in active use and putting pipe dreams of various diameter on
>     the backburner.
>
>     A.
>
>
>         This draft briefly describes use cases that benefit from
>         Network Slicing. We have divided use cases into broader
>         categories, and mention a few related requirements.
>
>         welcome both comments and contributions. This is first version
>         and very much a work in progress.
>

---

From: <[email-masked]>
Date: Wed, 22 Mar 2017 10:15:32 +0000

Hi Anton,

Please see inline.

Cheers,
Med

De : Anton Ivanov [mailto:[email-masked]]
Envoyé : mercredi 22 mars 2017 10:47
À : BOUCADAIR Mohamed IMT/OLN; Kiran.Makhijani; [email-masked]
Cc : Lee, Yiu ([email-masked])
Objet : Re: [Netslices] New draft on Network Slicing use cases

On 22/03/17 09:22, [email-masked]<mailto:[email-masked]> wrote:
Dear Anton, all,

vCPE itself - no. The whole vertical - Virtualized Home Network + Backhaul or VPN resource to transport it + the vCPE instance at the provider CO is an obvious slice.
[Med] That makes more sense to me … even if the pieces you quoted seems to adopt a microscopic level (per-subscriber slice). I prefer a more aggregate vision that is not per-subscriber…but per class of services/application/customers sharing a common set of requirements. Obviously, the use of VPN or other means is deployment-specific and should be kept as such.

It is a better fit to the "abstract" definition of a slice than the 5G use case.

some documents that can be cited are available here: https://tools.ietf.org/html/draft-lee-vhs-ps-02 and https://tools.ietf.org/html/draft-lee-vhs-usecases-02.

A.

Cheers,
Med

De : Netslices [mailto:[email-masked]] De la part de Anton Ivanov
Envoyé : samedi 18 mars 2017 16:24
À : Kiran.Makhijani; [email-masked]<mailto:[email-masked]>
Objet : Re: [Netslices] New draft on Network Slicing use cases

-Kiran

A.

Regards

Netslices mailing list

---

From: Anton Ivanov <[email-masked]>
Date: Wed, 22 Mar 2017 10:21:24 +0000

On 22/03/17 10:15, [email-masked] wrote:
>
> Hi Anton,
>
> Please see inline.
>
> Cheers,
>
> Med
>
> *De :*Anton Ivanov [mailto:[email-masked]]
> *Envoyé :* mercredi 22 mars 2017 10:47
> *À :* BOUCADAIR Mohamed IMT/OLN; Kiran.Makhijani; [email-masked]
> *Cc :* Lee, Yiu ([email-masked])
> On 22/03/17 09:22, [email-masked] 
> <mailto:[email-masked]> wrote:
>
>     Dear Anton, all,
>
> provider CO is an obvious slice.
>
> [Med] That makes more sense to me … even if the pieces you quoted 
> seems to adopt a microscopic level (per-subscriber slice).
>

Per subscriber slice is still a slice.

A.

> I prefer a more aggregate vision that is not per-subscriber…but per 
> class of services/application/customers sharing a common set of 
> requirements. Obviously, the use of VPN or other means is 
> deployment-specific and should be kept as such.
>
> *À :* Kiran.Makhijani; [email-masked] <mailto:[email-masked]>