Subject: Re: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

From: Alex Galis <[email-masked]>
Date: Fri, 5 May 2017 11:34:01 +0100

Dear NetSlicing folks

Re: Preparation for a Network Slicing BoF at IETF 99 in Prague

Following our last successful workshop at IETF 98 (i.e. Monday 27th March 2017 - see enclosed short notes and minutes) a 20 strong group is progressing with development of 5 drafts which are both synchronised and crossed checked planed for release in early June 2017 in support for the planed Network Slicing BoF at IETF 99 in Prague:

Network Slicing Drafts:

Draft No1 -  Use cases & Requirements  (updates)

Draft No2 -  Gap-Analysis

Draft No3 -  Architecture/Framework + Definitions (updates)

Draft No4 -  Problem Statement (updates)

Draft No5 -  NS Charter (updates)

Please note that all the above drafts will utilise and are based on an extended NS definition - only physical /logical partition of connectivity resources in a network - connectivity resource slicing  - is initially considered out of scope of these documents as inappropriate and insufficient for further work on Network Slicing.

All versions of the above drafts are currently on the NetSlices Github repository https://github.com/netslices/IETF-NetSlices

Would you be so kind as to express your further interest in participating as contributors/reviewers to the above drafts by sending an interest message to my self ([email-masked] <mailto:[email-masked]>). I will include your email in this workgroup.

In addition please post your GITHUB account to Kiran Makhijani <[email-masked]> for full write / read access to the NetSlices Github.

We are preparing a Network Slicing BoF at IETF99 and your support and contributions would be both valued and appreciated.

Thank you in advance

Best Regards

Alex

> On 29 Mar 2017, at 00:51, Alex Galis <[email-masked]> wrote:
> 
> Dear NetSlicing folks,
> 
>  
> 
> Re: NS side meeting – IETF98 Monday 27th March 2017 18:15-21:15
> 
>  
> 
> It was a great pleasure to meet some of you at the NS side meeting of Monday 27th March 2017 in Chicago.
>  
> 
> My short notes as minutes of this meeting as follows:
> 
> 1.     Scope of the meeting: Scope of the NS meeting: Present and discuss use cases, architecture and identify technical problems to be address by future work at IETF
> 
> 2.     An audience of approx 125 with a very full agenda
> 
> I. Context & Revisited NS Problem Statement
> 
> #01: “Introductory Document and Revised Problem Statement walk through” – presenter: Alex Galis - UCL - Huawei
>  
> 
> II. Towards NS Use Cases
> 
> #02: “5G Network Slicing - 3GPP Use Case background” - presenter: Xavier DeFoy -InterDigital
> 
> #03: “Generalized Market/Service Verticals with Network Slicing Use cases”- presenter: K. Makhijani- Huawei
> 
> #04: “An ICN service delivery prototype using slices” - presenter: Ravi Ravindran - Huawei
>  
> 
> III. Towards Operators Ecosystem Viewpoints
> 
> #05: “Network Slicing architecture”- presenter: Liang Geng – China Mobile
> 
> #06: “Network Slicing: Technical Viewpoints and Functional Roles”- presenter: Pedro Martinez-Julia – NICT Japan
>  
> 
> III. Towards Manufactures Viewpoints
> 
> #07: “How to slice Network Slicing for the IETF” - presenter: H. Flinck - Nokia
> 
> #08: “ACTN Virtual Network operation (with Network Slicing Insights)” - presenter: G. Grammel - Juniper
> 
> #09: “Automatic Network Slicing Management for Transport Network”- presenter: Qiang Li - Huawei
> 
> #10: “Forwarding Path & Signaling Management”- presenter: S. Matsushima- SoftBank
>  
> 
> IV. Final Q&A & Conclusions: 30 mins
> 
> All slides from the NS meeting are at: https://github.com/netslices/IETF- <https://github.com/netslices/IETF->NetSlices/tree/master/IETF98_Sidemeeting023.
> 
> 
> 3.     The presenters have identified a significant number of problem areas to be addressed at IETF in particular:
> 
> 19 problem areas identified in #01
> 
> 7 problem areas identified in #02
> 
> 4 problem areas identified in #03
> 
> 4 problem areas identified in #04
> 
> 9 problem areas identified in #05
> 
> 8 problem areas identified in #06
> 
> 7 problem areas identified in #07
> 
> 7 problem areas identified in #09
> 
> 10 problem areas identified in #10
> 
>  
> 4.     Descriptive and/or prescriptive definitions for Network Slices were provided in #01, #05, #06, #07, #08
>  
> 
> 5.     Based on the audience response the following actions are recommended:
>  
> 
> • Action1: a WG forming BoF will be requested at the next IETF99 ( unanimous request)
>  
> • Action2: approx 40 member of the audience showed their interest to contribute in the next 3 months to
> 
> –      use cases,
> 
> –      problem statements,
> 
> –      requirements and architecture
> 
> –      Exposure Interface specification and data model
> 
> –      Efficient slice isolation with guarantees for isolation
>  
> • Action 3: Unanimous request to review and consolidate a descriptive and prescriptive definition of NS
> 
> • Action 4: A draft charter as problem statement for WG activities that would include:
> 
>  - the description of the standardisation methods / algorithms within the scope of IETF and the related documents ( NS definition, reference models, use cases, etc.)
> 
>  - a concrete work plan for 2 years
> 
> This charter be edited with contributions from the NS members of the mailing list and made available at https://github.com/netslices/IETF-NetSlices <https://github.com/netslices/IETF-NetSlices>
> 
> 
> Thank you for all presenters and participants to the meeting which generated significant discussion and interest.
>  
> Please add any further notes and/or further minutes for this NS side meeting
> 
> 
> Best Regards
> 
> Alex
> 
>  
> 
>  
> 
>  
> 
>  
> 
>  
> 
>  
> 
>  
> 
>  
> 
>  
> 
>  
> 
>  
> 
>  
> 
>  
> 
>

---

From: "Sprecher, Nurit (Nokia - IL/Kfar Sava)" <[email-masked]>
Date: Fri, 5 May 2017 12:46:39 +0000

Hello,
Thanks for the update.
I assume that NS stands for Network Slicing.
May I warmly recommend not to use it as such as NS is used by ETSI NFV for Network Service.
Of course there is a close relationship….that is exactly why we should prevent confusion.
Also, I am interested in reviewing these documents.
Best regards,
Nurit

From: Netslices [mailto:[email-masked]] On Behalf Of Alex Galis
Sent: Friday, May 05, 2017 1:34 PM
To: Network Slices <[email-masked]>
Cc: Alex Galis <[email-masked]>
Subject: Re: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

Dear NetSlicing folks

Would you be so kind as to express your further interest in participating as contributors/reviewers to the above drafts by sending an interest message to my self ([email-masked]<mailto:[email-masked]>). I will include your email in this workgroup.
In addition please post your GITHUB account to Kiran Makhijani <[email-masked]<mailto:[email-masked]>> for full write / read access to the NetSlices Github.

On 29 Mar 2017, at 00:51, Alex Galis <[email-masked]<mailto:[email-masked]>> wrote:

Dear NetSlicing folks,

II. Towards NS Use Cases

All slides from the NS meeting are at: https://github.com/netslices/IETF-NetSlices/tree/master/IETF98_Sidemeeting023.

–      use cases,

–      problem statements,

This charter be edited with contributions from the NS members of the mailing list and made available at https://github.com/netslices/IETF-NetSlices

Best Regards

Alex

---

From: <[email-masked]>
Date: Tue, 9 May 2017 10:41:46 +0000

Could you explain the difference between a network slice and network service please?

Is there a draft charter yet? – happy to review it, but I could only find some slides on github

Thanks
phil

Philip Eardley
Research and Innovation
This email contains BT information, which may be privileged or confidential. It's meant only for the individual(s) or entity named above. If you're not the intended recipient, note that disclosing, copying, distributing or using this information is prohibited. If you've received this email in error, please let me know immediately on the email address above. Thank you.
We monitor our email system, and may record your emails.
British Telecommunications plc
Registered office: 81 Newgate Street London EC1A 7AJ
Registered in England no: 1800000

From: Netslices [mailto:[email-masked]] On Behalf Of Sprecher, Nurit (Nokia - IL/Kfar Sava)
Sent: 05 May 2017 13:47
To: Alex Galis <[email-masked]>; Network Slices <[email-masked]>
Cc: Alex Galis <[email-masked]>
Subject: Re: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

Hello,
Thanks for the update.

From: Netslices [mailto:[email-masked]] On Behalf Of Alex Galis
Sent: Friday, May 05, 2017 1:34 PM
To: Network Slices <[email-masked]<mailto:[email-masked]>>
Cc: Alex Galis <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

Dear NetSlicing folks

Dear NetSlicing folks,

II. Towards NS Use Cases

–      use cases,

–      problem statements,

Best Regards

Alex

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Wed, 10 May 2017 08:01:29 +0900

> Could you explain the difference between a network slice and network

Network Service: The means to supply/deliver a set of functions linked
to the network (e.g. connectivity or distributed data storage).

Network Slice: A portion of a network that is provided to a user for it
to manage as needed, remarking that a slice ("the network portion") is
composed of several portions of physical or virtual underlying resources
that are administratively put together under the control of such user.

The differences are clear, the relation is that the flexibility offered
by network slices makes them ideal for instantiating network services,
but they are not the same thing, by no means.

> find some slides on github

We are still working on it...

> phil

Regards,
Pedro

-- 
Pedro Martinez-Julia
Network Science and Convergence Device Technology Laboratory
Network System Research Institute
National Institute of Information and Communications Technology (NICT)
4-2-1, Nukui-Kitamachi, Koganei, Tokyo 184-8795, Japan
Email: [email-masked]
---------------------------------------------------------
*** Entia non sunt multiplicanda praeter necessitatem ***

---

From: <[email-masked]>
Date: Thu, 11 May 2017 09:37:32 +0000

Pedro,

Thanks. Your definition of a network slice seems to be just the network. 

However, I looked at one of Alex's slides on the github (slide 6 https://github.com/netslices/IETF-NetSlices/blob/master/NS-WG_Charter-Draft%201.pptx ), which says:

<<
Early NS – SParticion of resources
Physical partition of networks (e.g. VPN, Overlay, Virtual Networks)
Modern NS: Slice as a union of subsets of resources & NFs at a given time

So the "modern" definition of slicing seems to include functions as well as networking resources. 

Network Service, as defined by ETSI, includes both the network functions and the infrastructure connecting the functions. See for instance Figure 2 (page 11) http://www.etsi.org/deliver/etsi_gs/NFV/001_099/002/01.01.01_60/gs_NFV002v010101p.pdf 

So I think there needs to be more clarity about the definition of a network slice and the difference with a network service

Best wishes
phil

-----Original Message-----
From: Pedro Martinez-Julia [mailto:[email-masked]] 
Sent: 10 May 2017 00:01
To: Eardley,PL,Philip,TUD1 R <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

> Could you explain the difference between a network slice and network 

Network Service: The means to supply/deliver a set of functions linked to the network (e.g. connectivity or distributed data storage).

Network Slice: A portion of a network that is provided to a user for it to manage as needed, remarking that a slice ("the network portion") is composed of several portions of physical or virtual underlying resources that are administratively put together under the control of such user.

The differences are clear, the relation is that the flexibility offered by network slices makes them ideal for instantiating network services, but they are not the same thing, by no means.

Regards,
Pedro

--
Pedro Martinez-Julia
Network Science and Convergence Device Technology Laboratory Network System Research Institute National Institute of Information and Communications Technology (NICT) 4-2-1, Nukui-Kitamachi, Koganei, Tokyo 184-8795, Japan
Email: [email-masked]
---------------------------------------------------------
*** Entia non sunt multiplicanda praeter necessitatem ***

---

From: "Sprecher, Nurit (Nokia - IL/Kfar Sava)" <[email-masked]>
Date: Thu, 11 May 2017 18:33:29 +0000

Hello,

As the information is publicly open, I am happy to share:

These are the current definitions:

- NS - term used in 3GPP SA5 specifications to refer to a "network service" defined in ETSI NFV GS NFV003:

network service: composition of Network Functions and defined by its functional and behavioral specification

NOTE: The Network Service contributes to the behavior of the higher layer service, which is characterized by at least performance, dependability, and security specifications. The end-to-end network service behavior

is the result of the combination of the individual network function behaviors as well as the behaviors of the network infrastructure composition mechanism.

- NSI - term used in 3GPP SA5 specifications to refer to "network slice instance" defined in NGMN White Paper "Description of Network Slicing Concept":

Network Slice Instance: a set of network functions, and resources to run these network functions, forming a complete instantiated logical network to meet certain network characteristics required by the Service Instance(s):

-              A network slice instance may be fully or partly, logically and/or physically, isolated from another network slice instance.

-              The resources comprises of physical and logical resources.

-              A Network Slice Instance may be composed of Sub-network Instances, which as a special case may be shared by multiple network slice instances. The Network Slice Instance is defined by a Network Slice Blueprint.

-              Instance-specific policies and configurations are required when creating a Network Slice Instance.

-              Network characteristics examples are ultra-low-latency, ultra-reliability, etc.

The definitions of NSI in 3GPP SA2 and SA5 may be changing.

SA5 slice definition is (as documented in the latest draft TR 28.801):

network slice instance: a set of network functions and the resources for these network functions which are arranged and configured, forming a complete logical network to meet certain network characteristics

SA2 definitions (from TR 23.799):

Network Slice Template (NST): is a logical representation of the Network Function(s) and corresponding resource requirements necessary to provide the required telecommunication services and network capabilities.

Network Slice Instance (NSI): is an instance created from a Network Slice Template (NST).

Network Slice: is a concept describing a system behavior which is implemented via Network Slice Instance(s).
Best regards,
Nurit

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 09, 2017 1:42 PM
To: Sprecher, Nurit (Nokia - IL/Kfar Sava) <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

Thanks
phil

Philip Eardley
Research and Innovation

From: Netslices [mailto:[email-masked]] On Behalf Of Sprecher, Nurit (Nokia - IL/Kfar Sava)
Sent: 05 May 2017 13:47
To: Alex Galis <[email-masked]<mailto:[email-masked]>>; Network Slices <[email-masked]<mailto:[email-masked]>>
Cc: Alex Galis <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

Hello,
Thanks for the update.

Dear NetSlicing folks

Dear NetSlicing folks,

II. Towards NS Use Cases

–      use cases,

–      problem statements,

Best Regards

Alex

---

From: "Kiran.Makhijani" <[email-masked]>
Date: Thu, 11 May 2017 19:45:09 +0000

Hello Nurit,

Thanks for share in concise manner.

Conceptually, the definitions make sense. Of all the definitions below network service looks most precise to me. NGMN’s version of a slice instance says a lot and 3GPP’s says very little (dependent on network slice template).

Speaking for myself, some points where we may need to alter these definitions -

1.       a clear association between a network service and a slice [is service = slice or slice = composition of (services) or both].

2.       Slice template to be a management or orchestration concept and should not be of any/major significance in control or data plane. Therefore, definition of a slice instance should be independent of a slice template. For control plane an instance could be a “set or single resource specification(s)”.

3.       Basing on strict resource isolation for many services, I am unsure about sharing of sub-network instances as mentioned below.

These definitions are good - it should be okay to tweak them (not reinvent) so that their meaning is not lost and IETF’s scope is clear as well.

Regards
Kiran

From: Netslices <[email-masked]> on behalf of "Sprecher, Nurit (Nokia - IL/Kfar Sava)" <[email-masked]>
Date: Thursday, May 11, 2017 at 11:33 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "Sartori, Cinzia (Nokia - DE/Munich)" <[email-masked]>, "Andrianov, Anatoly (Nokia - US/Arlington Heights)" <[email-masked]>, "a.galis" <[email-masked]>
Subject: Re: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

Hello,

Thanks
phil

Philip Eardley
Research and Innovation

Hello,
Thanks for the update.

Dear NetSlicing folks

Dear NetSlicing folks,

II. Towards NS Use Cases

–      use cases,

–      problem statements,

Best Regards

Alex

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Fri, 12 May 2017 07:26:35 +0900

Dear Philip,

My concept of "network resource" is clearly wider than I have achieved
to communicate. When I talk about a "resource" I am actually meaning an
"abstract object", which can be anything (e.g. physical/virtual device,
physical/virtual/software service, real/represented persons, and also
actual things, from IoT). Therefore, a "network resource" is any object
related to the network (connected and/or with networking abilities).

I hope this clarifies my definition of this matter.

Regards,
Pedro

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 12 May 2017 03:51:18 +0000

Hi Nurit, Kiran,

Thanks for raising the discussion about network slicing definition. I agree with Kiran that we should give a definition which is based on the existing ones and also make the IETF’s scope clearer.

In my understanding, the definition of network slice in NGMN and 3GPP mainly focuses on the network functions and the needed resources, while does not explicitly cover the characteristics of the network which provides the required connection between the network functions. So from IETF’s perspective, maybe it is necessary to emphasize both the network connections/topology and the network functions which together form a logical network slice.

As for the relationship between network service and network slice, a network service can be provided in a particular network slice, and a network slice can also be seen as a service provided by the network slicing provider to a slice tenant. Maybe it depends on the different definition of “service”.

Best regards,
Jie

From: Netslices [mailto:[email-masked]] On Behalf Of Kiran.Makhijani
Sent: Friday, May 12, 2017 3:45 AM
To: Sprecher, Nurit (Nokia - IL/Kfar Sava) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Cc: Andrianov, Anatoly (Nokia - US/Arlington Heights) <[email-masked]>; Sartori, Cinzia (Nokia - DE/Munich) <[email-masked]>; [email-masked]
Subject: Re: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

Hello Nurit,

Regards
Kiran

From: Netslices <[email-masked]<mailto:[email-masked]>> on behalf of "Sprecher, Nurit (Nokia - IL/Kfar Sava)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, May 11, 2017 at 11:33 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "Sartori, Cinzia (Nokia - DE/Munich)" <[email-masked]<mailto:[email-masked]>>, "Andrianov, Anatoly (Nokia - US/Arlington Heights)" <[email-masked]<mailto:[email-masked]>>, "a.galis" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

Hello,

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Tuesday, May 09, 2017 1:42 PM
To: Sprecher, Nurit (Nokia - IL/Kfar Sava) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

Thanks
phil

Philip Eardley
Research and Innovation

Hello,
Thanks for the update.

Dear NetSlicing folks

Dear NetSlicing folks,

II. Towards NS Use Cases

–      use cases,

–      problem statements,

Best Regards

Alex

---

From: Leeyoung <[email-masked]>
Date: Fri, 12 May 2017 04:40:04 +0000

Hi Jie,

ACTN has been using the term network slicing for a while. The following is our current definition from TEAS WG standpoint, which is defined in the current ACTN framework document:

        Network Slicing: Network slicing is a collection of resources
        that are used to establish logically dedicated virtual networks
        over TE networks. It allows a network provider to provide
        dedicated virtual networks for application/customer over a
        common network infrastructure. The logically dedicated
        resources are a part of the larger common network
        infrastructures that are shared among various network slice
        instances which are the end-to-end realization of network
        slicing, consisting of the combination of physically or
        logically dedicated resources.

One caveat is that ACTN’s context is Traffic Engineered networks (MPLS/MPLS-TE/TP, OTN, WSON, Flexi-grid optical) which is connection-oriented packet and optical networks.

See more details on ACTN: https://tools.ietf.org/html/draft-ietf-teas-actn-framework-05

Thanks.
Young

From: Netslices [mailto:[email-masked]] On Behalf Of Dongjie (Jimmy)
Sent: Thursday, May 11, 2017 10:51 PM
To: Kiran.Makhijani <[email-masked]>; Sprecher, Nurit (Nokia - IL/Kfar Sava) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Cc: Sartori, Cinzia (Nokia - DE/Munich) <[email-masked]>; Andrianov, Anatoly (Nokia - US/Arlington Heights) <[email-masked]>; [email-masked]
Subject: Re: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

Hi Nurit, Kiran,

Best regards,
Jie

From: Netslices [mailto:[email-masked]] On Behalf Of Kiran.Makhijani
Sent: Friday, May 12, 2017 3:45 AM
To: Sprecher, Nurit (Nokia - IL/Kfar Sava) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Andrianov, Anatoly (Nokia - US/Arlington Heights) <[email-masked]<mailto:[email-masked]>>; Sartori, Cinzia (Nokia - DE/Munich) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

Hello Nurit,

Regards
Kiran

Hello,

Thanks
phil

Philip Eardley
Research and Innovation

Hello,
Thanks for the update.

Dear NetSlicing folks

Dear NetSlicing folks,

II. Towards NS Use Cases

–      use cases,

–      problem statements,

Best Regards

Alex

---

From: "Sprecher, Nurit (Nokia - IL/Kfar Sava)" <[email-masked]>
Date: Fri, 12 May 2017 09:53:34 +0000

Hello,
Please see inline.
Best regards,
Nurit

From: Kiran.Makhijani [mailto:[email-masked]]
Sent: Thursday, May 11, 2017 10:45 PM
To: Sprecher, Nurit (Nokia - IL/Kfar Sava) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Cc: Sartori, Cinzia (Nokia - DE/Munich) <[email-masked]>; Andrianov, Anatoly (Nokia - US/Arlington Heights) <[email-masked]>; [email-masked]
Subject: Re: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

Hello Nurit,

1.      a clear association between a network service and a slice [is service = slice or slice = composition of (services) or both].
Nurit: this is not really accurate.
Slice is not a ETSI NFV NS and is not a composition of those. Slice (in 3GPP terms) is a layer above NS (set of 3GPP applications with corresponding application links and configurations) where NS is just a set (optionally interconnected) of “black boxes” a.k.a. ETSI NFV defined VNFs and PNFs with some recursion allowed. In SA5 we plan to define a 1:1 mapping between slice subnet (3GPP term) and NS (NFV term). Where our subnet will be “NS+” (contain all the application info such as application topology, configuration, etc…).
For IETF slice (if scope is similar to ETSI NFV and is application agnostic), it may be OK to state that IETF slice is equal to ETSI NFV NS.

2.      Slice template to be a management or orchestration concept and should not be of any/major significance in control or data plane. Therefore, definition of a slice instance should be independent of a slice template. For control plane an instance could be a “set or single resource specification(s)”.
Nurit: This is the view of 3GPP SA5 – slice template is a special kind of subnet template (I believe a slice is just a special kind of a subnet). A subnet template will contain 3GPP MIB (application specific topology), some slice specific parameters (e.g. requirements for isolation, features such as support of mobility, etc…) and the whole NSD of the corresponding ETSI NFV NS (NSD contains forwarding graphs, etc…).

  1.  Nurit: The high level isolation requirement was security specific – to address security concerns in special cases, not from the resource management perspective.

These definitions are good - it should be okay to tweak them (not reinvent) so that their meaning is not lost and IETF’s scope is clear as well.
As mentioned below, the definition  in 3GPP may still change, but it is highly important to align to ensure consistent definitions across the industry.

Regards
Kiran

Hello,

Thanks
phil

Philip Eardley
Research and Innovation

Hello,
Thanks for the update.

Dear NetSlicing folks

Dear NetSlicing folks,

II. Towards NS Use Cases

–      use cases,

–      problem statements,

Best Regards

Alex

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 12 May 2017 11:44:38 +0100

On 12/05/2017 10:53, Sprecher, Nurit (Nokia - IL/Kfar Sava) wrote:
>
> 3.Basing on strict resource isolation for many services, I am unsure 
> about sharing of sub-network instances as mentioned below.
>
>  4. Nurit: The high level isolation requirement was security specific
>     – to address security concerns in special cases, not from the
>     resource management perspective.
>

Nurit

Don't you need isolation to also ensure the dynamics of the system, i.e. 
to be sure to meet the loss, latency and b/w requirements or are 
operators backing away from that?

Stewart

---

From: Alex Galis <[email-masked]>
Date: Mon, 15 May 2017 17:00:00 +0100

Hi Nurit and All

Please note the unified terms used in the last period in the IETF Network Slicing presentations at the IETF97 & IETF98 and drafts’ work (i.e. gihhub repository: https://github.com/alexgalis/IETF-NetSlices <https://github.com/alexgalis/IETF-NetSlices>)

Best Regards
Alex

Resource Slice - A grouping of physical or virtual (network, compute, storage) resources which. It inherits the characteristics of the resources which are also bound to the capability of the resource. A resource slice could be one of the component of Network Slice, however on its own does not represent fully a Network Slice.

Network slice - A Network slice is a managed group of subsets of resources, network functions / network virtual functions at the data, control, management/orchestration planes and services at a given time.  Network slice is programmable and has the ability to expose its capabilities. The behaviour of the network slice realized via network slice instance(s).

(1) The Service Instance component

•     Represents the end-user service or business services.

•     An instance of an end-user service or a business service that is realized within or by a NS. 

•     Would be provided by the network operator or by 3rd parties.

 (2) A Network Slice Instance component

•     Represented by a set of network functions, virtual network functions and resources at a given time

•     Forms a complete instantiated logical network to meet certain network characteristics required by the Service Instance(s). 

•     Provides network characteristics which are required by a Service Instance.

•     May also be shared across multiple Service Instances

 (3) Resources component – it includes: Physical, Logical & Virtual resources

•     Physical & Logical resources - An independently manageable partition of a physical resource, which inherits the same characteristics as the physical resource and whose capability is bound to the capability of the physical resource.  It is dedicated to a Network Function or shared between a set of Network Functions.

•     Virtual resources - An abstraction of a physical or logical resource, which may have different characteristics from that resource, and whose capability may not be bound to the capability of that resource.

 (4) Slice Element Manager (SEM) and Capability exposure component

•     Slice Element Manager (SEM) is instantiated in each Network Slice and it manages all access permissions and all interaction between a Network Slice and external functions (i.e. other Network Slices, Orchestrators, etc). Each SEM converts requirements from orchestrator into virtual resources and manages virtual resources of a slice. SEM also exchanges information of virtual resources with other slice element managers via a dedicated resource interface.

•     Allow 3rd parties to access via APIs information regarding services provided by the slice (e.g. connectivity information, QoS, mobility, autonomicity, etc.)

•     Allow dynamical customization of the network characteristics for different diverse use cases within the limits set of functions by the operator.  Network slice enables the operator to create networks customized to provide flexible solutions for different market scenarios, which have diverse requirements, with respect to the functionality, performance and resource separation.

•     It includes a description of the structure (and contained components) and configuration of the slice instance.

Network slice template - A complete description of the structure, configuration and the plans/work flows for how to instantiate and control the Network Slice Instance during its life cycle.

Network Slice Instance - An activated network slice. It is created based on network template. A set of managed run-time network functions, and resources to run these network functions, forming a complete instantiated logical network to meet certain network characteristics required by the service instance(s). It provides the network characteristics that are required by a service instance. A network slice instance may also be shared across multiple service instances provided by the network operator. The network slice instance may be composed by none, one or more sub-network instances, which may be shared by another network slice instance.

> On 12 May 2017, at 10:53, Sprecher, Nurit (Nokia - IL/Kfar Sava) <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Hello,
> Please see inline.
> Best regards,
> Nurit
>  
> From: Kiran.Makhijani [mailto:[email-masked] <mailto:[email-masked]>] 
> To: Sprecher, Nurit (Nokia - IL/Kfar Sava) <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> Cc: Sartori, Cinzia (Nokia - DE/Munich) <[email-masked] <mailto:[email-masked]>>; Andrianov, Anatoly (Nokia - US/Arlington Heights) <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> Nurit: The high level isolation requirement was security specific – to address security concerns in special cases, not from the resource management perspective.
>  
> From: Netslices <[email-masked] <mailto:[email-masked]>> on behalf of "Sprecher, Nurit (Nokia - IL/Kfar Sava)" <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> Cc: "Sartori, Cinzia (Nokia - DE/Munich)" <[email-masked] <mailto:[email-masked]>>, "Andrianov, Anatoly (Nokia - US/Arlington Heights)" <[email-masked] <mailto:[email-masked]>>, "a.galis" <[email-masked] <mailto:[email-masked]>>
> From: [email-masked] <mailto:[email-masked]> [mailto:[email-masked] <mailto:[email-masked]>] 
> To: Sprecher, Nurit (Nokia - IL/Kfar Sava) <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> Cc: [email-masked] <mailto:[email-masked]>
> From: Netslices [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Sprecher, Nurit (Nokia - IL/Kfar Sava)
> Sent: 05 May 2017 13:47
> To: Alex Galis <[email-masked] <mailto:[email-masked]>>; Network Slices <[email-masked] <mailto:[email-masked]>>
> Cc: Alex Galis <[email-masked] <mailto:[email-masked]>>
> From: Netslices [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Alex Galis
> To: Network Slices <[email-masked] <mailto:[email-masked]>>
> Cc: Alex Galis <[email-masked] <mailto:[email-masked]>>
> All versions of the above drafts are currently on the NetSlices Github repository https://github.com/netslices/IETF-NetSlices <https://github.com/netslices/IETF-NetSlices>
>  
>  
> In addition please post your GITHUB account to Kiran Makhijani <[email-masked] <mailto:[email-masked]>> for full write / read access to the NetSlices Github.
>  
> On 29 Mar 2017, at 00:51, Alex Galis <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Dear NetSlicing folks,
> 
>  
>

---

From: "Kiran.Makhijani" <[email-masked]>
Date: Mon, 15 May 2017 23:05:16 +0000

Hi Nurit,
Sorry for late reply, I took Friday off. You have brought interesting insights from 3GPP & NFV’s perspective but I am still struggling. Please see below [km].

[km]
understood from SA5’s perspective.
To clarify, I might have used network service (NS) in place of a service (I think you call it application). Am I right?
For me a slice can host (i) a specific service e.g. only V2X service, (ii) a slice maybe a generalized network within which an operator can offer 2 or 3 different services such as VoIP, IPTV, Internet access etc. such services can be offered within or without a slice (difference being assurance vs best-effort).

So, the subtle difference between ‘composition of service’ and ‘layer above NS’ is related to resource isolation vs sharing? i.e. if we say layer above, it may share resources from layer below.

IETF looks at all communication and connectivity and related protocol aspects, so NFV’s NS definition seems restrictive.

Also, IMO, IETF slice ‘should not’ be application agnostic and subnet concept should be more flexible, defining interconnection (or transport) aspects both - with in a subnet and between subnets. In my mind, an administrative domain could be a single subnet or maybe a group of subnets.

Regards
Kiran

---

From: "Flinck, Hannu (Nokia - FI/Espoo)" <[email-masked]>
Date: Thu, 18 May 2017 12:49:24 +0000

Hello Kiran,

Can you please elaborate a bit further what you mean by saying: IETF slice ‘should not’ be application agnostic.

Best regards
Hannu

Sent: Tuesday, May 16, 2017 2:05 AM

Hi Nurit,

[km]

Regards
Kiran

---

From: "Kiran.Makhijani" <[email-masked]>
Date: Thu, 18 May 2017 17:52:49 +0000

what I mean is -  a slice “should not be agnostic” of network resource requirements of an application.

For example, if the application is multimedia – say Hi-res video has latency is bound to X ms and Y Mbps bandwidth has to be guaranteed. For immersive it will be even lower latency and higher bandwidth. So, this kind of application awareness is needed.

Regards
Kiran

From: "Flinck, Hannu (Nokia - FI/Espoo)" <[email-masked]>
Date: Thursday, May 18, 2017 at 5:49 AM
To: Kiran Makhijani <[email-masked]>, "Sprecher, Nurit (Nokia - IL/Kfar Sava)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "Andrianov, Anatoly (Nokia - US/Arlington Heights)" <[email-masked]>, "Sartori, Cinzia (Nokia - DE/Munich)" <[email-masked]>, "a.galis" <[email-masked]>
Subject: RE: [Netslices] Preparation for a Network Slicing BoF at IETF 99 in Prague

Hello Kiran,

Best regards
Hannu

Hi Nurit,

[km]

Regards
Kiran