Subject: [Netslices] Network Slicing (NETSLICING): BoF Objectives

From: Benoit Claise <[email-masked]>
Date: Wed, 14 Jun 2017 13:50:48 +0200

Dear all,

It's time to prepare this coming non-WG forming BoF.

A BoF is successful when the proponents are able to clearly explain 
their problem statement to the audience, to get the audience to agree 
that this is an important topic, and propose (a start of) a solution as 
a way forward. RFC 5434 is a good read, from which I particularly like:

    In those cases, the goal of the
    BOF is to demonstrate that the community has agreement that:

           - there is a problem that needs solving, and the IETF is the right
             group to attempt solving it.

           - there is a critical mass of participants willing to work on the
             problem (e.g., write drafts, review drafts, etc.).

           - the scope of the problem is well defined and understood, that
             is, people generally understand what the WG will work on (and
             what it won't) and what its actual deliverables will be.

           - there is agreement that the specific deliverables (i.e.,
             proposed documents) are the right set.

           - it is believed that the WG has a reasonable probability of
             having success (i.e., in completing the deliverables in its
             charter in a timely fashion).

Not all questions are valid for a non working forming BoF, but you 
should keep these questions in mind.

The BoF objectives should be:
- Network slicing is not a new concept but has some specific meaning and 
expectations in 5G. We need to understand the 3GPP requirements for the 
IETF.
- We need to make a sure that we agree on terminology and the meaning of 
terms.
- Personally, I'm not clear if we speak about underlay or overlay. Which 
layers/technologies do we speak about here?
- This network slicing work is very broad, and other WGs doing the 
related work. I see some interactions with the OPS, the INT (by overlay 
or underlay), and the RTG area.
   Specifically for the OPS aspects, it seems like the drafts want to 
specify a full system architecture and a full provisioning system.
   We need to identify some IETF deliverables, in line with the 3GPP 
requirements.

We also have to realize that we don't need a new WG to coordinate work 
in different WGs.

Because of the BoF time constraints, the chairs will have soon [1] a 
structured agenda.

Regards, Benoit (as responsible AD).

[1] for the fun part, see 
https://datatracker.ietf.org/doc/draft-farrel-soon/

---

From: Georgios Karagiannis <[email-masked]>
Date: Wed, 21 Jun 2017 15:54:57 +0000

Dear Benoit,

Thank you very much for the provided recommendations.
Regarding the following point on  “3GPP requirements”, do you expect that IETF should receive recommendations/requirements  from 3GPP  in the context of solving standardization network slicing challenges which are within the IETF scope?

“We need to identify some IETF deliverables, in line with the 3GPP requirements.”

Best regards,
Georgios

From: Netslices [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Wednesday, June 14, 2017 1:51 PM
To: [email-masked]
Subject: [Netslices] Network Slicing (NETSLICING): BoF Objectives

Dear all,

A BoF is successful when the proponents are able to clearly explain their problem statement to the audience, to get the audience to agree that this is an important topic, and propose (a start of) a solution as a way forward. RFC 5434 is a good read, from which I particularly like:

Not all questions are valid for a non working forming BoF, but you should keep these questions in mind.

The BoF objectives should be:
- Network slicing is not a new concept but has some specific meaning and expectations in 5G. We need to understand the 3GPP requirements for the IETF.
- We need to make a sure that we agree on terminology and the meaning of terms.
- Personally, I'm not clear if we speak about underlay or overlay. Which layers/technologies do we speak about here?
- This network slicing work is very broad, and other WGs doing the related work. I see some interactions with the OPS, the INT (by overlay or underlay), and the RTG area.
  Specifically for the OPS aspects, it seems like the drafts want to specify a full system architecture and a full provisioning system.
  We need to identify some IETF deliverables, in line with the 3GPP requirements.

We also have to realize that we don't need a new WG to coordinate work in different WGs.

Because of the BoF time constraints, the chairs will have soon [1] a structured agenda.

[1] for the fun part, see https://datatracker.ietf.org/doc/draft-farrel-soon/

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 21 Jun 2017 17:25:51 +0100

Hey Georgios,
 
We plan to give a rep from 3gpp some time on the agenda to tell us about the current status of 5g work wrt network slicing.
 
This may map to specific dependencies on IETF work, or might not.
 
I think the messages should be that:
- If 3gpp has requirements we should attend to them
- If requirements are voiced as being 5g requirements, but do not come from 3gpp
   we should be aware (and beware)
- If *other* requirements for network slicing arise (that are not driven by 3gpp)
   we will not rule them out, but will assess them as we would other work
 
Adrian
 
From: Netslices [mailto:[email-masked]] On Behalf Of Georgios Karagiannis
Sent: 21 June 2017 16:55
To: Benoit Claise; [email-masked]
Subject: Re: [Netslices] Network Slicing (NETSLICING): BoF Objectives
 
Dear Benoit,

Best regards,
Georgios

Dear all,

---

From: Georg Mayer <[email-masked]>
Date: Fri, 23 Jun 2017 13:37:18 +0200

Hello,

speaking as the 3GPP liaison towards IETF.

3GPP looks at 5G Network Slicing from different perspectives, e.g.
- architecture
- radio access & core network
- operation & maintenance
- mobility & sessions management
- security
- extension of existing 3GPP protocols

If IETF Netslices is intended to work towards 5G / 3GPP, then we first
of all need to answer one question: Are there any requests or
requirements from 3GPP to IETF regarding network slicing?

The answer so far is no.

What we see is that most of the issues indicated above can be handled by
3GPP internally by evolving existing protocol solutions (e.g.
Mobility/Session Management protocol etc) towards 5G or by making use of
existing solutions.

The work in 3GPP is still in progress, i.e. the "no" might not be the
final answer. But so far the information I've collected from the
different working groups in 3GPP is, that we at this moment don't have
anything that we plan to indicate to IETF as requirements on Network
Slicing.

I know that many of you will not like this message, I nevertheless hope
you don't shoot the messenger (that's me). We need to be open and honest
here and I don't want to create any illusions.

Beyond Slicing ...

We started a major effort since the last IETF to get possible 5G related
3GPP requirements to IETF. There is a number of possible candidates
where we currently look into, but they are (at this moment) not in the
area of network slicing.

On the other hand we need to ensure that the work on 5G related issues
stays well coordinated between the involved standards bodies (there are
many more obviously) and that we end up with a coherent set of standards.

Please also be aware that 3GPP has a very demanding schedule for
completion of the first phase of 5G, which is June/September 2018.
Within 3GPP we work hand-in-hand across several working groups and
develop architecture, protocol requirements and solutions more or less
in parallel. We need to make sure that work which is done in IETF is
well phased-in to this endeavor.

I will present 3GPP work on 5G and collaboration plans with IETF at a
dedicated time slot in Prague (most likely Tuesday noon, watch out for
the updated Agenda) at the next IETF meeting.

Having said all that, obviously I don't want to stop any of the
activities on this list. I just want to make clear the background in
3GPP and what we can at this moment realistically foresee.

Thanks and cheers,
Georg

-- 
Georg Mayer
3GPP CT Chairman
HUAWEI Technologies
Mobile: +43 699 1900 5758

On 2017-06-21 18:25, Adrian Farrel wrote:
> Hey Georgios,
> 
>  
> 
> We plan to give a rep from 3gpp some time on the agenda to tell us about
> the current status of 5g work wrt network slicing.
> 
>  
> 
> *From:*Netslices [mailto:[email-masked]] *On Behalf Of
> *Georgios Karagiannis
> *Sent:* 21 June 2017 16:55
> *To:* Benoit Claise; [email-masked]
> *Subject:* Re: [Netslices] Network Slicing (NETSLICING): BoF Objectives
> 
>  
> 
> Dear Benoit,
> 
>  
> 
> Regarding the following point on  “3GPP requirements”, do you expect
> that IETF should receive recommendations/requirements  from 3GPP  in the
> context of solving standardization network slicing challenges which are
> within the IETF scope?
> 
>  
> 
> *From:*Netslices [mailto:[email-masked]] *On Behalf Of
> *Benoit Claise
> *Sent:* Wednesday, June 14, 2017 1:51 PM
> *To:* [email-masked]
> *Subject:* [Netslices] Network Slicing (NETSLICING): BoF Objectives
> 
>  
> 
> Dear all,
> 
> 
> _______________________________________________
> Netslices mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netslices
>

---

From: Anton Ivanov <[email-masked]>
Date: Fri, 23 Jun 2017 12:46:15 +0100

Excellent.

Finally, 3GPP itself to state clearly that there are NO 3GPP aspects for 
us to look at.

As I have said before, if there is something non-3GPP for us to work on, 
let's do it. IMHO - there are a few use cases of resource + network like 
vCPE systems, etc which are worth considering and which look like a slice.

Anything else which is 3GPP related should stay where it belongs - 3GPP.

A.

---

From: <[email-masked]>
Date: Fri, 23 Jun 2017 12:02:22 +0000

Dear Georg, 

Thank you for sharing this message. 

I do fully agree that any 3GPP-specific work should stay within 3GPP unless an explicit request is sent to the IETF. 

That's said, from what I understood from various proponents of the netslices effort is that the assumption 
"If IETF Netslices is intended to work towards 5G " is NOT CORRECT. 5G is one use case among others that can be considered. The proposed work (referring to the gap-analysis) is not specific to 5G at all. 

Cheers,
Med

> -----Message d'origine-----
> De : Netslices [mailto:[email-masked]] De la part de Georg
> Mayer
> Envoyé : vendredi 23 juin 2017 13:37
> À : [email-masked]; 'Georgios Karagiannis'; 'Benoit Claise';
> [email-masked]
> Cc : Erik Guttman; MORAND Lionel IMT/OLN
> Objet : Re: [Netslices] Network Slicing (NETSLICING): BoF Objectives
> 
> Hello,
>

---

From: "qiangli (D)" <[email-masked]>
Date: Sat, 24 Jun 2017 04:53:41 +0000

Hi Med,

I think we share the same opinion on current IETF-Netslicing, which carries out its work from IP based transport network aspect rather than 5G. I also believe that the IETF-NetSlicing work does not intend to interfere in the internal affairs of 3GPP. 
Now to the network slicing, the transport network in IETF needs to provide matching resource for the network slices in 3GPP. Therefore, the coordination between 3GPP and IETF is inevitable, although the specific requirement is not clear enough now. The IETF-NetSlicing work is also trying to get ready for this coordination from the IETF perspective.

Best regards,

Cristina QIANG

-----Original Message-----
From: Netslices [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, June 23, 2017 8:02 PM
To: Georg Mayer; [email-masked]; Georgios Karagiannis; 'Benoit Claise'; [email-masked]
Cc: Erik Guttman; MORAND Lionel IMT/OLN
Subject: Re: [Netslices] Network Slicing (NETSLICING): BoF Objectives

Dear Georg, 

That's said, from what I understood from various proponents of the netslices effort is that the assumption "If IETF Netslices is intended to work towards 5G " is NOT CORRECT. 5G is one use case among others that can be considered. The proposed work (referring to the gap-analysis) is not specific to 5G at all. 

Cheers,
Med

> Mayer Envoyé : vendredi 23 juin 2017 13:37 À : [email-masked]; 
> 'Georgios Karagiannis'; 'Benoit Claise'; [email-masked] Cc : Erik 
> Guttman; MORAND Lionel IMT/OLN Objet : Re: [Netslices] Network Slicing 
> (NETSLICING): BoF Objectives
> 
> Hello,
> 
> What we see is that most of the issues indicated above can be handled 
> by 3GPP internally by evolving existing protocol solutions (e.g.
> Mobility/Session Management protocol etc) towards 5G or by making use 
> of existing solutions.
> 
> I know that many of you will not like this message, I nevertheless 
> hope you don't shoot the messenger (that's me). We need to be open and 
> honest here and I don't want to create any illusions.
> 
> 
> Beyond Slicing ...
> 
> We started a major effort since the last IETF to get possible 5G 
> related 3GPP requirements to IETF. There is a number of possible 
> candidates where we currently look into, but they are (at this moment) 
> not in the area of network slicing.
> 
> stays well coordinated between the involved standards bodies (there 
> are many more obviously) and that we end up with a coherent set of standards.
> 
> > We plan to give a rep from 3gpp some time on the agenda to tell us 
> > about the current status of 5g work wrt network slicing.
> >
> >
> >
> > that IETF should receive recommendations/requirements  from 3GPP  in 
> > the context of solving standardization network slicing challenges 
> > which are within the IETF scope?
> >
> >
> >
> > their problem statement to the audience, to get the audience to 
> > agree that this is an important topic, and propose (a start of) a 
> > solution as a way forward. RFC 5434 is a good read, from which I particularly like:
> >
> > - Network slicing is not a new concept but has some specific meaning 
> > and expectations in 5G. We need to understand the 3GPP requirements 
> > for the IETF.
> > - Personally, I'm not clear if we speak about underlay or overlay. 
> > Which layers/technologies do we speak about here?
> > related work. I see some interactions with the OPS, the INT (by 
> > overlay or underlay), and the RTG area.

---

From: Georgios Karagiannis <[email-masked]>
Date: Sun, 25 Jun 2017 08:22:46 +0000

Hi Georg,

Thanks for the provided information.

Please note that I agree with the comment provided by Christina Qiang that the transport network in IETF needs to provide matching resource for the network slices in 3GPP.

Assuming that IETF will provide recommendations that show how the transport network in IETF matches resources for the network slices in 3GPP, will then the 3GPP community be open for discussions on whether these recommendations are useful (for 3GPP specifications) in the context of 5G and beyond?

Best regards,
Georgios

-----Original Message-----
From: qiangli (D) 
Sent: Saturday, June 24, 2017 6:54 AM
To: [email-masked]; Georg Mayer; [email-masked]; Georgios Karagiannis; 'Benoit Claise'; [email-masked]
Cc: Erik Guttman; MORAND Lionel IMT/OLN
Subject: RE: [Netslices] Network Slicing (NETSLICING): BoF Objectives

Hi Med,

Best regards,

Cristina QIANG

-----Original Message-----
From: Netslices [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, June 23, 2017 8:02 PM
To: Georg Mayer; [email-masked]; Georgios Karagiannis; 'Benoit Claise'; [email-masked]
Cc: Erik Guttman; MORAND Lionel IMT/OLN
Subject: Re: [Netslices] Network Slicing (NETSLICING): BoF Objectives

Dear Georg, 

Cheers,
Med

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 26 Jun 2017 10:18:48 +0000

Hi Georgios, all,

just a couple of reminders and a note

- As the "Transport ADs" made us notice, with the term transport network we are not referring to layer 4 in the stack but to the network used to carry packets from one end to the other, typically layers 2 and 3 (but could be also 0 and 1).

- " Assuming that IETF will provide recommendations that show how the transport network in IETF matches resources for the network slices in 3GPP" - This is good and I encourage the list to review the excellent draft written by Dan King (https://tools.ietf.org/html/draft-king-teas-applicability-actn-slicing-00 )

- " will then the 3GPP community be open for discussions on whether these recommendations are useful (for 3GPP specifications) in the context of 5G and beyond?" - Great idea, this would be highly appreciated.

BR
Daniele  

-----Original Message-----
From: Netslices [mailto:[email-masked]] On Behalf Of Georgios Karagiannis
Sent: domenica 25 giugno 2017 10:23
To: Georg Mayer <[email-masked]>
Cc: Erik Guttman <[email-masked]>; [email-masked]; MORAND Lionel IMT/OLN <[email-masked]>; 'Benoit Claise' <[email-masked]>; [email-masked]; [email-masked]; qiangli (D) <[email-masked]>
Subject: Re: [Netslices] Network Slicing (NETSLICING): BoF Objectives

Hi Georg,

Best regards,
Georgios

-----Original Message-----
From: qiangli (D)
Sent: Saturday, June 24, 2017 6:54 AM
To: [email-masked]; Georg Mayer; [email-masked]; Georgios Karagiannis; 'Benoit Claise'; [email-masked]
Cc: Erik Guttman; MORAND Lionel IMT/OLN
Subject: RE: [Netslices] Network Slicing (NETSLICING): BoF Objectives

Hi Med,

Best regards,

Cristina QIANG

-----Original Message-----
From: Netslices [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, June 23, 2017 8:02 PM
To: Georg Mayer; [email-masked]; Georgios Karagiannis; 'Benoit Claise'; [email-masked]
Cc: Erik Guttman; MORAND Lionel IMT/OLN
Subject: Re: [Netslices] Network Slicing (NETSLICING): BoF Objectives

Dear Georg, 

Cheers,
Med

---

From: "Sprecher, Nurit (Nokia - IL/Kfar Sava)" <[email-masked]>
Date: Tue, 27 Jun 2017 20:50:12 +0000

Hello Georg,

Please see inline <Nurit> ….

Best regards,

Nurit

-----Original Message-----
From: Netslices [mailto:[email-masked]] On Behalf Of Georg Mayer
Sent: Friday, June 23, 2017 2:37 PM
To: [email-masked]; 'Georgios Karagiannis' <[email-masked]>; 'Benoit Claise' <[email-masked]>; [email-masked]
Cc: Erik Guttman <[email-masked]>; [email-masked]
Subject: Re: [Netslices] Network Slicing (NETSLICING): BoF Objectives

Hello,

<Nurit> was the below something agreed by 3GPP or is it your own view and interpretation on the relationship to the work done in 3GPP?

It seems you are speaking on behalf of the whole 3GPP, not just CT group…

If this is not a case, please make it clear that this is your own view and pls do not confuse the community to think this is the 3GPP position/view.

- architecture

<Nurit> “management” not “maintenance” in 3GPP terms

- security

If IETF Netslices is intended to work towards 5G / 3GPP, then we first of all need to answer one question: Are there any requests or requirements from 3GPP to IETF regarding network slicing?

The answer so far is no.

<Nurit> The answer is actually “yes”. This was highlighted in the LS from SA5 to SA (S5A-170313) – “Regarding the TN part supporting connectivity within and between CN and RAN parts, 3GPP management system will provide link requirements (e.g. topology, QOS parameters) to the TN management system. SA5 will identify relevant standard groups and industry fora, and trigger the cooperation discussion addressing the TN management.”

What we see is that most of the issues indicated above can be handled by 3GPP internally by evolving existing protocol solutions (e.g.

Mobility/Session Management protocol etc) towards 5G or by making use of existing solutions.

The work in 3GPP is still in progress, i.e. the "no" might not be the final answer. But so far the information I've collected from the different working groups in 3GPP is, that we at this moment don't have anything that we plan to indicate to IETF as requirements on Network Slicing.

<Nurit> See above (3GPP SA5 plans on producing TN requirements for each slice instance. They do plan to “hand” them over to NFVO and let it forward the requirements to the appropriate management entities that could be defined in IETF.)…

I know that many of you will not like this message, I nevertheless hope you don't shoot the messenger (that's me). We need to be open and honest here and I don't want to create any illusions.

<Nurit> I am not sure the message here is on behalf of 3GPP so let’s be careful with statements. If the IETF works on network slicing it is essential to understand the context and align with related activities in the industry.

Beyond Slicing ...

We started a major effort since the last IETF to get possible 5G related 3GPP requirements to IETF. There is a number of possible candidates where we currently look into, but they are (at this moment) not in the area of network slicing.

On the other hand we need to ensure that the work on 5G related issues stays well coordinated between the involved standards bodies (there are many more obviously) and that we end up with a coherent set of standards.

Please also be aware that 3GPP has a very demanding schedule for completion of the first phase of 5G, which is June/September 2018.

Within 3GPP we work hand-in-hand across several working groups and develop architecture, protocol requirements and solutions more or less in parallel. We need to make sure that work which is done in IETF is well phased-in to this endeavor.

I will present 3GPP work on 5G and collaboration plans with IETF at a dedicated time slot in Prague (most likely Tuesday noon, watch out for the updated Agenda) at the next IETF meeting.

Having said all that, obviously I don't want to stop any of the activities on this list. I just want to make clear the background in 3GPP and what we can at this moment realistically foresee.

Thanks and cheers,

Georg

--

Georg Mayer

3GPP CT Chairman

HUAWEI Technologies

> - If requirements are voiced as being 5g requirements, but do not come

> from 3gpp

> - If *other* requirements for network slicing arise (that are not driven

> by 3gpp)

> *To:* Benoit Claise; [email-masked]<mailto:[email-masked]>

> “We need to identify some IETF deliverables, in line with the 3GPP

> requirements.”

> *To:* [email-masked]<mailto:[email-masked]>

> [email-masked]<mailto:[email-masked]>

Netslices mailing list

[email-masked]<mailto:[email-masked]>

---

From: "Sprecher, Nurit (Nokia - IL/Kfar Sava)" <[email-masked]>
Date: Tue, 27 Jun 2017 21:08:20 +0000

Hello Georg,

Best regards,

Nurit

-----Original Message-----
From: Netslices [mailto:[email-masked]] On Behalf Of Georg Mayer
Sent: Friday, June 23, 2017 2:37 PM
To: [email-masked]; 'Georgios Karagiannis' <[email-masked]>; 'Benoit Claise' <[email-masked]>; [email-masked]
Cc: Erik Guttman <[email-masked]>; [email-masked]
Subject: Re: [Netslices] Network Slicing (NETSLICING): BoF Objectives

Hello,

- architecture

- security

The answer so far is no.

Beyond Slicing ...

Thanks and cheers,

Georg

--

Georg Mayer

3GPP CT Chairman

HUAWEI Technologies

Netslices mailing list