Subject: Re: [Netslices] Timing service

From: Gert Grammel <[email-masked]>
Date: Wed, 21 Jun 2017 11:42:42 +0000

Lian,

It seems that indirectly you are confirming a point made earlier. My perception in this discussion is that there is a common sense about "slice" being a construct that looks like a network and is controlled separately from other "slices". However, this is not even close to a practical definition. Many of the past concepts are implicitly named "slice" now, but do not have may things in common: Layers, switching-regions, technology domains, vendor-domains, routing areas, Management domains, virtualization, VPN, Tunnels … (continue with anything you like)

So unless we come up with a good-enough definition of a slice, much of the current discussion is mute. My definition of "slice" is that it is a logical construct (i.e. virtual), while yours would include physical constructs as well. Both are valid starting points, none of those starting points is good enough, but somehow the community would need to converge on a crisp definition.

Gert

From: GENG Liang <[email-masked]>
Date: Wednesday, 21. June 2017 at 06:18
To: Gert Grammel <[email-masked]>, AshwoodsmithPeter <[email-masked]>, Stewart Bryant <[email-masked]>, Thomas Nadeau <[email-masked]>
Cc: Anton Ivanov <[email-masked]>, "[email-masked]" <[email-masked]>, Daniele Ceccarelli <[email-masked]>
Subject: Re: Re: [Netslices] Timing service

Gert

I am not sure what you mean by "virtualized" in the scope of slicing. Is it logical isolation or the virtualization in NFV scope?

Though there has not been a solid definition of slice, but IMHO the dedication a network slice provide may consist of both logical (virtualized of not) and physical isolations, standalone or hybrid.

Taking timing service as an example
- ToD+1PPS is a physical dedicating - Conceptually it is a "hard" dedicated physical "timing service slice"
-1588 can have certain dedication, i.e. in Ethernet MAC layer to avoid congestion with data traffic - Conceptually it is a "soft" dedicated logical (but not virtualized) "timing service slice"

Though I am trying to make use of the slicing concept, I am actually not so sure if there is necessity for timing service to wear the network slicing hat given the existing manner of dedication. However, i do agree that timing service is an underlay which should serve whatever slice is running over it and I don't see the value of providing differentiated timing services from operator's point of view at this moment - we will anyway provide the timing service to support 5G requirement which is considered most critical. Hence share it for all the data planes will be most economical choice .

Best wishes
Liang

________________________________
Liang GENG
China Mobile Research Institute

From: Gert Grammel<mailto:[email-masked]>
Date: 2017-06-21 03:13
To: AshwoodsmithPeter<mailto:[email-masked]>; Stewart Bryant<mailto:[email-masked]>; Thomas Nadeau<mailto:[email-masked]>
CC: Anton Ivanov<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Daniele Ceccarelli<mailto:[email-masked]>
Subject: Re: [Netslices] Timing service
Peter,

Do you suggest a de-virtualized version of a network slice?
I think that is stretching the meaning of "slice" a bit too far.

Gert

On 2017-06-20, 20:52, "AshwoodsmithPeter" <[email-masked]> wrote:

    The only subtle point I would make is that nothing prevents the timing to be its own 'slice', its aware of all the physical links, sources of grand master,  and who needs what levels of precision. It can compute where the boundary clocks go and establish primary and backup trees (disjoint MST's). So the mechanisms that are used to control slices can be used to control two bare metal timing 'slices'.

    Either that or have a completely different mechanism to manage them but there is a certain elegance to reusing the slicing architecture to create a primary and backup timing 'slices'.

    Peter

    -----Original Message-----
    From: Netslices [mailto:[email-masked]] On Behalf Of Stewart Bryant
    Sent: Tuesday, June 20, 2017 2:07 PM
    To: Thomas Nadeau <[email-masked]>; Gert Grammel <[email-masked]>
    Cc: Anton Ivanov <[email-masked]>; [email-masked]; Daniele Ceccarelli <[email-masked]>
    Subject: Re: [Netslices] Timing service

    Yes, I suspect that timing is an underlying resource provided by the fabric to a slice if needed.

    I raised the subject because timing is so important to 5G, and people are beginning not to trust GPS.

    - Stewart

    On 20/06/2017 18:02, Thomas Nadeau wrote:
    > I think you, Anton, Stewart and I are in violent agreement then. 8)
    >
    > —Tom
    >
    >> On Jun 20, 2017:12:40 PM, at 12:40 PM, Gert Grammel <[email-masked]> wrote:
    >>
    >> Hi Tom, Stewart,
    >>
    >> Perhaps my writing was too cryptic. Daniele was actually asking to build timing slices and I was arguing that timing should be left to the underlying physical layer: "… timing accuracy is an attribute of a physical layer that cannot be virtualized/sliced/layered…". If my reading is correct, we seem to share that view.
    >> The maximum a slice can do is to filter for resources that support a given timing requirement if that constraint was given.
    >>
    >> Gert
    >>
    >> On 2017-06-20, 16:33, "Netslices on behalf of Thomas Nadeau" <[email-masked] on behalf of [email-masked]> wrote:
    >>
    >>
    >>     Gert:
    >>
    >>     I think its a bit simpler than that. The slicing use cases require a timing service to be available to it.
    >>     I assume that service must be accurate and reliable to some specification.  However, aside from that
    >>     there does not seem to be any requirement/need to have that service encased within the
    >>     slice.  In essence, virtualization of the 1588 service is not a requirement - running a bare metal
    >>     version that is shared amongst all the slices, etc… seems perfectly acceptable.
    >>
    >>     —Tom
    >>
    >>
    >>> On Jun 20, 2017:8:38 AM, at 8:38 AM, Gert Grammel <[email-masked]> wrote:
    >>>
    >>> Daniele, Anton,
    >>>
    >>> this discussion is basically asking two questions:
    >>> 1) Is timing a service?
    >>> 2) Is timing a characteristic of a slice?
    >>>
    >>> In my view timing accuracy is an attribute of a physical layer that cannot be virtualized/sliced/layered (another aspect is fate sharing). It is reasonable to imagine a "slice" where timing capabilities are enabled by default on all resources. As an example, mobile traffic MAY need to be transported on SyncE capable links only. In such scenario a client would not  require to dynamically instantiate timing on links but could instantiate a "slice" on a set of timing enabled links.
    >>> So it would work similar as with SRLG whereby two slices could be created avoiding fate sharing whereby it is the physical topology dictating the fate, not the number of virtualized connections carried.
    >>>
    >>> Thoughts?
    >>>
    >>> Gert
    >>>
    >>> P.S.: with slice I mean constructs like described in
    >>> https://tools.ietf.org/html/draft-king-teas-applicability-actn-slici
    >>> ng-00
    >>>
    >>>
    >>> On 2017-06-20, 12:57, "Netslices on behalf of Anton Ivanov" <[email-masked] on behalf of [email-masked]> wrote:
    >>>
    >>>    On 20/06/17 11:22, Daniele Ceccarelli wrote:
    >>>> Hi Anton,
    >>>>
    >>>> wouldn't it be possible to have a scenario in which we need synchronization for a slice which is built on top of a non synchronized network?
    >>>    There is a very good Russian saying "нельзя объять необъятное". The
    >>>    English equivalent is "You cannot have your cake and eat it too".
    >>>
    >>>    It is easier to implement sync at the lower layer and share it out than
    >>>    to guarantee that some or all of the virtual overlays will have jitter
    >>>    within the limits required for 4G or onwards sync.
    >>>
    >>>    We cannot cater for every possible requirement. There are reasonable and
    >>>    unreasonable asks.
    >>>
    >>>    That does not mean that there is no time sync aspect to the whole thing.
    >>>    There is an open question of how to share (with all relevant SLA
    >>>    restrictions) a common underlying time sync service securely between
    >>>    multiple slices and what can be the precision for that. One subcase of
    >>>    this may be (note the very big "may") having ONE (just one) sync enabled
    >>>    slice which we can just about guarantee and how do we fan it out at the
    >>>    edge to all consumers as a shared service.
    >>>
    >>>    But definitely not: "Allocate as many time-sync enabled slices on a
    >>>    network as you see fit".
    >>>
    >>>    A.
    >>>
    >>>> Just asking myself it this would make sense.
    >>>>
    >>>> BR
    >>>> Daniele
    >>>>
    >>>> -----Original Message-----
    >>>> From: Netslices [mailto:[email-masked]] On Behalf Of
    >>>> Anton Ivanov
    >>>> Sent: martedì 20 giugno 2017 11:44
    >>>> To: [email-masked]
    >>>> Subject: Re: [Netslices] Timing service
    >>>>
    >>>> Err...
    >>>>
    >>>> What does it have to do with slicing?
    >>>>
    >>>> I do not see a scenario where a slice will need to peruse its own special, different from everyone else time synchronization as a common use case.
    >>>>
    >>>> Sure, we can play with sync as a one-off use case to prove, disprove or test particular SLAs and assumptions, but I do not see the network design rationale for per-slice sync to get anywhere near requirements.
    >>>>
    >>>> A.
    >>>>
    >>>>
    >>>> On 16/06/17 12:17, Stewart Bryant wrote:
    >>>>> I was at a 5G seminar yesterday where it was explained that the
    >>>>> timing requirements for 5G are even stricter than they are for
    >>>>> existing systems (which in itself is a challenge).
    >>>>>
    >>>>> They were talking of a 200ns requirement with 20ns expected from 2020.
    >>>>>
    >>>>> The latency requirements for timing services are different from
    >>>>> the latency requirements of other services. They do not need
    >>>>> minimum latency (although that is nice to have) they need latency
    >>>>> consistently and latency symmetry.
    >>>>>
    >>>>> So one question I have is how we transmit the timing service. Does
    >>>>> it go in the underlay and provides time as a service to the NSI,
    >>>>> or does it go in a single slice, or does it go in multiple slices?
    >>>>>
    >>>>> - Stewart
    >>>>>
    >>>>> _______________________________________________
    >>>>> Netslices mailing list
    >>>>> [email-masked]
    >>>>> https://www.ietf.org/mailman/listinfo/netslices
    >>>>>
    >>>> _______________________________________________
    >>>> Netslices mailing list
    >>>> [email-masked]
    >>>> https://www.ietf.org/mailman/listinfo/netslices
    >>>>
    >>>    _______________________________________________
    >>>    Netslices mailing list
    >>>    [email-masked]
    >>>    https://www.ietf.org/mailman/listinfo/netslices
    >>>
    >>>
    >>> _______________________________________________
    >>> Netslices mailing list
    >>> [email-masked]
    >>> https://www.ietf.org/mailman/listinfo/netslices
    >>     _______________________________________________
    >>     Netslices mailing list
    >>     [email-masked]
    >>     https://www.ietf.org/mailman/listinfo/netslices
    >>
    >>
    >> _______________________________________________
    >> Netslices mailing list
    >> [email-masked]
    >> https://www.ietf.org/mailman/listinfo/netslices
    > _______________________________________________
    > Netslices mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/netslices

    _______________________________________________
    Netslices mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/netslices

_______________________________________________
Netslices mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netslices

---

From: Leeyoung <[email-masked]>
Date: Wed, 21 Jun 2017 14:32:06 +0000

Hi,

I think we need to make distinctions between the network slice view that customer sees and the actual instantiation of the network slice in the network.

As many shared (e.g., Med and Gert and others), I think network slice view is always abstract/virtual whereas the instantiation of network slice into the network may comprise of virtual resources and physical resources. As Med shared, how the instantiation of network slice is done is internal to the network provider.

Best regards,
Young

From: Netslices [mailto:[email-masked]] On Behalf Of Gert Grammel
Sent: Wednesday, June 21, 2017 6:43 AM
To: GENG Liang <[email-masked]>; AshwoodsmithPeter <[email-masked]>; Stewart Bryant <[email-masked]>; Thomas Nadeau <[email-masked]>
Cc: Anton Ivanov <[email-masked]>; [email-masked]; Daniele Ceccarelli <[email-masked]>
Subject: Re: [Netslices] Timing service

Lian,

Gert

From: GENG Liang <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 21. June 2017 at 06:18
To: Gert Grammel <[email-masked]<mailto:[email-masked]>>, AshwoodsmithPeter <[email-masked]<mailto:[email-masked]>>, Stewart Bryant <[email-masked]<mailto:[email-masked]>>, Thomas Nadeau <[email-masked]<mailto:[email-masked]>>
Cc: Anton Ivanov <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>
Subject: Re: Re: [Netslices] Timing service

Gert

Best wishes
Liang

Gert

On 2017-06-20, 20:52, "AshwoodsmithPeter" <[email-masked]<mailto:[email-masked]>> wrote:

    Peter

    -----Original Message-----
    From: Netslices [mailto:[email-masked]] On Behalf Of Stewart Bryant
    Sent: Tuesday, June 20, 2017 2:07 PM
    To: Thomas Nadeau <[email-masked]<mailto:[email-masked]>>; Gert Grammel <[email-masked]<mailto:[email-masked]>>
    Cc: Anton Ivanov <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>
    Subject: Re: [Netslices] Timing service

    - Stewart

    On 20/06/2017 18:02, Thomas Nadeau wrote:
    >> On Jun 20, 2017:12:40 PM, at 12:40 PM, Gert Grammel <[email-masked]<mailto:[email-masked]>> wrote:
    >>
    >> Hi Tom, Stewart,
    >>
    >> On 2017-06-20, 16:33, "Netslices on behalf of Thomas Nadeau" <[email-masked] on behalf of [email-masked]<mailto:[email-masked][email-masked]>> wrote:
    >>
    >>
    >>     Gert:
    >>
    >>> On Jun 20, 2017:8:38 AM, at 8:38 AM, Gert Grammel <[email-masked]<mailto:[email-masked]>> wrote:
    >>>
    >>> Daniele, Anton,
    >>>
    >>> On 2017-06-20, 12:57, "Netslices on behalf of Anton Ivanov" <[email-masked] on behalf of [email-masked]<mailto:[email-masked][email-masked]>> wrote:
    >>>
    >>>> To: [email-masked]<mailto:[email-masked]>
    >>>>> [email-masked]<mailto:[email-masked]>
    >>>> [email-masked]<mailto:[email-masked]>
    >>>    [email-masked]<mailto:[email-masked]>
    >>> [email-masked]<mailto:[email-masked]>
    >>     [email-masked]<mailto:[email-masked]>
    >> [email-masked]<mailto:[email-masked]>
    > [email-masked]<mailto:[email-masked]>

    _______________________________________________
    Netslices mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.ietf.org/mailman/listinfo/netslices

_______________________________________________
Netslices mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netslices

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 21 Jun 2017 14:49:55 +0000

Hi Young,

Agree that the customers should be unaware of the details of network slice instantiation, while it is important to make sure that the slice operators are provided with the right tools to instantiate the required slices.

Best regards,
Jie

From: Netslices [mailto:[email-masked]] On Behalf Of Leeyoung
Sent: Wednesday, June 21, 2017 10:32 PM
To: Gert Grammel; GENG Liang; AshwoodsmithPeter; Stewart Bryant; Thomas Nadeau
Cc: Anton Ivanov; [email-masked]; Daniele Ceccarelli
Subject: Re: [Netslices] Timing service

Hi,

Best regards,
Young

To: GENG Liang <[email-masked]<mailto:[email-masked]>>; AshwoodsmithPeter <[email-masked]<mailto:[email-masked]>>; Stewart Bryant <[email-masked]<mailto:[email-masked]>>; Thomas Nadeau <[email-masked]<mailto:[email-masked]>>

Lian,

Gert

Gert

Best wishes
Liang

Gert

    Peter

    -----Original Message-----
    From: Netslices [mailto:[email-masked]] On Behalf Of Stewart Bryant
    Sent: Tuesday, June 20, 2017 2:07 PM
    To: Thomas Nadeau <[email-masked]<mailto:[email-masked]>>; Gert Grammel <[email-masked]<mailto:[email-masked]>>
    Cc: Anton Ivanov <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>
    Subject: Re: [Netslices] Timing service

    - Stewart

---

From: AshwoodsmithPeter <[email-masked]>
Date: Wed, 21 Jun 2017 14:58:17 +0000

I think it’s getting very difficult to decide what is physical and what is virtual anyway. Is a lambda physical or virtual, is a CPU core physical or virtual, are the sub carriers physical or virtual..

The important thing is that the degree of isolation (or not) on any given segment of a slice meets the QOS requirements to the statistical degree that is desired without compromising the other slices.

I think therefore that physical or logical is not useful for slice definition, but hard/soft isolation is perhaps a better term since it implies a usable grey area in between.

Peter

From: Leeyoung
Sent: Wednesday, June 21, 2017 10:32 AM
To: Gert Grammel <[email-masked]>; GENG Liang <[email-masked]>; AshwoodsmithPeter <[email-masked]>; Stewart Bryant <[email-masked]>; Thomas Nadeau <[email-masked]>
Cc: Anton Ivanov <[email-masked]>; [email-masked]; Daniele Ceccarelli <[email-masked]>
Subject: RE: [Netslices] Timing service

Hi,

Best regards,
Young

Lian,

Gert

Gert

Best wishes
Liang

Gert

    Peter

    -----Original Message-----
    From: Netslices [mailto:[email-masked]] On Behalf Of Stewart Bryant
    Sent: Tuesday, June 20, 2017 2:07 PM
    To: Thomas Nadeau <[email-masked]<mailto:[email-masked]>>; Gert Grammel <[email-masked]<mailto:[email-masked]>>
    Cc: Anton Ivanov <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>
    Subject: Re: [Netslices] Timing service

    - Stewart

---

From: David Allan I <[email-masked]>
Date: Wed, 21 Jun 2017 15:37:56 +0000

I’ve  had trouble with “virtual” and “resource” being used together as it is a bit of an oxymoron. Best I can do to pry these apart is conceptually a physical resource that can be applied to a virtualized environment.

IMO timing cannot be virtualized, but it can consume physical resources and provide a service to a virtualized environment.

My 2 cents
Dave

From: Netslices [mailto:[email-masked]] On Behalf Of AshwoodsmithPeter
Sent: Wednesday, June 21, 2017 7:58 AM
To: Leeyoung <[email-masked]>; Gert Grammel <[email-masked]>; GENG Liang <[email-masked]>; Stewart Bryant <[email-masked]>; Thomas Nadeau <[email-masked]>
Cc: Anton Ivanov <[email-masked]>; [email-masked]; Daniele Ceccarelli <[email-masked]>
Subject: Re: [Netslices] Timing service

Peter

From: Leeyoung
Sent: Wednesday, June 21, 2017 10:32 AM
To: Gert Grammel <[email-masked]<mailto:[email-masked]>>; GENG Liang <[email-masked]<mailto:[email-masked]>>; AshwoodsmithPeter <[email-masked]<mailto:[email-masked]>>; Stewart Bryant <[email-masked]<mailto:[email-masked]>>; Thomas Nadeau <[email-masked]<mailto:[email-masked]>>
Cc: Anton Ivanov <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Netslices] Timing service

Hi,

Best regards,
Young

Lian,

Gert

Gert

Best wishes
Liang

Gert

    Peter

    -----Original Message-----
    From: Netslices [mailto:[email-masked]] On Behalf Of Stewart Bryant
    Sent: Tuesday, June 20, 2017 2:07 PM
    To: Thomas Nadeau <[email-masked]<mailto:[email-masked]>>; Gert Grammel <[email-masked]<mailto:[email-masked]>>
    Cc: Anton Ivanov <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>
    Subject: Re: [Netslices] Timing service

    - Stewart

---

From: Igor Bryskin <[email-masked]>
Date: Wed, 21 Jun 2017 17:38:17 +0000

Hi Peter,

I fully agree with you, I like to think about network resources as abstract resources which may represent either physical resources, or partitions of physical resources (logical resources) or virtualized resources or a combination of thereof.  Abstract resources make up abstract topologies which could be constrained, optimized and/or otherwise tailored acording to provider policies and client preferences.

Igor
From:AshwoodsmithPeter
To:Leeyoung,Gert Grammel,GENG Liang,Stewart Bryant,Thomas Nadeau,
Cc:Anton Ivanov,[email-masked],Daniele Ceccarelli,
Date:2017-06-21 11:05:15
Subject:Re: [Netslices] Timing service

Peter

From: Leeyoung

Hi,

Best regards,
Young

Lian,

Gert

Gert

Best wishes
Liang

Gert

    Peter

    -----Original Message-----
    From: Netslices [mailto:[email-masked]] On Behalf Of Stewart Bryant
    Sent: Tuesday, June 20, 2017 2:07 PM
    To: Thomas Nadeau <[email-masked]<mailto:[email-masked]>>; Gert Grammel <[email-masked]<mailto:[email-masked]>>
    Cc: Anton Ivanov <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>
    Subject: Re: [Netslices] Timing service

    - Stewart

    On 20/06/2017 18:02, Thomas Nadeau wrote:
    > ―Tom
    >>     ―Tom

---

From: GENG Liang <[email-masked]>
Date: Thu, 22 Jun 2017 05:28:42 +0000

Hello Young and all,

Fully agree that the point of network slice is an abstract view of the network resources and the instantiation of network slice is done internally by operators.

I think the veiwpoint Young proposed is very helpful.

Customer view of network slice - abstraction of resources with certain required arrangement
Infrastructure owner/operators view of network slice - instantiation of this abstraction with maps to either virtual or physical resources, with either physical (hard) or logical (soft) isolations.

In addition to this, I also share the view of the transparency of network slice in customer's view.

Best wishes
Liang

From: Leeyoung<mailto:[email-masked]>
Date: 2017-06-21 22:32
To: Gert Grammel<mailto:[email-masked]>; GENG Liang<mailto:[email-masked]>; AshwoodsmithPeter<mailto:[email-masked]>; Stewart Bryant<mailto:[email-masked]>; Thomas Nadeau<mailto:[email-masked]>
CC: Anton Ivanov<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Daniele Ceccarelli<mailto:[email-masked]>
Subject: RE: [Netslices] Timing service
Hi,

Best regards,
Young

Lian,

Gert

Gert

Best wishes
Liang

Gert

    Peter

    -----Original Message-----
    From: Netslices [mailto:[email-masked]] On Behalf Of Stewart Bryant
    Sent: Tuesday, June 20, 2017 2:07 PM
    To: Thomas Nadeau <[email-masked]<mailto:[email-masked]>>; Gert Grammel <[email-masked]<mailto:[email-masked]>>
    Cc: Anton Ivanov <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>
    Subject: Re: [Netslices] Timing service

    - Stewart