Subject: [Netslices] Applicability of Abstraction and Control of TE Networks (ACTN) to Network Slicing

From: <[email-masked]>
Date: Tue, 13 Jun 2017 17:00:43 +0100

Dear Netslices, 

I thought it might be helpful to write a TEAS I-D to summarise applicability
of ACTN to network slicing. The I-D highlights how ACTN might address some
of network slicing problem space, it also documents where/what gaps may
exist. The I-D URL is below, any review/comments on the TEAS list would be
most welcome. 

Applicability of Abstraction and Control of TE Networks (ACTN) to Network
Slicing

https://tools.ietf.org/html/draft-king-teas-applicability-actn-slicing-00

BR, Dan. 

-----Original Message-----
From: I-D-Announce [mailto:[email-masked]] On Behalf Of
[email-masked] <mailto:[email-masked]> 
Sent: 13 June 2017 16:03
To: [email-masked] <mailto:[email-masked]> 
Subject: I-D Action: draft-king-teas-applicability-actn-slicing-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

        Title           : Applicability of Abstraction and Control of TE
Networks (ACTN) to Network Slicing

        Author          : Daniel King

                Filename        :
draft-king-teas-applicability-actn-slicing-00.txt

                Pages           : 14

                Date            : 2017-06-13

Abstract:

   Network abstraction is a technique that can be applied to a network

   domain to manage network resources to create a virtualized network

   that is under the control of a network operator (or perhaps the

   customer).

   Network slicing is an approach to network operations that builds on

   the concept of network abstraction to provide programmability,

   flexibility, and modularity.  It uses techniques such as Software

   Defined Networking (SDN) and Network Function Virtualization (NFV)

   to create multiple logical (virtual) networks, each tailored for a

   given use case, on top of a common network.

   These logical networks are referred to as network slices. A network

   slice does not necessarily represent dedicated resources in the

   server network, but does constitute a commitment by the service

   provider to provide a specific level of service.

   The Abstraction and Control of Traffic Engineered Networks (ACTN)

   defines an SDN-based architecture that relies on the concepts of

   network and service abstraction to detach network and service

   control from the underlying data plane.

   This document outlines the applicability of ACTN to network

   slicing in an IETF technology network.  It also identifies the

   features of network slicing not currently within the scope of ACTN,

   and indicates where ACTN might be extended.

The IETF datatracker status page for this draft is:

<https://datatracker.ietf.org/doc/draft-king-teas-applicability-actn-slicing
/>
https://datatracker.ietf.org/doc/draft-king-teas-applicability-actn-slicing/

There are also htmlized versions available at:

 <https://tools.ietf.org/html/draft-king-teas-applicability-actn-slicing-00>
https://tools.ietf.org/html/draft-king-teas-applicability-actn-slicing-00

<https://datatracker.ietf.org/doc/html/draft-king-teas-applicability-actn-sl
icing-00>
https://datatracker.ietf.org/doc/html/draft-king-teas-applicability-actn-sli
cing-00

---

From: Gert Grammel <[email-masked]>
Date: Wed, 14 Jun 2017 17:02:14 +0000

Dan,

Thank you for trying to define slicing. I find it very clear and particularly appreciate the distinction between some known constructs and slices, really worth to read.
A few minor comments:

1.       <snip> This logical network is separated from other, often concurrent, logical networks each with independent control and management, and each of which can be created or modified on demand.

·         Is "independent control and management" a defining characteristic of a slice? IOW can a slice exist without control and management and can it exist without either control xor management?

2.       <snip> Each example represents a self-contained network that must be flexible enough to simultaneously accommodate diverse business-driven use cases from multiple players on a common network infrastructure.

·         If we assume a set of CPE-routers interconnected by p2p links, possibly combined with computing possibilities at CPE, the definition would consider it a slice (at least this is my understanding).

·         As the underlying (less complex) virtual private wire (or VPN) is also a slice, we end up in a hierarchical relationship. Can terms like overlay and underlay be used to describe this relationship or do we need new definitions?
Gert

From: Netslices <[email-masked]> on behalf of Daniel King <[email-masked]>
Date: Tuesday, 13. June 2017 at 18:00
To: "[email-masked]" <[email-masked]>
Subject: [Netslices] Applicability of Abstraction and Control of TE Networks (ACTN) to Network Slicing

Dear Netslices,

I thought it might be helpful to write a TEAS I-D to summarise applicability of ACTN to network slicing. The I-D highlights how ACTN might address some of network slicing problem space, it also documents where/what gaps may exist. The I-D URL is below, any review/comments on the TEAS list would be most welcome.

Applicability of Abstraction and Control of TE Networks (ACTN) to Network Slicing

BR, Dan.

-----Original Message-----
From: I-D-Announce [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: 13 June 2017 16:03
To: [email-masked]<mailto:[email-masked]>
Subject: I-D Action: draft-king-teas-applicability-actn-slicing-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Applicability of Abstraction and Control of TE Networks (ACTN) to Network Slicing

        Author          : Daniel King

                Filename        : draft-king-teas-applicability-actn-slicing-00.txt

                Pages           : 14

                Date            : 2017-06-13

Abstract:

   customer).

https://datatracker.ietf.org/doc/html/draft-king-teas-applicability-actn-slicing-00